abclinuxu.cz AbcLinuxu.cz itbiz.cz ITBiz.cz HDmag.cz HDmag.cz abcprace.cz AbcPráce.cz
AbcLinuxu hledá autory!
Inzerujte na AbcPráce.cz od 950 Kč
Rozšířené hledání
×
dnes 00:44 | Komunita

Feral Interactive, společnost zabývající se vydáváním počítačových her pro operační systémy macOS a Linux, nabízí své hry na Steamu vývojářům open source 3D grafické knihovny Mesa zdarma. Podmínkou je minimálně 25 commitů za posledních 5 let. Stejnou nabídku dostali vývojáři knihovny Mesa v roce 2015 od Valve. O rok dříve dostali od Valve tuto nabídku vývojáři Debianu a Ubuntu.

Ladislav Hagara | Komentářů: 0
včera 23:55 | Nová verze

Opera 44, verze 44.0.2510.857, byla prohlášena za stabilní. Nejnovější verze tohoto webového prohlížeče je postavena na Chromiu 57. Z novinek vývojáři Opery zdůrazňují podporou Touch Baru na nejnovějších MacBoocích Pro (gif). Přehled novinek pro vývojáře na blogu Dev.Opera.

Ladislav Hagara | Komentářů: 1
včera 20:56 | Pozvánky

V úterý 28. dubna se koná další Prague Containers Meetup. Přijďte si zopakovat, jak psát kvalitnější Dockerfile a jaké novinky a ulehčení přináší ansible-container, který vám umožní spravovat celý životní cyklus vašeho kontejneru. Místo konání: Concur, Bucharova 11, Praha-Stodůlky.

little-drunk-jesus | Komentářů: 0
včera 17:00 | Nová verze

Po půl roce od vydání verze 3.22 bylo vydáno GNOME ve verzi 3.24 s kódovým názvem Portland. Vydání obsahuje 28 459 změn od přibližně 753 přispěvatelů. Z novinek lze zmínit funkci noční světlo, přepracovaná nastavení, aplikaci Recepty, zdokonalenou oblast pro upozornění nebo zdokonalený webový prohlížeč. Podrobnosti i s náhledy v poznámkách k vydání a v novinkách pro vývojáře a správce systémů.

Ladislav Hagara | Komentářů: 3
včera 11:55 | Humor

Majitelé koček by měli být obezřetní při používání desktopového prostředí XFCE ve výchozím nastavení. Používání XFCE může mást jejich kočky a vést k poškrábání displeje. Jedná se o chybu 12117. K dispozici je již patch.

Ladislav Hagara | Komentářů: 17
21.3. 15:55 | Nová verze

Byla vydána verze 7.5 sady aplikací pro SSH komunikaci OpenSSH. Jedná se o opravné vydání. Volba UsePrivilegeSeparation v sshd_config se stala zastaralou (deprecated). Upozornit lze na změnu formátu log záznamů. Novou verzi OpenSSH již nelze přeložit s upstreamem nepodporovanými verzemi OpenSSL.

Ladislav Hagara | Komentářů: 0
21.3. 14:44 | Nová verze

Byla vydána verze 5.1.0 svobodného integrovaného vývojového prostředí KDevelop. Z novinek lze zdůraznit podporu LLDB. Programátoři mohou nově ladit své programy pomocí GDB nebo LLDB MI. Jedná se o jeden z výsledků Google Summer of Code (GSoC 2016). Zdrojové kódy lze nově přímo z menu KDevelopu analyzovat pomocí nástroje Cppcheck. Přibyla podpora OpenCL. Vylepšena byla podpora programovacího jazyka Python. Přímo z menu lze měnit barevná schémata KDevelopu.

Ladislav Hagara | Komentářů: 6
21.3. 08:33 | Komunita

Emulátor terminálu Terminix byl s verzí 1.5.4 přejmenován na Tilix. Název Terminix se nelíbil společnosti Terminix, jež má registrovanou ochrannou známku Terminix. Společnost Terminix se zabývá hubením škůdců. Emulátor terminálu Tilix je naprogramován v programovacím jazyce D a využívá GtkD, což je rozšíření ke knihovně GTK+ pro D.

Ladislav Hagara | Komentářů: 7
20.3. 17:55 | Zajímavý software

Bill Zissimopoulos vydal po 16 měsících vývoje WinFsp ve verzi 2017. Jedná se o Windows File System Proxy aneb FUSE pro Windows. Díky WinFsp a SSHFS-Win si i uživatelé Windows mohou připojit vzdálené souborové systémy prostřednictvím šifrovaného spojení SSH (SSHFS). Zdrojové kódy WinFsp jsou k dispozici na GitHubu pod licencí GPLv3 [reddit].

Ladislav Hagara | Komentářů: 14
20.3. 16:44 | Pozvánky

Brněnská pobočka Red Hatu otevře opět po roce dveře studentům a všem zájemcům z řad veřejnosti. Připravena je řada přednášek, workshopů a kódovacích soutěží. Akce se koná dne 5. dubna 2017 od 13 do 19 hodin na adrese Purkyňova 111, Brno v Technologickém parku. Detaily naleznete na webu události a na Facebook stránce.

… více »
Jary | Komentářů: 2
Jak se stavíte k trendu ztenčování přenosných zařízení (smartphony, notebooky)?
 (14%)
 (2%)
 (72%)
 (3%)
 (10%)
Celkem 914 hlasů
 Komentářů: 72, poslední 1.3. 11:16
    Rozcestník

    Dotaz: Instalace DBD::Oracle na AMD64 (Oracle XE)

    16.11.2008 02:24 Jan Grmela | skóre: 45 | blog: Kilo šťávy z lachtana | Brno
    Instalace DBD::Oracle na AMD64 (Oracle XE)
    Přečteno: 724×
    Příloha:

    Dobrý den, mám následující problém:

    V klidu jsem na svůj čerstvý Centos 5.2 x86_64 nainstaloval RPM Oracle XE z webu. Všechno funguje normálně, webová správa běží. Jenže bych moc rád používal DBI rozhraní z Perlu, k čemuž je samozřejmě potřeba DB driver. Když jsem se ale pokusil nainstalovat CPANem DBD::Oracle, nezdařilo se to. GCC mám nainstalované, řídil jsem se radami z různých mailing listů ohledně nastavení PATH, ORACLE_HOME a podobně. Také jsem změnil hodnotu v /usr/lib/oracle/xe/app/oracle/product/10.2.0/server/ctx/lib/env_ctx.mk z LIBDIR=lib na LIBDIR=lib32, jak se doporučuje tady, nic z toho ale nepomohlo a kompilace stále selhává na stejné chybě (celý výpis v příloze):

    /usr/bin/ld: skipping incompatible /usr/lib/oracle/xe/app/oracle/product/10.2.0/server/lib//libclntsh.so when searching for -lclntsh
    /usr/bin/ld: cannot find -lclntsh
    collect2: ld returned 1 exit status
    make: *** [blib/arch/auto/DBD/Oracle/Oracle.so] Error 1

    Nenapadá mě žádné rozumné řešení vzniklé situace (kromě přeinstalace systému na 32-bit) -- Oracle XE je nabízen jen ve 32-bit verzi. A pořizovat si licenci na Standard Edition One za 15k kvůli projektu do školy se mi opravdu nechce :-)

    Píšu pro Pivní recenze a protože mě to IT už fakt nebaví, tak jsme si s klukama postavili pivovar Lucky Bastard

    Odpovědi

    16.11.2008 09:22 pht | skóre: 48 | blog: pht
    Rozbalit Rozbalit vše Re: Instalace DBD::Oracle na AMD64 (Oracle XE)
    tahle chyba znamena ze nemate prislusnou knihovnu v prislusne bitove verzi. odhadoval bych to tak, ze mate 64bit perl a 32bit oracle vcetne client knihoven, coz samozrejme dohromady slinkovat nelze. potrebujete 64bit oracle nebo 32bit perl. (nebo zkusit nejakej perl-only driver, coz ale nevim jestli existuje)
    In Ada the typical infinite loop would normally be terminated by detonation.
    16.11.2008 12:01 Jan Grmela | skóre: 45 | blog: Kilo šťávy z lachtana | Brno
    Rozbalit Rozbalit vše Re: Instalace DBD::Oracle na AMD64 (Oracle XE)
    To samozřejmě vím. 32-bit Perl nepřichází v úvahu kvůli tomu, že na Perlu závisí půlka systému a 64-bit Oracle neexistuje (v této verzi).

    Zatím to vypadá tak, že budu muset přeinstalovat systém. Naštěstí to není zas taková tragedie, jelikož jsem ho nainstaloval teprv včera a ještě nic moc nenastavoval.
    Píšu pro Pivní recenze a protože mě to IT už fakt nebaví, tak jsme si s klukama postavili pivovar Lucky Bastard
    16.11.2008 12:24 Ladicek | skóre: 28 | blog: variace | Havlíčkův brod
    Rozbalit Rozbalit vše Re: Instalace DBD::Oracle na AMD64 (Oracle XE)
    pořizovat si licenci na Standard Edition One za 15k kvůli projektu do školy se mi opravdu nechce :-)
    Noo, for the purpose of developing a single prototype of your application si můžeš "velký" Oracle stáhnout zdarma, stačí registrace :-)
    Ještě na tom nejsem tak špatně, abych četl Viewegha.
    16.11.2008 14:53 Jan Grmela | skóre: 45 | blog: Kilo šťávy z lachtana | Brno
    Rozbalit Rozbalit vše Re: Instalace DBD::Oracle na AMD64 (Oracle XE)
    Super, to jsem nevěděl. Tím pádem je problém vyřešen. Díky!
    Píšu pro Pivní recenze a protože mě to IT už fakt nebaví, tak jsme si s klukama postavili pivovar Lucky Bastard
    18.11.2008 18:01 Ivan
    Rozbalit Rozbalit vše Re: Instalace DBD::Oracle na AMD64 (Oracle XE)
    Na tohle je oracle instantclient. Ma to cca 50MB. Jsou v tom klientsky klihovny, sdk(headery) a sqlplus. tnsping bohuzel chybi. InstantClient je ve verzi 32/64bit 10g/11g. Dokonce to ma .rpm a .deb balicky.

    Ivan
    18.11.2008 23:16 Ruda
    Rozbalit Rozbalit vše Re: Instalace DBD::Oracle na AMD64 (Oracle XE)
    Na serveru to nepujde bez souhlasne stejnebitove verze jako je hostitelsky system pro databazi. A co se tyce klienta, pozor na 10g a starsi libstdc++ nez je v systemu (binarky klientskych knihoven jsou u 10g se starsi libstdc++ kompilovany). Pri vyvoji s OCI/OCCI a kombinaci ruznych verzi libstdc++ beha mraz po zadech na nepochopitelnych padech. 11g klient s aktualni libstdc++.so.6 to resi..
    19.11.2008 15:33 Ivan
    Rozbalit Rozbalit vše Re: Instalace DBD::Oracle na AMD64 (Oracle XE)
    Posledni problem s OCCI byl v tom, ze g++ zmenilo ABI pro vyjimky. Pokud OCCI vyvolalo vyjimku, nebylo mozne ji odchytit v kodu kompilovanem novejsim g++ a vse skoncilo segfaultem. Cele se to chovalo velice divne v gdb z tech padu bylo dost zmateny. Oracle je bohuzel dost konzervativni v nevydava novejsi verze OCCI pokazde kdyz g++ zmeni ABI.

    Založit nové vláknoNahoru

    Tiskni Sdílej: Linkuj Jaggni to Vybrali.sme.sk Google Del.icio.us Facebook

    ISSN 1214-1267   www.czech-server.cz
    © 1999-2015 Nitemedia s. r. o. Všechna práva vyhrazena.