abclinuxu.cz AbcLinuxu.cz itbiz.cz ITBiz.cz HDmag.cz HDmag.cz abcprace.cz AbcPráce.cz
AbcLinuxu hledá autory!
Inzerujte na AbcPráce.cz od 950 Kč
Rozšířené hledání
×
dnes 13:11 | IT novinky

Byl aktualizován seznam 500 nejvýkonnějších superpočítačů na světě TOP500. Dle očekávání se nejvýkonnějším superpočítačem stal superpočítač Summit. Český superpočítač Salomon klesl na 139. místo. Další přehledy a statistiky na stránkách projektu.

Ladislav Hagara | Komentářů: 0
dnes 09:00 | Nová verze

Po téměř 13 měsících vývoje od vydání verze 5.26 byla vydána nová stabilní verze 5.28 programovacího jazyka Perl. Do vývoje se zapojilo 77 vývojářů. Změněno bylo přibližně 730 tisíc řádků v 2 200 souborech. Přehled novinek a změn v podrobném seznamu.

Ladislav Hagara | Komentářů: 5
dnes 05:55 | Komunita

Při prvním spuštění Ubuntu 18.04 LTS (Bionic Beaver) je spuštěn nástroj Ubuntu Report. Pokud uživatel souhlasí, jsou pomocí tohoto nástroje odeslány do Canonicalu informace o daném počítači (doba instalace, počet procesorů, rozlišení displeje, velikost paměti, časová zóna, ...). Will Cooke, vedoucí týmu Ubuntu Desktop, zveřejnil na blogu Canonicalu první získané statistiky. Infografika na It's FOSS.

Ladislav Hagara | Komentářů: 0
včera 09:55 | Nová verze

Byl vydán Debian 8.11, tj. jedenáctá a současně poslední opravná verze Debianu 8 s kódovým názvem Jessie. Uživatelům je doporučen přechod na Debian 9 Stretch nebo využít LTS (Debian Long Term Support). LTS podpora Debianu 8 je plánována do 30. června 2020. LTS podpora Debianu 7 Wheezy skončila 31. května 2018.

Ladislav Hagara | Komentářů: 0
včera 09:11 | IT novinky

Hodnota Bitcoinu, decentralizované kryptoměny, klesla pod 6 000 dolarů. Před půl rokem byla hodnota Bitcoinu téměř 20 000 dolarů.

Ladislav Hagara | Komentářů: 32
23.6. 12:33 | Zajímavý projekt

Kernel.org představil lore.kernel.org, tj. archiv diskusního listu vývojářů linuxového jádra LKML (Linux Kernel Mailing List) s řadou zajímavých funkcí. Archiv běží na softwaru Public Inbox.

Ladislav Hagara | Komentářů: 0
23.6. 10:55 | Nová verze

Po devíti měsících vývoje od vydání verze 10.0 byla vydána verze 11.0 open source alternativy GitHubu, tj. softwarového nástroje s webovým rozhraním umožňujícího spolupráci na zdrojových kódech, GitLab (Wikipedie). Představení nových vlastností v příspěvku na blogu a na YouTube.

Ladislav Hagara | Komentářů: 2
22.6. 20:44 | Nová verze

Po více než 3 měsících vývoje od vydání verze 238 oznámil Lennart Poettering vydání verze 239 správce systému a služeb systemd (GitHub, NEWS).

Ladislav Hagara | Komentářů: 57
22.6. 15:00 | Nová verze

Bylo oznámeno vydání nové stabilní verze 1.28 a beta verze 1.29 open source textového editoru Atom (Wikipedie). Přehled novinek i s náhledy v příspěvku na blogu. Podrobnosti v poznámkách k vydání. Atom 1.28 je postaven na Electronu 2.0.

Ladislav Hagara | Komentářů: 3
22.6. 14:00 | Nová verze

Byla vydána nová verze 2.3.0 multiplatformního svobodného frameworku pro zpracování obrazu G'MIC (GREYC's Magic for Image Computing, Wikipedie). Přehled novinek i s náhledy na PIXLS.US.

Ladislav Hagara | Komentářů: 0
Jak čtete delší texty z webových stránek?
 (78%)
 (22%)
 (4%)
 (7%)
 (2%)
 (10%)
Celkem 258 hlasů
 Komentářů: 39, poslední 21.6. 17:44
    Rozcestník

    Dotaz: apt-get chyba

    13.8.2006 17:17 tomik4668 | skóre: 8
    apt-get chyba
    Přečteno: 169×
    Ahoj..potreboval bych poradit s jednou veci.. jaksi jsem se drbal v aptitude a chtel jsem odstranit starsiho firefoxa a odinstalovat..jenze nakym zahadnym zpusobem jsem vymazal i nejakych par knihoven..nevim jakych ale proste bylo to ztraceno..kdyz jsem si stahnul novejsi verzi v DEB balicku a chtel ji nainstalovat tak me to nevalilo a vypsalo me to toto..
    debian:/home/tomik/download_programs# dpkg --install firefox_1.5.dfsg+1.5.0.6-1_i386.deb
    (Čtu databázi ... nyní je nainstalováno 93991 souborů a adresářů.)
    Připravuji nahrazení firefox 1.5.dfsg+1.5.0.6-1 (pomocí firefox_1.5.dfsg+1.5.0.6-1_i386.deb) ...
    Rozbaluji náhradu firefox ...
    dpkg: nesplněné závislosti zamezily konfiguraci balíku firefox:
     firefox závisí na libatk1.0-0 (>= 1.12.1); avšak:
      verze balíku libatk1.0-0 v systému je 1.8.0-4.
     firefox závisí na libc6 (>= 2.3.6-6); avšak:
      verze balíku libc6 v systému je 2.3.2.ds1-22sarge3.
     firefox závisí na libcairo2 (>= 1.2.0); avšak:
      Balík libcairo2 není nainstalován.
     firefox závisí na libfreetype6 (>= 2.2); avšak:
      verze balíku libfreetype6 v systému je 2.1.7-2.5.
     firefox závisí na libgcc1 (>= 1:4.1.0); avšak:
      verze balíku libgcc1 v systému je 1:3.4.3-13.
     firefox závisí na libglib2.0-0 (>= 2.10.0); avšak:
      verze balíku libglib2.0-0 v systému je 2.6.4-1.
     firefox závisí na libgtk2.0-0 (>= 2.8.0); avšak:
      verze balíku libgtk2.0-0 v systému je 2.6.4-3.1.
     firefox závisí na libpango1.0-0 (>= 1.12.3); avšak:
      verze balíku libpango1.0-0 v systému je 1.8.1-1.
     firefox závisí na libstdc++6 (>= 4.1.0); avšak:
      Balík libstdc++6 není nainstalován.
     firefox závisí na libxinerama1; avšak:
      Balík libxinerama1 není nainstalován.
    dpkg: chyba při zpracovávání firefox (--install):
     problém se závislostmi - nechávám nezkonfigurované
    Při zpracování nastaly chyby:
     firefox
    
    kdyz jsem se pokousel instalovat jednotlivy knihovny rucne pres apt-get install tak to vypisovalo porad dokola a jen se menilo poradi..

    Provedl jsem dokonce i UPDATE a UPGRADE a pri tom upgradu me to vypsalo, ze nemam ty knihovny co chybi Firefoxu..nevi jak na to..

    Prosim o radu jak z toho ven..dekuji vsem za navrhy..budu vam vdecny..

    Odpovědi

    13.8.2006 18:04 fakenickname | skóre: 42 | blog: fakeblog
    Rozbalit Rozbalit vše Re: apt-get chyba
    Chjo, tak zaprvé: nevím jak debian ale v ubuntu je firefox tak silně spjatý se svými závislotmi, že jej prakticky nelze upgradovat. Jednoduše řečeno - odinstalování distribučního firefoxu a instalace firefoxu z .deb balíčku z netu je velká hloupost, která nemůže skončit ničím jiným než takovým peklem. Osobně bych tedy odinstaloval veškeré firefox balíky ze systému a zkusil opravit závislosti. Něco jako
    apt-get remove --purge firefox
    apt-get check
    
    A to by snad mělo trochu pomoct.
    A za druhé: pokud tedy chceš upgradovat Firefox tak je mnohem čistější si stáhnout "Firefox 1.5.0.6 pro Linux - Český bez instalátoru (8,1 MB)" z czilla.cz, rozbalit do nějakého vhodného adresáře (já například používám /home/dum8d0g/.firefox_bonecho-beta apod.) a z onoho adresáře spustit binárku 'firefox'. Takhle můžeš mít naistalovaný stabilní firefox z distra, vývojovou verzi, další jinou verzi, no prostě jak se ti bdue chtít :) .. Dej vědět jestli to pomůže..
    13.8.2006 18:13 tomik4668 | skóre: 8
    Rozbalit Rozbalit vše Re: apt-get chyba
    No tak je to OKej..uz se mi to podarilo rozjet ze to na me aspon nehaze ze muu chybi zavysli knihovny..sem ubral ze SOURCE LISTU odkaz na UNSTABLE vetev a v poho se spustil UPDATE a UGRADE ten FIREFOX odstranil..takze pohodka.. Tak ohledne te binarky..dobre rozbalim si tu spakovanej FIREFOX trebas do HOME/nekam/nekam a pak ho budu zpoustet... A jako opkud ho budu potom chtit odstranit tak bude stacit ho normalne smaznout jo? Nebo tam mam este neco spustit..a nebude vadit ze to trebas nema potrebny knihovny..ale to asi vse potrebny bude primo v tom archivu ze? Jinak ti dekuju za echo...Tomin
    13.8.2006 18:58 fakenickname | skóre: 42 | blog: fakeblog
    Rozbalit Rozbalit vše Re: apt-get chyba
    Pokud budeš chtít odstranit binární firefox stažený např. z czilla nebo jiných mozilla mirrorů, stačí pouze smazat adresář, kam jsi rozbalil obsah staženého archivu. Většina nastavení však zůstává v ~/.mozilla takže odstraněním rozbaleného archivu nic nepokazíš. O knihovny v případě tohoto nedistribučního staticky slinkovaného (?) binárního firefoxu vůbec není potřeba se starat.. (fixme)
    13.8.2006 19:09 tomik4668 | skóre: 8
    Rozbalit Rozbalit vše Re: apt-get chyba
    Dik uz ho mam aj nastavenej jako ikonu..;-) Jo muzu te este otravovat s jednou veci esi se semka este podivas? Sice to s timhle trosku nesouvisi..ale...:-)

    Nejde mi do hlavy odinstalovavani balicku...dyz se to pta pri odinstalaci ze sou na tom balicku nejaky balicky, ktery ho vyuzivaji..nemusim mit strach ho odstranit i s tema zavis.balickama?

    Pac napr.sem chtel odebrat AMOR a vypasalo mi to ze to odstrani kde a este nejaky balicky...mam strach to udelat..nebo je ten APT tak chytrej a neodsttranil by balicky kery vyuzivaji jinaci programky..nebo je tak blbej..:-D DIK za tuto posledni OTAZKU...trosku stupidni..:-D Mej se cao...Tomin

    13.8.2006 19:24 fakenickname | skóre: 42 | blog: fakeblog
    Rozbalit Rozbalit vše Re: apt-get chyba
    Polož to prosím jako nový dotaz, aby ti co se budou zajímat o stejnou odpověd, jí mohli snáz najít.
    13.8.2006 19:30 Sinuhet | skóre: 31
    Rozbalit Rozbalit vše Re: apt-get chyba

    Jestlize se budete pokouset odstranit napr. balicek kdelibs-bin, na kterem zavisi cele KDE, tak s nim zmizi i KDE. Od toho jsou tam ty zavislosti, aby jste nejake aplikaci neurval pod zadkem knihovnu, kterou potrebuje pro svuj chod. Proto take vzdy pouzivejte apt-get/aptitude, ktere takove zavislosti resi automaticky a na dpkg se obracejte jen ve vyjimecnych pripadech.

    Ad firefox: Odkud jste se ho pokousel instalovat? Mam takovy pocit, ze jste si stahl jeden balicek z unstable a pres dpkg se ho snazil protlacit do stable systemu. No to pochopitelne nepujde prave proto, ze mu musite dodat jeste knihovny spravnych verzi. Takze do /etc/apt/sources.list si zpatky pridejte odkazy unstable a spustte apt-get update; aptitude install firefox. Odinstalace/instalace/upgrade firefoxu samozrejme v debianu funguje bez problemu.

    13.8.2006 20:32 Pavel
    Rozbalit Rozbalit vše partition - rozsireni disku

    Vlákno bylo přesunuto do samostatné diskuse.

    Založit nové vláknoNahoru

    Tiskni Sdílej: Linkuj Jaggni to Vybrali.sme.sk Google Del.icio.us Facebook

    ISSN 1214-1267   www.czech-server.cz
    © 1999-2015 Nitemedia s. r. o. Všechna práva vyhrazena.