abclinuxu.cz AbcLinuxu.cz itbiz.cz ITBiz.cz HDmag.cz HDmag.cz abcprace.cz AbcPráce.cz
AbcLinuxu hledá autory!
Inzerujte na AbcPráce.cz od 950 Kč
Rozšířené hledání
×

včera 11:33 | Pozvánky

Konference LinuxDays 2017 proběhne o víkendu 7. a 8. října v Praze v Dejvicích v prostorách FIT ČVUT. Konference OpenAlt 2017 proběhne o víkendu 4. a 5. listopadu na FIT VUT v Brně. Organizátoři konferencí vyhlásili CFP (LinuxDays, OpenAlt). Přihlaste svou přednášku nebo doporučte konference známým.

Ladislav Hagara | Komentářů: 0
včera 06:00 | Nová verze

Byla vydána verze 1.3.0 odlehčeného desktopového prostředí Lumina (Wikipedie, GitHub) postaveného nad toolkitem Qt. Z novinek lze zmínit nový motiv ikon nahrazující Oxygen (material-design-[light/dark]) nebo vlastní multimediální přehrávač (lumina-mediaplayer).

Ladislav Hagara | Komentářů: 2
26.6. 17:33 | Bezpečnostní upozornění

Před šesti týdny byly publikovány výsledky bezpečnostního auditu zdrojových kódů OpenVPN a nalezené bezpečnostní chyby byly opraveny ve verzi OpenVPN 2.4.2. Guido Vranken minulý týden oznámil, že v OpenVPN nalezl další čtyři bezpečnostní chyby (CVE-2017-7520, CVE-2017-7521, CVE-2017-7522 a CVE-2017-7508). Nejzávažnější z nich se týká způsobu, jakým aplikace zachází s SSL certifikáty. Vzdálený útočník může pomocí speciálně

… více »
Ladislav Hagara | Komentářů: 1
26.6. 06:55 | Zajímavý projekt

V Edici CZ.NIC vyšla kniha Průvodce labyrintem algoritmů. Kniha je ke stažení zcela zdarma (pdf) nebo lze objednat tištěnou verzi za 339 Kč (připojení přes IPv4) nebo 289 Kč (připojení přes IPv6).

Ladislav Hagara | Komentářů: 6
26.6. 06:33 | Zajímavý software

Byla vydána verze 2.2.0 svobodného správce hesel KeePassXC (Wikipedie). Jedná se o komunitní fork správce hesel KeePassX s řadou vylepšení.

Ladislav Hagara | Komentářů: 0
26.6. 06:11 | IT novinky

Vývojář Debianu Henrique de Moraes Holschuh upozorňuje v diskusním listu debian-devel na chybu v Hyper-Threadingu v procesorech Skylake a Kaby Lake od Intelu. Za určitých okolností může chyba způsobit nepředvídatelné chování systému. Doporučuje se aktualizace mikrokódu CPU nebo vypnutí Hyper-Threadingu v BIOSu nebo UEFI [reddit].

Ladislav Hagara | Komentářů: 0
24.6. 01:23 | Komunita

Phoronix spustil 2017 Linux Laptop Survey. Tento dotazník s otázkami zaměřenými na parametry ideálního notebooku s Linuxem lze vyplnit do 6. července.

Ladislav Hagara | Komentářů: 3
23.6. 22:44 | Nová verze

Po třech měsících vývoje od vydání verze 5.5.0 byla vydána verze 5.6.0 správce digitálních fotografií digiKam (digiKam Software Collection). Do digiKamu se mimo jiné vrátila HTML galerie a nástroj pro vytváření videa z fotografií. V Bugzille bylo uzavřeno více než 81 záznamů.

Ladislav Hagara | Komentářů: 1
23.6. 17:44 | Nová verze

Byla vydána verze 9.3 open source alternativy GitHubu, tj. softwarového nástroje s webovým rozhraním umožňujícího spolupráci na zdrojových kódech, GitLab. Představení nových vlastností v příspěvku na blogu a na YouTube.

Ladislav Hagara | Komentářů: 3
23.6. 13:53 | Nová verze

Simon Long představil na blogu Raspberry Pi novou verzi 2017-06-21 linuxové distribuce Raspbian určené především pro jednodeskové miniaturní počítače Raspberry Pi. Společně s Raspbianem byl aktualizován také instalační nástroj NOOBS (New Out Of the Box Software). Z novinek lze zdůraznit IDE Thonny pro vývoj v programovacím jazyce Python a především offline verzi Scratche 2.0. Ten bylo dosud možné používat pouze online. Offline bylo možné používat pouze Scratch ve verzi 1.4. Z nového Scratchu lze ovládat také GPIO piny. Scratch 2.0 vyžaduje Flash.

Ladislav Hagara | Komentářů: 2
Chystáte se pořídit CPU AMD Ryzen?
 (6%)
 (31%)
 (1%)
 (9%)
 (44%)
 (9%)
Celkem 851 hlasů
 Komentářů: 65, poslední 1.6. 19:16
    Rozcestník

    Dotaz: libstdc++-libc6.1-1.so.2 do FC6

    26.11.2006 11:18 ondre | skóre: 3
    libstdc++-libc6.1-1.so.2 do FC6
    Přečteno: 175×
    Zdravim, mam starsi aplikaci, vyzadujici knihovnu libstdc++-libc6.1-1.so.2. Ta by se mela dat ziskat treba z compat-libstdc++-296-2.96-138.i386.rpm. V FC6 je ale nainstalovana novejsi libstdc++-libc6.2*. Muzete mi prosim poradit jak doinstalovat uvedenou starsi knihovnu? Dodavam ze tu novejsi pouziva mnoho programu, odebrat ji nepujde. Dekuji

    Odpovědi

    26.11.2006 11:31 #Tom | skóre: 32 | blog: Inspirace, aneb co jsem kde vyhrabal
    Rozbalit Rozbalit vše Re: libstdc++-libc6.1-1.so.2 do FC6
    To jsou, mám ten pocit, všechno knihovny od řady GCC 2.95.x (2.96 je jen redhatí zlepšovák). Mohlo by stačit udělat symbolický odkaz pojmenovaný libstdc++-libc6.1-1.so.2 vedoucí na již nainstalovanou knihovnu podobného jména.
    26.11.2006 12:10 ondre | skóre: 3
    Rozbalit Rozbalit vše Re: libstdc++-libc6.1-1.so.2 do FC6
    Diky, zkusil jsem. Instal se ted dostane do jineho chyboveho stavu, chybi mu libXp.so. Zrejme to neni uplne ciste reseni
    26.11.2006 12:57 #Tom | skóre: 32 | blog: Inspirace, aneb co jsem kde vyhrabal
    Rozbalit Rozbalit vše Re: libstdc++-libc6.1-1.so.2 do FC6
    To by s tím nemělo mít nic společného, libXp.so je knihovna XFree86/Xorg.
    26.11.2006 11:33 Petr Šobáň | skóre: 79 | blog: soban | Olomouc
    Rozbalit Rozbalit vše Re: libstdc++-libc6.1-1.so.2 do FC6
    No a co ti brání mět tam i starší verzi knihovny ?

    Buďto nainstaluješ příslušný balíček, nebo pokud se šprajcuje stačí si vytáhnout příslušné knihovny *.so

    PS. Od toho jsou compat balíčky takže fizicky stačí doinstalovat normálně compat balíček - pokud potřebuješ i starší knihovny jak je v distribuci vememe ze starší distribuce zase compat balíček.
    26.11.2006 12:08 ondre | skóre: 3
    Rozbalit Rozbalit vše Re: libstdc++-libc6.1-1.so.2 do FC6
    Diky za tip, tohle jsem zkousel. Upozorni me ze soubory z instalovaneho baliku koliduji s jiz nainstalovanymi-novejsimi. Jak to obejit - nevim
    26.11.2006 14:10 Petr Šobáň | skóre: 79 | blog: soban | Olomouc
    Rozbalit Rozbalit vše Re: libstdc++-libc6.1-1.so.2 do FC6
    Tak tam ty soubory již jsou takže vzít starší compat balíček.

    A nebo pokud program vyžaduje stejné hlavní číslo a pouze nějakou podverzi tak ten soubor vytáhnout z balíčku - soubor.so a přidat ho ručně.

    Jinak pokud tam ten compat balíček je tak by to mělo fungovat nebo potřebuješ nějakej ještě starší compat balíček.

    compat balíčky pro FC můžou být nainstalovány všechny zároveň samozřejmě nejdou nainstalovat stejné - prostě postupuje se stylem mám FC6 potřebuji compat balíček pro starší program vemu nejnovější balíček compat z FC6 chce to starší vemu nejnovější compat z FC5 ....nejnovější compat z FC4 ......

    Jinak co ti ten program přesně napsal je možné že chybí pouze link na tu knihovnu
    lrwxrwxrwx 1 root root      12 zář 26 18:12 libattr.so -> libattr.so.1
    lrwxrwxrwx 1 root root      16 zář 23 14:10 libattr.so.1 -> libattr.so.1.1.0
    -rwxr-xr-x 1 root root   14488 čec 12 08:52 libattr.so.1.1.0
    
    Někdy se stane že program hledá třeba libattr.so.1.1

    Což tam není tak udělat link na libattr.so.1.1.0

    Nebo se někdy hledá libattr.so.1.0 udělat link na libattr.so.1.1.0 atd....

    Pokud se neliší hlavní číslo tak většinou to novější knihovna umí obsloužit.

    Prostě by to chtělo tu chybu sem napsat a taky výpis těch verzí knihoven co tam máš se stejným názvem.
    26.11.2006 13:57 miro | skóre: 18 | blog: miro
    Rozbalit Rozbalit vše Re: libstdc++-libc6.1-1.so.2 do FC6
    Toto ma vie tiez dobre nazlostit.
    Jednoducho kniznica vyssieho cisla by mala byt automaticky spatne kompatibilna s nizsimi verziami. Inak potom nechapem prinos update a pod...
    26.11.2006 14:19 Petr Šobáň | skóre: 79 | blog: soban | Olomouc
    Rozbalit Rozbalit vše Re: libstdc++-libc6.1-1.so.2 do FC6
    Ono to tak je pokud se nemění hlavní číslo.

    Problém někdy bývá že program někdy natvrdo hledá soubor s knihovnou třeba knihovna.so.1.1.3 a ty tam máš novější knihovna.so.1.1.4 takže tam musíš udělat link který bude mít název knihovna.so.1.1.3 a bude ukazovat na knihovna.so.1.1.4.

    Pokud by program vyžadoval knihovna.so.1 tak to bude fungovat neboť většinou tam máš už link se jménem knihovna.so.1 který ukazuje na aktuální knihovna.so.1.1.4.

    Prostě problém je v tom že někteří programátoři jsou prasata a vyžadují přesně tu jednu knihovnu verze 1.1.3 a nezajímá je že máš 1.1.4 která je 100% kompatibilní a pouze jsou v ní nějaké kosmetické věci.

    Jinak pokud jsou mezi knihovnamy velké změny tak musíš potom mět nainstalované obě a to jsou právě kompatibilní balíčky které mají starší knihovny a potom nic nebrání tomu aby jsi měl obě knihovny v OS jak třeba knihovna.so.1.1.4 i knihovna.so.1.1.3
    27.11.2006 09:27 ondre | skóre: 3
    Rozbalit Rozbalit vše Re: libstdc++-libc6.1-1.so.2 do FC6
    Diky vam, symbolicky link na novou knihovnu po prejmenovani tak, aby se tvaril jako stara verze zafungoval/po dodani libXp.
    Mel bych ale jeste jeden dotaz:
    Ten program /maple9/ funguje jen tehdy, pokud mam v /etc/modprobe.conf toto: alias ipv6 off
    To ale zpusobi fatal error pri nabihani systemu, FC hlasi ze jadro neni kompilovane s podporou IPV6. Nicmene to nabehne. Nevite co vlastne dela ipv6?
    Dekuji
    27.11.2006 15:42 miro | skóre: 18 | blog: miro
    Rozbalit Rozbalit vše Re: libstdc++-libc6.1-1.so.2 do FC6
    IPv6 je nova verzia adresovania zariadeni na internete. Obsiahne omnoho viac adries, nez tomu bolo doteraz (IPv4?)

    Založit nové vláknoNahoru

    Tiskni Sdílej: Linkuj Jaggni to Vybrali.sme.sk Google Del.icio.us Facebook

    ISSN 1214-1267   www.czech-server.cz
    © 1999-2015 Nitemedia s. r. o. Všechna práva vyhrazena.