abclinuxu.cz AbcLinuxu.cz itbiz.cz ITBiz.cz HDmag.cz HDmag.cz abcprace.cz AbcPráce.cz
AbcLinuxu hledá autory!
Inzerujte na AbcPráce.cz od 950 Kč
Rozšířené hledání
×
včera 22:00 | Komunita

Portál Stack Overflow po roce opět vyzpovídal své uživatele, jedná se především o vývojáře softwaru, a zveřejnil (podcast) detailní výsledky průzkumu. Průzkumu se letos zúčastnilo více než 64 tisíc vývojářů. Jejich nejmilovanější platformou je linuxový desktop. Ten je také druhou nejpoužívanější platformou vývojářů.

Ladislav Hagara | Komentářů: 1
24.3. 11:55 | Komunita

Vývojový tým OpenSSL ve spolupráci s iniciativou Core Infrastructure konsorcia Linux Foundation spustil proces přelicencování této kryptografické knihovny ze současné licence na licenci Apache Licence v 2.0 (ASLv2). Nová licence usnadní začleňování OpenSSL do dalších svobodných a open source projektů. Všichni dosavadní vývojáři OpenSSL (Authors) obdrží v následujících dnech email s prosbou o souhlas se změnou licence.

Ladislav Hagara | Komentářů: 21
24.3. 01:11 | Komunita

Před třemi týdny Mozilla.cz představila projekt Photon, jehož cílem je návrh a implementace nového vzhledu Firefoxu. Včera zveřejnila první náhled vzhledu Photon. Práce na projektu Photon jsou rozděleny do pěti týmů, které celkem čítají 19 lidí. Zaměřují se na zlepšení prvního spuštění Firefoxu a zaujetí nových uživatelů, celkovou úpravu vzhledu, zlepšení animací, zrychlení odezvy uživatelského rozhraní a také upravení nabídek. Vývoj lze sledovat v Bugzille.

Ladislav Hagara | Komentářů: 44
23.3. 20:00 | Komunita

OneDrive pro firmy je již ve webových prohlížečích na Linuxu stejně rychlý jako na Windows. Microsoft opravil chybu z listopadu loňského roku. OneDrive pro firmy běžel na Linuxu mnohem pomaleji než na Windows. V popisu chyby bylo uvedeno, že stačilo v prohlížeči na Linuxu nastavit v user-agentu Windows a vše se zrychlilo. Odpovědí Microsoftu bylo (Internet Archive: Wayback Machine), že Linux není podporován. Po bouřlivých diskusích na redditu i Hacker News byla chyba nalezena a opravena.

Ladislav Hagara | Komentářů: 6
23.3. 19:00 | Zajímavý projekt

Byla vyhlášena soutěž Hackaday Prize 2017. Soutěž je určena vývojářům open source hardwaru. Pro výherce je připraveno celkově 250 tisíc dolarů. Každý ze 120 finalistů získá tisíc dolarů. Nejlepší pak navíc 50, 30, 20, 15, 10 a 5 tisíc dolarů. Jedná se již o čtvrtý ročník soutěže. V roce 2014 zvítězil projekt globální sítě open source pozemních satelitních stanic SatNOGS. V roce 2015 zvítězil open source systém pro řízení elektrických invalidních vozíků pohybem očí Eyedriveomatic. V roce 2016 zvítězil modulární robot Dtto.

Ladislav Hagara | Komentářů: 0
23.3. 15:00 | Bezpečnostní upozornění

Byla vydána Samba ve verzích 4.6.1, 4.5.7 a 4.4.12. Řešen je bezpečnostní problém CVE-2017-2619. Pomocí symbolických odkazů a souběhu (symlink race) lze "teoreticky" získat přístup k souborům, které nejsou sdíleny. Linuxové distribuce jsou postupně aktualizovány (Debian).

Ladislav Hagara | Komentářů: 0
23.3. 07:43 | Nová verze

Na Steamu se objevil port hry Arma: Cold War Assault (Operation Flashpoint) pro Mac a Linux. … více »

creon | Komentářů: 30
23.3. 05:55 | Nová verze

Po 18 měsících od vydání verze 8.0 byla vydána verze 9.0 open source alternativy GitHubu, tj. softwarového nástroje s webovým rozhraním umožňujícího spolupráci na zdrojových kódech, GitLab. Představení nových vlastností v příspěvku na blogu a na YouTube.

Ladislav Hagara | Komentářů: 0
23.3. 03:33 | Komunita

Platnost posledního patentu souvisejícího s Dolby Digital (AC-3) vypršela. Po MP3 se tak do Fedory oficiálně dostane také kodek AC-3.

Ladislav Hagara | Komentářů: 5
23.3. 00:44 | Komunita

Feral Interactive, společnost zabývající se vydáváním počítačových her pro operační systémy macOS a Linux, nabízí své hry na Steamu vývojářům open source 3D grafické knihovny Mesa zdarma. Podmínkou je minimálně 25 commitů za posledních 5 let. Stejnou nabídku dostali vývojáři knihovny Mesa v roce 2015 od Valve. O rok dříve dostali od Valve tuto nabídku vývojáři Debianu a Ubuntu.

Ladislav Hagara | Komentářů: 0
Jak se stavíte k trendu ztenčování přenosných zařízení (smartphony, notebooky)?
 (14%)
 (2%)
 (71%)
 (3%)
 (10%)
Celkem 937 hlasů
 Komentářů: 72, poslední 1.3. 11:16
    Rozcestník

    Dotaz: ATI -Radeon, fglrx, istalacia, aticonfig fault,

    19.8.2008 00:16 faidron | skóre: 16
    ATI -Radeon, fglrx, istalacia, aticonfig fault,
    Přečteno: 1200×
    compaq:/home/ondro/Download # ./ati-driver-installer-8.28.8.run 
    
    Creating directory fglrx-install
    
    Verifying archive integrity... All good.
    
    Uncompressing ATI Proprietary Linux Driver-8.28.8.....................................................................................................................................................................................................................................................................................................................................................................................................................................................................................
    
    ==================================================
    
     ATI Technologies Linux Driver Installer/Packager 
    
    ==================================================
    
    Detected configuration:
    
    Architecture: i686 (32-bit)
    
    which: no XFree86 in (/sbin:/usr/sbin:/usr/local/sbin:/root/bin:/usr/local/bin:/usr/bin:/bin:/usr/bin/X11:/usr/X11R6/bin:/usr/games:/opt/kde3/bin:/usr/lib/jvm/jre/bin:/usr/lib/mit/bin:/usr/lib/mit/sbin)
    
    X Server: unable to detect
    Removing temporary directory: fglrx-install
    
    -----------------------------------------------------
    
    compaq:/home/ondro/Download # zypper in XFree86
    
    Reading installed packages...
    
    'xorg-x11' providing 'XFree86' is already installed.
    
    Nothing to do.
    
     -------------------------------------------------------
    
    Ja mam naistalovane toto:
    compaq:/home/ondro/Download # zypper se ati
    
    Reading installed packages...
    
    i | OpenOffice_org-templates-presentation-layouts | Presentation Lay-> | package
    
    i | ati-fglrxG01-kmp-debug                        | ATI "fglrx" driv-> | package
    
    i | ati-fglrxG01-kmp-default                      | ATI "fglrx" driv-> | package
    
    i | ati-fglrxG01-kmp-pae                          | ATI "fglrx" driv-> | package
    
    i | atitvout                                      | Tool for Control-> | package
    
      | audacious-plugins-visualization-paranormal    | Paranormal Visua-> | package
    
    
    -----------------------------------------------------

    A ked spustim toto:
    compaq:/home/ondro/Download # aticonfig --initial --input=/etc/X11/xorg.conf
    
    Uninitialised file found, configuring.
    
    Segmentation fault
    
    
    -----------------------------------------------------

    Moj modul RADEON:
    compaq:/home/ondro/Download # lsmod | grep radeon
    
    radeon                140036  3 
    
    drm                    98200  4 radeon
    
    
    ----------------------------------------------------- Moja karta:
    compaq:/home/ondro/Download # lspci
    
    00:00.0 Host bridge: ATI Technologies Inc RS200/RS200M AGP Bridge [IGP 340M] (rev 02)
    
    00:01.0 PCI bridge: ATI Technologies Inc PCI Bridge [IGP 340M]
    
    01:05.0 VGA compatible controller: ATI Technologies Inc Radeon IGP 330M/340M/350M
    
    
    ----------------------------------------------------- Chcel by som fglrx modul namiesto radeon .

    Preco to nejde standardne nainstalovat? Xfree86 missing?

    Neviem si rady, kde zacat.

    Odpovědi

    19.8.2008 15:30 faidron | skóre: 16
    Rozbalit Rozbalit vše Re: ATI -Radeon, fglrx, istalacia, aticonfig fault,
    Nik nepise,ale snazim sa prist a to preco, ci nie je nik kto podobny poblem riesil, alebo nikdo nerozumie oco vlastne ide. Ja by som bol rad k by mi nikedo pomohol. Schcem naistalovat ATI driver fglrx cez:

    ati-driver-installer-8.28.8.run

    ale vyhadzuje mi chybu:
    which: no XFree86 in directories
    
    X Server: unable to detect
    Removing temporary directory: fglrx-install
    
    Co s tymnetusim, ale niekdo by mohol vediet, preto som tu dal cele vypisy toho ako je moj system na grafiku nakonfigurovany.
    19.8.2008 16:38 Phantom Alien | skóre: 18 | blog: Kelvin_Fitnick | Doma
    Rozbalit Rozbalit vše Re: ATI -Radeon, fglrx, istalacia, aticonfig fault,
    Tvoje distribuce nemá balíčkovací systém? Podle zmínek o zypperu usuzuju, že budeš mít OpenSuse. Proč se snažíš instalovat se staženého instalátoru, když jde nainstalovat v Suse ovladače pro ati na pár kliknutí v yastu? Možná pro to máš nějaký důvod, to já nevim. Rozhodně bych touto cestou nezačínal.
    Tahle patička nemá hlavu ani patu
    19.8.2008 22:36 faidron
    Rozbalit Rozbalit vše Re: ATI -Radeon, fglrx, istalacia, aticonfig fault,
    Mam Open Suse 11, a som prekvapenymnoymi vylepseniami napr. zypper Ten vypis som urobil na OS aby bolo zrejme ktore balicky mam nainstalovane. Ja som to skusal cez ten run installer, koli tomu ze ak si dam na OS tento prikaz vypise toto a ja vobec neviem preco sa neda fglrx modul zkompilovat.
    compaq:/etc/X11 # aticonfig --initial
    Uninitialised file found, configuring.
    Segmentation fault
    
    A hned potom co zadam : sax2 -r -m 0=fglrx ; zahlasi chybu a pozrite si log:

    /var/log/Xorg.99.log
    (II) LoadModule: "record"
    (II) Loading /usr/lib/xorg/modules//extensions/librecord.so
    (II) Module record: vendor="X.Org Foundation"
    	compiled for 1.4.0.90, module version = 1.13.0
    	Module class: X.Org Server Extension
    	ABI class: X.Org Server Extension, version 0.3
    (II) Loading extension RECORD
    (II) LoadModule: "fglrx"
    (II) Loading /usr/lib/xorg/modules//drivers/fglrx_drv.so
    (II) Module fglrx: vendor="FireGL - ATI Technologies Inc."
    	compiled for 7.1.0, module version = 8.51.3
    	Module class: X.Org Video Driver
    (II) LoadModule: "kbd"
    (II) Loading /usr/lib/xorg/modules//input/kbd_drv.so
    (II) Module kbd: vendor="X.Org Foundation"
    	compiled for 1.4.0.90, module version = 1.3.1
    	Module class: X.Org XInput Driver
    	ABI class: X.Org XInput driver, version 2.0
    (II) LoadModule: "mouse"
    (II) Loading /usr/lib/xorg/modules//input/mouse_drv.so
    (II) Module mouse: vendor="X.Org Foundation"
    	compiled for 1.4.0.90, module version = 1.3.0
    	Module class: X.Org XInput Driver
    	ABI class: X.Org XInput driver, version 2.0
    (II) LoadModule: "synaptics"
    (II) Loading /usr/lib/xorg/modules//input/synaptics_drv.so
    (II) Module synaptics: vendor="X.Org Foundation"
    	compiled for 4.3.99.902, module version = 1.0.0
    	Module class: X.Org XInput Driver
    	ABI class: X.Org XInput driver, version 2.0
    (II) Primary Device is: PCI 01:05:0
    (II) ATI Proprietary Linux Driver Version Identifier:8.51.3
    (II) ATI Proprietary Linux Driver Release Identifier: UNSUPPORTED-8.512                    
    (II) ATI Proprietary Linux Driver Build Date: Jul  3 2008 22:50:40
    (--) Assigning device section with no busID to primary device
    (EE) No devices detected.
    
    Fatal server error:
    no screens found
    compaq:~ # 
    
    19.8.2008 22:43 faidron
    Rozbalit Rozbalit vše Re: ATI -Radeon, fglrx, istalacia, aticonfig fault,
    Ach samozrejme tu chybu zahlasi lebo ziaden modul sa v adresaty nenechadza je tam len: fglrx_drv.so ale chyba mu fglrx_drv.la A moul nevie bezpecne zavies.

    Cize ako to vytvorit.
    20.8.2008 00:22 faidron | skóre: 16
    Rozbalit Rozbalit vše Re: ATI -Radeon, fglrx, istalacia, aticonfig fault,
    http://www.linuxquestions.org/questions/linux-software-2/ati-segmentation-fault-554958/

    nasiel som odpoved na podobnz problem. Trba editovat xorg.conf, autor uz vsak nepise ze ako?
    20.8.2008 08:12 Davule | skóre: 11 | blog: BANANOVI_TUCNACI
    Rozbalit Rozbalit vše Re: ATI -Radeon, fglrx, istalacia, aticonfig fault,

    Musíš použít nějaký editor. Který Tvoje distro má. OpenSuse používá tuším NANO.

    celý příkaz pro editaci by vypadal takto :

    nano -w /etc/X11/xorg.conf

    Zrovna ale řeším svoji atinu HD3870 a vím, že je v tom docela chaos

    Nejlepší manuály jsou na wiki

    Já nemám ve svém distru (Gentoo) YAST, takže jsem stáhnul ze stránek ATI ovladač pro svoji grafiku, spustil příkazem "sh ati-xxxxxxxx" a bylo hotovo. Ten instalátor sám nastaví i xorg.conf a je funkční vše i s 3D axcelerací. To mám ověřeno testy. Bohužel dle mojeho názoru nenastavil xorg.conf zrovna nejlépe, takže mi třeba COMPIZ jede hodně pomalu a s chybama (jako třeba že nemám okraje oken). Návodů je na netu hodně, ale výsledek je pořád stejný, ať použiju jakýkoliv

    Já bych postupoval tak, že bych stáhnul ovladač z www.ati.com a nainstaloval příkazem sh ati-xxxxx

    Bude všechno funkční a můžeš bádat (nebo spíš tápat jako já) dál co tomu chybí

    Napiš ještě jakou máš grafiku a drž se

    Dokumentace je pro blbce!! Já jsem BLBEC!!
    20.8.2008 08:38 Davule | skóre: 11 | blog: BANANOVI_TUCNACI
    Rozbalit Rozbalit vše Re: ATI -Radeon, fglrx, istalacia, aticonfig fault,

    Ještě mně s tou editací napadlo (dnes mám plodný den :-) ) spustit MCommander příkazem "mc". Když jsem používal Suse, tak tam byl. najet do adresáře /etc/X11, najít xorg.conf a zmáčknout F4 pro editaci. Je to dost pohodlné, ikdyž v tomhle případě je rychlejší nano.

    Dokumentace je pro blbce!! Já jsem BLBEC!!
    20.8.2008 09:42 pet
    Rozbalit Rozbalit vše Re: ATI -Radeon, fglrx, istalacia, aticonfig fault,
    Na Gentoo se ati-drivers správně instalují takto:
    Který driver mají Xka používat :
    /etc/make.conf: VIDEO_CARDS="fglrx"
    
    Na mém AMD chci poslední vydané drivery:
    /etc/portage/package.keywords:x11-drivers/ati-drivers ~amd64
    
    Ale ne úplně poslední, protože ty nefungují se dvěma velkými monitory:
    /etc/portage/package.mask:=x11-drivers/ati-drivers-8.493
    /etc/portage/package.mask:=x11-drivers/ati-drivers-8.501
    
    Kompilace / rekomlilace:
    emerge -1 xorg-server
    
    20.8.2008 12:14 Davule | skóre: 11 | blog: BANANOVI_TUCNACI
    Rozbalit Rozbalit vše Re: ATI -Radeon, fglrx, istalacia, aticonfig fault,

    Tazatel používá SUSE, ale když jste nakousli moje Gentoo, tak se zeptám, jestli pro AMD64 X2; Radeon HD je lepší driver "xglrx", nebo "radeonhd"

    Někdo píše fglrx a někdo radeonhd

    http://www.abclinuxu.cz/show/236130

    Dokumentace je pro blbce!! Já jsem BLBEC!!
    20.8.2008 16:05 pet
    Rozbalit Rozbalit vše Re: ATI -Radeon, fglrx, istalacia, aticonfig fault,
    Tazateli jsem odpověděl jinde ;-) .

    Já používám fglrx protože mám Radeon Xpress 1150. Ve fglrx jsou chyby a pokud vím tak radeonhd ještě není hotový, takže záleží na tom se kterým Vaše karta lépe splní Vaše požadavky.
    20.8.2008 09:18 pet
    Rozbalit Rozbalit vše Re: ATI -Radeon, fglrx, istalacia, aticonfig fault,
    
    (II) LoadModule: "fglrx"
    (II) Loading /usr/lib/xorg/modules//drivers/fglrx_drv.so
    (II) Module fglrx: vendor="FireGL - ATI Technologies Inc."
    	compiled for 7.1.0, module version = 8.51.3
    	Module class: X.Org Video Driver
    ...
    (II) Primary Device is: PCI 01:05:0
    (II) ATI Proprietary Linux Driver Version Identifier:8.51.3
    (II) ATI Proprietary Linux Driver Release Identifier: UNSUPPORTED-8.512                    
    (II) ATI Proprietary Linux Driver Build Date: Jul  3 2008 22:50:40
    (--) Assigning device section with no busID to primary device
    (EE) No devices detected.
    
    Fatal server error:
    no screens found
    
    Modul fglrx je zaveden, ale nenašel grafiku. Zřejmě máte ATInu, která není tímto driverem podporována.
    20.8.2008 10:52 faidron | skóre: 16
    Rozbalit Rozbalit vše Re: ATI -Radeon, fglrx, istalacia, aticonfig fault,
    Modul fglrx je zaveden, ale nenašel grafiku. Zřejmě máte ATInu, která není tímto driverem podporována.
    VGA compatible controller: ATI Technologies Inc Radeon IGP 330M/340M/350M
    
    mam ATI a tym ze nie je podporovana by problem bol vyrieseny, tak to tym nejde nainstalovat Myslite ze buduci notebook je lepsie kupit s ATI alebo nvidia?
    20.8.2008 15:58 pet
    Rozbalit Rozbalit vše Re: ATI -Radeon, fglrx, istalacia, aticonfig fault,
    Já mám s ATInama téměř vše včetně notebooku ;-) . Na některé starší ATIny je potřeba použít starší fglrx nebo otevřené drivery od Xorg. Ta vaše starší je: http://www.thinkwiki.org/wiki/ATI_Radeon_IGP_330M
    13.11.2008 00:30 ernie
    Rozbalit Rozbalit vše Re: ATI -Radeon, fglrx, istalacia, aticonfig fault,
    Mám podobný problém s ATI RADEON HD4830 Ati se chvástá, že řada 4800 je ve fglrx podporována ...

    Založit nové vláknoNahoru

    Tiskni Sdílej: Linkuj Jaggni to Vybrali.sme.sk Google Del.icio.us Facebook

    ISSN 1214-1267   www.czech-server.cz
    © 1999-2015 Nitemedia s. r. o. Všechna práva vyhrazena.