abclinuxu.cz AbcLinuxu.cz itbiz.cz ITBiz.cz HDmag.cz HDmag.cz abcprace.cz AbcPráce.cz
AbcLinuxu hledá autory!
Inzerujte na AbcPráce.cz od 950 Kč
Rozšířené hledání
×
eParkomat, startup z ČR, postoupil mezi finalisty evropského akcelerátoru ChallengeUp!
Robot na pivo mu otevřel dveře k opravdovému byznysu
Internet věcí: Propojený svět? Už se to blíží...
dnes 15:00 | Zajímavý software

Stop motion je technika animace, při níž je reálný objekt mezi jednotlivými snímky ručně upravován a posouván o malé úseky, tak aby po spojení vyvolala animace dojem spojitosti. Jaký software lze pro stop motion použít na Linuxu? Článek na OMG! Ubuntu! představuje Heron Animation. Ten bohužel podporuje pouze webové kamery. Podpora digitálních zrcadlovek je začleněna například v programu qStopMotion.

Ladislav Hagara | Komentářů: 0
včera 21:21 | Nová verze Ladislav Hagara | Komentářů: 0
včera 11:44 | Zajímavý projekt

Na Indiegogo byla spuštěna kampaň na podporu herní mini konzole a multimediálního centra RetroEngine Sigma od Doyodo. Předobjednat ji lze již od 49 dolarů. Požadovaná částka 20 000 dolarů byla překonána již 6 krát. Majitelé mini konzole si budou moci zahrát hry pro Atari VCS 2600, Sega Genesis nebo NES. Předinstalováno bude multimediální centrum Kodi.

Ladislav Hagara | Komentářů: 0
včera 00:10 | Nová verze

Byla vydána verze 4.7 redakčního systému WordPress. Kódové označením Vaughan bylo vybráno na počest americké jazzové zpěvačky Sarah "Sassy" Vaughan. Z novinek lze zmínit například novou výchozí šablonu Twenty Seventeen, náhledy pdf souborů nebo WordPress REST API.

Ladislav Hagara | Komentářů: 4
6.12. 12:00 | Zajímavý projekt

Projekt Termbox umožňuje vyzkoušet si linuxové distribuce Ubuntu, Debian, Fedora, CentOS a Arch Linux ve webovém prohlížeči. Řešení je postaveno na projektu HyperContainer. Podrobnosti v často kladených dotazech (FAQ). Zdrojové kódy jsou k dispozici na GitHubu [reddit].

Ladislav Hagara | Komentářů: 27
6.12. 11:00 | Bezpečnostní upozornění

Byly zveřejněny informace o bezpečnostní chybě CVE-2016-8655 v Linuxu zneužitelné k lokální eskalaci práv. Chyba se dostala do linuxového jádra v srpnu 2011. V upstreamu byla opravena minulý týden [Hacker News].

Ladislav Hagara | Komentářů: 2
5.12. 22:00 | Komunita

Přibližně před měsícem bylo oznámeno, že linuxová distribuce SUSE Linux Enterprise Server (SLES) běží nově také Raspberry Pi 3 (dokumentace). Obraz verze 12 SP2 pro Raspberry Pi 3 je ke stažení zdarma. Pro registrované jsou po dobu jednoho roku zdarma také aktualizace. Dnes bylo oznámeno, že pro Raspberry Pi 3 je k dispozici také nové openSUSE Leap 42.2 (zprávička). K dispozici je hned několik obrazů.

Ladislav Hagara | Komentářů: 6
5.12. 06:00 | Zajímavý software

OMG! Ubuntu! představuje emulátor terminálu Hyper (GitHub) postavený na webových technologiích (HTML, CSS a JavaScript). V diskusi k článku je zmíněn podobný emulátor terminálu Black Screen. Hyper i Black Screen používají framework Electron, stejně jako editor Atom nebo vývojové prostředí Visual Studio Code.

Ladislav Hagara | Komentářů: 50
5.12. 06:00 | Zajímavý článek

I letos vychází řada ajťáckých adventních kalendářů. QEMU Advent Calendar 2016 přináší každý den nový obraz disku pro QEMU. Programátoři se mohou potrápit při řešení úloh z kalendáře Advent of Code 2016. Kalendáře Perl Advent Calendar 2016 a Perl 6 Advent Calendar přinášejí každý den zajímavé informace o programovacím jazyce Perl. Stranou nezůstává ani programovací jazyk Go.

Ladislav Hagara | Komentářů: 10
3.12. 16:24 | Nová verze

Byla vydána Mageia 5.1. Jedná se o první opravné vydání verze 5, jež vyšla v červnu loňského roku (zprávička). Uživatelům verze 5 nepřináší opravné vydání nic nového, samozřejmě pokud pravidelně aktualizují. Vydání obsahuje všechny aktualizace za posledního téměř půldruhého roku. Mageia 5.1 obsahuje LibreOffice 4.4.7, Linux 4.4.32, KDE4 4.14.5 nebo GNOME 3.14.3.

Ladislav Hagara | Komentářů: 17
Kolik máte dat ve svém domovském adresáři na svém primárním osobním počítači?
 (32%)
 (24%)
 (29%)
 (7%)
 (5%)
 (3%)
Celkem 790 hlasů
 Komentářů: 50, poslední 29.11. 15:50
Rozcestník
Reklama

Dotaz: ath wifi deb

2.4.2009 21:45 meydlo
ath wifi deb
Přečteno: 492×

dobry den

Novonainstalovany debian 2.6.26-1-amd64. A problem pripojit sa na AP

pri mandrive 2008 a 2009 mi vsetko slo v pohode... mam ju tiez nainstalovanu preto by som sa chcel spytat ci nieje mozne preniest nejake nastavenia...

iwconfig pod mandrivou>

wlan0     IEEE 802.11bg  ESSID:"none" 
          Mode:Managed  Frequency:2.462 GHz  Access Point: 00:4F:67:02:EE:30  
          Bit Rate=24 Mb/s   Tx-Power=20 dBm  
          Retry min limit:7   RTS thr:off   Fragment thr=2352 B  
          Encryption key:abcd-efgh-ij   Security mode:open
          Power Management:off
          Link Quality=62/100  Signal level:-62 dBm  Noise level=-102 dBm
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0
 

isconfig na deb>

wlan0     IEEE 802.11  ESSID:"none" 
          Mode:Managed  Frequency:2.412 GHz  Access Point: Not-Associated  
          Tx-Power=20 dBm  
          Retry min limit:7   RTS thr:off   Fragment thr=2352 B  
          Encryption key:off
          Link Quality:0  Signal level:0  Noise level:0
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0
 

> na deb. mi nenajde ziadnu siet pricom ich je tu perdo..:-/...

aneb co s tim?  dakujem

Odpovědi

vencour avatar 2.4.2009 21:54 vencour | skóre: 55 | blog: Tady je Vencourovo | Praha+západní Čechy
Rozbalit Rozbalit vše Re: ath wifi deb

Je to modul ath5k? Jak se tváří "ip link"? Občas je nutné dát link up ... tedy "ip link set wlan0 up" a pak teprve uvidíte výsledek hledání v "iwlist wlan0 scan". Nevim proč přesně, jestli to má souvislost se supsendem, občas mi pomůže až odebrání/přidání modulu, používam skripty místo network managera. Používam gentoo a jádro 2.6.28 a 2.6.29.

Ty nejhlubší objevy nečekají nutně za příští hvězdou. Jsou uvnitř nás utkány do vláken, která nás spojují, nás všechny.
2.4.2009 22:02 meydlo
Rozbalit Rozbalit vše Re: ath wifi deb

debian:/home/meydlo# ip link set wlan0 up
debian:/home/meydlo# iwlist wlan0 scan
wlan0     No scan results
 

kozzi avatar 2.4.2009 22:03 kozzi | skóre: 55 | blog: vse_o_vsem | Pacman (Bratrušov)
Rozbalit Rozbalit vše Re: ath wifi deb
co mas za wifi? Jak si to zkousel nastavit? Jak nenajde? Jak si zkouselvyhledat site? Bud konkretnejsi
Linux je jako mušketýři "jeden za všechny, všichni za jednoho"
kozzi avatar 2.4.2009 22:04 kozzi | skóre: 55 | blog: vse_o_vsem | Pacman (Bratrušov)
Rozbalit Rozbalit vše Re: ath wifi deb
nejlepe sem hod vypis prikazu lspci
Linux je jako mušketýři "jeden za všechny, všichni za jednoho"
vencour avatar 2.4.2009 22:24 vencour | skóre: 55 | blog: Tady je Vencourovo | Praha+západní Čechy
Rozbalit Rozbalit vše Re: ath wifi deb

Plus dmesg by mohlo pomoct.

Ty nejhlubší objevy nečekají nutně za příští hvězdou. Jsou uvnitř nás utkány do vláken, která nás spojují, nás všechny.
3.4.2009 14:29 meydlo
Rozbalit Rozbalit vše Re: ath wifi deb

meydlo@debian:~$ lspci|grep -i ath
03:00.0 Ethernet controller: Atheros Communications Inc. AR242x 802.11abg Wireless PCI Express Adapter (rev 01)
 

 

3.4.2009 14:48 meydlo
Rozbalit Rozbalit vše Re: ath wifi deb

nevim ci toto bude spravne co si chcel ale snad;)

meydlo@debian:~$ dmesg|grep -i wlan
[   24.939084] ADDRCONF(NETDEV_UP): wlan0: link is not ready

meydlo@debian:~$ dmesg|grep -i ath
[    9.563367] ath5k_pci 0000:03:00.0: registered as 'phy0'
[    9.567745] ath5k phy0: Support for RF2425 is under development.
[    9.755448] ath5k phy0: Atheros AR2425 chip found (MAC: 0xe2, PHY: 0x70)
 

kozzi avatar 3.4.2009 15:33 kozzi | skóre: 55 | blog: vse_o_vsem | Pacman (Bratrušov)
Rozbalit Rozbalit vše Re: ath wifi deb
JJ mam stejnou wifi. Jediny co nechapu je ze behem asi tak posledniho mesice ci dvou jsem o teto karte psal snad 20krat jak ji zprovoznit a stale lidi nejsou schopni si na to najit odpoved a museji se ptat dokola :-D. U teto wifi je potreba pouzivat jadra aspon ve verzi 2.6.27, takze nejlepe jadro 2.6.28. Pripadne si muzes nainstalovat ovladac madwifi, ale ne normalni ale tento upraveny ktery obsahuje podporu pro tvoji wifi. http://snapshots.madwifi-project.org/madwifi-hal-0.10.5.6/madwifi-hal-0.10.5.6-r3968-20090402.tar.gz
Linux je jako mušketýři "jeden za všechny, všichni za jednoho"
3.4.2009 19:16 meydlo
Rozbalit Rozbalit vše Re: ath wifi deb

dakujem za vibornu odpoved :)

len ja predsa to nevim poriesit....

# make clear
/bin/sh: line 0: cd: /lib/modules/2.6.26-1-amd64/build: Adresár alebo súbor neexistuje
Makefile.inc:66: *** /lib/modules/2.6.26-1-amd64/build is missing, please set KERNELPATH.  Stop.

(vasa odpoved bude zniet ze citaj nastav si kernelpath ale.. ako a kde?) [ako > nech pls nieje odpoved ako 'root' a cez 'gedit']

dakujem ze sa problem pohol pekne doprdu:)
 

vencour avatar 3.4.2009 19:39 vencour | skóre: 55 | blog: Tady je Vencourovo | Praha+západní Čechy
Rozbalit Rozbalit vše Re: ath wifi deb

Já to zdůraznim: Vaše karta je podporovaná až od jádra 2.6.28, případně s ovladačem od madwifi.

Ty nejhlubší objevy nečekají nutně za příští hvězdou. Jsou uvnitř nás utkány do vláken, která nás spojují, nás všechny.
3.4.2009 22:12 meydlo
Rozbalit Rozbalit vše Re: ath wifi deb

ja som si stiahol driver z linku ktory tu hodil kozzi a toto je vypis ked som ho chcel instalovat;) (=> madwiifi)

vencour avatar 3.4.2009 22:29 vencour | skóre: 55 | blog: Tady je Vencourovo | Praha+západní Čechy
Rozbalit Rozbalit vše Re: ath wifi deb

Budiž. V souboru install je návod na postup ...

  $ export KERNELPATH=/usr/src/linux-2.6.3
  $ make
atd.

Ty nejhlubší objevy nečekají nutně za příští hvězdou. Jsou uvnitř nás utkány do vláken, která nás spojují, nás všechny.
3.4.2009 20:18 crt
Rozbalit Rozbalit vše Re: ath wifi deb

pre nedavnom som riesil nieco take,ta ista karta a chovala sa podobne,scan bez vysledkov...kazdopadne nove jadro a bolo treba ju zapnut v /sys/devices/platform/nieco ...

 

kozzi avatar 3.4.2009 22:54 kozzi | skóre: 55 | blog: vse_o_vsem | Pacman (Bratrušov)
Rozbalit Rozbalit vše Re: ath wifi deb
nemáš nainstalované hlavičkové soubory. Takže si nainstaluj balíčke linux-headers ci tak nejak. Mozna kernel-headers. pak by ti to melo fungovat. Staci pak zadat make a jako root pak zadat make install. A mozan bude zapotrebi jeste zakazat aby se pouzival ten ath5k. To se da udelat tak ze ho das do blacklist, ted si nejsme jistej co mas za distro tak kdyztak kdyz to jeste nepojede dej vedet a ja poradim
Linux je jako mušketýři "jeden za všechny, všichni za jednoho"
4.4.2009 10:59 meydlo
Rozbalit Rozbalit vše Re: ath wifi deb

nevim ci som to urobil spravne (snad ano)
# apt-get install linux-headers-2.6-amd64
/uspesne sa to nainstalovalo/

debian:/home/meydlo/Desktop/madwifi-hal-0.10.5.6-r3968-20090402# make ./kernelversion.c:13:30: error: linux/utsrelease.h: Adresár alebo súbor neexistuje Makefile.inc:91: *** KERNELCONF: /lib/modules/2.6.26-1-amd64/build/.config does not exist.. Stop.

tak som si povedal ze>
echo > /lib/modules/2.6.26-1-amd64/build/.config

a skusil znovu

debian:/home/meydlo/Desktop/madwifi-hal-0.10.5.6-r3968-20090402# make
./kernelversion.c:13:30: error: linux/utsrelease.h: Adresár alebo súbor neexistuje
ath_hal/ah_target.inc:5: *** ARCH must be defined.  Stop.

kozzi avatar 4.4.2009 13:56 kozzi | skóre: 55 | blog: vse_o_vsem | Pacman (Bratrušov)
Rozbalit Rozbalit vše Re: ath wifi deb
zkus toto:
apt-get install linux-headers-2.6.26-1-amd64
a az potom to make a make install
Linux je jako mušketýři "jeden za všechny, všichni za jednoho"
5.4.2009 09:33 meydlo
Rozbalit Rozbalit vše Re: ath wifi deb

debian:/home/meydlo# apt-get install linux-headers-2.6.26-1-amd64
linux-headers-2.6.26-1-amd64 je už najnovšej verzie.
Nasledovné balíky boli nainštalované automaticky a už viac nie sú potrebné:
  khelpcenter4 htdig lockfile-progs

debian:/home/meydlo/Desktop/madwifi-hal-0.10.5.6-r3968-20090402# make
./kernelversion.c:13:30: error: linux/utsrelease.h: Adresár alebo súbor neexistuje
ath_hal/ah_target.inc:5: *** ARCH must be defined.  Stop.
 

kozzi avatar 5.4.2009 10:22 kozzi | skóre: 55 | blog: vse_o_vsem | Pacman (Bratrušov)
Rozbalit Rozbalit vše Re: ath wifi deb
to je divne. to by nemelo. co vypise tento prikaz:
ls /usr/src/linux-headers-2.6.26-1-amd64/include/linux/ | grep uts
a take tento prikaz:
uname -a
Linux je jako mušketýři "jeden za všechny, všichni za jednoho"
5.4.2009 10:35 meydlo
Rozbalit Rozbalit vše Re: ath wifi deb

debian:/home/meydlo# ls /usr/src/linux-headers-2.6.26-1-amd64/include/linux/ | grep uts
ls: cannot access /usr/src/linux-headers-2.6.26-1-amd64/include/linux/: Adresár alebo súbor neexistuje

konkretne uz  "/usr/src" je vypriahnute

debian:/home/meydlo# uname -a
Linux debian 2.6.26-1-amd64 #1 SMP Fri Mar 13 17:46:45 UTC 2009 x86_64 GNU/Linux

kozzi avatar 5.4.2009 10:54 kozzi | skóre: 55 | blog: vse_o_vsem | Pacman (Bratrušov)
Rozbalit Rozbalit vše Re: ath wifi deb
To mas nejaky divny, by to tam melo byt. tak to tam zkus narvat rucne. Stahni si:
http://security.debian.org/debian-security/pool/updates/main/l/linux-2.6/linux-headers-2.6.26-1-amd64_2.6.26-13lenny2_amd64.deb
a pomoci:
 dpkg -i linux-headers-2.6.26-1-amd64_2.6.26-13lenny2_amd64.deb
To tam narvi. Pak uz to snad bude ok
Linux je jako mušketýři "jeden za všechny, všichni za jednoho"
5.4.2009 11:12 meydlo
Rozbalit Rozbalit vše Re: ath wifi deb

debian:/usr/src# dpkg -i linux-headers-2.6.26-1-amd64_2.6.26-13lenny2_amd64.deb
urobilo to pekne

debian:/home/meydlo/Desktop/madwifi-hal-0.10.5.6-r3968-20090402# ls /usr/src/linux-headers-2.6.26-1-amd64/include/linux/ | grep uts
uts.h
utsname.h
utsrelease.h

debian:/home/meydlo/Desktop/madwifi-hal-0.10.5.6-r3968-20090402# make
./kernelversion.c:13:30: error: linux/utsrelease.h: Adresár alebo súbor neexistuje
ath_hal/ah_target.inc:5: *** ARCH must be defined.  Stop.
 

kozzi avatar 5.4.2009 12:10 kozzi | skóre: 55 | blog: vse_o_vsem | Pacman (Bratrušov)
Rozbalit Rozbalit vše Re: ath wifi deb
no tak to uz mi hlava nebere :-D. zkus jeste toto:
apt-get install linux-headers-2.6.26-1-common
neco uz musi zabrat :)
Linux je jako mušketýři "jeden za všechny, všichni za jednoho"
5.4.2009 12:58 meydlo
Rozbalit Rozbalit vše Re: ath wifi deb

odpoved znie... ze uz je najnovsej verzie (uz som ho mal)

kozzi avatar 5.4.2009 14:18 kozzi | skóre: 55 | blog: vse_o_vsem | Pacman (Bratrušov)
Rozbalit Rozbalit vše Re: ath wifi deb
hmm mas to pokazene jinak si to nedovedu vysvetlit. Me to vzdy fungovalo. Urcite tam bude enjaka zrada, ze ti chyby nejakej balick ci co. Ja uz fakt nevim.
Linux je jako mušketýři "jeden za všechny, všichni za jednoho"
5.4.2009 16:40 meydlo
Rozbalit Rozbalit vše Re: ath wifi deb

co uz budem.. musiet dat novsi kernel ;)... ale fakt diky za snahu  *THUMBS UP*

Založit nové vláknoNahoru

Tiskni Sdílej: Linkuj Jaggni to Vybrali.sme.sk Google Del.icio.us Facebook

ISSN 1214-1267   www.czech-server.cz
© 1999-2015 Nitemedia s. r. o. Všechna práva vyhrazena.