abclinuxu.cz AbcLinuxu.cz itbiz.cz ITBiz.cz HDmag.cz HDmag.cz abcprace.cz AbcPráce.cz
AbcLinuxu hledá autory!
Inzerujte na AbcPráce.cz od 950 Kč
Rozšířené hledání
×
dnes 05:55 | Komunita

Dries Buytaert, autor a vedoucí projektu Drupal a prezident Drupal Association, požádal soukromě před několika týdny Larryho Garfielda, jednoho z klíčových vývojářů Drupalu, aby projekt Drupal opustil. Larry Garfield minulý týden na svých stránkách napsal, že důvodem jsou jeho BDSM praktiky a rozpoutal tím bouřlivou diskusi. Na druhý den reagoval Dries Buytaert i Drupal Association. Pokračuje Larry Garfield [reddit].

Ladislav Hagara | Komentářů: 0
dnes 04:44 | Humor

Společnost SAS zveřejnila na svých stránkách studii s názvem Open Source vs Proprietary: What organisations need to know (pdf). Organizace by měly například vědět, že ideální je mix 40 % open source softwaru a 60 % proprietárního softwaru [Slashdot].

Ladislav Hagara | Komentářů: 0
včera 23:33 | Zajímavý software

Byl vydán ShellCheck ve verzi 0.4.6. Jedná se o nástroj pro statickou analýzu shellových skriptů. Shellové skripty lze analyzovat na webové stránce ShellChecku, v terminálu nebo přímo z textových editorů. Příklady kódů, na které analýza upozorňuje a doporučuje je přepsat. ShellCheck je naprogramován v programovacím jazyce Haskell. Zdrojové kódy jsou k dispozici na GitHubu pod licencí GPLv3.

Ladislav Hagara | Komentářů: 0
včera 23:33 | Pozvánky

Czech JBoss User Group zve na setkání JBUG v Brně, které se koná ve středu 5. dubna 2017 v prostorách Fakulty informatiky Masarykovy univerzity v místnosti A318 od 18:00. Přednáší Pavol Loffay na téma Distributed Tracing and OpenTracing in Microservice Architecture.

… více »
mjedlick | Komentářů: 0
včera 11:33 | Zajímavý článek

Národní centrum kybernetické bezpečnosti (NCKB) vypracovalo (pdf) 26 podrobných bezpečnostních doporučení pro síťové správce. Tato doporučení jsou nastavena tak, aby je bylo možné aplikovat v každé instituci. Jsou rozdělena na tři základní části: bezpečnost infrastruktury, bezpečnost stanic a serverů a bezpečnost uživatelů.

Ladislav Hagara | Komentářů: 11
včera 05:55 | Komunita

Prezident Nadace pro svobodný software (FSF) Richard M. Stallman vyhlásil na slavnostním ceremoniálu v rámci konference LibrePlanet 2017 vítěze Free Software Awards za rok 2016. Ocenění za společenský přínos získal SecureDrop (Wikipedie). Za rozvoj svobodného softwaru byl oceněn Alexandre Oliva (Wikipedie).

Ladislav Hagara | Komentářů: 0
včera 04:44 | Nová verze

Byla vydána verze 0.7.0 debugovacího nástroje cgdb. Mezi novinky patří například zvýrazňování syntaxe jazyka Rust. Podrobnosti v poznámkách o vydání.

Neel | Komentářů: 0
25.3. 22:00 | Komunita

Portál Stack Overflow po roce opět vyzpovídal své uživatele, jedná se především o vývojáře softwaru, a zveřejnil (podcast) detailní výsledky průzkumu. Průzkumu se letos zúčastnilo více než 64 tisíc vývojářů. Jejich nejmilovanější platformou je linuxový desktop. Ten je také druhou nejpoužívanější platformou vývojářů.

Ladislav Hagara | Komentářů: 7
24.3. 11:55 | Komunita

Vývojový tým OpenSSL ve spolupráci s iniciativou Core Infrastructure konsorcia Linux Foundation spustil proces přelicencování této kryptografické knihovny ze současné licence na licenci Apache Licence v 2.0 (ASLv2). Nová licence usnadní začleňování OpenSSL do dalších svobodných a open source projektů. Všichni dosavadní vývojáři OpenSSL (Authors) obdrží v následujících dnech email s prosbou o souhlas se změnou licence.

Ladislav Hagara | Komentářů: 32
24.3. 01:11 | Komunita

Před třemi týdny Mozilla.cz představila projekt Photon, jehož cílem je návrh a implementace nového vzhledu Firefoxu. Včera zveřejnila první náhled vzhledu Photon. Práce na projektu Photon jsou rozděleny do pěti týmů, které celkem čítají 19 lidí. Zaměřují se na zlepšení prvního spuštění Firefoxu a zaujetí nových uživatelů, celkovou úpravu vzhledu, zlepšení animací, zrychlení odezvy uživatelského rozhraní a také upravení nabídek. Vývoj lze sledovat v Bugzille.

Ladislav Hagara | Komentářů: 51
Jak se stavíte k trendu ztenčování přenosných zařízení (smartphony, notebooky)?
 (14%)
 (2%)
 (71%)
 (3%)
 (10%)
Celkem 947 hlasů
 Komentářů: 72, poslední 1.3. 11:16
    Rozcestník
    Štítky: není přiřazen žádný štítek

    Dotaz: quagga +ospf +filter

    27.4.2009 14:11 hates | skóre: 30 | blog: Jak_jsem_se_dostal_k_linuxu
    quagga +ospf +filter
    Přečteno: 311×

    Mam zasadni problem. na koncovem routeru na ktery se mi dostavaji routy pomoci OSPF potrebuji odfiltrovat nejake subnety. melo by to jit pomoci ospfd a access\/listu ale nejak neprichazim na to jak to filtrovat. pro predstavu je to asi takhle

     

     

    192.168.1.0                                             192.168.1.0
    
    192.168.2.0   router1 ---------------------- router2    192.168.3.0
    
    192.168.3.0 

     

     

    to znamena ze na routeru router2 potrebuji odfiltrovat routu 192.168.2.0

     

    nevi nekdo jak to udelat tak abych nemusel zaasahovat do nastaveni ospfd na routeru1 ale nastavil bych si pouze ospfd na router2 berte to tak ze veskere subnety jsou jak na router1 tak na router2 distribuovany pomoci OSPFD

    Odpovědi

    27.4.2009 14:39 Dušan Hokův | skóre: 43 | blog: Fedora a další...
    Rozbalit Rozbalit vše Re: quagga +ospf +filter
    pomoci routemapy, viz. zde
    27.4.2009 14:50 hates | skóre: 30 | blog: Jak_jsem_se_dostal_k_linuxu
    Rozbalit Rozbalit vše Re: quagga +ospf +filter

    to jsem zkousel ale nejak jsem to nepochopil a nebo spatne. to bych musel udelat na router1, ale ja to pravidlo potrebuji odfiltrovat az na tom router2. na jine routery se ta routa jiz propagovat zase ma.

    27.4.2009 15:20 Dušan Hokův | skóre: 43 | blog: Fedora a další...
    Rozbalit Rozbalit vše Re: quagga +ospf +filter
    ukazte konfigurak...
    27.4.2009 15:27 hates | skóre: 30 | blog: Jak_jsem_se_dostal_k_linuxu
    Rozbalit Rozbalit vše Re: quagga +ospf +filter

    konfigurak na router2

     

    Current configuration:
    !
    hostname console-hates-ospfd
    password heslo
    enable password heslo
    log file /var/log/quagga/ospfd.log
    log stdout
    !
    !
    !
    interface eth0
     ip ospf cost 10
    !
    interface eth1 
     ip ospf cost 10
    !
    interface eth2
    !
    interface lo
    !
    interface sit0
    !
    interface tap0
     description OpenVPN 
     ip ospf network point-to-point
     ip ospf cost 5000
    !
    router ospf
     ospf router-id 10.3.6.144
     redistribute connected
     redistribute static
     passive-interface eth0
     passive-interface eth1
     passive-interface eth2
     network 10.8.0.0/24 area 1.5.3.0
     network 192.168.88.0/24 area 1.5.3.0
     network 192.168.89.0/24 area 1.5.3.0
     neighbor 10.8.0.1
    !
    line vty
    !
    end
    

    a prijate routy

    88.146.196.127  10.8.0.1        255.255.255.255 UGH   20     0        0 tap0
    10.132.29.130   10.8.0.1        255.255.255.255 UGH   20     0        0 tap0
    88.146.196.126  10.8.0.1        255.255.255.255 UGH   20     0        0 tap0
    88.146.196.125  10.8.0.1        255.255.255.255 UGH   20     0        0 tap0
    192.168.55.4    10.8.0.1        255.255.255.252 UG    5020   0        0 tap0
    192.168.55.0    10.8.0.1        255.255.255.252 UG    5020   0        0 tap0
    10.132.29.136   10.8.0.1        255.255.255.248 UG    20     0        0 tap0
    10.132.29.8     10.8.0.1        255.255.255.248 UG    20     0        0 tap0
    10.132.29.128   10.8.0.1        255.255.255.248 UG    20     0        0 tap0
    10.132.29.0     10.8.0.1        255.255.255.248 UG    20     0        0 tap0
    10.132.29.144   10.8.0.1        255.255.255.248 UG    20     0        0 tap0
    10.132.29.168   10.8.0.1        255.255.255.248 UG    20     0        0 tap0
    10.132.29.40    10.8.0.1        255.255.255.248 UG    20     0        0 tap0
    10.132.29.160   10.8.0.1        255.255.255.248 UG    20     0        0 tap0
    10.132.29.32    10.8.0.1        255.255.255.248 UG    20     0        0 tap0
    10.132.29.184   10.8.0.1        255.255.255.248 UG    20     0        0 tap0
    10.132.29.56    10.8.0.1        255.255.255.248 UG    20     0        0 tap0
    10.132.29.176   10.8.0.1        255.255.255.248 UG    20     0        0 tap0
    10.132.29.48    10.8.0.1        255.255.255.248 UG    20     0        0 tap0
    10.132.29.16    10.8.0.1        255.255.255.240 UG    20     0        0 tap0
    10.132.29.240   10.8.0.1        255.255.255.240 UG    5030   0        0 tap0
    10.9.0.0        10.8.0.1        255.255.255.240 UG    20     0        0 tap0
    10.132.29.192   10.8.0.1        255.255.255.224 UG    5030   0        0 tap0
    10.132.29.64    10.8.0.1        255.255.255.192 UG    20     0        0 tap0
    172.20.21.0     10.8.0.1        255.255.255.0   UG    20     0        0 tap0
    192.168.5.0     10.8.0.1        255.255.255.0   UG    5020   0        0 tap0
    172.20.20.0     10.8.0.1        255.255.255.0   UG    20     0        0 tap0
    192.168.4.0     10.8.0.1        255.255.255.0   UG    5030   0        0 tap0
    192.168.3.0     10.8.0.1        255.255.255.0   UG    5030   0        0 tap0
    192.168.2.0     10.8.0.1        255.255.255.0   UG    5020   0        0 tap0
    192.168.1.0     10.8.0.1        255.255.255.0   UG    5010   0        0 tap0
    172.16.0.0      10.8.0.1        255.255.255.0   UG    5020   0        0 tap0
    10.8.0.0        0.0.0.0         255.255.255.0   U     0      0        0 tap0
    10.3.6.0        0.0.0.0         255.255.255.0   U     0      0        0 eth0
    192.168.89.0    0.0.0.0         255.255.255.0   U     0      0        0 eth2
    172.20.10.0     10.8.0.1        255.255.255.0   UG    5040   0        0 tap0
    192.168.88.0    0.0.0.0         255.255.255.0   U     0      0        0 eth1
    127.0.0.0       0.0.0.0         255.0.0.0       U     0      0        0 lo
    0.0.0.0         10.8.0.1        0.0.0.0         UG    1      0        0 tap0


    co potrebuji tak je aby napriklad routy 192.168.2.0/24 a routa 0.0.0.0 nebyla v routovaci tabulce a byly odfiltrovany

    27.4.2009 15:35 NN
    Rozbalit Rozbalit vše Re: quagga +ospf +filter

    Myslim, ze na router 1 pujde zakazat propagaci pres tu mapu, takze se tam sice ta routa dostane,ale nebude se propagovat dal:

    access-list stub accept 192.168.2.0/24

    access-list stub deny any any

     

    route-map filter deny 1 match ip address stub

     

    redistribute connected metric 100 metric-type 1 route-map filter

     

    Tak nejak..

    NN

    27.4.2009 15:44 hates | skóre: 30 | blog: Jak_jsem_se_dostal_k_linuxu
    Rozbalit Rozbalit vše Re: quagga +ospf +filter

    asi jsem to blbe popsal. rekneme ze router2 ma dostavat tyhle routy z routeru 1. to ze je na routeru 1 routa 192.168.1.0 .2.0 .3.0 je v poradku. dale je router 3 ktery tyto routy dostat ma ale router 2 ma dostat pouze rozsah 192.168.1.0 a .3.0/24 tak ze filtrovat potrebuji az na routeru2 a ne na routeru1. pokud bych ten filtr udelal na router1 tak se mi nezpropaguje na router3. doufam ze jsem se do toho nezamotal.

    28.4.2009 09:07 NN
    Rozbalit Rozbalit vše Re: quagga +ospf +filter

    Myslel jsem router 2, kazdopadne jak mate zepojeny router 3, protoze pokud predchozi aplikujete na router 2

    routery za routerem 2 to uz neuvidi, alespon si to tak predstavuji. Nebo chcete pouze filtrovat tuto jednu sit

    pouze na tomto routerua, ale propagovat ji dal?

    NN

    28.4.2009 10:38 hates | skóre: 30 | blog: Jak_jsem_se_dostal_k_linuxu
    Rozbalit Rozbalit vše Re: quagga +ospf +filter
    Příloha:

    Pro predstavu prikladam nakres casti site v priloze.

     

    Jedna se mi o tenhle pripad

    Routery R1 - R5 si mezi sebou predavaji routy vcetne bran do internetu. to je v poradku. a vsechno funguje tak jak ma. dale je pomoci VPNky pripojen router R6, ktery ma svou defaultni branu. co ja potrebuji tak na routeru R6 odfiltrovat routu pro defaultni branu (dostane se mi na ni totiz routa 0.0.0.0 via 10.8.0.1) a kvuli ni mi spadne tunel. dale co bych potreboval, aby jiz na tom routeru nebyly site napriklad 192.168.2.0/24 a 192.168.3.0/24. Pravidlo by melo byt na in (tj odfiltruj routy, ktere prichazi skrze OSPF a nedavej je do filtrovaci tabulky). Na routeru R6 je jeste navic vic routovacich tabulek a podle pravidel se dale routuje. ale to si jiz poresim. jedna se mi hlavne o ten filtr tech rout, ktere prichazeji do OSPF.

    Založit nové vláknoNahoru

    Tiskni Sdílej: Linkuj Jaggni to Vybrali.sme.sk Google Del.icio.us Facebook

    ISSN 1214-1267   www.czech-server.cz
    © 1999-2015 Nitemedia s. r. o. Všechna práva vyhrazena.