abclinuxu.cz AbcLinuxu.cz itbiz.cz ITBiz.cz HDmag.cz HDmag.cz abcprace.cz AbcPráce.cz
AbcLinuxu hledá autory!
Inzerujte na AbcPráce.cz od 950 Kč
Rozšířené hledání
×

dnes 01:44 | IT novinky

V Las Vegas končí bezpečnostní konference Black Hat USA 2017 (Twitter) a začíná bezpečnostní konference DEF CON 25 (Twitter). V rámci Black Hat budou vyhlášeny výsledky letošní Pwnie Awards (Twitter). Pwnie Awards oceňují to nejlepší, ale i to nejhorší z IT bezpečnosti (bezpečnostní Oscar a Malina v jednom). V kategorii "Lamest Vendor Response" byl například nominován také Lennart Poettering za jeho přístup k řešení bezpečnostních chyb v systemd, viz například chyba s uživatelem 0day.

Ladislav Hagara | Komentářů: 0
dnes 00:22 | Bezpečnostní upozornění

Nitay Artenstein z Exodus Intelligence se v příspěvku na blogu společnosti podrobně věnuje bezpečností chybě Broadpwn (CVE-2017-9417). Její analýzu provedl také Zhuowei Zhang na blogu Booster Ok. Jedná se o chybu ve firmwaru Wi-Fi chipsetů BCM43xx od Broadcomu. Útočník může vzdáleně získat kontrolu nad zařízením. Chyba byla již opravena v macOS, iOS i Androidu [Hacker News].

Ladislav Hagara | Komentářů: 1
včera 22:55 | IT novinky

Intel končí s vývojovými deskami Joule, Edison, Galileo a také s Arduino 101 a Curie.

Ladislav Hagara | Komentářů: 0
včera 14:44 | Nová verze

Byla vydána nová verze 42.3 linuxové distribuce openSUSE Leap. Jedná se už o třetí vydání, které staví na SUSE Linux Enterprise (SLE). Výchozím jádrem je opět poslední LTS verze, tedy řada 4.4. Podrobnosti v oznámení o vydání a v poznámkách k vydání.

Ladislav Hagara | Komentářů: 15
včera 14:30 | Nová verze

Google Chrome 60 byl prohlášen za stabilní. Nejnovější stabilní verze 60.0.3112.78 tohoto webového prohlížeče přináší řadu oprav a vylepšení. Vylepšeny byly také nástroje pro vývojáře (YouTube). Opraveno bylo 40 bezpečnostních chyb.

Ladislav Hagara | Komentářů: 0
25.7. 22:33 | IT novinky

Společnosti Adobe, Apple, Facebook, Google, Microsoft a Mozilla společně oznámily konec Flashe. Podpora Flashe oficiálně skončí na konci roku 2020.

Ladislav Hagara | Komentářů: 14
25.7. 05:55 | Komunita

Před 10 lety, v červenci 2007, se začal prodávat svobodný chytrý telefon Neo 1973 (vnitřní označení GTA01). Za jeho vývojem stáli vývojáři projektu Openmoko (Wikipedie). O rok později bylo možné koupit jejich druhý telefon Neo FreeRunner (GTA02). V roce 2011 byl představena platforma GTA04. Tuto platformu využívá také projekt Neo900, jehož cílem je vývoj nástupce telefonu Nokia N900. Nahlédnutí do historie Openmoko a další informace v článku na Vanille.de [Hacker News].

Ladislav Hagara | Komentářů: 23
25.7. 04:44 | Komunita

Tým Debianu zabývající se reprodukovatelnými sestaveními (Reproducible Builds), tj. kdokoli může nezávisle ověřit, že daný binární .deb balíček vznikl překladem daných zdrojových kódů, oznámil, že 94 % balíčků Debianu lze přeložit a sestavit reprodukovatelně. V únory 2015 to bylo 83 % [reddit].

Ladislav Hagara | Komentářů: 4
24.7. 11:22 | Komunita

Mozilla.cz informuje, že na blogu Mozilly věnovaném bezpečnosti byly zveřejněny výsledky bezpečnostního auditu služby Firefox Accounts, v českých překladech účet Firefoxu, sloužící hlavně k přihlašování k synchronizaci Firefox Sync. Nalezeno bylo celkem 15 bezpečnostních chyb, z toho jedna byla označena jako kritická a tři jako vážné.

Ladislav Hagara | Komentářů: 0
24.7. 11:00 | Nová verze

Byla vydána první stabilní verze 1.0 svobodného komunikačního softwaru Ring (Wikipedie). Ring, původně SFLphone, je součástí projektu GNU [reddit].

Ladislav Hagara | Komentářů: 4
Těžíte nějakou kryptoměnu?
 (4%)
 (2%)
 (20%)
 (74%)
Celkem 105 hlasů
 Komentářů: 6, poslední včera 18:53
    Rozcestník

    Dotaz: Jak updatovat PHP 5.2.1 na novější verzi?

    11.1.2010 14:23 Kall Ell | skóre: 15
    Jak updatovat PHP 5.2.1 na novější verzi?
    Přečteno: 370×
    Ahoj všem, chtěl bych se zeptat, jak mám updatovat PHP5 pod debianem. Mám verzi 5.2.0 a potřebuji novější. Stáhnul jsem si balíček deb php5-common 5.2.6, ale při instalaci mě dpkg hlásí závislosti na libc6 a to je zase závislé na dalších balíčcích. V aptitude když dám vyhledat php5-common tak mě najde jen verzi 5.2.0. poradíte? Mám debian etch.

    Řešení dotazu:


    Odpovědi

    11.1.2010 14:43 NN
    Rozbalit Rozbalit vše Re: Jak updatovat PHP 5.2.1 na novější verzi?
    apt-get -f install 
    NN
    11.1.2010 15:49 Kall Ell | skóre: 15
    Rozbalit Rozbalit vše Re: Jak updatovat PHP 5.2.1 na novější verzi?
    tak to nepomohlo, 0 aktualizováno, 0 instalováno, 0 k odstranění a 0 neaktualizováno. :-(
    11.1.2010 16:54 Kall Ell | skóre: 15
    Rozbalit Rozbalit vše Re: Jak updatovat PHP 5.2.1 na novější verzi?
    Nemůže být problém v tom, že mám etch a balíček s novější verzí php 5.2.6 je určená pro lenny?
    daan avatar 12.1.2010 02:44 daan | skóre: 6 | blog: Clairvoyant | Bratislava
    Rozbalit Rozbalit vše Re: Jak updatovat PHP 5.2.1 na novější verzi?
    V Debiane existuju tzv. backports repozitare, ktore by presne tento problem mali riesit - http://www.backports.org/dokuwiki/doku.php :)
    12.1.2010 06:24 Lubos Kopecky | skóre: 32
    Rozbalit Rozbalit vše Re: Jak updatovat PHP 5.2.1 na novější verzi?
    pridej si do /etc/apt/sources.list radek
    deb http://packages.dotdeb.org etch all
    a pak dej
    aptitude update 
    aptitude install php5
    mela by se ti nainstalovat verze php5 verze 5.2.12
    13.1.2010 15:04 Kall Ell | skóre: 15
    Rozbalit Rozbalit vše Re: Jak updatovat PHP 5.2.1 na novější verzi?
    Tak jsem to udělal a skutečne se mě nainstaloval PHP 5.2.12, nic méně mám jinej problém, není propojený s apachem, apach jede, ale php ne. Kde se to nastavuje v apache2? nevíte? Když spustím stránku s php kódem tak mě ji dává explorer ke stahnutí.
    13.1.2010 15:32 Kall Ell | skóre: 15
    Rozbalit Rozbalit vše Re: Jak updatovat PHP 5.2.1 na novější verzi?
    Tak jsem si zapnul podrobější logování apache2 a zjistil jsem následující. PHP vyhodí chybu, že nemůže nahrát dynamickou knihovnu. "Unable to load dynamic libary" odkazuje se na složku "/usr/lib/php5/20060613+lfs/" kde hledá soubory *.so. Ta složka existuje, ale je v ní pouze jedna knihovna a sice pdo.so. Poradíte co s tím? kde je mám vzít?
    13.1.2010 16:58 volvox | skóre: 16
    Rozbalit Rozbalit vše Re: Jak updatovat PHP 5.2.1 na novější verzi?
    Zkopírujte ten chybový výpis celý, takhle z toho není zřejmé, co chybí.
    13.1.2010 16:54 volvox | skóre: 16
    Rozbalit Rozbalit vše Re: Jak updatovat PHP 5.2.1 na novější verzi?
    Podívejte se do adresáře /etc/apache2/mods-enabled/, jestli je v něm soubor php5.conf a php5.load. Pokud ne, povolte PHP pomocí přikazu
    a2enmod php5
    a mělo by to běžet.
    13.1.2010 17:16 Kall Ell | skóre: 15
    Rozbalit Rozbalit vše Re: Jak updatovat PHP 5.2.1 na novější verzi?
    původne to tam nebylo, tak jsem ty tam ty dva soubory zkopíroval ze složky /etc/apache2/mods-availabled/. Ten příkaz mě hlásí "this module is already enabled!". Ten log sem hodím večer.
    13.1.2010 17:33 volvox | skóre: 16
    Rozbalit Rozbalit vše Re: Jak updatovat PHP 5.2.1 na novější verzi?
    Patrně je modul zaveden už někde jinde v konfiguraci Apache, zřejmě ruční úpravou konf. souborů. Správný postup v Debianu je pomocí uvedeného příkazu. Ta chyba "Unable to load ..." s tím IMHO nesouvisí, to bych spíš tipoval na chybějící Apache direktivu
    AddType application/x-httpd-php .php .phtml .php3
    13.1.2010 21:04 Kall Ell | skóre: 15
    Rozbalit Rozbalit vše Re: Jak updatovat PHP 5.2.1 na novější verzi?
    Příloha:
    tu direktivu jsem tam našel, je právě v tom souboru php5.conf, která se načítá. příkládám část log souboru s chybovou hláškou.
    13.1.2010 21:40 Lubos Kopecky | skóre: 32
    Rozbalit Rozbalit vše Re: Jak updatovat PHP 5.2.1 na novější verzi?
    co ti rekne
    ls /usr/lib/php5/20060613+lfs/
    ?
    13.1.2010 21:43 Lubos Kopecky | skóre: 32
    Rozbalit Rozbalit vše Re: Jak updatovat PHP 5.2.1 na novější verzi?
    priapdne jeste
    ls /usr/lib/php5/
    13.1.2010 21:53 volvox | skóre: 16
    Rozbalit Rozbalit vše Re: Jak updatovat PHP 5.2.1 na novější verzi?
    Tak ty chyby od PHP jsou způsobeny tím, že se snaží natáhnout neexistující knihovny PHP rozšíření, jak sám výše píšete, máte v adresáři /usr/lib/php5/20060613+lfs/ jen pdo.so. Zřejmě je tedy nemáte nainstalovány, nebo jsou nainstalovány, ale pro jinou - původní - verzi PHP. To snadno zjístíte příkazem:
    aptitude show php5-nazev-modulu
    tedy např.:
    aptitude show php5-curl
    V řádku State zjistíte, jestli je balík instalován, v řádku Version, v jaké verzi.

    Zřejmě vám z původní verze PHP zůstaly konf. soubory v /etc/php5/apache2/conf.d/, kde je pro uložena ne uložena konfigurace.

    Každopádně to s problémem neprovádění PHP skriptů nesouvisí - to vám už funguje?
    15.1.2010 10:27 Kall Ell | skóre: 15
    Rozbalit Rozbalit vše Re: Jak updatovat PHP 5.2.1 na novější verzi?
    Tak problém vyřešen. Jak píše volvox skutečně se jsem updatoval PHP a config zůstal způvodní. Pomocí aptitude install php-modul jsem dohrál všechny moduly a už mě to funguje. Asi pět modulů se mě nahrát nepodařilo, protože aptitude nenašel potřebný balíček, ale to jsou moduly které nepotřebuji. Takže Vám všem moc děkuji za pomoc.
    24.1.2010 14:33 Ajfel
    Rozbalit Rozbalit vše Re: Jak updatovat PHP 5.2.1 na novější verzi?
    Hmmm, tak me se stalo neco podobneho, akorat problem je v tom, ze mam na serveru nekolik virtualnich serveru a nektere jedou normalne a nektere delaji to co delalo tobe, konfigurace prochazim horem spodem a porad nemuzu na nic dojit

    Založit nové vláknoNahoru

    Tiskni Sdílej: Linkuj Jaggni to Vybrali.sme.sk Google Del.icio.us Facebook

    ISSN 1214-1267   www.czech-server.cz
    © 1999-2015 Nitemedia s. r. o. Všechna práva vyhrazena.