abclinuxu.cz AbcLinuxu.cz itbiz.cz ITBiz.cz HDmag.cz HDmag.cz abcprace.cz AbcPráce.cz
AbcLinuxu hledá autory!
Inzerujte na AbcPráce.cz od 950 Kč
Rozšířené hledání
×

dnes 00:44 | Pozvánky

V sobotu 21. října 2017 se na půdě Elektrotechnické fakulty ČVUT v Praze uskuteční RT-Summit – setkání vývojářů linuxového jádra a uživatelů jeho real-time verze označované jako preempt-rt.

… více »
Pavel Píša | Komentářů: 1
včera 23:44 | Bezpečnostní upozornění

V Linuxu byla nalezena bezpečnostní chyba CVE-2017-15265 zneužitelná k lokální eskalaci práv. Jedná se o chybu v části ALSA (Advanced Linux Sound Architecture).

Ladislav Hagara | Komentářů: 1
včera 22:44 | Komunita

Greg Kroah-Hartman informuje na svém blogu, že do zdrojových kódu linuxového jádra bylo přidáno (commit) prohlášení Linux Kernel Enforcement Statement. Zdrojové kódy Linuxu jsou k dispozici pod licencí GPL-2.0. Prohlášení přidává ustanovení z GPL-3.0. Cílem je chránit Linux před patentovými trolly, viz například problém s bývalým vedoucím týmu Netfilter Patrickem McHardym. Více v často kladených otázkách (FAQ).

Ladislav Hagara | Komentářů: 2
včera 22:04 | Pozvánky

Rádi bychom vás pozvali na přednášku o frameworku Avocado. Jedná se o testovací framework další generace, inspirovaný Autotestem a moderními vývojovými nástroji, jako je třeba git. Přednáška se bude konat 23. října od 17 hodin na FEL ČVUT (Karlovo náměstí, budova E, auditorium K9 – KN:E 301). Více informací na Facebooku.

… více »
mjedlick | Komentářů: 0
včera 21:44 | Bezpečnostní upozornění

Nový útok na WPA2 se nazývá KRACK a postihuje prakticky všechna Wi-Fi zařízení / operační systémy. Využívá manipulace s úvodním handshake. Chyba by měla být softwarově opravitelná, je nutné nainstalovat záplaty operačních systémů a aktualizovat firmware zařízení (až budou). Mezitím je doporučeno používat HTTPS a VPN jako další stupeň ochrany.

Václav HFechs Švirga | Komentářů: 2
15.10. 00:11 | Zajímavý projekt

Server Hackaday představuje projekt RainMan 2.0, aneb jak naučit Raspberry Pi 3 s kamerovým modulem pomocí Pythonu a knihovny pro rozpoznávání obrazu OpenCV hrát karetní hru Blackjack. Ukázka rozpoznávání karet na YouTube. Zdrojové kódy jsou k dispozici na GitHubu.

Ladislav Hagara | Komentářů: 0
14.10. 15:11 | IT novinky

Online obchod s počítačovými hrami a elektronickými knihami Humble Bundle byl koupen společností IGN. Dle oficiálních prohlášení by měl Humble Bundle dále fungovat stejně jako dosud.

Ladislav Hagara | Komentářů: 8
14.10. 06:00 | Zajímavý článek

Brendan Gregg již v roce 2008 upozornil (YouTube), že na pevné disky se nemá křičet, že jim to nedělá dobře. Plotny disku se mohou rozkmitat a tím se mohou prodloužit časy odezvy pevného disku. V září letošního roku proběhla v Buenos Aires konference věnovaná počítačové bezpečnosti ekoparty. Alfredo Ortega zde demonstroval (YouTube, pdf), že díky tomu lze pevný disk použít také jako nekvalitní mikrofon. Stačí přesně měřit časy odezvy

… více »
Ladislav Hagara | Komentářů: 7
13.10. 14:33 | Komunita

Společnost SUSE natočila a na YouTube zveřejnila dva nové videoklipy: 25 Years - SUSE Music Video (7 Years parody) a Linus Said - Music Parody (Momma Said).

Ladislav Hagara | Komentářů: 6
13.10. 12:55 | Zajímavý projekt

Autoři stránky Open Source Game Clones se snaží na jednom místě shromažďovat informace o open source klonech proprietárních počítačových her. Přidat další hry nebo návrhy na zlepšení lze na GitHubu. Na stránce Open Source Text Games jsou shromažďovány informace o open source textových hrách. Opět lze k vylepšení nebo doplnění stránky použít GitHub.

Ladislav Hagara | Komentářů: 1
Těžíte nějakou kryptoměnu?
 (6%)
 (2%)
 (15%)
 (76%)
Celkem 717 hlasů
 Komentářů: 24, poslední 27.9. 08:30
    Rozcestník

    Dotaz: Instalace starsiho gcc

    7.4.2010 22:34 Jezuch
    Instalace starsiho gcc
    Přečteno: 141×
    Dobrý den. Mám takový problém, potřebuji kvůli své bakalářské práci nainstalovat starší verzi gcc, konkrétně se mi jedná o gcc 4.1 4.2 a 4.3. Dělám to na vyrtuálních strojích, pro každou instalaci mám jeden vyhrazený, mám všude dané debian. Verze jsem dal takové aby se v balíčkách tyto gcc vyskytovali, problém je s jejich instalací, pokud instaluji jen balíčky gcc-4.1 například, gcc mi nefunguje, pokud jeste doinstaluji balicek gcc cele se mi to hlasi jako jina verze. Kde dělám chybu. Děkuji.

    Odpovědi

    7.4.2010 22:49 ferda mravenec
    Rozbalit Rozbalit vše Re: Instalace starsiho gcc
    Nainstaluj si takovou verzi Debianu, aby nasledne "apt-get install gcc" nainstalovalo presne to, co potrebujes.
    Bilbo avatar 7.4.2010 23:03 Bilbo | skóre: 29
    Rozbalit Rozbalit vše Re: Instalace starsiho gcc
    "gcc" je v debianu jen metabalíček závisející na nejnovější verzi gcc (např. v debian unstable je to gcc-4.4) a obsahující i symlink /usr/bin/gcc směřující na tu nejnovější verzi. Pak se logicky hlásí gcc jako jiná verze, protože to je jiná verze. Starší verze jsou k dispozici pod jmény obsahující číslo verze, tedy pro gcc 4.1 je to balíček "gcc-4.1" (resp. "g++-4.1" pro C++ kompilátor a "cpp-4.1" pro preprocesor)

    Je možná mít na jednom stroji najednou nainstalované balíčky pro gcc 4.1, 4.2 a 4.3, pak je nutná ale místo "gcc" volat konkrétní verzi. To lze udělat buď tak, že si v /usr/bin udělám symlink z gcc na gcc-4.X (kde X je verze co zrovna potřebuji, analogicky pro g++ a cpp), případně pokud se používá něcop jako configure tak se nastaví jiný kompilátor přes proměnné, např stylem:

    CC=gcc-4.1 CXX=g++-4.1 CPP=cpp-4.1 CXXCPP=cpp-4.1./configure && make

    Případně pokud nepoužívám configure tak si tam nějak nastavím, aby se místo prostého gcc/g++ volala konkrétní verze
    Big brother is not watching you anymore. Big Brother is telling you how to live...
    7.4.2010 23:23 Šangala | skóre: 56 | blog: Dutá Vrba - Wally
    Rozbalit Rozbalit vše Re: Instalace starsiho gcc
    <joke>Zbytečná práce</joke> :)
    Lze nainstalovat 4.1; 4.2; 4.3 na jednom Debianu (Lenny)
    Pak existuje linka asi /usr/bin/gcc (lze zjistit pomocí which gcc), která pravděpodobně ukazuje na poslení instalované gcc-čko nebo na to, které se skýrvá pod balíčkem gcc.
    Balíček gcc je poslední verze gcc-čka, třeba 4.4.
    Proto stačí jen změnit linku (man ln) aby ukazovala na gcc-4.3 či gcc-4.2 či gcc-4.1, tím jen přepínat použitý compiler na jednom stroji.
    Neznám konkrétní použití, ale pokud nepoužíváte přímo gcc, tak pomocí:
    export CC=gcc-4.1 (případně s celou cestou)
    přestavíte na používání gcc-4.1.

    Po instalaci balíčku gcc 4.1 (pravděpodobně) nevznikne linka gcc -> gcc-4.1, jen proto to nefunguje
    To, že trpíš stihomamem, ještě neznamená, že po tobě nejdou. ⰞⰏⰉⰓⰀⰜⰉ ⰗⰞⰅⰜⰘ ⰈⰅⰏⰉ ⰒⰑⰎⰉⰁⰕⰅ ⰏⰉ ⰒⰓⰄⰅⰎ ·:⁖⁘⁙†
    Chytrex avatar 7.4.2010 23:34 Chytrex | skóre: 28 | Bohumín
    Rozbalit Rozbalit vše Re: Instalace starsiho gcc
    Jo viděl bych to stejně.. takže shrnuto pro tazatele:

    # ln -s /usr/bin/gcc-4.1 /usr/bin/gcc pro zfunkčnění GCC.. a pokud budeš mít na stejném stroji i 4.3ku tak pak jen rm /usr/bin/gcc a vytvořit korektní symlink.
    Hrdý člen KERNEL ULTRAS .:. define QUESTION ((bb) || !(bb)) .:. Odmítám vaši realitu a nahrazuji ji svou vlastní..
    8.4.2010 09:23 Jezuch
    Rozbalit Rozbalit vše Re: Instalace starsiho gcc
    Díky moc. Opravdu to tak bylo. Stačí zadat přesnou verzi gcc, kterou chci spustit. Moc díky.

    Založit nové vláknoNahoru

    Tiskni Sdílej: Linkuj Jaggni to Vybrali.sme.sk Google Del.icio.us Facebook

    ISSN 1214-1267   www.czech-server.cz
    © 1999-2015 Nitemedia s. r. o. Všechna práva vyhrazena.