abclinuxu.cz AbcLinuxu.cz itbiz.cz ITBiz.cz HDmag.cz HDmag.cz abcprace.cz AbcPráce.cz
AbcLinuxu hledá autory!
Inzerujte na AbcPráce.cz od 950 Kč
Rozšířené hledání
×

dnes 03:00 | Komunita

Na Humble Bundle lze získat počítačovou hru Company of Heroes 2 (Wikipedie, YouTube) běžící také v Linuxu zdarma. Speciální akce končí v sobotu v 19:00.

Ladislav Hagara | Komentářů: 0
dnes 02:00 | Zajímavý software

Christian Kellner představil na svém blogu projekt Bolt řešící bezpečnost rozhraní Thunderbolt 3 na Linuxu. Pomocí příkazu boltctl nebo rozšíření GNOME Shellu lze komunikovat s démonem boltd a například zakázat neznámá zařízení a předejít tak útokům typu Thunderstrike nebo DMA.

Ladislav Hagara | Komentářů: 0
dnes 01:00 | Nová verze

Po půl roce vývoje od vydání verze 11.0 byla vydána verze 11.1 svobodného softwaru pro vytváření datových úložišť na síti FreeNAS (Wikipedie). Nejnovější FreeNAS je postaven na FreeBSD 11.1. Přehled novinek v příspěvku na blogu. Zdůraznit lze zvýšení výkonu OpenZFS, počáteční podporu Dockeru nebo synchronizaci s cloudovými službami Amazon S3 (Simple Storage Services), Backblaze B2 Cloud, Google Cloud a Microsoft Azure

Ladislav Hagara | Komentářů: 0
včera 23:55 | Nová verze

Po dvou měsících vývoje od vydání verze 235 oznámil Lennart Poettering vydání verze 236 správce systému a služeb systemd (GitHub, NEWS).

Ladislav Hagara | Komentářů: 0
včera 20:00 | Nová verze Ladislav Hagara | Komentářů: 0
včera 19:33 | Pozvánky

Pražská Fedora 27 Release Party, oslava nedávného vydání Fedory 27, se uskuteční 19. prosince od 19:00 v prostorách společnosti Etnetera (Jankovcova 1037/49). Na programu budou přednášky o novinkách, diskuse, neřízený networking atd.

Ladislav Hagara | Komentářů: 0
včera 18:11 | Nová verze

Byla vydána verze 2.11.0 QEMU (Wikipedie). Přispělo 165 vývojářů. Provedeno bylo více než 2 000 commitů. Přehled úprav a nových vlastností v seznamu změn.

Ladislav Hagara | Komentářů: 0
včera 17:44 | Komunita

Canonical oznámil dostupnost kryptografických balíčků s certifikací FIPS 140-2 úrovně 1 pro Ubuntu 16.04 LTS pro předplatitele podpory Ubuntu Advantage Advanced. Certifikace FIPS (Federal Information Processing Standards) jsou vyžadovány (nejenom) vládními institucemi USA.

Ladislav Hagara | Komentářů: 2
včera 16:11 | Zajímavý software

Společnost Avast uvolnila zdrojové kódy svého dekompilátoru RetDec (Retargetable Decompiler) založeného na LLVM. Vyzkoušet lze RetDec jako webovou službu nebo plugin pro interaktivní disassembler IDA. Zdrojové kódy RetDec jsou k dispozici na GitHubu pod open source licencí MIT.

Ladislav Hagara | Komentářů: 3
13.12. 11:00 | Zajímavý software
Na Good Old Games je v rámci aktuálních zimních slev zdarma k dispozici remasterovaná verze klasické point&click adventury Grim Fandango, a to bez DRM a pro mainstreamové OS včetně GNU/Linuxu. Akce trvá do 14. prosince, 15:00 SEČ.
Fluttershy, yay! | Komentářů: 6
Jak se vás potenciálně dotkne trend odstraňování analogového audio konektoru typu 3,5mm jack z „chytrých telefonů“?
 (8%)
 (1%)
 (1%)
 (1%)
 (75%)
 (14%)
Celkem 990 hlasů
 Komentářů: 45, poslední 1.12. 19:00
    Rozcestník

    Dotaz: Nejede VLC v Debianu Lenny 5.0.3

    polo23 avatar 26.4.2010 20:09 polo23 | skóre: 26 | blog: polo23
    Nejede VLC v Debianu Lenny 5.0.3
    Přečteno: 191×
    Ahoj, nedavno jsme instaloval VLC z testing repozitare ale protoze se mi nepodarilo sladit barvy tak jsme nainstaloval zpet VLC 0.8.6. Bohuzel mi nejde spustit. Pise to

    vlc: symbol lookup error: /usr/lib/i686/cmov/libavcodec.so.51: undefined symbol: lzo1x_decode

    Resilo se to uz tady

    http://www.abclinuxu.cz/poradna/linux/show/297137

    ale mne to nepomohlo:(Dale vypisy nekterych prikazu z vyse uvedeneho prispevku...

    ldd /usr/lib/i686/cmov/libavcodec.so.51
    linux-gate.so.1 => (0xb80a2000) libavutil.so.49 => /usr/lib/i686/cmov/libavutil.so.49 (0xb7b2e000) libz.so.1 => /usr/lib/libz.so.1 (0xb7b19000) libm.so.6 => /lib/i686/cmov/libm.so.6 (0xb7af2000) libfaad.so.0 => /usr/lib/libfaad.so.0 (0xb7ab3000) libgsm.so.1 => /usr/lib/libgsm.so.1 (0xb7aa6000) libtheora.so.0 => /usr/lib/libtheora.so.0 (0xb7a5f000) libvorbisenc.so.2 => /usr/lib/libvorbisenc.so.2 (0xb7966000) libvorbis.so.0 => /usr/lib/libvorbis.so.0 (0xb793e000) libpthread.so.0 => /lib/i686/cmov/libpthread.so.0 (0xb7924000) libc.so.6 => /lib/i686/cmov/libc.so.6 (0xb77c5000) /lib/ld-linux.so.2 (0xb80a3000) libogg.so.0 => /usr/lib/libogg.so.0 (0xb77c0000)


    readelf -a /usr/lib/i686/cmov/libavutil.so.49 |grep lzo1x_decode
    89: 000061f0 1389 FUNC GLOBAL DEFAULT 13 av_lzo1x_decode@@LIBAVUTIL_49


    http://www.it-kurz.cz

    Řešení dotazu:


    Odpovědi

    Fuky avatar 26.4.2010 20:51 Fuky | skóre: 52 | blog: 4u
    Rozbalit Rozbalit vše Re: Nejede VLC v Debianu Lenny 5.0.3
    Jak jsem zmiňoval v uvedeném příspěvku tak od LIBAVUTIL_VERSION_MAJOR >= 50 se lzo1x_decode přejmenovala na av_lzo1x_decode. A dle tvého výpisu readelf se v tvé libavutil.so nachází av_lzo1x_decode, ale libavcodec.so očekává původní název fce tj. lzo1x_decode. Tj. pro nápravu proveď downgrade i knihovny libavutil.so.
    polo23 avatar 26.4.2010 21:13 polo23 | skóre: 26 | blog: polo23
    Rozbalit Rozbalit vše Re: Nejede VLC v Debianu Lenny 5.0.3
    Jeste takova hloupa otazka... Jak se takovy downgrade provadi?:) Nikdy jsem nic takoveho nedelal. Zkousel jsme akorat aptitude remove libavutil.so. Ale to nefunguje.
    http://www.it-kurz.cz
    Fuky avatar 26.4.2010 21:45 Fuky | skóre: 52 | blog: 4u
    Rozbalit Rozbalit vše Re: Nejede VLC v Debianu Lenny 5.0.3

    Pokud potřebuješ zjistit v jakém balíčku (již nainstalovaném) se nachází nějaký soubor můžeš použít:

    $ dpkg -S libavutil.so
    

    Občas se hodí prohledávat soubory i v ještě nenainstalovaných balíčcích (update stačí zavolat jen jednou nebo při změně repozitářů):

    $ apt-file update
    $ apt-file search libavutil.so
    

    Takže námi zmiňovaná knihovna se nachází v balíčku libavutil49.

    Při používání více repozitářů (backports, testing, unstable atp.) se občas hodí vypsat dostupné verze daného balíčku:

    $ aptitude -v show libavutil49
    

    Pokud vyžaduji verzi, která by se implicitně neinstalovala (buď proto, že je starší nebo patří do repozitářu z nižší prioritou), stačí ji specifikovat za názvem balíčku (celý řetězec za Version:):

    # aptitude install libavutil49=0.svn20080206-18+lenny1
    
    Fuky avatar 26.4.2010 21:50 Fuky | skóre: 52 | blog: 4u
    Rozbalit Rozbalit vše Re: Nejede VLC v Debianu Lenny 5.0.3
    repozitářu z nižší prioritou => repozitářů s nižší prioritou
    polo23 avatar 26.4.2010 22:22 polo23 | skóre: 26 | blog: polo23
    Rozbalit Rozbalit vše Re: Nejede VLC v Debianu Lenny 5.0.3
    Diky pomohlo VLC uz funguje.
    http://www.it-kurz.cz

    Založit nové vláknoNahoru

    Tiskni Sdílej: Linkuj Jaggni to Vybrali.sme.sk Google Del.icio.us Facebook

    ISSN 1214-1267   www.czech-server.cz
    © 1999-2015 Nitemedia s. r. o. Všechna práva vyhrazena.