abclinuxu.cz AbcLinuxu.cz itbiz.cz ITBiz.cz HDmag.cz HDmag.cz abcprace.cz AbcPráce.cz
AbcLinuxu hledá autory!
Inzerujte na AbcPráce.cz od 950 Kč
Rozšířené hledání
×
eParkomat, startup z ČR, postoupil mezi finalisty evropského akcelerátoru ChallengeUp!
Robot na pivo mu otevřel dveře k opravdovému byznysu
Internet věcí: Propojený svět? Už se to blíží...
včera 21:21 | Nová verze Ladislav Hagara | Komentářů: 0
včera 11:44 | Zajímavý projekt

Na Indiegogo byla spuštěna kampaň na podporu herní mini konzole a multimediálního centra RetroEngine Sigma od Doyodo. Předobjednat ji lze již od 49 dolarů. Požadovaná částka 20 000 dolarů byla překonána již 6 krát. Majitelé mini konzole si budou moci zahrát hry pro Atari VCS 2600, Sega Genesis nebo NES. Předinstalováno bude multimediální centrum Kodi.

Ladislav Hagara | Komentářů: 0
včera 00:10 | Nová verze

Byla vydána verze 4.7 redakčního systému WordPress. Kódové označením Vaughan bylo vybráno na počest americké jazzové zpěvačky Sarah "Sassy" Vaughan. Z novinek lze zmínit například novou výchozí šablonu Twenty Seventeen, náhledy pdf souborů nebo WordPress REST API.

Ladislav Hagara | Komentářů: 1
6.12. 12:00 | Zajímavý projekt

Projekt Termbox umožňuje vyzkoušet si linuxové distribuce Ubuntu, Debian, Fedora, CentOS a Arch Linux ve webovém prohlížeči. Řešení je postaveno na projektu HyperContainer. Podrobnosti v často kladených dotazech (FAQ). Zdrojové kódy jsou k dispozici na GitHubu [reddit].

Ladislav Hagara | Komentářů: 25
6.12. 11:00 | Bezpečnostní upozornění

Byly zveřejněny informace o bezpečnostní chybě CVE-2016-8655 v Linuxu zneužitelné k lokální eskalaci práv. Chyba se dostala do linuxového jádra v srpnu 2011. V upstreamu byla opravena minulý týden [Hacker News].

Ladislav Hagara | Komentářů: 2
5.12. 22:00 | Komunita

Přibližně před měsícem bylo oznámeno, že linuxová distribuce SUSE Linux Enterprise Server (SLES) běží nově také Raspberry Pi 3 (dokumentace). Obraz verze 12 SP2 pro Raspberry Pi 3 je ke stažení zdarma. Pro registrované jsou po dobu jednoho roku zdarma také aktualizace. Dnes bylo oznámeno, že pro Raspberry Pi 3 je k dispozici také nové openSUSE Leap 42.2 (zprávička). K dispozici je hned několik obrazů.

Ladislav Hagara | Komentářů: 6
5.12. 06:00 | Zajímavý software

OMG! Ubuntu! představuje emulátor terminálu Hyper (GitHub) postavený na webových technologiích (HTML, CSS a JavaScript). V diskusi k článku je zmíněn podobný emulátor terminálu Black Screen. Hyper i Black Screen používají framework Electron, stejně jako editor Atom nebo vývojové prostředí Visual Studio Code.

Ladislav Hagara | Komentářů: 50
5.12. 06:00 | Zajímavý článek

I letos vychází řada ajťáckých adventních kalendářů. QEMU Advent Calendar 2016 přináší každý den nový obraz disku pro QEMU. Programátoři se mohou potrápit při řešení úloh z kalendáře Advent of Code 2016. Kalendáře Perl Advent Calendar 2016 a Perl 6 Advent Calendar přinášejí každý den zajímavé informace o programovacím jazyce Perl. Stranou nezůstává ani programovací jazyk Go.

Ladislav Hagara | Komentářů: 10
3.12. 16:24 | Nová verze

Byla vydána Mageia 5.1. Jedná se o první opravné vydání verze 5, jež vyšla v červnu loňského roku (zprávička). Uživatelům verze 5 nepřináší opravné vydání nic nového, samozřejmě pokud pravidelně aktualizují. Vydání obsahuje všechny aktualizace za posledního téměř půldruhého roku. Mageia 5.1 obsahuje LibreOffice 4.4.7, Linux 4.4.32, KDE4 4.14.5 nebo GNOME 3.14.3.

Ladislav Hagara | Komentářů: 17
3.12. 13:42 | Pozvánky

V Praze probíhá konference Internet a Technologie 16.2, volné pokračování jarní konference sdružení CZ.NIC. Konferenci lze sledovat online na YouTube. K dispozici je také archiv předchozích konferencí.

Ladislav Hagara | Komentářů: 0
Kolik máte dat ve svém domovském adresáři na svém primárním osobním počítači?
 (32%)
 (24%)
 (29%)
 (8%)
 (5%)
 (3%)
Celkem 785 hlasů
 Komentářů: 50, poslední 29.11. 15:50
Rozcestník
Reklama

Dotaz: Program si vynucuje spuštění pod Xkama a pod rootem

31.8.2010 20:00 pepa
Program si vynucuje spuštění pod Xkama a pod rootem
Přečteno: 185×
Dostal se mi sem prográmek, kterej je potřeba spustit s terminálu (v grafickém prostředí), ale pod rootem. Pokud v terminálu su-čkuju, vyplivne hlášku:
Gtk-WARNING **: cannot open display: :0.0
Přímo z grafického prostředí pomocí kdesu (příkaz) spustit taky nejde. Je nějaký způsob, abych nemusel jet pod rootem s celejma Xkama? Díky

Odpovědi

31.8.2010 20:12 reqw5q23
Rozbalit Rozbalit vše Re: Program si vynucuje spuštění pod Xkama a pod rootem
ssh -X root@localhost "xxx"
31.8.2010 20:18 pepa
Rozbalit Rozbalit vše Re: Program si vynucuje spuštění pod Xkama a pod rootem
ssh: connect to host localhost port 22: Connection refused
rADOn avatar 31.8.2010 21:09 rADOn | skóre: 44 | blog: bloK | Praha
Rozbalit Rozbalit vše Re: Program si vynucuje spuštění pod Xkama a pod rootem
Za takovyhle rady be se mely trhat koule.
"2^24 comments ought to be enough for anyone" -- CmdrTaco
31.8.2010 20:40 sivlk | skóre: 15 | blog: sivlk
Rozbalit Rozbalit vše Re: Program si vynucuje spuštění pod Xkama a pod rootem
janko> xhost +
janko> su
root> program
root> exit
janko> xhost -
31.8.2010 20:53 Ash | skóre: 53
Rozbalit Rozbalit vše Re: Program si vynucuje spuštění pod Xkama a pod rootem
Má root přístup k X? xhost +local:root
31.8.2010 21:01 Tomas
Rozbalit Rozbalit vše Re: Program si vynucuje spuštění pod Xkama a pod rootem

Nainstalovat si balík se souborem /lib/security/pam_xauth.so, ale nejspíš jej už máte.

Jako uživatel vytvořit adresář .xauth s právy 700

mkdir ~/.xauth
chmod +700 ~/.xauth

V adresáři .xauth vytvořit soubor export s obsahem root a s právy 600

echo root >> ~/.xauth/export
chmod 600 ~/.xauth/export

Jako root vytvořit adresář .xauth s právy 700

mkdir ~/.xauth
chmod +700 ~/.xauth

Jako root v adresáři .xauth vytvořit soubor import se jménem uživatele a s právy 600

echo pepa >> ~/.xauth/import
chmod 600 ~/.xauth/import

Pak ještě přidat do souboru /etc/pam.d/su na konec řádek


session optional /lib/security/pam_xauth.so

No a to je vše. Od této chvíle pokud se přilásíte přes su, pak root "zdědí" přístup k X serveru.

Pro technické sťouraly: vyexportuje ~/.Xauthority někam do tempu a rootovi se nastaví proměná $XAUTHORITY

Bilbo avatar 31.8.2010 22:55 Bilbo | skóre: 29
Rozbalit Rozbalit vše Re: Program si vynucuje spuštění pod Xkama a pod rootem
Existuje na to (např. v debianu) balík "sux", kde po nainstalování se místo "su" použije "sux" a to je wrapper kolem "su" který veškeré machinace s xauth, předáváním $DISPLAY, apod. (jak tu naznačoval někdo v jiném řešení) udělá automaticky.

Pokud v distribuci sux není jako balíček, dá se stáhnout z jeho homepage: http://fgouget.free.fr/sux/
Big brother is not watching you anymore. Big Brother is telling you how to live...

Založit nové vláknoNahoru

Tiskni Sdílej: Linkuj Jaggni to Vybrali.sme.sk Google Del.icio.us Facebook

ISSN 1214-1267   www.czech-server.cz
© 1999-2015 Nitemedia s. r. o. Všechna práva vyhrazena.