abclinuxu.cz AbcLinuxu.cz itbiz.cz ITBiz.cz HDmag.cz HDmag.cz abcprace.cz AbcPráce.cz
AbcLinuxu hledá autory!
Inzerujte na AbcPráce.cz od 950 Kč
Rozšířené hledání
×
včera 16:11 | Nová verze

Byla vydána verze 8.0 open source unixového operačního systému NetBSD (Wikipedie). Přehled novinek v poznámkách k vydání.

Ladislav Hagara | Komentářů: 0
včera 12:33 | Zajímavý projekt

Uživatel denholmsdead již více než rok zveřejňuje na redditu své obrázky s linuxovou tématikou. Náhledy obrázků jsou k dispozici na linux.pictures. Obrázky v plném rozlišení na GitLabu.

Ladislav Hagara | Komentářů: 1
20.7. 18:55 | Zajímavý projekt

Společnosti Google, Microsoft, Twitter a Facebook společně představily open source platformu Data Transfer Project (DTP). Cílem platformy je zjednodušit uživatelům přechod a přenos dat mezi jednotlivými online službami. Podrobnosti v pdf a na GitHubu.

Ladislav Hagara | Komentářů: 3
20.7. 18:33 | Nová verze

Canonical a Microsoft společně oznámili, že PowerShell Core je nově dostupný také jako snap balíček na Snapcraftu. Microsoft uvolnil zdrojové kódy PowerShellu (Wikipedie, GitHub) v srpnu 2016 pod open source licencí MIT a naportoval je na Linux.

Ladislav Hagara | Komentářů: 2
20.7. 13:11 | Zajímavý projekt

Novinkou v minor aktualizaci webového prohlížeče Vivaldi je podpora vyhledávače Qwant (Wikipedie). Vývojáři Vivaldi zdůrazňují, že se jedná o evropský vyhledávač respektující soukromí uživatelů.

Ladislav Hagara | Komentářů: 7
20.7. 01:33 | Nová verze

Po šesti letech od vydání verze 1.0 byla vydána verze 2.0 multiplatformního editoru tagů MusicBrainz Picard (Wikipedie). Přehled novinek, vylepšení a oprav v changelogu.

Ladislav Hagara | Komentářů: 0
19.7. 16:22 | Nová verze Ladislav Hagara | Komentářů: 14
19.7. 15:00 | Komunita

Dnes končí podpora Ubuntu 17.10 Artful Aardvark. Uživatelům je doporučen přechod na Ubuntu 18.04 Bionic Beaver s prodlouženou podporou do roku 2023. Podpora standardních verzí Ubuntu je 9 měsíců. Verze 17.10 byla vydána 19. října 2017.

Ladislav Hagara | Komentářů: 12
19.7. 13:33 | Bezpečnostní upozornění

Společnost Oracle vydala čtvrtletní bezpečnostní aktualizaci svých softwarových produktů (CPU, Critical Patch Update). Opraveno bylo celkově 334 bezpečnostních chyb. V Oracle Java SE je například opraveno 8 bezpečnostních chyb. Všechny jsou vzdáleně zneužitelné bez autentizace. V Oracle MySQL je opraveno 31 bezpečnostních chyb. Vzdáleně zneužitelných bez autentizace je 7 z nich.

Ladislav Hagara | Komentářů: 0
19.7. 13:11 | Zajímavý software

Nick Clifton zveřejnil na blogu společnosti Red Hat věnujícímu se počítačové bezpečnosti nástroj, pomocí kterého lze ověřit, zda jsou binární spustitelné soubory odolné vůči variantě 1 bezpečnostní chyby Spectre v procesorech.

Ladislav Hagara | Komentářů: 0
Jak čtete delší texty z webových stránek?
 (78%)
 (20%)
 (5%)
 (7%)
 (2%)
 (10%)
Celkem 374 hlasů
 Komentářů: 40, poslední 29.6. 10:21
    Rozcestník

    Dotaz: sprava slackware

    28.6.2003 07:59 Petr Mach
    sprava slackware
    Přečteno: 68×
    Uvazuji o pouziti slackware na jednoho hw slabeho notebooka. Myslim ze linuxu vcelku rozumim a konfigurace skrz konfiguracni soubory mi nebude delat potize. Ceho se obavam je instalace sw. System balicku slackware, jak jsem pochopil, nema kontrolu zavislosti, nedovedu si predstavit, jak potom neco instalovat. Nedokazu si predstavit, ze by clovek instaloval stovky balicku s tim, ze by u kazdeho znal zavislosti a co poskytuje a hlidal to mezi nimi navzajem z hlavy po dobu nekolika let. Imho tak velice brzy budu mit v systemu bordel (dll hell), jako byval ve win9x, ktere neco takoveho take postradaly. Jak se to tedy dela?

    Odpovědi

    28.6.2003 09:54 Jáchym Čepický | skóre: 29 | blog: U_Jachyma
    Rozbalit Rozbalit vše sprava slackware
    Já to dělám takhle:

    Nainstaluješ systém.
    Spustíš program a když dostaneš hlášku, že chybí knihovna xy (což se zase TAK často nestává)
    Nainstaluješ balíček, který se tváří, že by ji mohl obsahovat

    dá se to docela odhadnout kde a co.

    obecně se doporučuje nešetřit na skupině 'l' (libs), předejdeš tam 99% problémů.

    na další soft jsem začal používat swaret je to nástroj podobnej apt-get (zdůrazňuji: jenom podobnej), fachá asi takhle:

    # swaret --install gaim
    
    koukne na servery, stáhne, naistaluje, koukne na závislé balíčky a řekne ti, který to jsou (zatím automaticky neinstaluje a nestahuje).

    pokud dáš při instalaci volbu newbie/menu, tak se ke každé skupině balíčků nainstalují ty "povinné" a tím pádem se nemusíš bát situace, že by to po instalaci nejelo....

    podle mě je to, že slack je odkázanej na editaci konfiguráků bohapustá pověra. slackware má několik výbornejch grafickejch utilitek (grafickejch asi jako mc - v konzoli), který si na něc nehrajou, jsou ďábelsky rychlý a dělaj přesně to, co po ních člověk chce.

    se slackwarem dělám zatím jenom chvíli (asi 2 měsíce), ale řekl bych, že je po těch všech RH výraznej skok dopředu....

    a právě proto, že ho mám tak krátce, budu rád za doplnění někoho zkušenějšího.

    Jáchym

    28.6.2003 10:02 Petr Mach
    Rozbalit Rozbalit vše sprava slackware
    Dobre, to je chybejici knihovna. Jak ale poznam kterou verzi? Jak mam zjistovat nekompatibilitu ruznych verzi knihoven? Kdy jedna aplikace potrebuje takovou verzi, druha onakou, kazda s tou druhou pada. To se bohuzel deje, jak poznam ktera z mnoha potrebnych knihoven je ta konfliktni? Jak to je s upgrade a tak dale. Verim ze instalace systemu jeste jde, ale pak je potreba tu instalaci nekolik let udrzovat.

    Jak ten swaret pozna ktere balicky jsou zavisle, existuje o tom nekde nejaka informace?

    Me konfigurace skrz konfiguracni soubory nevadi, ja takto primo konfiguruji i sve redhaty.
    28.6.2003 10:24 Jáchym Čepický | skóre: 29 | blog: U_Jachyma
    Rozbalit Rozbalit vše sprava slackware
    je možný, že jsem mám v počítači 2 verze jedný knihovny (libtcl8.3.so a libtcl8.4.so) (pokud to jsou 2 verze - v tom se nevyznám a ke štěstí mi to nechybí), aniž by se viditelně třískaly? Jinak to je přesně ta zpětná vazba, kterou dostaneš: "chybí knihovna libtcl8.3.so ..."

    upgrate buď nově naistalovat (v tom případě lze udělat konfigurák pomocí tagů, ve kterém nadefinuješ co chceš naistalovat a můžeš to používat pořád dokola)

    nebo od verze 9.0 lze upratovat z CDčka, anižbys musel celý systém přeintalovávat (viz penguin.cz)

    nebo viz qwert.cz - vycházej pravidelné aktualizace různých částí systému a je tam nepostradatelný překlad slackwarebook

    nebo

    # swaret  --upgrade -a           Upgrade all installed Packages (auto)
    jak to pozná nevím (fachá to a to mi ke štěstí stačí) více na stránce swaretu (zmíněné výše).

    podobných projektů pro slackware je víc a něco se dá dočíst v článkuIndian na GNU/Linux Users Group

    Jáchym

    29.6.2003 08:27 Petr Mach
    Rozbalit Rozbalit vše sprava slackware
    Dekuji za linky a odpovedi, presvedcilo me to abych slackware zkusil :-).
    28.6.2003 20:07 Vlastimil Ott | skóre: 66 | blog: Plastique | Opava
    Rozbalit Rozbalit vše sprava slackware
    Podle mého názoru (netvrdím, že jsem zkušenější!!) platí jedna věc: základní knihovny jsou na cd, potom existuje adresář /extra, který je tuším na dalším cd, nebo na netu -- tam jsou např. Java, SDL apod. Další zdroj balíčků je www.linuxpackages.net; když jsou k danému balíčku potřebné další, autor to uvádí jako závislost. Buď je najdeš na netu, nebo je přímo tentýž autor poskytuje. Já ještě používám checkinstall. Když kompiluješ, provedeš configure, make a checkinstall. Ten vytvoří balíček, který můžeš lehce odinstalovat. Pokud nemůžu najít balíček s knihovnou, ale znám její jméno, potom googloojoo; najdu zdrojáky a postupu zase stejně. Konflikt verzí jsem nezažil; používám buď kompilaci, nebo balíčky pro verzi 9. Ty pro osmičku pochopitelně nejedou. --vo
    Práce: Liberix, o.p.s. | Blog: OpensourceBlog.cz | Online kurz Zlatý WordPress
    29.6.2003 04:56 freeuser
    Rozbalit Rozbalit vše sprava slackware
    upgradepkg *.tgz
    30.6.2003 09:33 Hynek (Pichi) Vychodil | skóre: 43 | blog: Pichi | Brno
    Rozbalit Rozbalit vše sprava slackware
    melo by ti na to stacit ldd `which jmeno_programu` v kombinaci s grep co_mi_chybi MANIFEST (samozrejme pote co si ten manifest nekde rozbalim).
    XML je zbytečný, pomalý, nešikovný balast, znovu vynalézané kolo a ještě ke všemu šišaté, těžké a kýčovitě pomalované.

    Založit nové vláknoNahoru

    Tiskni Sdílej: Linkuj Jaggni to Vybrali.sme.sk Google Del.icio.us Facebook

    ISSN 1214-1267   www.czech-server.cz
    © 1999-2015 Nitemedia s. r. o. Všechna práva vyhrazena.