abclinuxu.cz AbcLinuxu.cz itbiz.cz ITBiz.cz HDmag.cz HDmag.cz abcprace.cz AbcPráce.cz
AbcLinuxu hledá autory!
Inzerujte na AbcPráce.cz od 950 Kč
Rozšířené hledání
×

včera 20:55 | Komunita

Linux ve VirtualBoxu nebude potřebovat Přídavky pro hosta (Guest Additions). Budou součástí linuxového jádra. Ovladač vboxguest by se měl dostat do Linuxu 4.16. Ovladač vboxsf by měl následovat.

Ladislav Hagara | Komentářů: 5
včera 17:11 | Komunita

Vývojáři Thunderbirdu žádají o vyplnění dotazníku. Upřednostňujete klasický vzhled nebo raději Monterail (GitHub)?

Ladislav Hagara | Komentářů: 14
včera 12:22 | Komunita

Mozilla.cz informuje, že většina problémů s rychlostí Firefoxu 57 při použití open source odečítače NVDA (NonVisual Desktop Access) budou vyřešeny hned v další verzi Firefoxu 58. NVDA je zatím dostupný pouze pro operační systémy Windows.

Ladislav Hagara | Komentářů: 0
včera 05:55 | Bezpečnostní upozornění

V knihovně glibc (GNU C Library) byla nalezena a v upstreamu opravena bezpečnostní chyba CVE-2018-1000001 (buffer underflow) zneužitelná k lokální eskalaci práv. Podrobnosti na halfdog.net.

Ladislav Hagara | Komentářů: 0
16.1. 13:11 | Komunita

Mozilla.cz informuje o 2 plánovaných novinkách ve Firefoxu. Nové webové funkce budou ve Firefoxu dostupné jen přes HTTPS (en) a nové verze Firefoxu přinesou rychlejší přepínání panelů (předehřívání nebo žhavení panelů, anglicky tab warming).

Ladislav Hagara | Komentářů: 5
16.1. 12:44 | IT novinky

Hodnota Bitcoinu, decentralizované kryptoměny, klesla na cca 12 000 dolarů. Před měsícem byla hodnota Bitcoinu téměř 20 000 dolarů [reddit].

Ladislav Hagara | Komentářů: 28
16.1. 05:55 | Bezpečnostní upozornění

Bezpečnostní tým Cisco Talos upozorňuje na celou řadu bezpečnostních chyb v Blenderu. Vývojáři Blenderu byli o chybách informování již v září. Dosud tyto chyby ale opraveny nebyly. Doporučeno je neotevírat v Blenderu soubory z nedůvěryhodných zdrojů.

Ladislav Hagara | Komentářů: 2
15.1. 17:22 | Bezpečnostní upozornění

Společnost F-Secure upozorňuje na bezpečnostní "problém" v Intel AMT (Active Management Technology). Útočník s fyzickým přístupem k počítači s povoleným AMT a nenastaveným heslem k MEBx (Management Engine BIOS Extension) může obejít heslo nastavené v BIOSu, pin v TPM, přihlašovací jméno a heslo do operačního systému nebo i šifrování disků restartováním tohoto počítače a při jeho startu zavedením MEBx (CTRL-P) a zadáním výchozího hesla "admin". Pak už útočníkovi stačí pouze změnit heslo a povolit vzdálený přístup k počítači na úrovni AMT.

Ladislav Hagara | Komentářů: 10
15.1. 15:11 | Zajímavý projekt

Na Indiegogo byla dnes spuštěna kampaň na podporu 6 palcového notebooku a kapesní herní konzole GPD WIN 2. Cena v rámci kampaně byla stanovena na 649 dolarů. Cílová částka 100 tisíc dolarů byla překonána již 8 krát. Ukázka s Linuxem na YouTube.

Ladislav Hagara | Komentářů: 5
15.1. 05:55 | Bezpečnostní upozornění

V GitLabu, v open source alternativě GitHubu, tj. v softwarovém nástroji s webovým rozhraním umožňujícím spolupráci na zdrojových kódech, byl nalezen vážný bezpečnostní problém. Bezpečnostní aktualizace bude vydána ve středu 17. ledna v 00:59.

Ladislav Hagara | Komentářů: 3
Jak se vás potenciálně dotkne trend odstraňování analogového audio konektoru typu 3,5mm jack z „chytrých telefonů“?
 (7%)
 (1%)
 (1%)
 (1%)
 (77%)
 (13%)
Celkem 1317 hlasů
 Komentářů: 53, poslední včera 16:55
    Rozcestník

    Dotaz: Verze pythonu a kompatibilita knihoven

    29.4.2012 12:55 Karlos
    Verze pythonu a kompatibilita knihoven
    Přečteno: 287×
    Dobry den, uz ponekolikate jsem narazil na tento problem: Pouzivam distribuci Backtrack (vychazi z Ubuntu) a pres repozitare mam nainstalovany python2.6 a python2.7. Programy pisu v Pythonu 2.7. Narazil jsem na potrebu pouzit nejakou knihovnu, v tomto pripade psutil:
    aptitude search psutil
    i   psutils                                                                                                  - A collection of PostScript document handling utilities                                                            
    i   python-psutil                                                                                            - module providing convenience functions for managing processes                             
    
    Nainstaloval jsem tedy tyto baliky a nyni se Python chova takto:
    # python
    Python 2.6.5 (r265:79063, Apr 16 2010, 13:09:56) 
    [GCC 4.4.3] on linux2
    Type "help", "copyright", "credits" or "license" for more information.
    >>> import psutil
    >>> 
    
    a
    # python2.7
    Python 2.7.1 (r271:86832, Apr 30 2011, 10:03:29) 
    [GCC 4.4.3] on linux2
    Type "help", "copyright", "credits" or "license" for more information.
    >>> import psutil
    Traceback (most recent call last):
      File "< stdin>", line 1, in < module>
    ImportError: No module named psutil
    >>> 
    
    Tedy knihovna v Pythonu 2.6 funguje a ve verzi 2.7 ne. Toto se mi stalo uz s nekolikatou knihovnou, jak tedy prosim muzu zajistit, aby se nainstalovani knihovny pomoci aptitude projevilo i ve verzi pythonu 2.7?

    Odpovědi

    29.4.2012 14:04 chrono
    Rozbalit Rozbalit vše Re: Verze pythonu a kompatibilita knihoven
    Ak nie je v tej distribúcii skompilovaný balíček pre python 2.7, tak je potrebné buď požiadať správcu toho balíčka aby ho skompiloval aj pre verziu 2.7, alebo si budeš musieť ten balíček skompilovať ty.
    30.4.2012 15:00 Lukáš Kotek | skóre: 15
    Rozbalit Rozbalit vše Re: Verze pythonu a kompatibilita knihoven
    Zkuste psutil nainstalovat přes pip.
    Lidstvo vydává obrovské prostředky na ochranu sebe sama před sebou samým. Znáte lepší definici šílenství?
    30.4.2012 23:48 Karlos
    Rozbalit Rozbalit vše Re: Verze pythonu a kompatibilita knihoven
    Co je pip?
    1.5.2012 15:03 Karlos
    Rozbalit Rozbalit vše Re: Verze pythonu a kompatibilita knihoven
    Ok, tak uz jsem to dogoolil, ale naprosto stejny problem, pip se nainstaloval pouze pro python2.6 a knihovny stahuje pouze pro tuto verzi.
    1.5.2012 15:45 Lukáš Kotek | skóre: 15
    Rozbalit Rozbalit vše Re: Verze pythonu a kompatibilita knihoven
    Ještě můžete zkusit easy_install. Měl by být už ve výchozí instalaci pythonu v adresáři Scripts. Tak můžete nainstalovat pip, nebo rovnou psutil.
    Lidstvo vydává obrovské prostředky na ochranu sebe sama před sebou samým. Znáte lepší definici šílenství?

    Založit nové vláknoNahoru

    Tiskni Sdílej: Linkuj Jaggni to Vybrali.sme.sk Google Del.icio.us Facebook

    ISSN 1214-1267   www.czech-server.cz
    © 1999-2015 Nitemedia s. r. o. Všechna práva vyhrazena.