abclinuxu.cz AbcLinuxu.cz itbiz.cz ITBiz.cz HDmag.cz HDmag.cz abcprace.cz AbcPráce.cz
AbcLinuxu hledá autory!
Inzerujte na AbcPráce.cz od 950 Kč
Rozšířené hledání
×
eParkomat, startup z ČR, postoupil mezi finalisty evropského akcelerátoru ChallengeUp!
Robot na pivo mu otevřel dveře k opravdovému byznysu
Internet věcí: Propojený svět? Už se to blíží...
dnes 15:00 | Zajímavý software

Stop motion je technika animace, při níž je reálný objekt mezi jednotlivými snímky ručně upravován a posouván o malé úseky, tak aby po spojení vyvolala animace dojem spojitosti. Jaký software lze pro stop motion použít na Linuxu? Článek na OMG! Ubuntu! představuje Heron Animation. Ten bohužel podporuje pouze webové kamery. Podpora digitálních zrcadlovek je začleněna například v programu qStopMotion.

Ladislav Hagara | Komentářů: 0
včera 21:21 | Nová verze Ladislav Hagara | Komentářů: 0
včera 11:44 | Zajímavý projekt

Na Indiegogo byla spuštěna kampaň na podporu herní mini konzole a multimediálního centra RetroEngine Sigma od Doyodo. Předobjednat ji lze již od 49 dolarů. Požadovaná částka 20 000 dolarů byla překonána již 6 krát. Majitelé mini konzole si budou moci zahrát hry pro Atari VCS 2600, Sega Genesis nebo NES. Předinstalováno bude multimediální centrum Kodi.

Ladislav Hagara | Komentářů: 0
včera 00:10 | Nová verze

Byla vydána verze 4.7 redakčního systému WordPress. Kódové označením Vaughan bylo vybráno na počest americké jazzové zpěvačky Sarah "Sassy" Vaughan. Z novinek lze zmínit například novou výchozí šablonu Twenty Seventeen, náhledy pdf souborů nebo WordPress REST API.

Ladislav Hagara | Komentářů: 4
6.12. 12:00 | Zajímavý projekt

Projekt Termbox umožňuje vyzkoušet si linuxové distribuce Ubuntu, Debian, Fedora, CentOS a Arch Linux ve webovém prohlížeči. Řešení je postaveno na projektu HyperContainer. Podrobnosti v často kladených dotazech (FAQ). Zdrojové kódy jsou k dispozici na GitHubu [reddit].

Ladislav Hagara | Komentářů: 27
6.12. 11:00 | Bezpečnostní upozornění

Byly zveřejněny informace o bezpečnostní chybě CVE-2016-8655 v Linuxu zneužitelné k lokální eskalaci práv. Chyba se dostala do linuxového jádra v srpnu 2011. V upstreamu byla opravena minulý týden [Hacker News].

Ladislav Hagara | Komentářů: 2
5.12. 22:00 | Komunita

Přibližně před měsícem bylo oznámeno, že linuxová distribuce SUSE Linux Enterprise Server (SLES) běží nově také Raspberry Pi 3 (dokumentace). Obraz verze 12 SP2 pro Raspberry Pi 3 je ke stažení zdarma. Pro registrované jsou po dobu jednoho roku zdarma také aktualizace. Dnes bylo oznámeno, že pro Raspberry Pi 3 je k dispozici také nové openSUSE Leap 42.2 (zprávička). K dispozici je hned několik obrazů.

Ladislav Hagara | Komentářů: 6
5.12. 06:00 | Zajímavý software

OMG! Ubuntu! představuje emulátor terminálu Hyper (GitHub) postavený na webových technologiích (HTML, CSS a JavaScript). V diskusi k článku je zmíněn podobný emulátor terminálu Black Screen. Hyper i Black Screen používají framework Electron, stejně jako editor Atom nebo vývojové prostředí Visual Studio Code.

Ladislav Hagara | Komentářů: 50
5.12. 06:00 | Zajímavý článek

I letos vychází řada ajťáckých adventních kalendářů. QEMU Advent Calendar 2016 přináší každý den nový obraz disku pro QEMU. Programátoři se mohou potrápit při řešení úloh z kalendáře Advent of Code 2016. Kalendáře Perl Advent Calendar 2016 a Perl 6 Advent Calendar přinášejí každý den zajímavé informace o programovacím jazyce Perl. Stranou nezůstává ani programovací jazyk Go.

Ladislav Hagara | Komentářů: 10
3.12. 16:24 | Nová verze

Byla vydána Mageia 5.1. Jedná se o první opravné vydání verze 5, jež vyšla v červnu loňského roku (zprávička). Uživatelům verze 5 nepřináší opravné vydání nic nového, samozřejmě pokud pravidelně aktualizují. Vydání obsahuje všechny aktualizace za posledního téměř půldruhého roku. Mageia 5.1 obsahuje LibreOffice 4.4.7, Linux 4.4.32, KDE4 4.14.5 nebo GNOME 3.14.3.

Ladislav Hagara | Komentářů: 17
Kolik máte dat ve svém domovském adresáři na svém primárním osobním počítači?
 (32%)
 (24%)
 (29%)
 (7%)
 (5%)
 (3%)
Celkem 790 hlasů
 Komentářů: 50, poslední 29.11. 15:50
Rozcestník
Reklama

Dotaz: instalace adobe flash playeru - převod rpm na apt?

24.6.2014 14:11 Tess
instalace adobe flash playeru - převod rpm na apt?
Přečteno: 1386×
potřebuju nainstalovat na lubuntu flash player od adobe, teď mám nainstalovanou alternativu ale jdou mi třeba jen videa na youtube, když si chci pustit video na ivysílání, tak to vypisuje hlášku s požadavkem flashe od adobe... flash jsem si stáhla ale je ve formátu rpm.. jak to převést do jiného formátu který by šel nainstalovat nebo jak to nainstalovat? smart package manager mi ten stáhnutý soubor nenajde.. díky

Odpovědi

24.6.2014 14:20 Nobody
Rozbalit Rozbalit vše Re: instalace adobe flash playeru - převod rpm na apt?
1) stahni flash player ve formatu tar.gz.
2) gunzip -c flash.tar.gz | tar -x
3) libflashplayer a usr/ presun do ~/.mozilla/plugins
24.6.2014 16:57 Tess
Rozbalit Rozbalit vše Re: instalace adobe flash playeru - převod rpm na apt?
nejdříve jsem zkusila nainstalovat ten program, ale neřeší to můj problém :( takže jsem jela podle návodu výše.. extrahovala jsem stáhnutý flash soubor tar.gz pomocí terminálu, tím se mi vytvořily 3 soubory včetně readme, složku usr a soubor libflashplayer.so jsem překopírovala do mozilla/plugins, ale nejde to, vždy to hodí hlášku: usr - chyba při vytváření adresáře - operace zamítnuta, a u libflash - chyba při otevírání souboru, co je špatně???
Václav 24.6.2014 17:22 Václav "Darm" Novák | skóre: 26 | blog: Darmovy_kecy | Bechyně / Praha
Rozbalit Rozbalit vše Re: instalace adobe flash playeru - převod rpm na apt?
A co jsi používala za alternativu? Odinstalovala jsi ji před nainstalováním těch restricted-extras?

Raději bych to řešil touhle cestou, než vysvětlovat ruční kopírování a pak skončit s flashem na který nebudeš dostávat bezpečnostní opravy…
Cross my heart and hope to fly, stick a cupcake in my eye!
25.6.2014 15:36 Nobody
Rozbalit Rozbalit vše Re: instalace adobe flash playeru - převod rpm na apt?
Asi nemas prava. Kopirovat mas do .mozilla/plugins ve svem domovskem adrasari, tzn.:
cp -R usr /home/jmenouzivatele/.mozilla/plugins/.
cp libflashplayer.so /home/jmenouzivatele/.mozilla/plugins/.
Václav 24.6.2014 14:22 Václav "Darm" Novák | skóre: 26 | blog: Darmovy_kecy | Bechyně / Praha
Rozbalit Rozbalit vše Re: instalace adobe flash playeru - převod rpm na apt?
Pokud je to jen trochu možné, doporučuji vyhnout se instalaci programů z webových stránek a vždy používat repozitáře.

Pokud jde o věci jako flash, různé kodeky a podobně, měl by to vyřešit balíček lubuntu-restricted-extras

v terminálu:

sudo apt-get install lubuntu-restricted-extras

nebo to samé v grafickém správci balíčku synaptic
Cross my heart and hope to fly, stick a cupcake in my eye!
24.6.2014 16:50 Tess
Rozbalit Rozbalit vše Re: instalace adobe flash playeru - převod rpm na apt?
nejdříve jsem zkusila nainstalovat ten program, ale neřeší to můj problém :( takže jsem jela podle návodu výše.. extrahovala jsem stáhnutý flash soubor tar.gz pomocí terminálu, tím se mi vytvořily 3 soubory včetně readme, složku usr a soubor libflashplayer.so jsem překopírovala do mozilla/plugins, ale nejde to, vždy to hodí hlášku: usr - chyba při vytváření adresáře - operace zamítnuta, a u libflash - chyba při otevírání souboru co je špatně???
24.6.2014 17:23 MadCatX
Rozbalit Rozbalit vše Re: instalace adobe flash playeru - převod rpm na apt?
V Linuxu nejde bez práv roota (něco jako Administrator ve Windows) zapisovat jinam než do /home/<jméno uživatele>. Nicméně v Ubuntu by nemělo být potřeba Flash Player instalovat takto ručně, mělo by stačit
  1. Otevřít soubor se seznamem povolených repozitářů (servery, odkud Ubuntu stahuje balíčky se softwarem)
      gksu leafpad /etc/apt/sources.list
      
  2. Ověřit, že v tomto souboru není zakomentovaný následující řádek (=nezačíná znakem #)
      deb http://us.archive.ubuntu.com/ubuntu/ trusty multiverse
      
    Pokud zakomentovaný je, stačí úvodní # smazat a soubor uložit. (Předpokládám, že je nasintalováno poslední Lubuntu 14.04. Pokud jde o starší verzi, bude tam místo trusty např. saucy č raring)
  3. Nainstalovat Flash Player takto
      sudo apt-get install flashplugin-installer 
      
  4. Po restartování prohlížeče by měl být Flash Player k dispozici.
Kdyby to snad z nějakého důvodu nefungovalo, stačí spustit správce souborů pomocí
gksu pcmanfm
a půjde to nainstalovat i ručním překopírováním libflashplayer.so do /usr/lib/mozilla/plugins
25.6.2014 17:01 Tess
Rozbalit Rozbalit vše Re: instalace adobe flash playeru - převod rpm na apt?
ten řádek ve druhém bodě jsem tam vůbec nenašla, tak jsem ho tam dopsala u třetího bodu, provede to operaci a pak to vypíše 0 installed, 0 aktualizováno a 10 neaktualizováno.. a když jsem překopírovala ručně ty dva soubory u 4, tak to šlo :) ale nijak to nevyřešilo můj problém, na ivysílání to pořád vypisuje nutnost mít nainstalovaný adobe flash player verze... a vyšší... :(
25.6.2014 18:36 MadCatX
Rozbalit Rozbalit vše Re: instalace adobe flash playeru - převod rpm na apt?
Tohle se mně celé moc nezdá. Co je to za verzi Lubuntu a odkud jsi vzala ten balíček s Flashem? Na oficiálním webu Adobe je totiž ke stažení i APT balíček pro Ubuntu 10.04+ s Flashem 11.2, který na iVysilani.cz funguje v pohodě. Co původně obsahoval /etc/apt/sources.list?
25.6.2014 19:11 Tess
Rozbalit Rozbalit vše Re: instalace adobe flash playeru - převod rpm na apt?
obsahoval cz.archive.ubuntu.com a security.ubuntu.com
25.6.2014 19:21 MadCatX
Rozbalit Rozbalit vše Re: instalace adobe flash playeru - převod rpm na apt?
No to jo, ale pro jakou verzi? Pro poslední verzi Ubuntu by mělo za adresou repozitáře být uvedeno trusty. Verze Ubuntu se dá přečíst třeba ze souboru /etc/lsb-release.
25.6.2014 19:30 Tess
Rozbalit Rozbalit vše Re: instalace adobe flash playeru - převod rpm na apt?
Lubuntu 14.04
25.6.2014 20:28 MadCatX
Rozbalit Rozbalit vše Re: instalace adobe flash playeru - převod rpm na apt?
Musel jsem si to vyzkoušet na LiveCD Lubuntu a narazil jsem u toho na trochu nešikovný problém. Nevypadal ten tvůj /etc/apt/sources.list původně takto?
deb cdrom:[Lubuntu 14.04 LTS _Trusty Tahr_ - Release amd64 (20140416.2)]/ trusty main multiverse restricted universe
deb http://archive.ubuntu.com/ubuntu/ trusty main restricted universe multiverse
deb http://security.ubuntu.com/ubuntu/ trusty-security main restricted universe multiverse
deb http://archive.ubuntu.com/ubuntu/ trusty-updates main restricted universe multiverse
Pokud ano, bude se instalátor balíčků snažit instalovat software z instalačního CD místo z webu. Software z webových repozitárů je samozřejmě aktuálnější a zrovna v případě balíčku flashplugin-installer ta neshoda mezi verzí na CD a verzí na webu způsobí, že se Flash nenainstaluje korektně. Pokud to tak je, navrhoval bych
  1. Uvést /etc/apt/sources.list do původního stavu
  2. "Odinstalovat" balíček s Flashem
    sudo apt-get remove flashplugin-installer
  3. Smazat libflashplayer.so z /usr/lib/mozilla/plugins
  4. Z /etc/apt/sources.list vyhodit řádek obsahující cdrom: (stačilo by ho i zakomentovat připsáním # na začátek řádku)
  5. Aktualizovat systém pomocí
    sudo apt-get update
  6. Nainstalovat Flash znovu pomocí
    sudo apt-get install flashplugin-installer
V mém případě tohle fungovalo...

Dotaz na Ubuntisty/Debianisty mezi námi: Z jakého důvodu - kromě silné intoxikace psychotropní látkou odpovědného vývojáře - je tohle proboha standardní nastavení!? Je to takhle i na jiných odnožích Ubuntu?
26.6.2014 15:14 Tess
Rozbalit Rozbalit vše Re: instalace adobe flash playeru - převod rpm na apt?
ano, mám to tam velmi obdobné jak mám ten sources.list uvést do původního stavu? kde si to můžu okopírovat? děkuju :)
26.6.2014 15:53 Tess
Rozbalit Rozbalit vše Re: instalace adobe flash playeru - převod rpm na apt?
tak jsem provedla vše podle bodů.. při instalaci to už opravdu něco dělalo, ne jako dřív.. :) ale když spustím youtube, tak je tam prázdné pole, to samé na ivysílání (dřív mi to vypisovalo požadavky a obrázek stromečku).. když ale spustím konrolní stránky adobe, tak tam mi flash jede, ale shock flash mi nejede (a přitom ho v doplňcích mám zapnutej).. teď asi bude problém v nastavení prohlížeči.. :( zkoušela jsem jiný prohlížeč - chromium, ale tam mi nefunguje vkládání textu do polí.. jak do pole pro zadání adresy, tak všude jinde..
26.6.2014 16:34 MadCatX
Rozbalit Rozbalit vše Re: instalace adobe flash playeru - převod rpm na apt?
Aspoň něco, možná tam něco zůstalo po tom původním flashi. V /usr/lib/mozilla/plugins/ by měl být jen flashplugin-alternative.so. Když ve Firefoxu napíšeš do adresního řádku about:plugins, vypíše se seznam nainstalovaných pluginů. "Shockwave Flash" tam musí být jen jednou, v Path musí být uvedena správná cesta k "flashplugin-alternative.so" a Version 11.2.202.378.

S Chromiem jsem měl vždycky dost dobrou zkušenost. Skoro mě napadá, zda by nebylo lepší to načisto přeinstalovat, opravit sources.list (bude-li to nutné, nesmí prostě být jako první zdroj sofwaru uveden cdrom), aktualizovat systém a až pak zkusit instalovat prohlížeče a Flash.
27.6.2014 17:37 Tess
Rozbalit Rozbalit vše Re: instalace adobe flash playeru - převod rpm na apt?
tak jsem přeinstalovala kompletně celý linux i se smazáním dat.. poté upravila source list, aktualizovala systém, aktualizovala všechny programy přes správce aktualizací, stáhla adobe flash player.. to všechno přes terminál.. flash jede, jen asi není povolený v prohlížeči nebo je tam nějaký jiný problém.. protože opět prázdná pole tam, kde má flash přehrávat video.. :( :( co mám dělat? vypnutí hardwarové akcelerace jsem zkoušela a nic to nemění.. :(
27.6.2014 19:20 MadCatX
Rozbalit Rozbalit vše Re: instalace adobe flash playeru - převod rpm na apt?
Co je to vůbec za stroj a co za verzi Flashe tam bylo na Win XP? Flash má totiž od nějaké verze nenápadné omezení, kvůli kterému nefunguje na starších procesorech (platí jen pro 32bit). Podrobné informace o procesoru se dají zjistit z výpisu cat /proc/cpuinfo. Videa z YouTube se dají přehrát i přes HTML5, na YT je to ale třeba zvlášť povolit, viz http://youtube.com/html5
27.6.2014 20:09 Tess
Rozbalit Rozbalit vše Re: instalace adobe flash playeru - převod rpm na apt?
na Xpéčkách mi flash jel v pohodě na chrome.. CPU: AMD AthlonXP 2200+ 1.80 (teď 1.79) GHz/266MHz socket A BOX, 32 bit
27.6.2014 21:51 MadCatX
Rozbalit Rozbalit vše Re: instalace adobe flash playeru - převod rpm na apt?
Athlon XP 2200+ nepodporuje instrukční sadu SSE2, bez které Flash 11.2 nefunguje. Jediným řešením je ruční instalace starší verze, která toto omezení nemá. Je tedy potřeba
  1. Odinstalovat současný Flash
  2. Stáhnout poslední verzi, která si vystačí bez SSE2 (http://fpdownload.macromedia.com/get/flashplayer/installers/archive/fp_11.1.102.63_archive.zip)
  3. Z tohoto archivu rozbalit flashplayer11_1r102_63_linux.i386.tar.gz, kde je obsažena libflashplayer.so
  4. Nakopírovat tuto libflashplayer.so do /usr/lib/mozilla/plugins/
  5. Ve Firefoxu v about:config změnit hodnotu extensions.blocklist.enabled na false, aby si Firefox nestěžoval, že je nainstalována stará verze pluginu
  6. Kdekoliv, kde je to možné využívat místo Flashe HTML5
29.6.2014 10:31 Tess
Rozbalit Rozbalit vše Re: instalace adobe flash playeru - převod rpm na apt?
dostala jsem se ke 4. bodu, při ručním kopírování se mi zobrazí okno s výsledkem: usr: Chyba při vytváření adresáře: Operace zamítnuta libflashplayer.so: Chyba při otevírání souboru „/usr/lib/mozilla/plugins/libflashplayer.so“: Operace zamítnuta

koukla jsem se do sources listu kde jsem odkomentovala: deb http://archive.canonical.com/ubuntu trusty partner deb-src http://archive.canonical.com/ubuntu trusty partner

ostatní mám odkomentované, ale stále to nejde

HTML 5 jsem nastavila, nicméně se mi video promítá jako prezentace obrázků, tak jsem vypnula v nastavení hardwarovou akceleraci, nepomohlo :( :(

je ještě něco co mohu zkusit? kdyby bylo jen na mě, tak bych si nainstalovala gnash, mě youtube stačí, ale rodina se chce koukat na ivysílání a na iplay od primy..

díky za trpělivost :)
29.6.2014 11:01 MadCatX
Rozbalit Rozbalit vše Re: instalace adobe flash playeru - převod rpm na apt?
Pro kopírování kamkoliv mimo /home jsou potřeba práva roota, viz http://www.abclinuxu.cz/poradna/linux/show/392978#6
29.6.2014 11:36 Tess
Rozbalit Rozbalit vše Re: instalace adobe flash playeru - převod rpm na apt?
už to jede!!! :) :)

použila jsem: gksu pcmanfm

ještě jednou moc děkuju :)

HTML 5 jsem musela vypnout, protože se mi to přehrává jako prezentace obrázků..

24.6.2014 18:34 Petr Šobáň | skóre: 79 | blog: soban | Olomouc
Rozbalit Rozbalit vše Re: instalace adobe flash playeru - převod rpm na apt?
Já používám normálně balíček co je v ubuntu a i vysílání funguje na české televizi.

Mám nainstalovaný balíček flashplugin-installer a ubuntu-restricted-extras.

Jinak v ubuntu jsou dva balíčky tak je možný že ten druhý nefunguje, takže odinstaluj všechny balíčky co nějak souvisí s flash a vyber tyto dva a nainstaluj a musí to chodit.

Jinak vím že někdy dříve byl problém s konfigurací flash, nevím zda muselo být povoleno nebo zakázano HW akcelerace grafiky v flash jinak to nehrálo.

Založit nové vláknoNahoru

Tiskni Sdílej: Linkuj Jaggni to Vybrali.sme.sk Google Del.icio.us Facebook

ISSN 1214-1267   www.czech-server.cz
© 1999-2015 Nitemedia s. r. o. Všechna práva vyhrazena.