abclinuxu.cz AbcLinuxu.cz itbiz.cz ITBiz.cz HDmag.cz HDmag.cz abcprace.cz AbcPráce.cz
AbcLinuxu hledá autory!
Inzerujte na AbcPráce.cz od 950 Kč
Rozšířené hledání
×
dnes 05:55 | Komunita

Dries Buytaert, autor a vedoucí projektu Drupal a prezident Drupal Association, požádal soukromě před několika týdny Larryho Garfielda, jednoho z klíčových vývojářů Drupalu, aby projekt Drupal opustil. Larry Garfield minulý týden na svých stránkách napsal, že důvodem jsou jeho BDSM praktiky a rozpoutal tím bouřlivou diskusi. Na druhý den reagoval Dries Buytaert i Drupal Association. Pokračuje Larry Garfield [reddit].

Ladislav Hagara | Komentářů: 0
dnes 04:44 | Humor

Společnost SAS zveřejnila na svých stránkách studii s názvem Open Source vs Proprietary: What organisations need to know (pdf). Organizace by měly například vědět, že ideální je mix 40 % open source softwaru a 60 % proprietárního softwaru [Slashdot].

Ladislav Hagara | Komentářů: 0
včera 23:33 | Zajímavý software

Byl vydán ShellCheck ve verzi 0.4.6. Jedná se o nástroj pro statickou analýzu shellových skriptů. Shellové skripty lze analyzovat na webové stránce ShellChecku, v terminálu nebo přímo z textových editorů. Příklady kódů, na které analýza upozorňuje a doporučuje je přepsat. ShellCheck je naprogramován v programovacím jazyce Haskell. Zdrojové kódy jsou k dispozici na GitHubu pod licencí GPLv3.

Ladislav Hagara | Komentářů: 0
včera 23:33 | Pozvánky

Czech JBoss User Group zve na setkání JBUG v Brně, které se koná ve středu 5. dubna 2017 v prostorách Fakulty informatiky Masarykovy univerzity v místnosti A318 od 18:00. Přednáší Pavol Loffay na téma Distributed Tracing and OpenTracing in Microservice Architecture.

… více »
mjedlick | Komentářů: 0
včera 11:33 | Zajímavý článek

Národní centrum kybernetické bezpečnosti (NCKB) vypracovalo (pdf) 26 podrobných bezpečnostních doporučení pro síťové správce. Tato doporučení jsou nastavena tak, aby je bylo možné aplikovat v každé instituci. Jsou rozdělena na tři základní části: bezpečnost infrastruktury, bezpečnost stanic a serverů a bezpečnost uživatelů.

Ladislav Hagara | Komentářů: 11
včera 05:55 | Komunita

Prezident Nadace pro svobodný software (FSF) Richard M. Stallman vyhlásil na slavnostním ceremoniálu v rámci konference LibrePlanet 2017 vítěze Free Software Awards za rok 2016. Ocenění za společenský přínos získal SecureDrop (Wikipedie). Za rozvoj svobodného softwaru byl oceněn Alexandre Oliva (Wikipedie).

Ladislav Hagara | Komentářů: 0
včera 04:44 | Nová verze

Byla vydána verze 0.7.0 debugovacího nástroje cgdb. Mezi novinky patří například zvýrazňování syntaxe jazyka Rust. Podrobnosti v poznámkách o vydání.

Neel | Komentářů: 0
25.3. 22:00 | Komunita

Portál Stack Overflow po roce opět vyzpovídal své uživatele, jedná se především o vývojáře softwaru, a zveřejnil (podcast) detailní výsledky průzkumu. Průzkumu se letos zúčastnilo více než 64 tisíc vývojářů. Jejich nejmilovanější platformou je linuxový desktop. Ten je také druhou nejpoužívanější platformou vývojářů.

Ladislav Hagara | Komentářů: 7
24.3. 11:55 | Komunita

Vývojový tým OpenSSL ve spolupráci s iniciativou Core Infrastructure konsorcia Linux Foundation spustil proces přelicencování této kryptografické knihovny ze současné licence na licenci Apache Licence v 2.0 (ASLv2). Nová licence usnadní začleňování OpenSSL do dalších svobodných a open source projektů. Všichni dosavadní vývojáři OpenSSL (Authors) obdrží v následujících dnech email s prosbou o souhlas se změnou licence.

Ladislav Hagara | Komentářů: 32
24.3. 01:11 | Komunita

Před třemi týdny Mozilla.cz představila projekt Photon, jehož cílem je návrh a implementace nového vzhledu Firefoxu. Včera zveřejnila první náhled vzhledu Photon. Práce na projektu Photon jsou rozděleny do pěti týmů, které celkem čítají 19 lidí. Zaměřují se na zlepšení prvního spuštění Firefoxu a zaujetí nových uživatelů, celkovou úpravu vzhledu, zlepšení animací, zrychlení odezvy uživatelského rozhraní a také upravení nabídek. Vývoj lze sledovat v Bugzille.

Ladislav Hagara | Komentářů: 51
Jak se stavíte k trendu ztenčování přenosných zařízení (smartphony, notebooky)?
 (14%)
 (2%)
 (71%)
 (3%)
 (10%)
Celkem 947 hlasů
 Komentářů: 72, poslední 1.3. 11:16
    Rozcestník

    Dotaz: Nastaveni wfif klienta na OpenWRT

    19.9.2015 08:05 slackware
    Nastaveni wfif klienta na OpenWRT
    Přečteno: 189×
    Preji pekny den panove, nejde mi nastavit na openwrt wifi klient. Respektive si myslim ze jsem vsechno nastavil a stejne se nepripoji k apcku. Jedna se o router Nexx wt1520 s openwrt Bleeding Edge-r46796. Nastaveni wifi:
    /etc/config/wireless
    
    config wifi-device wlan0  
            option type     mac80211
            option channel  11
            option hwmode   11g
            option path     '10180000.wmac'
            option htmode   HT20
            # REMOVE THIS LINE TO ENABLE WIFI:
            option disabled 0
    
    config wifi-iface
            option device   wlan0 
            option network  lan
            option mode     sta
            option ssid     HomeNet
            option encryption psk2
            option key      TajneHeslooo
    
    
    Nastaveni site:
    /etc/config/network
    
    config interface 'lan'        
           option ifname 'wlan0'            
            option force_link '1'             
            option macaddr '00:0c:43:70:e5:83'
            option type 'bridge'       
            option proto 'static'         
            option ipaddr '192.168.1.1'   
            option netmask '255.255.255.0'
    #       option ip6assign '60'
                                
    
    
    Vypis wifi info:
    
    root@OpenWrt:/# iwinfo 
    wlan0     ESSID: unknown
              Access Point: 00:00:00:00:00:00
              Mode: Client  Channel: unknown (unknown)
              Tx-Power: 20 dBm  Link Quality: unknown/70
              Signal: unknown  Noise: unknown
              Bit Rate: unknown
              Encryption: unknown
              Type: nl80211  HW Mode(s): 802.11bgn
              Hardware: unknown [Generic MAC80211]
              TX power offset: unknown
              Frequency offset: unknown
              Supports VAPs: yes  PHY name: phy0
    
    
    Konfigurace je po mich upravach. Kdyz to vratim do defaultniho nastaveni, je v konfiguracnich soouborech pouzito radio0. I kdyz jej zachovam a prepisu jen mode z ap na sta a pridam sifrovani s klicem stejne se nenapoji. Cilem je aby router mel v bridgi wifi (klient mod s wpa2) a lan.

    Odpovědi

    19.9.2015 13:29 petr_p | skóre: 59 | blog: pb
    Rozbalit Rozbalit vše Re: Nastaveni wfif klienta na OpenWRT

    WiFi klient nemůže být v bridgi s jiným ethernetovým rozhraním:

    Když z ethernetu přijde rámec pro AP, bridge jej pošle do wifi rozhraní. I kdyby se jej klient pokusil odvysílat, tak jej AP bude ignorovat, protože žádný wifi klient s linkovou adresou rovnou zdrojové adrese rámce (tedy zařezení z ethernetové linky) není na AP asociován. Asociován je jen klient pod adresou wifi rozhraní. Zrovna tak obráceně AP nebude vědět, kam rámec odeslat, protože žádný asociovaný wifi nemá takovou linkovou adresu. Kdyby wifi klient zdrojovou adresu rámce přepsal na vlastní (L2 NAT), tak bude problém s opačným směrem, protože odpověď bude na linkové vrstvě určena klientovi, který nijak nebude moci rozpoznat, že jej má přepsat zpátky a přeslat to ethernetu (ethernet je bezstavový).

    Existuje rozšíření 802.11, které tuneluje rámce to 802.11 rámců (název si nepamatuji), ale na to musí být AP i dotyčný klient ručně nastaveny.

    Tohle všechno ovšem neřeší, proč se vám klient neasociuje na AP.

    19.9.2015 14:21 slackware
    Rozbalit Rozbalit vše Re: Nastaveni wfif klienta na OpenWRT
    V pripade kdy nepujde dat do bridge ani proxy arp ethernet s wlan, provedl bych nat nebo routing. Ale proc se nechce asociovat?

    Založit nové vláknoNahoru

    Tiskni Sdílej: Linkuj Jaggni to Vybrali.sme.sk Google Del.icio.us Facebook

    ISSN 1214-1267   www.czech-server.cz
    © 1999-2015 Nitemedia s. r. o. Všechna práva vyhrazena.