abclinuxu.cz AbcLinuxu.cz itbiz.cz ITBiz.cz HDmag.cz HDmag.cz abcprace.cz AbcPráce.cz
AbcLinuxu hledá autory!
Inzerujte na AbcPráce.cz od 950 Kč
Rozšířené hledání
×
včera 22:00 | Komunita

Portál Stack Overflow po roce opět vyzpovídal své uživatele, jedná se především o vývojáře softwaru, a zveřejnil (podcast) detailní výsledky průzkumu. Průzkumu se letos zúčastnilo více než 64 tisíc vývojářů. Jejich nejmilovanější platformou je linuxový desktop. Ten je také druhou nejpoužívanější platformou vývojářů.

Ladislav Hagara | Komentářů: 0
24.3. 11:55 | Komunita

Vývojový tým OpenSSL ve spolupráci s iniciativou Core Infrastructure konsorcia Linux Foundation spustil proces přelicencování této kryptografické knihovny ze současné licence na licenci Apache Licence v 2.0 (ASLv2). Nová licence usnadní začleňování OpenSSL do dalších svobodných a open source projektů. Všichni dosavadní vývojáři OpenSSL (Authors) obdrží v následujících dnech email s prosbou o souhlas se změnou licence.

Ladislav Hagara | Komentářů: 8
24.3. 01:11 | Komunita

Před třemi týdny Mozilla.cz představila projekt Photon, jehož cílem je návrh a implementace nového vzhledu Firefoxu. Včera zveřejnila první náhled vzhledu Photon. Práce na projektu Photon jsou rozděleny do pěti týmů, které celkem čítají 19 lidí. Zaměřují se na zlepšení prvního spuštění Firefoxu a zaujetí nových uživatelů, celkovou úpravu vzhledu, zlepšení animací, zrychlení odezvy uživatelského rozhraní a také upravení nabídek. Vývoj lze sledovat v Bugzille.

Ladislav Hagara | Komentářů: 38
23.3. 20:00 | Komunita

OneDrive pro firmy je již ve webových prohlížečích na Linuxu stejně rychlý jako na Windows. Microsoft opravil chybu z listopadu loňského roku. OneDrive pro firmy běžel na Linuxu mnohem pomaleji než na Windows. V popisu chyby bylo uvedeno, že stačilo v prohlížeči na Linuxu nastavit v user-agentu Windows a vše se zrychlilo. Odpovědí Microsoftu bylo (Internet Archive: Wayback Machine), že Linux není podporován. Po bouřlivých diskusích na redditu i Hacker News byla chyba nalezena a opravena.

Ladislav Hagara | Komentářů: 6
23.3. 19:00 | Zajímavý projekt

Byla vyhlášena soutěž Hackaday Prize 2017. Soutěž je určena vývojářům open source hardwaru. Pro výherce je připraveno celkově 250 tisíc dolarů. Každý ze 120 finalistů získá tisíc dolarů. Nejlepší pak navíc 50, 30, 20, 15, 10 a 5 tisíc dolarů. Jedná se již o čtvrtý ročník soutěže. V roce 2014 zvítězil projekt globální sítě open source pozemních satelitních stanic SatNOGS. V roce 2015 zvítězil open source systém pro řízení elektrických invalidních vozíků pohybem očí Eyedriveomatic. V roce 2016 zvítězil modulární robot Dtto.

Ladislav Hagara | Komentářů: 0
23.3. 15:00 | Bezpečnostní upozornění

Byla vydána Samba ve verzích 4.6.1, 4.5.7 a 4.4.12. Řešen je bezpečnostní problém CVE-2017-2619. Pomocí symbolických odkazů a souběhu (symlink race) lze "teoreticky" získat přístup k souborům, které nejsou sdíleny. Linuxové distribuce jsou postupně aktualizovány (Debian).

Ladislav Hagara | Komentářů: 0
23.3. 07:43 | Nová verze

Na Steamu se objevil port hry Arma: Cold War Assault (Operation Flashpoint) pro Mac a Linux. … více »

creon | Komentářů: 30
23.3. 05:55 | Nová verze

Po 18 měsících od vydání verze 8.0 byla vydána verze 9.0 open source alternativy GitHubu, tj. softwarového nástroje s webovým rozhraním umožňujícího spolupráci na zdrojových kódech, GitLab. Představení nových vlastností v příspěvku na blogu a na YouTube.

Ladislav Hagara | Komentářů: 0
23.3. 03:33 | Komunita

Platnost posledního patentu souvisejícího s Dolby Digital (AC-3) vypršela. Po MP3 se tak do Fedory oficiálně dostane také kodek AC-3.

Ladislav Hagara | Komentářů: 5
23.3. 00:44 | Komunita

Feral Interactive, společnost zabývající se vydáváním počítačových her pro operační systémy macOS a Linux, nabízí své hry na Steamu vývojářům open source 3D grafické knihovny Mesa zdarma. Podmínkou je minimálně 25 commitů za posledních 5 let. Stejnou nabídku dostali vývojáři knihovny Mesa v roce 2015 od Valve. O rok dříve dostali od Valve tuto nabídku vývojáři Debianu a Ubuntu.

Ladislav Hagara | Komentářů: 0
Jak se stavíte k trendu ztenčování přenosných zařízení (smartphony, notebooky)?
 (14%)
 (2%)
 (72%)
 (3%)
 (10%)
Celkem 932 hlasů
 Komentářů: 72, poslední 1.3. 11:16
    Rozcestník

    Dotaz: openWRT statické přidělení IPv6 adres do LAN

    14.2.2016 22:01 lertimir | skóre: 59 | blog: Par_slov
    openWRT statické přidělení IPv6 adres do LAN
    Přečteno: 214×
    Tedy trochu se cítím hloupě ale nedaří se mi to najít. Rád bych, aby do lokální sítě dostal statickou konfiguraci dhcpv6, vždy stejné adresy IPv6 pro zařízení s DHCP protokolem. IPv6 mi funguje. V /etc/config/network mám
    config interface 'lan'
            option force_link '1'
            option type 'bridge'
            option proto 'static'
            option ip6assign '60'
            option _orig_ifname 'eth0.1 wlan0 wlan1'
            option _orig_bridge 'true'
            option ipaddr '10.0.0.140'
            option ifname 'eth0.1'
            option netmask '255.255.0.0'
    
    config interface 'wan6'
            option ifname '@wan'
            option _orig_ifname '@wan'
            option _orig_bridge 'false'
            option proto 'dhcpv6'
            option macaddr '30:B5:C2:69:6C:66'
    
    od poskytovatele přes klienta dhcpv6 dostanu vše co potřebuji, (interní sít a masku a vnější adresu s maskou) Komunikace bez problémů funguje (ven). Problém je v tom, že na rozdíl od IPv4, kde mám v /etc/config/dhcp naskládané jména a IPv4 adresy a každé zařízení je dostane vždy stejné, na IPv6 OWRT používá několik sufixů, které k zařízením strká v podstatě náhodně. Takže různá zařízení mohou dostat stejnou IPv6 adresu v různém čase. Pro komunikaci ven to problém není, ale pro komunikaci na zařízení ano. Protože ssh v tabulce known_host má adresu pro jiný stroj a stěžuje si, což blokne automatický proces jako je zálohování. A na openWRT Network configuration a DNS and DHCP configuration nic není. První řeší jak udělat funkční IPv6 (což je) a druhé jak DHCP konfigurovat staticky pro IPv4. A přitom ten dhcpv6 jaké nějak pracuje, zařízení (nějaké) IPv6 adresy mají. Očekával bych že bud do dhcp nebo do něčeho podobného (dhcpv6) napíšu podobnou konfiguraci se sufixem (nebo plnou adresou) pro jednotlivá zařízení a bude. Ale nikde neumím najít co kam napsat.

    Řešení dotazu:


    Odpovědi

    14.2.2016 22:09 lertimir | skóre: 59 | blog: Par_slov
    Rozbalit Rozbalit vše Re: openWRT statické přidělení IPv6 adres do LAN
    Hm tak pardon. Nejen selektivní slepota při čtení vlastního textu ale i při čtení manuálu. řešení položka hostid v dhcp poli host.
    14.2.2016 22:15 Petr Šobáň | skóre: 79 | blog: soban | Olomouc
    Rozbalit Rozbalit vše Re: openWRT statické přidělení IPv6 adres do LAN
    Je to celkem jednoduché zařízení dostávají dvě IPv6 adresy jednu s náhodně generovanou a druhou založenou na MAC adrese ta je pořád stejná.

    Ale pokud chceš přidělovat svoje vlastní tak to taky jde ale nedá se to zatím naklikat.

    Musíš v konfiguráku svázat MAC, DUID s prefixem.
    14.2.2016 22:18 Petr Šobáň | skóre: 79 | blog: soban | Olomouc
    Rozbalit Rozbalit vše Re: openWRT statické přidělení IPv6 adres do LAN
    config host
            option name 'sony-vaio'
            option ip '192.168.1.x'
            option mac '54:42:49:xx:xx:xx'
            option duid '0004901071a15f278795aa0dd83bde8bxxxx'
            option hostid '00000003'
    14.2.2016 22:38 lertimir | skóre: 59 | blog: Par_slov
    Rozbalit Rozbalit vše Re: openWRT statické přidělení IPv6 adres do LAN
    A jak se to DUID získá? kde si ho zařízení generuje. Zajímá mne to hlavně proto, že máme dvě zařízení oba notebooky HP jeden EleteBook a druhý ProBook a ted vidím v LUCI, že je server vidí se stejným kolizním DUID. (což je patrně příčina všech potíží)
    14.2.2016 22:50 Petr Šobáň | skóre: 79 | blog: soban | Olomouc
    Rozbalit Rozbalit vše Re: openWRT statické přidělení IPv6 adres do LAN
    Bez DUID mě to ten sufix nepřiřadí, jak se generuje nemám páru nikdy jsem po tom nepátral.

    Prostě používám ty IPv6 založené na MAC adrese.

    Adresy založené na EUI se používají jak pro linkové, tak i pro globální adresy. Její největší výhodou je, že se automaticky chovají jako statické adresy (alespoň při zachování prefixu a MAC adresy). Tím v mnohých případech odpadá potřeba ručně konfigurovat adresy či mapování mezi MAC a IP, které je zde automatické. Vyhnete se tím i použití dynamického DNS a podobným věcem.

    Viz: Architektura IPv6 – konfigurace adres a objevování sousedů (2)
    14.2.2016 23:31 lertimir | skóre: 59 | blog: Par_slov
    Rozbalit Rozbalit vše Re: openWRT statické přidělení IPv6 adres do LAN
    Ano bez DUID to ten sufix skutečně nepřiřadí. to co mne tedy zarazilo, že to DUID je v luci (stránka DNS a DHCP) u mne na těch dvou zařízeních stejné. Zatím jsem našel, že ho generuje NetworkMAnager (když tedy jede) a je na obou strojích openSUSE původně nainstalované načisto 13.2 s tím že jeden jsem změnil na Thumbleweed. Nicméně jak zajistíš že když napišeš jménem ssh cilovy-stroj a tvuj systém dostane z openwrt všechny adresy, tak si vybere EUI adresu .
    14.2.2016 23:49 Petr Šobáň | skóre: 79 | blog: soban | Olomouc
    Rozbalit Rozbalit vše Re: openWRT statické přidělení IPv6 adres do LAN
    Jednoduše DNS server.

    Prostě tam pozadávám ty IPv6 AAAA záznamy založené na EUI. (Mám DNS v internetu a pokud OpenWRT nezná stroj tak přepošle dotaz na DNS v internetu.)

    DNS jde rozběhnout i na OpenWRT.

    PS. Nemají ty dva notebooky stejnou MAC na síťovkách.
    15.2.2016 18:31 petr_p | skóre: 59 | blog: pb
    Rozbalit Rozbalit vše Re: openWRT statické přidělení IPv6 adres do LAN
    To by při korektní implementaci vadit nemělo. Za předpokladu, že se nejedná o nějaké embedded zařízení bez trvalé zapisovatelné paměti, DHCP klient by měl DUID vyrobit mimo jiné z náhodného čísla a DUID si uložit pro další použití.
    14.2.2016 22:30 lertimir | skóre: 59 | blog: Par_slov
    Rozbalit Rozbalit vše Re: openWRT statické přidělení IPv6 adres do LAN
    stejně v Luci to nenaklikávám, protože notebooky tam mám navolené tak že oba interfacy (drát i wifi) dostavají stejnou IP právě proto aby na je mohl jednoduše zalohovač. A tohle se LUCI nelíbí takže ručo. A z těch dvou adres co si vybere klient kam se obrátí. mě vybírá tu náhodnou možná proto že má scope "global dynamic" a ta od MAC "global nonprefixroute dynamic". Ale asi by mě to mělo už chodit
    14.2.2016 22:15 NN
    Rozbalit Rozbalit vše Re: openWRT statické přidělení IPv6 adres do LAN
    Jakou mas verzi wrt?

    Založit nové vláknoNahoru

    Tiskni Sdílej: Linkuj Jaggni to Vybrali.sme.sk Google Del.icio.us Facebook

    ISSN 1214-1267   www.czech-server.cz
    © 1999-2015 Nitemedia s. r. o. Všechna práva vyhrazena.