abclinuxu.cz AbcLinuxu.cz itbiz.cz ITBiz.cz HDmag.cz HDmag.cz abcprace.cz AbcPráce.cz
AbcLinuxu hledá autory!
Inzerujte na AbcPráce.cz od 950 Kč
Rozšířené hledání
×
dnes 20:33 | Zajímavý projekt

Byly zveřejněny schémata, firmware a instrukce pro sestavení trackballu Ploopy. Ten používá Arduino, senzor PMW3360 a 1,75palcovou kouli. Zdrojové soubory jsou šířeny pod open-hardware licencí CERN a GNU GPLv3. Tvar je inspirovaný klasickým trackballem Microsoft Trackball Explorer, jehož výroba byla ukončena kolem roku 2005 bez náhrady; projekt Ploopy se k tomu ale z právních důvodů nehlásí. Již vyrobené díly je možno objednat za 200 kanadských dolarů. Další podrobnosti v příspěvcích uživatele crop_octagon na Redditu.

Fluttershy, yay! | Komentářů: 8
dnes 20:22 | Nová verze

Vyšlo desktopové prostředí KDE Plasma 5.17. Novinkou je např. „noční režim“ (pro X11, nejen Wayland), skrytí upozornění při prezentacích (když je připojena obrazovka se stejným obrazem), lepší podpora HiDPI, optimalizace využití zdrojů a mnoho drobných zlepšení a oprav.

Fluttershy, yay! | Komentářů: 1
dnes 12:55 | Pozvánky

Spolek OpenAlt zve příznivce otevřených řešení a přístupu na 169. brněnský sraz, který proběhne v pátek 18. října od 19:00 v restauraci Racek (Jungmanova 5). Před srazem proběhne v 18:00 komentovaná prohlídka nových prostor hackerspacu base48 (přístup je z Mojmírova náměstí).

Ladislav Hagara | Komentářů: 8
dnes 05:55 | Bezpečnostní upozornění

V příkazu sudo byla nalezena a ve verzi 1.8.28 byla již opravena bezpečnostní chyba CVE-2019-14287. V souboru /etc/sudoers lze nastavit, aby daný uživatel mohl konkrétní příkaz spouštět s právy libovolného uživatele (ALL) nebo libovolného uživatele kromě uživatele root (ALL, !root). Spustí-li tento uživatel daný příkaz se sudo s volbou -u#-1 nebo -u#4294967295, tj. pod uživatelem -1 nebo 4294967295, nebude vyžadována autentizace a příkaz se spustí pod právy roota.

Ladislav Hagara | Komentářů: 1
dnes 01:33 | Nová verze

Po více než roce a čtvrt od vydání verze 3.7.0 byla vydána nová verze 3.8.0 programovacího jazyka Python. Přehled novinek v aktualizované dokumentaci. Podrobný přehled změn v Changelogu.

Ladislav Hagara | Komentářů: 14
včera 16:11 | IT novinky

Ke zhlédnutí na Invidious a YouTube je videozáznam rozborky a sborky mobilního telefonu Librem 5.

Ladislav Hagara | Komentářů: 44
včera 13:33 | Komunita

Richard Stallman, zakladatel hnutí svobodného softwaru, se dnes v e-mailové konferenci guix-devel vyjádřil, že svobodný software je apolitický, resp. jedinou přípustnou politikou je politika svobodného softwaru. Reagoval na některé návrhy, že by se do svobodného softwaru měl zabudovat feminismus nebo jiný -ismus. Říká, že témata jako komunismus nebo sexuální orientace jsou „off-topic“. Je v pořádku mít politické názory, ale lidé

… více »
xkucf03 | Komentářů: 92
včera 05:55 | Nová verze

Po téměř dvou letech vývoje od vydání verze 2.0 byla vydána verze 2.1.0 svobodného softwaru ScummVM (Wikipedie) umožňujícího bezproblémový běh mnoha klasických adventur na zařízeních, pro které nebyly nikdy určeny. Podrobnosti v poznámkách k vydání.

Ladislav Hagara | Komentářů: 3
13.10. 10:55 | IT novinky

Josef Průša představil novou 3D tiskárnu Original Prusa MINI. Její cena je 9 990 Kč a tisknout lze na ní objekty do velikosti 18 × 18 × 18 cm.

Ladislav Hagara | Komentářů: 41
12.10. 13:11 | Nová verze

Byla vydána nová stabilní verze 3.0 svobodné decentralizované mikroblogovací platformy a sociální sítě podobné Twitteru Mastodon (Wikipedie). Detailní přehled novinek na GitHubu. Projekt lze podpořit na Patreonu. Aktuálně má přislíbeno 5 697 dolarů měsíčně.

Ladislav Hagara | Komentářů: 2
Kdy jste naposledy viděli počítač s připojeným běžícím CRT monitorem?
 (19%)
 (4%)
 (11%)
 (39%)
 (24%)
 (2%)
Celkem 401 hlasů
 Komentářů: 22, poslední 23.9. 08:36
Rozcestník

www.AutoDoc.Cz

Dotaz: openwrt LTE modem auto připojení

5.10. 18:35 Fanda
openwrt LTE modem auto připojení
Přečteno: 265×
Zdravíčko, rád bych se tu zeptal, jak by se dala vyřešit situace s openwrt a LTE modemem. Jde o to, že mám v autě router MR3020 s s USB LTE modemem. Všechno funguje. Když se ale dostanu někam, kde není signál, model se samozřejmě odpojí, ale už se nepřipojí. Jak by se prosím dalo vyřešit, aby se zase připojil, když je zase na signálu? Předem díky.

Odpovědi

BWPOW avatar 5.10. 18:58 BWPOW | skóre: 21 | Kosice
Rozbalit Rozbalit vše Re: openwrt LTE modem auto připojení
Hmm, divne, lebo moj sa pripoji normalne. Aku verziu OpenWRT pouzivas a ako vyzera tvoj /etc/config/network?
Prisiel som, videl som, hmm ... bwpow.eu
5.10. 19:04 Fanda
Rozbalit Rozbalit vše Re: openwrt LTE modem auto připojení
Připojí se mi automaticky při rebootu, to jo. Ale po výpadku a obnovení signálu ne.. dokonce ani po odpojení a připojení toho modemu za běhu routeru.
config interface 'loopback'
	option ifname 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'fdcb:0357:65b8::/48'

config interface 'lan'
	option type 'bridge'
	option ifname 'eth0'
	option proto 'static'
	option netmask '255.255.255.0'
	option ip6assign '60'
	option delegate '0'
	option ipaddr '192.168.0.1'

config device 'lan_dev'
	option name 'eth0'
	option macaddr 'ac:84:c6:7c:01:6e'

config interface 'lte'
	option ifname 'wwan0'
	option _orig_ifname 'wwan0'
	option _orig_bridge 'false'
	option proto 'ncm'
	option apn 'internet.t-mobile.cz'
	option authtype 'none'
	option delay '20'
	option pdptype 'IP'
	option ipv6 'auto'
	option delegate '0'
	option mode 'auto'
	option device '/dev/ttyUSB0'

config interface 'wwan'
	option proto 'static'
	option netmask '255.255.255.0'
	option gateway '192.168.1.1'
	option ipaddr '192.168.1.254'
5.10. 19:05 Fanda
Rozbalit Rozbalit vše Re: openwrt LTE modem auto připojení
OpenWrt SNAPSHOT r10099-cf46315 / LuCI Master (f138fc93)
Jendа avatar 5.10. 20:25 Jendа | skóre: 75 | blog: Výlevníček | JO70FB
Rozbalit Rozbalit vše Re: openwrt LTE modem auto připojení
Pravděpodobně skončí pppd a už ho nic nenahodí. Já jsem na tohle nikdy nepoužíval distribuční mechanismy, vždycky jsem si spouštěl pppd ručně, v nekonečné smyčce (s nějakým rozumným sleepem mezi pokusy). Nicméně ani spouštění pppd v cyklu nemusí stačit, doporučil bych pravidelně zkoušet spojení (ping někam do netu, případně pokud tam máš openvpn, tak ta má keepalive) a pokud se zjistí, že to zatuhlo, tak pppd killnout a spustit znova. Některé routery (Mikrotik hEX) dokonce umí hardwarový reset modemu odpojením od napájení.
Postavil si radar na kopci. Ale viděl na něm věci.
5.10. 21:29 Fanda
Rozbalit Rozbalit vše Re: openwrt LTE modem auto připojení
Mám to připojený přes NCM, tak teď laboruju s
#!/bin/sh
 if ! ping -q -c 1 -W 10 8.8.8.8 > /dev/null; then
    (ifup lte) &
 fi
Spouštím každou minutu.. tak uvidím, jestli to zafunguje. Myslel jsem, že ale najdu nějaké čistší řešení
8.10. 14:19 Fanda
Rozbalit Rozbalit vše Re: openwrt LTE modem auto připojení
Tak to nějak nezabralo :( modem se stejně po ztrátě signálu sám znovu nepřipojí...
k3dAR avatar 8.10. 15:24 k3dAR | skóre: 56
Rozbalit Rozbalit vše Re: openwrt LTE modem auto připojení
z praxe neznam, jen sem nasel, tedy neni to asi primarne pro tvuj problem, ale kdyz mas vice wan pristupu mezi kterejma to ma samo prepinat, ale treba to jde pouzit (nebo aspon se od toho odkopnout, ci vyuzit pridavane option healt_*) i pro auto aktivace jedne wwan:
https://openwrt.org/docs/guide-user/network/wan/multiwan/multiwan_package
nebo z toho odkazujici na jinej udrzovanej balik:
https://openwrt.org/docs/guide-user/network/wan/multiwan/mwan3
porad nemam telo, ale uz mam hlavu... nobody

Založit nové vláknoNahoru

Tiskni Sdílej: Linkuj Jaggni to Vybrali.sme.sk Google Del.icio.us Facebook

ISSN 1214-1267   www.czech-server.cz
© 1999-2015 Nitemedia s. r. o. Všechna práva vyhrazena.