abclinuxu.cz AbcLinuxu.cz itbiz.cz ITBiz.cz HDmag.cz HDmag.cz abcprace.cz AbcPráce.cz
AbcLinuxu hledá autory!
Inzerujte na AbcPráce.cz od 950 Kč
Rozšířené hledání
×
eParkomat, startup z ČR, postoupil mezi finalisty evropského akcelerátoru ChallengeUp!
Robot na pivo mu otevřel dveře k opravdovému byznysu
Internet věcí: Propojený svět? Už se to blíží...
včera 21:21 | Nová verze Ladislav Hagara | Komentářů: 0
včera 11:44 | Zajímavý projekt

Na Indiegogo byla spuštěna kampaň na podporu herní mini konzole a multimediálního centra RetroEngine Sigma od Doyodo. Předobjednat ji lze již od 49 dolarů. Požadovaná částka 20 000 dolarů byla překonána již 6 krát. Majitelé mini konzole si budou moci zahrát hry pro Atari VCS 2600, Sega Genesis nebo NES. Předinstalováno bude multimediální centrum Kodi.

Ladislav Hagara | Komentářů: 0
včera 00:10 | Nová verze

Byla vydána verze 4.7 redakčního systému WordPress. Kódové označením Vaughan bylo vybráno na počest americké jazzové zpěvačky Sarah "Sassy" Vaughan. Z novinek lze zmínit například novou výchozí šablonu Twenty Seventeen, náhledy pdf souborů nebo WordPress REST API.

Ladislav Hagara | Komentářů: 1
6.12. 12:00 | Zajímavý projekt

Projekt Termbox umožňuje vyzkoušet si linuxové distribuce Ubuntu, Debian, Fedora, CentOS a Arch Linux ve webovém prohlížeči. Řešení je postaveno na projektu HyperContainer. Podrobnosti v často kladených dotazech (FAQ). Zdrojové kódy jsou k dispozici na GitHubu [reddit].

Ladislav Hagara | Komentářů: 26
6.12. 11:00 | Bezpečnostní upozornění

Byly zveřejněny informace o bezpečnostní chybě CVE-2016-8655 v Linuxu zneužitelné k lokální eskalaci práv. Chyba se dostala do linuxového jádra v srpnu 2011. V upstreamu byla opravena minulý týden [Hacker News].

Ladislav Hagara | Komentářů: 2
5.12. 22:00 | Komunita

Přibližně před měsícem bylo oznámeno, že linuxová distribuce SUSE Linux Enterprise Server (SLES) běží nově také Raspberry Pi 3 (dokumentace). Obraz verze 12 SP2 pro Raspberry Pi 3 je ke stažení zdarma. Pro registrované jsou po dobu jednoho roku zdarma také aktualizace. Dnes bylo oznámeno, že pro Raspberry Pi 3 je k dispozici také nové openSUSE Leap 42.2 (zprávička). K dispozici je hned několik obrazů.

Ladislav Hagara | Komentářů: 6
5.12. 06:00 | Zajímavý software

OMG! Ubuntu! představuje emulátor terminálu Hyper (GitHub) postavený na webových technologiích (HTML, CSS a JavaScript). V diskusi k článku je zmíněn podobný emulátor terminálu Black Screen. Hyper i Black Screen používají framework Electron, stejně jako editor Atom nebo vývojové prostředí Visual Studio Code.

Ladislav Hagara | Komentářů: 50
5.12. 06:00 | Zajímavý článek

I letos vychází řada ajťáckých adventních kalendářů. QEMU Advent Calendar 2016 přináší každý den nový obraz disku pro QEMU. Programátoři se mohou potrápit při řešení úloh z kalendáře Advent of Code 2016. Kalendáře Perl Advent Calendar 2016 a Perl 6 Advent Calendar přinášejí každý den zajímavé informace o programovacím jazyce Perl. Stranou nezůstává ani programovací jazyk Go.

Ladislav Hagara | Komentářů: 10
3.12. 16:24 | Nová verze

Byla vydána Mageia 5.1. Jedná se o první opravné vydání verze 5, jež vyšla v červnu loňského roku (zprávička). Uživatelům verze 5 nepřináší opravné vydání nic nového, samozřejmě pokud pravidelně aktualizují. Vydání obsahuje všechny aktualizace za posledního téměř půldruhého roku. Mageia 5.1 obsahuje LibreOffice 4.4.7, Linux 4.4.32, KDE4 4.14.5 nebo GNOME 3.14.3.

Ladislav Hagara | Komentářů: 17
3.12. 13:42 | Pozvánky

V Praze probíhá konference Internet a Technologie 16.2, volné pokračování jarní konference sdružení CZ.NIC. Konferenci lze sledovat online na YouTube. K dispozici je také archiv předchozích konferencí.

Ladislav Hagara | Komentářů: 0
Kolik máte dat ve svém domovském adresáři na svém primárním osobním počítači?
 (32%)
 (23%)
 (29%)
 (7%)
 (5%)
 (3%)
Celkem 788 hlasů
 Komentářů: 50, poslední 29.11. 15:50
Rozcestník
Reklama

Dotaz: Problemy s 'make modules_install' v SuSE 9.0

31.1.2004 08:32 anon123 | skóre: 35 | blog: ganomi
Problemy s 'make modules_install' v SuSE 9.0
Přečteno: 52×
Dobry den preji.

Potreboval bych poradit s nasledujicim problemem pri instalaci modulu distribuce Suse 9.0. Kdyz zkompiluji nove jadro 2.6.1-3 tak se vrhnu na make modules, s cim neni absolutne zadny problem. Po zadani prikazu "make modules_install" me po to chvili prerusi a vypise tuto zpravu (vkladam i par radek pred tim):

INSTALL drivers/net/wan/z85230.ko

INSTALL drivers/atm/zatm.ko

INSTALL drivers/char/ftape/compressor/zft-compressor.ko

INSTALL drivers/char/ftape/zftape/zftape.ko

INSTALL lib/zlib_deflate/zlib_deflate.ko

INSTALL drivers/net/znet.ko

if [ -r System.map ]; then /sbin/depmod -ae -F System.map 2.6.1-3-"default"; fi

WARNING: Couldn't open directory /lib/modules/2.6.1-override-default: No such file or directory

linux:/usr/src/linux #

Muzete mi nekdo poradit co s tim, abych moduly naistaloval znova. Kdyz to zrestartuju, tak jak to je, tak mi to hodi "kernel panik".

Diky

Odpovědi

31.1.2004 08:37 anon123 | skóre: 35 | blog: ganomi
Rozbalit Rozbalit vše Problemy s
Jeste bych rad dodal, ze v /lib/modules to vytvorilo adresar 2.6.1-3-default. Tak nevim, proc chce zase pak jiny "2.6.1-override-default" Diky
31.1.2004 10:18 Karlos
Rozbalit Rozbalit vše Problemy s
Tyhlety SUSE kernely mi připadaj dost zbastlený,zkuste si radši stáhnout normální jádro.
31.1.2004 11:06 anon123 | skóre: 35 | blog: ganomi
Rozbalit Rozbalit vše Problemy s
Ale zase vsichni doporuci jadra z distribuce. Tak uz nevim co delat. Kazdy ma tady jiny nazor. Spis me ted zajima, kde muze byt chyba, abych to dejel. Nechci restartovat,abych nemusel reinstalovat.
31.1.2004 11:11 anon123 | skóre: 35 | blog: ganomi
Rozbalit Rozbalit vše Problemy s 'make modules_install' v SuSE 9.0
Take mi muzete rici, jak se ted treba vseho zbavit, abych mohl zkusit zkompilovat jinou verzi jadra. Mam namysli, jak odstranit to, co jsem uz nainstaloval viz. nahore. Staci to jen smazat z /lib/modules a /usr/src nebo jsou tam ovlivneny take dalsi soubory. Diky
31.1.2004 11:23 Petr Šobáň | skóre: 79 | blog: soban | Olomouc
Rozbalit Rozbalit vše Problemy s 'make modules_install' v SuSE 9.0
No a nemáte tam už kernel stejného jména který používáte ? Změňte to na něco jiného třeba 2.6.1-muj_kernel :-) Viz třeba:http://soban.wz.cz/linux/jadro.html :-) Jinak v souboru Makefile na začátku EXTRAVERSION = -muj_kernel
31.1.2004 11:46 anon123 | skóre: 35 | blog: ganomi
Rozbalit Rozbalit vše Problemy s 'make modules_install' v SuSE 9.0
Nemam tam stejne. Mam 2.4.21-166-default a to potrebuji zmenit na 2.6.1-3. Ale nejak se nevede, kvuli te hlasce. Nevim jak pokracovat. Dekuji za rady
1.2.2004 16:05 anon123 | skóre: 35 | blog: ganomi
Rozbalit Rozbalit vše Problemy s 'make modules_install' v SuSE 9.0
Tak jsem to zkusil make modules_install s jadrem z kernel.org (2.6.2-rc3) a zase mi to asi neprobehlo cele. Zase mi vybehla hlaska

if [ -r System.map ]; then /sbin/depmod -ae -F System.map 2.6.2-rc3"; fi

tentokrat bez toho varovani a u jineho souboru. Zajimalo by me co delam spatne nebo kde muze byt chyba???

Prosim poradte
1.2.2004 17:02 anon123 | skóre: 35 | blog: ganomi
Rozbalit Rozbalit vše Problemy s 'make modules_install' v SuSE 9.0
Tak to tady mam, znova po dalsim pokusu. A ted uz si vazne nevim rady, proc ty moduly nejdou nainstalovat.Tady je vypis poslednich radku:

INSTALL drivers/char/ftape/zftape/zftape.ko

INSTALL lib/zlib_deflate/zlib_deflate.ko

INSTALL drivers/media/video/zr36060.ko

INSTALL drivers/media/video/zr36067.ko

if [ -r System.map ]; then /sbin/depmod -ae -F System.map 2.6.2-rc3; fi

linux:/usr/src/linux #
3.2.2004 07:57 Antonín Kolísek | skóre: 33 | blog: PDA | Vyškov
Rozbalit Rozbalit vše Problemy s 'make modules_install' v SuSE 9.0
A v /lib/modules/ nyní opravdu nic není? Protože mi z tohoto teď nepřipadne že by bylo něco špatně.
3.2.2004 08:58 anon123 | skóre: 35 | blog: ganomi
Rozbalit Rozbalit vše Problemy s 'make modules_install' v SuSE 9.0
jsou tam moduly stare verze kernelu. Tato verze se ma a take instaluje do /lib/modules/2.6.2-rc3 ale skonci to tou hlaskou kterou jsem uvedl. Tak jsem take zkusil zase smazat ten vytvoreny adresar v /lib/modules a znova prikaz make modules_install a zase nic. Tak nevim kde je chyba. Vse delam podle navodu uz asi po pate a porad to same.
3.2.2004 10:10 Robert Krátký | skóre: 94 | blog: Robertův bloček
Rozbalit Rozbalit vše Problemy s 'make modules_install' v SuSE 9.0
Ale ta hlaska neznamena nejakou chybu... Opravdu se v /lib/modules neobjevi ten adresar '2.6.2-rc3'?
3.2.2004 13:41 Karel
Rozbalit Rozbalit vše Problemy s 'make modules_install' v SuSE 9.0
Ja mam SUSe 8.2 - a tam se pouziva initrd - po instalaci a prekopirovani jadra je v mem pripade jeste potreba vytvorit initrd soubor pomoci mkinitrd a nastavit ho v zavadeci - jsem zacatecnik tak jsem to vsechno tak nejak delal podle puvodniho jadra ... Jinak - pouzivam na root file systemu reiserfs a prave pri vytvareni initrd souboru pro jadro 2.6.1 mi to napise ze nemuze vlozit modul reiserfs.o. Nicmene to nevadi protoze mam reiserfs zkompilovan primo v jadre a nabootuju v pohode, akorat nevim proc ta hlaska ...
3.2.2004 15:16 anon123 | skóre: 35 | blog: ganomi
Rozbalit Rozbalit vše Problemy s 'make modules_install' v SuSE 9.0
No on se objevi, ale az po te co zadam prikaz make modules_install. Projede to par souboru a pak se to zastavi na te hlasce. Myslim ze to nedojede do konce. Neco v tom adresari /lib/modules/2.6.2-rc3 je, ale myslim, ze to neni cele. Protoze po restartu to nechce najet, zustane jen cerna obrazovka. A ta instalace trva par sekund. Da se nejak zjistit, jestli to naistalovalo vsechny moduly, ktere byly definovany???

Diky
3.2.2004 15:42 Robert Krátký | skóre: 94 | blog: Robertův bloček
Rozbalit Rozbalit vše Problemy s 'make modules_install' v SuSE 9.0
S nejvetsi pravdepodobnosti neni tvuj problem v instalaci modulu. Neni nic podivneho na tom, ze to trva jen par sekund. A ta hlaska je v poradku - neni to chyba. Takze pokud ti po restartu zustane jen cerna obrazovka, problem je jinde.

Mas nastaveno pouzivani framebufferu? Zkus to bez nej. Vypise to pri startu vubec neco?

Btw, kernel jsi predpokladam sam konfiguroval, takze sam nejlepe vis, ktere moduly by mely byt nainstalovany. Pokud si to nepamatujes, tak zkus (v adresari se zdrojovymi kody kernelu) grep "=m" .config.
3.2.2004 16:29 Petr Šobáň | skóre: 79 | blog: soban | Olomouc
Rozbalit Rozbalit vše Problemy s 'make modules_install' v SuSE 9.0
Dále nepotřebuješ ram disk ?

Dal jsi ty věci co potřebuješ při startu jako "Y" ovladače HD, VGA, a hlavně ten fs který používáš na tom linuxu ext3 (2) atrd.....

PS. Proč by měla instalace modulů trvat dlouho? Vždyť se pouze překopíruje pár souborů *.ko do příslušných adresářů.
3.2.2004 16:32 anon123 | skóre: 35 | blog: ganomi
Rozbalit Rozbalit vše Problemy s 'make modules_install' v SuSE 9.0
Take me to napadlo, ze asi bude problem nekde jinde. Ale predtim tam bylo to warning, tak jsem myslel, ze je nekde chyba v te instalaci. Ted vim, ze ta hlaska asi chybou neni. Nevedel jsem ze ta instalace trva tak kratce, protoze vytvoreni modulu trvalo dele. Take jsem nevedel ze jak to ma vlastne skoncit. Skoda ze tam neni neco jako, ze to bylo ukonceno. To asi zapomeli.

Tak diky moc. Moc mi to pomohlo.
3.2.2004 04:15 anon123 | skóre: 35 | blog: ganomi
Rozbalit Rozbalit vše Problemy s 'make modules_install' v SuSE 9.0
Poradil by mi nekdo prosim?
3.2.2004 09:21 Petr Šobáň | skóre: 79 | blog: soban | Olomouc
Rozbalit Rozbalit vše Problemy s 'make modules_install' v SuSE 9.0
Nějaké práva děláte to jako root, přeložily se ty moduly OK ?

Máte správné verze programů pro jádro 2.6.x ?
3.2.2004 09:30 anon123 | skóre: 35 | blog: ganomi
Rozbalit Rozbalit vše Problemy s 'make modules_install' v SuSE 9.0
Vse splneno.
Stanislav Brabec avatar 3.2.2004 10:32 Stanislav Brabec | skóre: 45 | Praha
Rozbalit Rozbalit vše Problemy s 'make modules_install' v SuSE 9.0
"make install" jste už dával?
3.2.2004 10:36 Petr Šobáň | skóre: 79 | blog: soban | Olomouc
Rozbalit Rozbalit vše Problemy s 'make modules_install' v SuSE 9.0
Asi by jste měl popsat přesně podrobněji co přesně děláte fakt věštecké koule nemáme. Máte rozbalené zdrojáky v adresáři /usr/src/linux-vaševerze_jadra + odkazy na to jádro jako linux a linux-2.6 ? Překládáte jádro takto:

export LANG=C
export LC_ALL=C

make clean
make menuconfig
make dep
make bzImage && make modules

Já potom upravím lilo a provedu

make modules_install

cp ./vmlinux /boot/vmlinux-2.6.1
cp ./arch/i386/boot/bzImage /boot/vmlinuz-2.6.1
cp ./System.map /boot/System.map-2.6.1

/sbin/lilo

a vše bez problémů (jádro 2.6.1) a i jiné bez problémů, mám FC a i na jiných distribucích by neměl být problém.

PS. jste si jist že se ty moduly řádně přeložily, máte podporu modulů v jádře "Y" nesnaží se to kopírovat ty moduly někam jinam.
3.2.2004 15:31 anon123 | skóre: 35 | blog: ganomi
Rozbalit Rozbalit vše Problemy s 'make modules_install' v SuSE 9.0
Popisi muj postup. Jsem v tomto zacatecnik, ale myslim, ze vse delam spravne, ale nevim jestli to u te instalace modulu jede vse spravne nebo jestli to nedojede. Takze.

Rozbalim zdrojaky do /usr/src/linux

Zadam make mrproper, make menuconfig (nastavim), make bzImage, make modules - toto vse je bez problemu!!!

Pak zadam make modules_install - po asi 5 sekundach to skonci s tou hlaskou co je uvedena nahore:

kdyz jsem zkousel predkompilovane suse jadro 2.6.1-3-default, tak to bylo(i s par radkami predtim):

INSTALL lib/zlib_deflate/zlib_deflate.ko

INSTALL drivers/net/znet.ko

if [ -r System.map ]; then /sbin/depmod -ae -F System.map 2.6.1-3-"default"; fi

WARNING: Couldn't open directory /lib/modules/2.6.1-override-default: No such file or directory

kdyz jsem zkousel jadro 2.6.2-rc3, tak to bylo(i s par radkami predtim):

INSTALL drivers/media/video/zr36060.ko

INSTALL drivers/media/video/zr36067.ko

if [ -r System.map ]; then /sbin/depmod -ae -F System.map 2.6.2-rc3; fi

Adresare se objevily v /lib/modules, ale myslim, ze se to tam nenakopirovalo cele, protore v prvnim pripade jsem dostal hlasku po restartu "kernel panic" a v pripade jadra 2.6.2-rc3 je jen cerna obrazovka.

Tak nevim jestli se ty moduly doinstalovali. Cekal bych hlasku jako ze instalace probehla v poradku, nebo neco tak.

Samozrejme jsem zkopiroval bzImage do boot, prejmenoval, vytvoril initrd atd.
Stanislav Brabec avatar 3.2.2004 15:44 Stanislav Brabec | skóre: 45 | Praha
Rozbalit Rozbalit vše Problemy s 'make modules_install' v SuSE 9.0
Nejsem si jistý, ale myslím si, že v 2.6 je před make modules_install nutné dát make install. Myslím, že jsem na to také narazil.
3.2.2004 15:45 Robert Krátký | skóre: 94 | blog: Robertův bloček
Rozbalit Rozbalit vše Problemy s 'make modules_install' v SuSE 9.0
Nic takoveho nutne neni. Uplne staci:
make [menu|x|g|old]config
make
make modules_install
Tot vse.
3.2.2004 16:35 anon123 | skóre: 35 | blog: ganomi
Rozbalit Rozbalit vše Problemy s 'make modules_install' v SuSE 9.0
Make install znamena, ze se provedou (make bzImage, make vmlinuz, make modules) najednou. Nebo tak nejak. Vse je popsane v prikazu "make help".
3.2.2004 15:44 Robert Krátký | skóre: 94 | blog: Robertův bloček
Rozbalit Rozbalit vše Problemy s 'make modules_install' v SuSE 9.0
Ne, zadne hlasky o uspesne instalaci se nedockas. Tvuj problem cela zjevne netkvi v modulech. Viz moje odpoved vyse.

Založit nové vláknoNahoru

Tiskni Sdílej: Linkuj Jaggni to Vybrali.sme.sk Google Del.icio.us Facebook

ISSN 1214-1267   www.czech-server.cz
© 1999-2015 Nitemedia s. r. o. Všechna práva vyhrazena.