abclinuxu.cz AbcLinuxu.cz itbiz.cz ITBiz.cz HDmag.cz HDmag.cz abcprace.cz AbcPráce.cz
AbcLinuxu hledá autory!
Inzerujte na AbcPráce.cz od 950 Kč
Rozšířené hledání
×
eParkomat, startup z ČR, postoupil mezi finalisty evropského akcelerátoru ChallengeUp!
Robot na pivo mu otevřel dveře k opravdovému byznysu
Internet věcí: Propojený svět? Už se to blíží...
včera 21:21 | Nová verze Ladislav Hagara | Komentářů: 0
včera 11:44 | Zajímavý projekt

Na Indiegogo byla spuštěna kampaň na podporu herní mini konzole a multimediálního centra RetroEngine Sigma od Doyodo. Předobjednat ji lze již od 49 dolarů. Požadovaná částka 20 000 dolarů byla překonána již 6 krát. Majitelé mini konzole si budou moci zahrát hry pro Atari VCS 2600, Sega Genesis nebo NES. Předinstalováno bude multimediální centrum Kodi.

Ladislav Hagara | Komentářů: 0
včera 00:10 | Nová verze

Byla vydána verze 4.7 redakčního systému WordPress. Kódové označením Vaughan bylo vybráno na počest americké jazzové zpěvačky Sarah "Sassy" Vaughan. Z novinek lze zmínit například novou výchozí šablonu Twenty Seventeen, náhledy pdf souborů nebo WordPress REST API.

Ladislav Hagara | Komentářů: 1
6.12. 12:00 | Zajímavý projekt

Projekt Termbox umožňuje vyzkoušet si linuxové distribuce Ubuntu, Debian, Fedora, CentOS a Arch Linux ve webovém prohlížeči. Řešení je postaveno na projektu HyperContainer. Podrobnosti v často kladených dotazech (FAQ). Zdrojové kódy jsou k dispozici na GitHubu [reddit].

Ladislav Hagara | Komentářů: 24
6.12. 11:00 | Bezpečnostní upozornění

Byly zveřejněny informace o bezpečnostní chybě CVE-2016-8655 v Linuxu zneužitelné k lokální eskalaci práv. Chyba se dostala do linuxového jádra v srpnu 2011. V upstreamu byla opravena minulý týden [Hacker News].

Ladislav Hagara | Komentářů: 2
5.12. 22:00 | Komunita

Přibližně před měsícem bylo oznámeno, že linuxová distribuce SUSE Linux Enterprise Server (SLES) běží nově také Raspberry Pi 3 (dokumentace). Obraz verze 12 SP2 pro Raspberry Pi 3 je ke stažení zdarma. Pro registrované jsou po dobu jednoho roku zdarma také aktualizace. Dnes bylo oznámeno, že pro Raspberry Pi 3 je k dispozici také nové openSUSE Leap 42.2 (zprávička). K dispozici je hned několik obrazů.

Ladislav Hagara | Komentářů: 6
5.12. 06:00 | Zajímavý software

OMG! Ubuntu! představuje emulátor terminálu Hyper (GitHub) postavený na webových technologiích (HTML, CSS a JavaScript). V diskusi k článku je zmíněn podobný emulátor terminálu Black Screen. Hyper i Black Screen používají framework Electron, stejně jako editor Atom nebo vývojové prostředí Visual Studio Code.

Ladislav Hagara | Komentářů: 50
5.12. 06:00 | Zajímavý článek

I letos vychází řada ajťáckých adventních kalendářů. QEMU Advent Calendar 2016 přináší každý den nový obraz disku pro QEMU. Programátoři se mohou potrápit při řešení úloh z kalendáře Advent of Code 2016. Kalendáře Perl Advent Calendar 2016 a Perl 6 Advent Calendar přinášejí každý den zajímavé informace o programovacím jazyce Perl. Stranou nezůstává ani programovací jazyk Go.

Ladislav Hagara | Komentářů: 10
3.12. 16:24 | Nová verze

Byla vydána Mageia 5.1. Jedná se o první opravné vydání verze 5, jež vyšla v červnu loňského roku (zprávička). Uživatelům verze 5 nepřináší opravné vydání nic nového, samozřejmě pokud pravidelně aktualizují. Vydání obsahuje všechny aktualizace za posledního téměř půldruhého roku. Mageia 5.1 obsahuje LibreOffice 4.4.7, Linux 4.4.32, KDE4 4.14.5 nebo GNOME 3.14.3.

Ladislav Hagara | Komentářů: 17
3.12. 13:42 | Pozvánky

V Praze probíhá konference Internet a Technologie 16.2, volné pokračování jarní konference sdružení CZ.NIC. Konferenci lze sledovat online na YouTube. K dispozici je také archiv předchozích konferencí.

Ladislav Hagara | Komentářů: 0
Kolik máte dat ve svém domovském adresáři na svém primárním osobním počítači?
 (32%)
 (24%)
 (29%)
 (8%)
 (5%)
 (3%)
Celkem 785 hlasů
 Komentářů: 50, poslední 29.11. 15:50
Rozcestník
Reklama

Dotaz: invalid conversion from ‘int’ to ‘void*’

21.9.2008 10:46 PetrHL | skóre: 16 | blog: petr_h | Neratovice
invalid conversion from ‘int’ to ‘void*’
Přečteno: 417×
Dobry den,

mam tu openSuse 11.0 a snazim se zkompilovat program TrustedQSL. Na strance http://packages.qa.debian.org/t/trustedqsl.html jsem stahl originalni zdrojaky a patch, ktery jsem na zdrojaky aplikoval. Program pouziva knihovny wxWindows. V Debianu je verze 2.6. V novem openSuse je verze 2.8. Kompilace spadne s chybou:

make[1]: Entering directory `/home/ok2cqr/tmp/TrustedQSL-1.11' if g++ -DHAVE_CONFIG_H -I. -I. -I. -Wall `"/usr/bin/wx-config" --cxxflags` -I/usr/include -I/usr/include -I/usr/include -g -O2 -MT tqsl.o -MD -MP -MF ".deps/tqsl.Tpo" -c -o tqsl.o tqsl.cpp; \ then mv -f ".deps/tqsl.Tpo" ".deps/tqsl.Po"; else rm -f ".deps/tqsl.Tpo"; exit 1; fi
In file included from tqslwiz.h:31, from tqsl.cpp:40:
certtree.h: In member function ‘CertTreeItemData* CertTree::GetItemData(int)’:
certtree.h:51: error: invalid conversion from ‘int’ to ‘void*’
certtree.h:51: error: initializing argument 1 of ‘wxTreeItemId::wxTreeItemId(void*)’

radek 51 v certtree.h je:

CertTreeItemData *GetItemData(int id) { return (CertTreeItemData *)wxTreeCtrl::GetItemData(id); }

Moje znalost C a C++ je velmi spatna. Vim co ta chyba znamena, ale vubec netusim jak to v tom zdrojaku opravit. Muzete mi prosim poradit?

Dekuji za pripadnou pomoc.

Petr
"Do, or do not. There is no 'try.'" -- Jedi Master Yoda | VPS za rozumnou cenu?

Řešení dotazu:


Odpovědi

21.9.2008 12:32 luky
Rozbalit Rozbalit vše Re: invalid conversion from ‘int’ to ‘void*’
Jednak nevim, jestli vam debiani patche na opensuse nejak pomohou, a pak je potreba wxWidgets kompatibilni s verzi 2.4, coz asi vase verze neni. Nicmene i 2.8 porad ma volby pro kompilaci kompatibilni s 2.4, tak si muzete udelat vlastni build (ale mozna by bylo lepsi zkusit primo 2.4 misto kompatibility ve vyssich verzich) a proti nemu pak kompilovat TrustedQSL.
21.9.2008 12:46 PetrHL | skóre: 16 | blog: petr_h | Neratovice
Rozbalit Rozbalit vše Re: invalid conversion from ‘int’ to ‘void*’
Ja bych to prave potreboval zkompilovat s novou verzi 2.8. Pak vytvorim rpm balicek pro openSuse, ktery si pak budou nainstalovat ostatni uzivalate TrustedQSL. Nekteri tezko zvladnou kompilaci proti verzi 2.4 :-(.

Petr
"Do, or do not. There is no 'try.'" -- Jedi Master Yoda | VPS za rozumnou cenu?
Fuky avatar 21.9.2008 13:52 Fuky | skóre: 52 | blog: 4u
Rozbalit Rozbalit vše Re: invalid conversion from ‘int’ to ‘void*’

V případě, že to chceš kompilovat s novou verzí knihovny, tak se připrav na to, že tohle může být pouze jedna z mnoha změn ve verzi 2.8 oproti 2.4 a Ty je všechny budeš muset opravovat...

Nebylo by lepší rovnou k TrustedQSL přikompilovat verzi 2.4, binárka bude sice trochu větší, ale nebudeš muset vytvářet patch, pro verzi 2.8.

21.9.2008 19:11 PetrHL | skóre: 16 | blog: petr_h | Neratovice
Rozbalit Rozbalit vše Re: invalid conversion from ‘int’ to ‘void*’
To by bylo skvele reseni ale bohuzel nevim jak na to.

Uz jsem se nejak prokousal upravami pro verzi 2.8. Program chodi dokud nenaimportuji certifikat. Po naimportovani program zmrzne. Mrzne i pri startu s naimportovanym certifikatem. Takze asi budu muset zkoumat. Ale zkompilovat to staticky by bylo take reseni. Je tam sice vice zavislosti ale staticky by to bylo nejlepsi. Jak to udelat?

Diky za rady.

Petr
"Do, or do not. There is no 'try.'" -- Jedi Master Yoda | VPS za rozumnou cenu?
22.9.2008 08:34 rastos | skóre: 60 | blog: rastos
Rozbalit Rozbalit vše Re: invalid conversion from ‘int’ to ‘void*’
Podľa dokumentácie je wxTreeCtrl::GetItemData deklarované ako
wxTreeItemData* GetItemData(const wxTreeItemId& item) const
Tipujem, že sa kompilátor sťažuje na to, že miesto

const wxTreeItemId& item

sa tam posiela

int id

Je otázne ako to riešiť. Môžeš to skúsiť pretypovať

...wxTreeCtrl::GetItemData((wxTreeItemId)id);

Môžeš skúsiť pátrať po tom, či TrustedQSL má fungovať s tou verzou wxWidgets, ktorú máš (a teda či platí tá deklarácia, ktorá je v tej dokumentácii). Alebo môžeš skúsiť nechať to prejsť pre-processorom a pozrieť čo tam vlastne má byť:
g++ -DHAVE_CONFIG_H -I. -I. -I. -Wall `"/usr/bin/wx-config" --cxxflags` -I/usr/include -I/usr/include -I/usr/include -E -MT tqsl.o -MD -MP -MF ".deps/tqsl.Tpo" -c -o tsql.txt tqsl.cpp
- a potom pozrieť do tsql.txt a nájsť ako vlastne vyzerá tá definícia GetItemData v CertTree a ako vyzerá GetItemData vo wxTreeCtrl.
Luboš Doležel (Doli) avatar 22.9.2008 13:13 Luboš Doležel (Doli) | skóre: 98 | blog: Doliho blog | Kladensko
Rozbalit Rozbalit vše Re: invalid conversion from ‘int’ to ‘void*’
Jenže tady nejde o funkci GetItemData, ale o konstruktor wxTreeItemId :-)
Řešení 1× (PetrHL (tazatel))
22.9.2008 13:37 PetrHL | skóre: 16 | blog: petr_h | Neratovice
Rozbalit Rozbalit vše Re: invalid conversion from ‘int’ to ‘void*’
Vyřešeno. Pomohl mi s tím na #wxWidgets David Hart. TrustedQSL lze zkompilovat a chodí. Problémů tam bylo několik ale tento byl asi nejhorší.
Opravená řádka vypadá takto:

CertTreeItemData *GetItemData(wxTreeItemId id) { return (CertTreeItemData *)wxTreeCtrl::GetItemData(id); }

Díky všem za rady a trpělivost.

Petr
"Do, or do not. There is no 'try.'" -- Jedi Master Yoda | VPS za rozumnou cenu?

Založit nové vláknoNahoru

Tiskni Sdílej: Linkuj Jaggni to Vybrali.sme.sk Google Del.icio.us Facebook

ISSN 1214-1267   www.czech-server.cz
© 1999-2015 Nitemedia s. r. o. Všechna práva vyhrazena.