abclinuxu.cz AbcLinuxu.cz itbiz.cz ITBiz.cz HDmag.cz HDmag.cz abcprace.cz AbcPráce.cz
AbcLinuxu hledá autory!
Inzerujte na AbcPráce.cz od 950 Kč
Rozšířené hledání
×

dnes 06:55 | Zajímavý projekt

V Edici CZ.NIC vyšla kniha Průvodce labyrintem algoritmů. Kniha je ke stažení zcela zdarma (pdf) nebo lze objednat tištěnou verzi za 339 Kč (připojení přes IPv4) nebo 289 Kč (připojení přes IPv6).

Ladislav Hagara | Komentářů: 0
dnes 06:33 | Zajímavý software

Byla vydána verze 2.2.0 svobodného správce hesel KeePassXC (Wikipedie). Jedná se o komunitní fork správce hesel KeePassX s řadou vylepšení.

Ladislav Hagara | Komentářů: 0
dnes 06:11 | IT novinky

Vývojář Debianu Henrique de Moraes Holschuh upozorňuje v diskusním listu debian-devel na chybu v Hyper-Threadingu v procesorech Skylake a Kaby Lake od Intelu. Za určitých okolností může chyba způsobit nepředvídatelné chování systému. Doporučuje se aktualizace mikrokódu CPU nebo vypnutí Hyper-Threadingu v BIOSu nebo UEFI [reddit].

Ladislav Hagara | Komentářů: 0
24.6. 01:23 | Komunita

Phoronix spustil 2017 Linux Laptop Survey. Tento dotazník s otázkami zaměřenými na parametry ideálního notebooku s Linuxem lze vyplnit do 6. července.

Ladislav Hagara | Komentářů: 2
23.6. 22:44 | Nová verze

Po třech měsících vývoje od vydání verze 5.5.0 byla vydána verze 5.6.0 správce digitálních fotografií digiKam (digiKam Software Collection). Do digiKamu se mimo jiné vrátila HTML galerie a nástroj pro vytváření videa z fotografií. V Bugzille bylo uzavřeno více než 81 záznamů.

Ladislav Hagara | Komentářů: 1
23.6. 17:44 | Nová verze

Byla vydána verze 9.3 open source alternativy GitHubu, tj. softwarového nástroje s webovým rozhraním umožňujícího spolupráci na zdrojových kódech, GitLab. Představení nových vlastností v příspěvku na blogu a na YouTube.

Ladislav Hagara | Komentářů: 3
23.6. 13:53 | Nová verze

Simon Long představil na blogu Raspberry Pi novou verzi 2017-06-21 linuxové distribuce Raspbian určené především pro jednodeskové miniaturní počítače Raspberry Pi. Společně s Raspbianem byl aktualizován také instalační nástroj NOOBS (New Out Of the Box Software). Z novinek lze zdůraznit IDE Thonny pro vývoj v programovacím jazyce Python a především offline verzi Scratche 2.0. Ten bylo dosud možné používat pouze online. Offline bylo možné používat pouze Scratch ve verzi 1.4. Z nového Scratchu lze ovládat také GPIO piny. Scratch 2.0 vyžaduje Flash.

Ladislav Hagara | Komentářů: 1
22.6. 14:24 | Nová verze

Opera 46, verze 46.0.2597.26, byla prohlášena za stabilní. Nejnovější verze tohoto webového prohlížeče je postavena na Chromiu 59. Z novinek lze zmínit například podporu APNG (Animated Portable Network Graphics). Přehled novinek pro vývojáře na blogu Dev.Opera. Oznámení o vydání zmiňuje také první televizní reklamu.

Ladislav Hagara | Komentářů: 0
22.6. 13:37 | IT novinky

I čtenáři AbcLinuxu před dvěma lety vyplňovali dotazníky věnované Retro ThinkPadu. Nyní bylo potvrzeno, že iniciativa Retro ThinkPad je stále naživu a Lenovo připravuje speciální edici ThinkPadu jako součást oslav jeho 25. výročí.

Ladislav Hagara | Komentářů: 29
22.6. 10:22 | Komunita

Bylo oznámeno, že frontend a runtime programovacího jazyka D bude začleněn do kolekce kompilátorů GCC (GNU Compiler Collection). Správcem byl ustanoven Iain Buclaw.

Ladislav Hagara | Komentářů: 7
Chystáte se pořídit CPU AMD Ryzen?
 (6%)
 (31%)
 (1%)
 (9%)
 (44%)
 (9%)
Celkem 837 hlasů
 Komentářů: 65, poslední 1.6. 19:16
    Rozcestník

    Dotaz: PHP – nefungující require

    25.8.2010 17:15 kokoška
    PHP – nefungující require
    Přečteno: 484×
    Nahrál jsem na platformu Linux na nové doméně svůj web, který mi na bezplatné doméně chodil bez problémů, ale na Linuxu mi nefuguje příkaz require. Jak to lze opravit? Na indexu.php načítám další soubory pomocí require, ale nefunguje to - je to tím Linuxem?

    Řešení dotazu:


    Odpovědi

    25.8.2010 17:26 jirkamailto | skóre: 31
    Rozbalit Rozbalit vše Re: Prosím, poraďte, jsem začátečník
    no jde o to, jestli se Vam ter require netluce s necim jinym, tedy jestli se nesnazite narequirovat neco vicekrat. Zkuste pouzit require_once.
    25.8.2010 17:31 jirkamailto | skóre: 31
    Rozbalit Rozbalit vše Re: Prosím, poraďte, jsem začátečník
    je mozne ze na starem hostingu jste pouzival PHP 5.2 a na novem mate PHP 5.3, me se to take stalo v jednom projektu a to ze jsem mel vicenasobny require
    26.8.2010 12:21 kokoška
    Rozbalit Rozbalit vše Re: Prosím, poraďte, jsem začátečník
    a co s tím mám dělat?
    26.8.2010 12:24 kokoška
    Rozbalit Rozbalit vše Re: Prosím, poraďte, jsem začátečník

    Raději vám zkopíruji část celého kódu, která nefunguje, bude tam možná pro vás
     zjevná chyba. Vždy se načte jen první soubor aaa.php a ten je tam pořád, ať kliknu na  jakýkoliv
     další odkaz s proměnnou, vždy se zobrazí jen soubor aaa.php i když v url je přenesena
      správná proměnná (číslo). Co je v kódu  špatně? Pokud používám jinou verzi PHP co s tím mám dělat?


    <?php
     if($od==0){require"aaa.php";}
    if($od==1){require"bbb.php";}
    if($od==2){require"ccc.php";}
    if($od==3){require"ddd.php";}
         ?>    
    </DIV>    
    <DIV ALIGN = CENTER id=menu>     
     <TABLE class="menu" BORDER="0">         
      <TR>           
       <TD class=>           
        <A class="menu"  HREF="index.php?od=0">xxx</A></TD>         
       <TD class="menu">        
        <A class="menu"  HREF="index.php?od=1">xxx</A></TD>         
       <TD class="menu">          
        <A class="menu"  HREF="index.php?od=2">xxxx</A></TD>       
       <TD class="menu">        
        <A class="menu"  HREF="index.php?od=3">xxx</A></TD>                  
      </TR>     
     </TABLE>    
    </DIV> 

    Řešení 1× (kokoška (tazatel))
    26.8.2010 12:35 Vojtěch Horký | skóre: 39 | blog: Vojtův zápisník | Praha
    Rozbalit Rozbalit vše Re: Prosím, poraďte, jsem začátečník
    Problém bude s tzv. register globals (český překlad netuším). Nahrazením $od$_GET['od'] by se to mělo zpravit.
    I am always ready to learn although I do not always like to be taught. (W. Churchill)
    26.8.2010 12:37 Vojtěch Horký | skóre: 39 | blog: Vojtův zápisník | Praha
    Rozbalit Rozbalit vše Re: Prosím, poraďte, jsem začátečník
    Ha, mělo by se to samozřejmě spravit :-D.
    I am always ready to learn although I do not always like to be taught. (W. Churchill)
    26.8.2010 12:41 kokoška
    Rozbalit Rozbalit vše Re: Prosím, poraďte, jsem začátečník
    DÍKY, TO BYLO ONO!!! Už to chodí!! Díky moc.
    25.8.2010 17:41 Dejv | skóre: 37 | blog: Jak ten blog nazvat ... ? | Ostrava
    Rozbalit Rozbalit vše Re: Prosím, poraďte, jsem začátečník

    A existuje cesta, ze ktere se snazis ty soubory requirovat? Nezapomen, ze linux pro oddeleni adresaru v ceste pouziva normalni lomitko (misto obraceneho ve windows).

    BTW, mas totalne blby titulek. Uz v titulku by mel byt zakladni popis problemu (napr. "PHP require problem").
    Pevne verim, ze zkusenejsi uzivatele me s mymi napady usmerni a poslou tam, kam tyto napady patri...
    25.8.2010 17:42 Sten
    Rozbalit Rozbalit vše Re: Prosím, poraďte, jsem začátečník
    Popis „nefunguje příkaz require“ by znamenal, že nefunguje PHP, což předpokládám, že není pravda. Jakou chybu to vypíše?
    26.8.2010 09:54 Šangala | skóre: 56 | blog: Dutá Vrba - Wally
    Rozbalit Rozbalit vše Re: PHP – nefungující require
    1. Cesty v Linuxu používají jiný oddělovač
    2. Přes výpis fce phpInfo(); si zjistěte nastavení include_path
    3. Na hostinzích je většinou vše tak nějak nastaveno právě pro Vás (web-domovský adresář, include path atd.) a u sebe na „tom Linuxu“ máte jistě jiné nastavení.
    To, že trpíš stihomamem, ještě neznamená, že po tobě nejdou. ⰞⰏⰉⰓⰀⰜⰉ ⰗⰞⰅⰜⰘ ⰈⰅⰏⰉ ⰒⰑⰎⰉⰁⰕⰅ ⰏⰉ ⰒⰓⰄⰅⰎ ·:⁖⁘⁙†

    Založit nové vláknoNahoru

    Tiskni Sdílej: Linkuj Jaggni to Vybrali.sme.sk Google Del.icio.us Facebook

    ISSN 1214-1267   www.czech-server.cz
    © 1999-2015 Nitemedia s. r. o. Všechna práva vyhrazena.