abclinuxu.cz AbcLinuxu.cz itbiz.cz ITBiz.cz HDmag.cz HDmag.cz abcprace.cz AbcPráce.cz
AbcLinuxu hledá autory!
Inzerujte na AbcPráce.cz od 950 Kč
Rozšířené hledání
×

dnes 08:00 | IT novinky

Andy Rubin, spoluzakladatel společnosti Android, jež byla v roce 2005 koupena Googlem, nyní CEO společnosti Essential Products, oznámil předprodej chytrého telefonu Essential. Telefon se začne rozesílat 1. září. Cena telefonu je 699 dolarů. Cena telefonu současně s 360° kamerou s rozlišením 4K byla stanovena na 749 dolarů. Kameru, v budoucnu i další příslušenství, lze k telefonu připojit pomocí konektoru s magnety.

Ladislav Hagara | Komentářů: 0
včera 13:44 | Zajímavý software

Evropská komise vydala novou verzi 1.4.0.1 svého open source v Javě naprogramovaného softwaru pro online průzkumy EUSurvey. Online dotazníky lze vytvářet na stránkách Evropské komise nebo si lze software stáhnout (zip a war) a nainstalovat lokálně. Zdrojové kódy jsou k dispozici pod licencí EUPL (European Union Public Licence).

Ladislav Hagara | Komentářů: 0
18.8. 23:55 | Komunita

Ubuntu 17.10 (Artful Aardvark) bude ve výchozím stavu zobrazovat Dok (Launcher). Jedná se o rozšíření GNOME Shellu Ubuntu Dock. To bylo forknuto z rozšíření Dash to Dock. Ukázka na YouTube [reddit].

Ladislav Hagara | Komentářů: 2
17.8. 15:33 | Nová verze

Byla vydána verze 17.08.0 KDE Aplikací (KDE Applications). Přehled novinek v kompletním seznamu změn a na stránce s dalšími informacemi. Aplikace kmag, kmousetool, kgoldrunner, kigo, konquest, kreversi, ksnakeduel, kspaceduel, ksudoku, kubrick, lskat a umbrello byly portovány na KDE Frameworks 5.

Ladislav Hagara | Komentářů: 0
17.8. 15:11 | Nová verze

Simon Long představil na blogu Raspberry Pi novou verzi 2017-08-16 linuxové distribuce Raspbian určené především pro jednodeskové miniaturní počítače Raspberry Pi. Společně s Raspbianem byl aktualizován také instalační nástroj NOOBS (New Out Of the Box Software). Nejnovější Raspbian je založen na Debianu 9 Stretch. Přehled novinek v poznámkách k vydání. Řešena je také bezpečnostní chyba Broadpwn (CVE-2017-9417).

Ladislav Hagara | Komentářů: 1
17.8. 12:33 | Nová verze

Byla vydána verze 3.2.0 programu pro skicování, malování a úpravu obrázků Krita. Přehled novinek v poznámkách k vydání a na YouTube.

Ladislav Hagara | Komentářů: 0
17.8. 11:44 | IT novinky

Minulý týden na šampionátu The International 2017 byl představen bot, který poráží profesionální hráče počítačové hry Dota 2. V nejnovějším příspěvku na blogu se organizace OpenAI o projektu více rozepsala a zveřejnila videozáznamy několika soubojů.

Ladislav Hagara | Komentářů: 7
16.8. 17:11 | Komunita

Byly zveřejněny videozáznamy přednášek z Fedora 26 Release Party konané 10. srpna v Praze.

Ladislav Hagara | Komentářů: 0
16.8. 15:33 | Komunita

Přesně před čtyřiadvaceti lety, 16. srpna 1993, oznámil Ian Murdock vydání "Debian Linux Release".

Ladislav Hagara | Komentářů: 8
16.8. 06:00 | Bezpečnostní upozornění

Ve virtualizačním softwaru Xen bylo nalezeno a opraveno 5 bezpečnostních chyb XSA-226 až XSA-230. Nejzávažnější z nich XSA-227 (CVE-2017-12137) umožňuje eskalaci privilegií a ovládnutí celého systému, tj. správce hostovaného systému se může stát správcem hostitelského systému.

Ladislav Hagara | Komentářů: 1
Těžíte nějakou kryptoměnu?
 (4%)
 (2%)
 (17%)
 (76%)
Celkem 358 hlasů
 Komentářů: 21, poslední 13.8. 09:57
    Rozcestník

    Dotaz: pureftpd neskompiluje na AIX 5.3 - problem s ptrace

    11.8.2010 08:36 Peter S.
    pureftpd neskompiluje na AIX 5.3 - problem s ptrace
    Přečteno: 423×
    V suvislosti s mojim predhcádzajúcim dotazom sa pokušam nainštalovať pureftpd na AIX 5.3, ale neskompiluje to, skončí to takto:
     gcc -DHAVE_CONFIG_H -I. -I..    -DCONFDIR=\"/etc\" -DSTATEDIR=\"/var\"  -g -O2 -MT ptracetest.o -MD -MP -MF .deps/ptracetest.Tpo -c -o ptracetest.o ptracetest.c
    ptracetest.c: In function 'main':
    ptracetest.c:81: warning: passing argument 4 of 'ptrace' makes integer from pointer without a cast
    ptracetest.c:81: error: too few arguments to function 'ptrace'
    make: 1254-004 The error code from the last command is 1.
    to ptracetest je asi nejaká bezpečnostná kontrola a zda sa že AIX tomu nevyhovuje...

    Vie mi niekto poradiť? Alebo mám skusiť iný ftp program?

    Odpovědi

    jose17 avatar 11.8.2010 13:26 jose17 | skóre: 43 | blog: Joseho_blog | Košice/Nové Mesto nad Váhom
    Rozbalit Rozbalit vše Re: pureftpd neskompiluje na AIX 5.3 - problem s ptrace
    cau peto, proftpd pre 4.3kovy aix z bullfreeware.com by nemohol byt? pripadne proftpd z linux toolboxu.
    Ja vim, on vi, ty nano!
    11.8.2010 16:56 Ivan
    Rozbalit Rozbalit vše Re: pureftpd neskompiluje na AIX 5.3 - problem s ptrace
    Hmm asi budes muset sahnout do zdrojaku: man ptrace64 na AIXu:
           int ptrace64 ( request, identifier, addr, data, buff)
    
           int request;
    
           long long identifier;
    
           long long addr;
    
           int data;
    
           int *buff;
    
    Ten parametr buff je tam navic(oproti Linuxu). Projdi si ten man a s nejvetsi pravdepodobnosti bude stacit dat navic jeden NULL argument.

    11.8.2010 21:51 PeterS. | skóre: 10
    Rozbalit Rozbalit vše Re: pureftpd neskompiluje na AIX 5.3 - problem s ptrace
    Vďaka za odpovede. No medzitým som nainštaloval vsftpd (tiež kompilácia, ale bezproblémová). Vyzerá že by to malo splnať požiadavky.

    Inak som prekvapený že ftp je na AIX taký problém...

    13.8.2010 08:31 Vít Heřman | skóre: 13
    Rozbalit Rozbalit vše Re: pureftpd neskompiluje na AIX 5.3 - problem s ptrace
    Ze zkusenosti vim ze kompilace na komercnich unixech jsou obcas trochu divocina, jak psal uz nekdo prede mnou - kdykoliv je podobny problem, zobraz si man ptrace na linuxu a na AIXu, porovnej rozdil a vetsinou pridas nebo uberes parametr a funguje to. Obcas je take potreba pridat nejakou knihovnu, protoze neco je na linuxu v libc a na jinych unixech to byt nemusi (treba na HP-UX je obcas potreba kompilovat s -lipv6 i kod ktery IPv6 vubec nepouziva).
    13.8.2010 13:31 Peter S.
    Rozbalit Rozbalit vše Re: pureftpd neskompiluje na AIX 5.3 - problem s ptrace
    ja nie som programátor, v C-čku a podobných jazykoch sa nevyznám, takže do editovania kodu sa veľmi nehrniem.

    Skôr som očakával, že najisť a stiahnuť rpm balík pre napr: pure-ftpd, proftpd alebo vsftpd bude triviálna vec. Resp. by niektorý z uvedených mohol byť priamo na AIX toolbox for linux Applications CD čo tu máme...
    15.8.2010 15:10 Vít Heřman | skóre: 13
    Rozbalit Rozbalit vše Re: pureftpd neskompiluje na AIX 5.3 - problem s ptrace
    Ocekavat, ze pro komercni unix bude k dispozici rpm balik s mym oblibenym softwarem je je sice docela bezne, ale znacne naivni. Jinak nechce se mi ted zapinat muj AIXovy stroj, ale myslim ze nejaky FTP demon bude urcite soucasti AIXu jako takoveho - i velmi obskurni Unixy ho maji. Prvni co bych zkusil by bylo "man ftpd" pripadne se kouknul do /etc/inetd.conf nebo podobneho souboru, ve SMITu by se urcite taky nejaka volba nasla.
    16.8.2010 09:53 Peter S.
    Rozbalit Rozbalit vše Re: pureftpd neskompiluje na AIX 5.3 - problem s ptrace
    defaultny ftp som samozrejme skušal, ale nepodarilo sami ho ohnúť podľa mojich potrieb. Neumožnuje špecifikovanie užívateľov ani zverejnených adresárov...

    ftp server je podľa mna uplne základný software, teda najmä na serverovom OS, takže fakt si nemyslím že mám prehnané nároky. V každom prípade ten vsftpd som rozbehal a dokonca som sa naučil ako robiť rpm balíky. :)
    jose17 avatar 16.8.2010 09:56 jose17 | skóre: 43 | blog: Joseho_blog | Košice/Nové Mesto nad Váhom
    Rozbalit Rozbalit vše Re: pureftpd neskompiluje na AIX 5.3 - problem s ptrace

    Neumožnuje špecifikovanie užívateľov
    a co /etc/ftpusers?
    Ja vim, on vi, ty nano!
    16.8.2010 10:16 Peter S.
    Rozbalit Rozbalit vše Re: pureftpd neskompiluje na AIX 5.3 - problem s ptrace
    ftpusers_ ...Specifies local user names that cannot be used by remote FTP clients...

    o tomto viem, ale ja by som práveže potreboval definovať uživateľov naopak. Uviesť tých (fakticky len jedného) ktorý pristupovať môže. Na tom serveri je ich cca 40. A teraz si uvedom, že v budúcnosti sa tam môžu vytvoriť další - kto si bude pamätať na aktuálizáciu ftpusers suboru?

    a plus dalšie veci boli dovolenie iba ro prístupu a iba do jedného adresáru...
    17.8.2010 00:53 msmucr
    Rozbalit Rozbalit vše Re: pureftpd neskompiluje na AIX 5.3 - problem s ptrace
    V souboru vsftpd.conf jsou tři volby týkající se seznamu uživatelů viz man vsftpd.conf

    userlist_enable=YES (povolení userlistu) userlist_deny=NO (volba NO umožní přihlášení pouze uživatelům, kteří jsou uvedeni v userlistu) userlist_file= odkaz na umístění samotného souboru (Volil bych jiný, než standardní soubor /etc/ftpusers, kde bývají zpravidla uvedeni uživatelé, co se přihlásit mohou, takže např. /etc/ftpusers_allowed)

    Michal

    jose17 avatar 17.8.2010 07:42 jose17 | skóre: 43 | blog: Joseho_blog | Košice/Nové Mesto nad Váhom
    Rozbalit Rozbalit vše Re: pureftpd neskompiluje na AIX 5.3 - problem s ptrace
    /etc/ftpusers, kde bývají zpravidla uvedeni uživatelé, co se přihlásit mohou
    v /etc/ftpusers su uzivatelia, ktori maju ftp zakazane (je obvykle, ze tu najdeme napr. uzivatela root)
    Ja vim, on vi, ty nano!
    17.8.2010 15:33 msmucr
    Rozbalit Rozbalit vše Re: pureftpd neskompiluje na AIX 5.3 - problem s ptrace
    Máte samozřejmě pravdu.. je to tak, jak píšete.. přepsal jsem se. Proto doporučuji udělat jiný soubor s uživateli, co se přihlásit mohou.

    Michal
    18.8.2010 18:19 Vít Heřman | skóre: 13
    Rozbalit Rozbalit vše Re: pureftpd neskompiluje na AIX 5.3 - problem s ptrace
    Však jsem také neřekl, že máte přehnané nároky, to nemáte. Ale vaše očekávání je naivní (teď prosím v tom nehledejte nic negativního - já se z téhle naivity léčil dost dlouho a pořád ještě nejsem úplně zdráv), prostě komerční Unixy jsou takové. Každý paynix je do značné míry painix :)

    AIX 5.3 nemám nainstalovaný, ale myslím, že by ho mělo podporavat pkgsrc (na 6.1 jsem s ním dost narazil), takže můžete zkusit to. Některé moje postřehy které jsem podržel v paměti jsem zaznamenal zde.
    18.8.2010 23:45 Peter S.
    Rozbalit Rozbalit vše Re: pureftpd neskompiluje na AIX 5.3 - problem s ptrace
    Je to v pohode. Zase som sa dačo naučil. A v rámci pracovného času, teda som bol za to zaplatený :) . A výsledkom je rpm balík ktorý si nainštalujem aj na iný server ked bude treba. Ako som si všimol po krátkom teste, beží to aj na 6.1. S binárnou kompatibilitou je AIX na tom asi dosť inak ako linux.

    Snažil som sa skompilovať a zabaliť do rpm aj nano - čo teda prebehlo uspešne, ale samotne nano nefugovalo korektne. Prejavovalo sa to napríklad pri skrolovaní, kurzor už nešiel dalej dole, ale pod nim bolo ešte pár riadkov textu, prípadne tie riadky sa opakovali aj nad kurzorom.... škoda...

    Ale fakt je že vzhľadom na to aký je ten unix veľký biznis a aké ma meno, by som fakt čakal lepší výber takýchto programov ako je ftp a pod...
    19.8.2010 18:05 Vít Heřman | skóre: 13
    Rozbalit Rozbalit vše Re: pureftpd neskompiluje na AIX 5.3 - problem s ptrace
    No, zkuste se na to podívat pohledem IBM. AIX běží jen na jejich velmi drahém hardware, a to jestli tam poběží nano nebo nějaký opensource FTP server pro ně z obchodního hlediska nehraje žádnou roli - od toho IBM podporuje Linux, aby se s podobnými věcmi nemuseli zabývat v AIXu. Důvodů, proč koupit POWER hardware s AIXem je určitě spousta, ale provoz FTP serveru to nebude.

    Pro člověka, který je zvyklý na Linux nebo BSD je přechod na komerční Unixy trochu šok. Já osobně jsem měl značně nerealistická očekávání, a představoval jsem si, že rozdíl mezi Linuxem a třeba AIX nebo HP-UX bude podobný jako mezi třeba Linuxem a BSD, jenže ta propast je daleko větší. Některé věci se zdají být naprosto nelogické a neintuitivní, ale po čase člověk zjistí, že se jedná spíš o "špatné" návyky z nekomerčních unixů. Jakkoliv je lákavé si říct "Unix je přece Unix", tak to bohužel takhle jednoduché není. Každý komerční unix má za sebou dlouho (a často velmi bohatou) historii a na rozdíl od Linuxových distribucí ta historie je dost často "živá". Proces kreativní destrukce tak jak funguje u Linuxu, ve stylu "Kašlat na to, uděláme to úplně jinak" dost dobře není možný, protože zákazníci zaplatili šílené peníze a teď očekávájí, že to bude fungovat hodně dlouho. Ne náhodou je jednou z novinek AIXu 7 možnost pouštět AIX 5.2 LPAR jako WPAR pod AIX 7 (nebo naopak - mám v těch různých xPAR bordel), aby zákazníci mohli svoje archaické systémy hezky přesunout z kolabujícího starého železa do virtualizace na novém naleštěném železe a jede se dál.

    Co se týká binární kompatibility - tuším, že spousta opensource software pro AIX se kompiluje pro AIX 4.3.3 nebo jaká je to verze, protože všechny další s ní jsou zpětně binárně kompatibilní. To opět souvisí s těmi nainvestovanými penězi zákazníků IBM :)

    Založit nové vláknoNahoru

    Tiskni Sdílej: Linkuj Jaggni to Vybrali.sme.sk Google Del.icio.us Facebook

    ISSN 1214-1267   www.czech-server.cz
    © 1999-2015 Nitemedia s. r. o. Všechna práva vyhrazena.