abclinuxu.cz AbcLinuxu.cz itbiz.cz ITBiz.cz HDmag.cz HDmag.cz abcprace.cz AbcPráce.cz
AbcLinuxu hledá autory!
Inzerujte na AbcPráce.cz od 950 Kč
Rozšířené hledání
×
včera 13:13 | Komunita
Nadace pro svobodný software (FSF) udělila certifikát Respects Your Freedom (RYF, Respektuje vaši svobodu) WiFi routeru TPE-NWIFIROUTER od ThinkPenguin. Router je dodáván s libreCMC (zprávička), svobodnou distribucí GNU/Linuxu vhodnou pro vestavěné systémy (WiFi routery). Značku RYF lze udělit hardwaru, nad kterým má jeho majitel kontrolu a je respektována jeho svoboda a soukromí.
Ladislav Hagara | Komentářů: 11
včera 12:00 | Nová verze
Bylo oznámeno vydání KDE Frameworks 5.2.0, nové generace knihoven KDE. Knihovny KDE Frameworks 5 (KDE Frameworks) jsou nástupcem knihoven z KDE 4 (KDE Platform). Původní knihovny byly rozděleny do více než 50 knihoven (API). Knihovny KDE Frameworks 5.2.0 jsou postaveny nad Qt 5.2.
Ladislav Hagara | Komentářů: 0
včera 11:16 | Nová verze
Vyšla verze 4.7.0 IDE KDevelop. Zřejmě jde o poslední velké vydání před přechodem na Qt 5 a KDE Frameworks 5; dále budou v této řadě pouze opravovány chyby.
davkol | Komentářů: 0
13.9. 22:11 | Zajímavý software

Pamatujete hru Caesar III? Projekt CaesarIA, který se snaží vytvořit open source remake této hry, spustil kampaň na Indiegogo, kde se snaží vybrat peníze na vývoj nové grafiky, textur, hudby a zvuků. Podpořit vývoj můžete do 4. listopadu.

mstarman | Komentářů: 1
12.9. 11:43 | Upozornění
Chcete-li své téma dostat na startovací čáru 9. ročníku, máte již jen nadcházející víkend a dva dny (do 16. 9.) na vyplnění formulář CFP. Pak až za rok. Prokrastinaci zmar!… více »
Ladislav Nešněra | Komentářů: 12
12.9. 01:06 | Humor
Dle plánu by mělo Ubuntu 14.10 s kódovým označením Utopic Unicorn vyjít 23. října. Nejenom příznivci Ubuntu si ale mohou svého jednorožce dle návodu (pdf) složit z papíru již dnes. [OMG! Ubuntu!]
Ladislav Hagara | Komentářů: 11
11.9. 21:57 | Pozvánky
Znáte někoho, kdo to nemá daleko do Modřan a chtěl by, aby se jeho děti dozvěděly něco o internetu, Linuxu a open source? V Domě dětí a mládeže Monet bude toto pololetí probíhat kurz zaměřený na toto téma.
Miška | Komentářů: 1
11.9. 13:12 | Zajímavý software
Vývojář Fedory Vojtěch Trefný nedávno představil nástroj blivet-gui (GitHub) určený ke správě diskových oddílů a LVM. Jedná se o grafickou nadstavbu nad modulem (knihovnou) pro Python Blivet (GitHub), který používá Anaconda při instalaci Fedory. [Fedora Magazine]
Ladislav Hagara | Komentářů: 25
11.9. 11:24 | Zajímavý projekt
Kdo z jakéhokoli důvodu nesnáší systemd jako init systém a nechce čekat na maturitu gnu/dmd, může přejít na runit. Preferuje jej nyní nová rolling-release distribuce Void, je k dispozici i v Archlinuxu a jiných distribucích.
Petr Ježek | Komentářů: 92
11.9. 11:09 | Bezpečnostní upozornění
Byl vydán Adobe Flash Player ve verzích 15.0.0.152 a 11.2.202.406. Dle bezpečnostního upozornění APSB14-21 je opraveno hned 12 závažných bezpečnostních chyb (CVE-2014-0547 až CVE-2014-0557 a CVE-2014-0559). Nainstalovanou a doporučenou verzi Adobe Flash Player, spolu s odkazem ke stažení, lze zjistit na stránce About Flash Player.
Ladislav Hagara | Komentářů: 10
Hlasuji z:
 (83%)
 (12%)
 (2%)
 (2%)
 (0%)
 (0%)
Celkem 3451 hlasů
 Komentářů: 42, poslední 25.8. 11:10
Rozcestník
Reklama
Autoškola testy online Levný benzín

KWin a postarší hardware

Martin Gräßlin se v zápisku Cena za podporu starého hardwaru zamýšlí nad stavem, kdy se od FLOSS světa očekává, že bude podporovat všemožný zastaralý hardware, a tím jaké problémy to přináší. Z hlediska KWinu jde zejména o hardware podporující pouze OpenGL 1.x nebo nepodporující NPOT textury.

Jednou stránkou je problém se sháněním či zapojováním starého hardwaru do nové sestavy kvůli testování, či omezení vývoje na staré sestavě. Druhou je pak údržba OpenGL 1.x a XRender backendu v KWinu a zvýšená komplexita, kterou tento kód způsobuje. Do budoucna se pak rýsují problémy s Qt 5 a Waylandem. Problém při odstranění OpenGL 1.x podpory však nastane s morálně zastaralým ale ne až starým Intel hardwarem a s Catalyst ovladači, které i pro moderní hardware používají ke kompozici nepřímé vykreslování a OpenGL 1.x. Zajímavým řešením může být podle Martina softwarový LLVM ovladač, jenž odstraní nutnost mít moderní grafický hardware. Pokud se tato cesta ukáže jako dostatečně výkoná, bude Martin zahození OpenGL 1.x kódu nakloněn.

22.2.2012 13:07 | Nicky726 | Komunita


Tiskni Sdílej: Linkuj Jaggni to Vybrali.sme.sk Google Del.icio.us Facebook

Komentáře

Vložit další komentář

22.2.2012 13:21 Lol Phirae | skóre: 21
Rozbalit Rozbalit vše Re: KWin a postarší hardware
Ano, nejlepší je totiž každé prostředí zasrat co nejvíc animovanými, hardwarově náročnými a zcela nepotřebnými, práci zdržujícími hejblaty, blikadly a efekty, aby na samotnou práci zbylo co nejméně zdrojů. Z tohoto hlediska je taková "hrůza" jako nutnost podporovat OpenGL 1.x železo skutečně tou největší brzdou "pokroku" ve stylu KDE4 či Gnome3.

Vývojáři evidentně potřebují pořádnou ránu do palice (případně onen kopanec do zadnice zmiňovaný pod zprávičkou o KDE PIM Sprint), aby se jim rozbřesklo!
22.2.2012 13:36 magor
Rozbalit Rozbalit vše Re: KWin a postarší hardware
nikto ta nenuti to pouzivat kludne prejdi na openbox. Nam normalnym co nepouzivaju 10 rocny HW je podpora OpenGL 1.x u riti
22.2.2012 13:40 Lol Phirae | skóre: 21
Rozbalit Rozbalit vše Re: KWin a postarší hardware
Používám Xfce. Opravdu při práci nepotřebuju, aby při spuštění okno aplikace dvakrát zarotovalo, provedlo fade-in, pak spustilo spustilo plamenný efekt následovaný uhašením deštěm, vše doprovázeno samozřejmě příslušnými zvuky.

Počítače hardwarově zcela dostačující např. pro běžné kancelářské použití jsou s tzv. "moderními" desktop distribucemi úplně k ničemu, patrně by si člověk měl co rok koupit nový, aby byl "in" a mohl si dosyta užívat "vymožeností" onoho "moderního" desktopového prostředí. Sice je to k hovnu, aplikace neplní ani základní funkce (viz KDE PIM), ale zato to úúúúúúžasně kchůůůl vypadá. Wow! :-(
otula avatar 22.2.2012 13:55 otula | skóre: 44 | blog: otakar | Adamov
Rozbalit Rozbalit vše Re: KWin a postarší hardware
Xfce sice nepoužívám, ale jinak +1
Kdo vám tvrdí, že jste paranoidní, ten v tom spiknutí s největší pravděpodobností jede taky.
22.2.2012 16:17 Erbureth | skóre: 16
Rozbalit Rozbalit vše Re: KWin a postarší hardware
Nechápu, co řešíš, OpenGL 2.x podporuje už R300, což jsou 10 let staré karty. Nehledě na to, že když 10 let staré železo nahradíš podobně výkonným strojem s moderní architekturou, tak se ti to za chvíli vrátí na ušetřené elektrice.
22.2.2012 16:26 Lol Phirae | skóre: 21
Rozbalit Rozbalit vše Re: KWin a postarší hardware
Řeším to, že přiblblé efekty jsou "náhražkou" za naprosto zásadní funkce aplikací. Aneb jsem opravdu nadšen tím, že místo toho, aby se vývojáři zaměřili na funkčnost, tak se zabývají tím, zda je HW uživatele vůbec hoden toho, aby si spustil jejich animované ozvučené omalovánky. Co na tom, že si uživatel chce přečíst maily a používat kalendář, na to serem, důležitější je, aby to vypadalo kchůůůch a používalo tydlencty hento "moderní" technolooogije. Např. bezva nápad je narvat MySQL server na každý desktop.
22.2.2012 16:32 Zopper | skóre: 12
Rozbalit Rozbalit vše Re: KWin a postarší hardware
*flame* Na to vám ale stačí `ed`, nějaké ty webové browsery a klikací kalendáře jsou na nic, neutáhne to můj osmibitový procesor */flame* :D
"Dlouho ještě chcete soudit proti právu, stranit svévolníkům?" Ž 82,2
22.2.2012 16:40 Lol Phirae | skóre: 21
Rozbalit Rozbalit vše Re: KWin a postarší hardware
Máš tam špatný tag. Ne *flame*, ale *troll*. Pokud někdo z vývojářů KDE řeší namísto toho, že si uživatel nemůže přečíst maily a používat IM to, jestli jim stojí za to podporovat ten hnusný zastaralý HW, na kterém špatně chodí jejich efekty, tak skutečně potřebuje ránu palicí do hlavy. Podobná dilemata snad můžou trápit vývojáře her, nicméně opravdu nevím, proč bych si na 10 let starém počítači nemohl spustil textový editor a číst email.
22.2.2012 16:56 Zopper | skóre: 12
Rozbalit Rozbalit vše Re: KWin a postarší hardware
Ale to můžeš, na výběr máte nástroje, které nepotřebují ani to openGL 1 - to je jeden z důvodů, proč mám linux, můžu si vybrat, co chci. Stěžovat si, že vývojářům KDE 4 (čili nových verzí) se nelíbí udržování podpory pro archaický HW mi přijde zcela bezpředmětné a zbytečné. Koneckonců, to je jako kdyby sis stěžoval, že nějaký starý elektrospotřebič z počátků elektrifikace nemůžeš zapojit do současné sítě. Jen to v oblasti informatiky probíhá mnohem rychleji.
"Dlouho ještě chcete soudit proti právu, stranit svévolníkům?" Ž 82,2
22.2.2012 17:00 Lol Phirae | skóre: 21
Rozbalit Rozbalit vše Re: KWin a postarší hardware
Prosímtě, a který že to elektrický spotřebič nemůže dnes připojit? Fakt mě to zajímá, který vynález se to stal neschopný držet pokrok s kmitáním elektronů.
22.2.2012 17:08 Zopper | skóre: 12
Rozbalit Rozbalit vše Re: KWin a postarší hardware
Třeba Edisonovy či Křižíkovy stejnosměrné spotřebiče.
"Dlouho ještě chcete soudit proti právu, stranit svévolníkům?" Ž 82,2
22.2.2012 17:17 Lol Phirae | skóre: 21
Rozbalit Rozbalit vše Re: KWin a postarší hardware
http://en.wikipedia.org/wiki/Inverter_(electrical)
22.2.2012 18:39 ¶
Rozbalit Rozbalit vše Re: KWin a postarší hardware
Hezky jsi to vystihl. U PC to akorát není "Inverter_(electrical)" ale novější HW. Takže nepodpora OpenGL 1.x no problem.
stativ avatar 22.2.2012 18:12 stativ | skóre: 54 | blog: SlaNé roury
Rozbalit Rozbalit vše Re: KWin a postarší hardware
Co mí kwin společného s maily a IM?
Ať sežeru elfa i s chlupama!!! stativ.kx.cz
22.2.2012 18:24 Lol Phirae | skóre: 21
Rozbalit Rozbalit vše Re: KWin a postarší hardware
Co má OpenGL 2.0 společného s window managerem? Ahaaa, jo vlastně, ty kulervoucí frikulín efekty, který všichni nutně potřebou k práci.
22.2.2012 18:46 ¶
Rozbalit Rozbalit vše Re: KWin a postarší hardware
Ulehčit procesoru tím že grafiku opravdu kreslí grafická karta ? Mě to připadá teda naprosto v pořádku. Efekty pokud to nevíš lze snadno vypnout.
22.2.2012 18:50 Lol Phirae | skóre: 21
Rozbalit Rozbalit vše Re: KWin a postarší hardware
Aha, takže nejdřív vytvoříme problém (zcela nesmyslné efekty) a pak budeme ulehčovat procesoru tím, že ty efekty musí podporovat grafika. Aha, jasně, lze to snadno vypnout. A ten fallback mode je v Gnome3 proč?
stativ avatar 22.2.2012 19:51 stativ | skóre: 54 | blog: SlaNé roury
Rozbalit Rozbalit vše Re: KWin a postarší hardware
Ne všechny efekty jsou nesmyslné, třeba náhledy oken jsou docela šikovná věc. Navíc jiné renderovací cesty (např. Xrender) než OpenGL nemají IMO v současnosti smysl, grafické karty jsou optimalizovány pro 3D API.

A stále jsi neodpověděl na otázku, co má kwin společného s mailem a IM.
Ať sežeru elfa i s chlupama!!! stativ.kx.cz
22.2.2012 20:36 Lol Phirae | skóre: 21
Rozbalit Rozbalit vše Re: KWin a postarší hardware
A stále jsi neodpověděl na otázku, co má kwin společného s mailem a IM.
Jako že by svoje úsilí měli místo nepotřebných kokotin (dámy prominou) zaměřit na zprovoznění zcela základních kritických funkcí. Na vopičárny s grafikou bude čas, až si bude moc přečíst maily, aniž by klienta s jeho mraky nesmyslných mysql procesů zabil OOM killer a přitom to půlku mailů nezežralo.

stativ avatar 23.2.2012 15:32 stativ | skóre: 54 | blog: SlaNé roury
Rozbalit Rozbalit vše Re: KWin a postarší hardware
Jako že by svoje úsilí měli místo nepotřebných kokotin (dámy prominou) zaměřit na zprovoznění zcela základních kritických funkcí.
Od kdy je mailový klient kritickou funkcí window manageru? Navíc pokud je mi známo, tak kwin posílat maily neumí.
Ať sežeru elfa i s chlupama!!! stativ.kx.cz
23.2.2012 15:58 Lol Phirae | skóre: 21
Rozbalit Rozbalit vše Re: KWin a postarší hardware
Řeč je o KDE a alokaci zdrojů. Tyhle šaškárny typu "to není můj píseček" si prosím Vás zkoušejte někde jinde, uživatele to absolutně nezajímá.
23.2.2012 16:07 Ladicek | skóre: 28 | blog: variace | Havlíčkův brod
Rozbalit Rozbalit vše Re: KWin a postarší hardware
Tyhle šaškárny o lidech coby zdrojích si zkoušejte někde jinde, to nás nezajímá.
Ještě na tom nejsem tak špatně, abych četl Viewegha.
23.2.2012 16:09 Lol Phirae | skóre: 21
Rozbalit Rozbalit vše Re: KWin a postarší hardware
Aha, jasně... A nějaký argument by se nanašel?
23.2.2012 16:11 Ladicek | skóre: 28 | blog: variace | Havlíčkův brod
Rozbalit Rozbalit vše Re: KWin a postarší hardware
Jak se do lesa?
Ještě na tom nejsem tak špatně, abych četl Viewegha.
23.2.2012 16:14 Lol Phirae | skóre: 21
Rozbalit Rozbalit vše Re: KWin a postarší hardware
Nevím, koukni se do mapy, kde máte ve vašem Prdelákově nejbližší les, a pak si zavolej taxika.
stativ avatar 23.2.2012 16:50 stativ | skóre: 54 | blog: SlaNé roury
Rozbalit Rozbalit vše Re: KWin a postarší hardware
Od začátku je řeč o kwin. A řečičky o alokaci zdrojů neberu -- proč nenadáváš na GNOME, že nedělají na kmailu (o kterém nejspíše mluvíš).
Ať sežeru elfa i s chlupama!!! stativ.kx.cz
23.2.2012 17:01 Lol Phirae | skóre: 21
Rozbalit Rozbalit vše Re: KWin a postarší hardware
A co je jako vývojářům konkurenčního projektu do KDE a jeho zprzněného PIM? :-D
stativ avatar 23.2.2012 18:35 stativ | skóre: 54 | blog: SlaNé roury
Rozbalit Rozbalit vše Re: KWin a postarší hardware
Asi to samé jako vývojářům kwinu do kmailu.
Ať sežeru elfa i s chlupama!!! stativ.kx.cz
23.2.2012 18:37 Lol Phirae | skóre: 21
Rozbalit Rozbalit vše Re: KWin a postarší hardware
Děkuji za "diskusi" a sbohem.
stativ avatar 23.2.2012 18:59 stativ | skóre: 54 | blog: SlaNé roury
Rozbalit Rozbalit vše Re: KWin a postarší hardware
Není zač :-D
Ať sežeru elfa i s chlupama!!! stativ.kx.cz
24.2.2012 09:31 Michal Vyskočil | skóre: 60 | blog: miblog | Praha
Rozbalit Rozbalit vše Re: KWin a postarší hardware
Alokace zdrojů, to je slovo do pranice. Konečně nás můžete osvítit svojí genialitou :-)

Tedy řekněme, že jste skutečně projektový manažer KDE*. Takže máte Martina, jako maníka se znalostmi C++, Qt, OpenGL a vnitřností X, což už samo o sobě je dost vzácná a neobvyklá kombinace vývojářských schopností. Teď po něm chcete, aby pracoval na křápu**, jakým je Akonadi a musíte ho nějak motivovat a zároveň nechcete, aby se po krátkém čase nasral natolik, aby odešel jinam (což při jeho skillsetu není nijak obtížné) a vám zůstaly na krku dva nefunkční projekty.

Jsem zvědav na vaše návrhy ...

* můžeme pro zjednodušení odhlédnout od faktu, že je to opensource projekt a předpokládejme, že je to normální zaměstnanecký poměr.

** povšimněte si, že tu nikdo nepolemizuje o tom, že by to nebyl křáp - řekl bych, že Akonadi je asi největší bloatware a warpoware v dosavadní historii otevřeného software.
When your hammer is C++, everything begins to look like a thumb.
24.2.2012 10:07 Lol Phirae | skóre: 21
Rozbalit Rozbalit vše Re: KWin a postarší hardware
Teď po něm chcete, aby pracoval na křápu**, jakým je Akonadi a musíte ho nějak motivovat a zároveň nechcete, aby se po krátkém čase nasral natolik, aby odešel jinam (což při jeho skillsetu není nijak obtížné) a vám zůstaly na krku dva nefunkční projekty.

Jsem zvědav na vaše návrhy ...
Motivovat někoho, aby pracoval na Akonadi? To snad jedině takhle - ačkoliv se obávám, že samotný "produkt" je asi výsledkem oné špatné kalibrace. :-D
little.owl avatar 24.2.2012 12:43 little.owl | skóre: 20 | Brighton
Rozbalit Rozbalit vše Re: KWin a postarší hardware
C++, Qt, OpenGL a vnitřností X, což už samo o sobě je dost vzácná a neobvyklá kombinace vývojářských schopností.
Hlavne ta X-ka jsou problem.

Popsal jste jadro pudla cele rady problemu OSS; komercni firma donuti vyvojare dotahnout veci do konce, predtim nez tam zacne implementovat nove a nove features.

24.2.2012 19:24 podlesh | skóre: 38 | Praha
Rozbalit Rozbalit vše Re: KWin a postarší hardware
Popsal jste jadro pudla cele rady problemu OSS; komercni firma donuti vyvojare dotahnout veci do konce, predtim nez tam zacne implementovat nove a nove features.
Odvážné tvrzení...
Rezza avatar 26.2.2012 21:06 Rezza | skóre: 25 | blog: rezza | Brno
Rozbalit Rozbalit vše Re: KWin a postarší hardware
No za celym KDE PIM stoji komercni firmy :)
little.owl avatar 23.2.2012 16:34 little.owl | skóre: 20 | Brighton
Rozbalit Rozbalit vše Re: KWin a postarší hardware
až si bude moc přečíst maily, aniž by klienta s jeho mraky nesmyslných mysql procesů zabil OOM killer a přitom to půlku mailů nezežralo.

Really? :-D :-D

Naposledy jsem to zkusil verzi 4.2, vidim, ze o hodne prichazim.
23.2.2012 16:40 Lol Phirae | skóre: 21
Rozbalit Rozbalit vše Re: KWin a postarší hardware
No to bezpochyby, je to prostě vynikající. Prostě MySQL jako cache totálně pravítkuje! Nemá to chybu, jen stále přemýšlím, jestli ten, kdo to vymyslel, je sadista, nebo si skutečně myslel, že tahle pitomost je skvělý nápad. Ale jinak je super, že "díky" sračkonádi a spol. můžu napsat emailového klienta za deset minut, to, že si pak uživatel poštu stejně nepřečte, to je jen takový drobný detail. :-D :-)
Marián Kyral avatar 24.2.2012 15:52 Marián Kyral | skóre: 28 | blog: Sem_Tam | Frýdek-Místek
Rozbalit Rozbalit vše Re: KWin a postarší hardware
Nevím co všichni mají s tím kmailem. Já používám Thunderbird a jsem spokojen. A mysql používá třeba amarok a taky bez problémů. Takže je vidět, že to není v mysql, ale v něčem jiném.
Jendа avatar 22.2.2012 20:01 Jendа | skóre: 68 | blog: Výlevníček | JO70FB
Rozbalit Rozbalit vše Re: KWin a postarší hardware
Šmarjá tak si nainstaluj WM, který tohle nepotřebuje. Já mám Intel Atom a taky na tom KDE/GNOME nespouštím.
Bluebear avatar 22.2.2012 23:41 Bluebear | skóre: 30 | blog: Bluebearův samožerblog | Praha
Rozbalit Rozbalit vše Re: KWin a postarší hardware
Před týdnem jsem pokusně rozjel KDE 4.8 na Atomu a podivil jsem se, jak svižné to je. Žádné problémy, normálně to chodí, nezadrhává se, ani nijak zvlášť nevytěžuje procesor - včetně grafických efektů (on-chip intelí grafárna).
I love the asylum, my own padded cell / I'll stay here forever for outside it's hell...
23.2.2012 10:15 Tets | skóre: 10
Rozbalit Rozbalit vše Re: KWin a postarší hardware
Potvrzuji. Používám na Atomu N550 (2GB RAM, víc chipset nepodporuje) nejnovější KDE a běží bez problémů. Největší problém mi dělá www prohlížeč, který mi při více otevřených náročnějších (Gmail, Reader, Google+, občas nějaký flash) záložkách sežere všechnu paměť :-(
22.2.2012 16:32 j
Rozbalit Rozbalit vše Re: KWin a postarší hardware
Hmm, a co kdyz mas zarizeni za nekolik (desitek, nekdy i stovek) MKc, soucasti toho zarizeni (klido 15, 20let stareho) je pocitac slouzici k jeho ovladani a na tom chces provozovat rozumne aktualni system, pricemz ses proste omezen HW, ktery nevymenis a novy zarizeni budes kupovat mozna za dalsich 15 - 20let, protoze dela vse co potrebujes a funguje ...
22.2.2012 16:39 Zopper | skóre: 12
Rozbalit Rozbalit vše Re: KWin a postarší hardware
Nevím, jestli bych si do takového zařízení instaloval nejnovější ubuntu. K čemu tam vůbec aktuální distribuce bude? Pokud je ten PC nějak pevně spojený s tím zařízením, pak bych tam stejně nic dalšího než jeho obsluhu nedělal - a myslím, že i starý systém svou úlohu splní.
"Dlouho ještě chcete soudit proti právu, stranit svévolníkům?" Ž 82,2
22.2.2012 16:42 Lol Phirae | skóre: 21
Rozbalit Rozbalit vše Re: KWin a postarší hardware
Např. kvůli tomu, že pro pět a více let starou distribuci nevycházejí žádné bezpečnostní aktualizace. Ale to neřeš, to je nad tvé chápání. Základ jsou ty 3D efekty, animace a tak. Na funkcionalitu a bezpečnost sere pes.
22.2.2012 17:14 mimi.vx | skóre: 35 | blog: Mimi.VX | Praha
Rozbalit Rozbalit vše Re: KWin a postarší hardware

urcite budu mit zarizeni za par mega pripojene primo na internet + na jeho ovladacim PC provozovat KDE ....

 

Ono neni lepsi pouzivat to co se na danou ulohu hodí nez bleeding edge veci co jsou urceny na uplne neco jineho ze ...

USE="-gnome";turris
22.2.2012 20:39 Lol Phirae | skóre: 21
Rozbalit Rozbalit vše Re: KWin a postarší hardware
Jistě, např. několik let starý prohlížeč, toť ideál bezpečnosti a záruka uživatelské spokojenosti. Dej si obklad na hlavu.
Bluebear avatar 22.2.2012 23:37 Bluebear | skóre: 30 | blog: Bluebearův samožerblog | Praha
Rozbalit Rozbalit vše Re: KWin a postarší hardware
Moment, tady něco nesedí.

Pokud máš specializovaný hardware za několik mega, bude to buď nějaké tovární zařízení (CNC soustruh, fréza či něco takového?) nebo nějaký sofistikovaný měřící, analytický nebo nějaký takový aparát. PC připojené k takovému zařízení má sloužit výhradně jako řídící terminál a nemá být připojeno nikam než do přesně zadefinované a omezené vnitřní sítě. Software tam nainstalovaný má být rovněž výhradně pro tyto účely. Tam nemá prohlížeč co dělat, stejně jako tam nemá co dělat kompilátor a podobně - to není pracovní stanice, to je speciální věc.
I love the asylum, my own padded cell / I'll stay here forever for outside it's hell...
22.2.2012 23:43 Lol Phirae | skóre: 21
Rozbalit Rozbalit vše Re: KWin a postarší hardware
Já se nebavím o žádných soustruzích a speciálním HW za několik mega. Používat děravý software je problém i na notebooku za 3 tisíce.
23.2.2012 09:55 Michal Vyskočil | skóre: 60 | blog: miblog | Praha
Rozbalit Rozbalit vše Re: KWin a postarší hardware
Moment, tady něco nesedí.
To bude tím, že jde o z prstu vycucaný příklad, takže žádné tvoje řešení nebude správné, protože Lol vzápětí přijde s dalšími dodatečnými podmínkami, nebo změnami zadání, anebo řekne, že KDE PIM stojí za houby, což je sice pravda, ale pro kwin irelevantní, Já bych to viděl tak, že pro poslední prohlížeč nepotřebuješ poslední KDE se všemi možnými grafickými efekty. Buďto stačí neinstalovat KDE, nebo efekty vypnout ...
When your hammer is C++, everything begins to look like a thumb.
Jendа avatar 22.2.2012 20:04 Jendа | skóre: 68 | blog: Výlevníček | JO70FB
Rozbalit Rozbalit vše Re: KWin a postarší hardware
Třeba proto, že ti došly IPv4 adresy, a tak nutně potřebuješ jádro a userland, který umí IPv6? Nebo proto, že někdo cracknul DES, a tak potřebuješ novější algoritmy, než ty z roku 1995?
Jendа avatar 22.2.2012 20:03 Jendа | skóre: 68 | blog: Výlevníček | JO70FB
Rozbalit Rozbalit vše Re: KWin a postarší hardware
Poslední Debian s Fluxboxem jsem provozoval na PI@166 MHz, 64 MiB RAM. Bez Xek jsem ho rozjel na routeru s 32 MiB RAM.
Josef Kufner avatar 22.2.2012 13:55 Josef Kufner | skóre: 63
Rozbalit Rozbalit vše Re: KWin a postarší hardware
Takový náhled okna při alt-tab není špatná věc. Přiměřené animace celkem zpřehledňují práci s GUI. Třeba při přetahování tabů ve Chrome se při prohození ta ouška šoupají namísto skokové změny a dost to pomáhá vidět, co se vlastně pod myší děje, aniž by to jakkoliv zdržovalo.

Navíc HW podpora kompozice může snížit zátěž hardwaru, protože při zobrazení okna není třeba jej překreslovat vždy, neboť je celé v textuře na grafické kartě. Ještě nedávno by to znamenalo otravovat aplikaci s tím, ať se překreslí a určitě znáš tu stopu, kterou zanechává rychle se posouvající okno.
Hello world ! Segmentation fault (core dumped)
22.2.2012 14:03 Zopper | skóre: 12
Rozbalit Rozbalit vše Re: KWin a postarší hardware
+1... Já taky nedám dopustit třeba nad stín kolem oken, pomáhá vizuálně oddělit jednotlivá okna, pokud se částečně překrývají. Za praktický efekt pak považuji i minimalizaci, pokud dojde k jakému "přemístění" okna do lišty - takže vidím, že to okno se minimalizovalo někam doleva/doprava a nemusím ho hledat na celé liště.
"Dlouho ještě chcete soudit proti právu, stranit svévolníkům?" Ž 82,2
22.2.2012 14:37 Rada | skóre: 14
Rozbalit Rozbalit vše Re: KWin a postarší hardware
S tím souhlasím, ale na druhou stranu myslím, že existují i jiné srovnatelně názorné způsoby zvýraznění a přitom řádově méně hardwarově náročné. Proto asi to rozčarování ve zdejší diskuzi. Osobně se mi také nelíbí to stálé zahazování podpory "zastaralého" hardwaru. Ono OpenGL 1.3 není zas tak stará věc. Především mě ale zlobí tohle nesmyslné honění se za čímsi... za cenu značného plýtvání. Stále vyhazovat hardware, nakupovat nový... a každé dva roky znova - to mi přijde nesmyslně spotřební. Ano, pokud potřebuji HW na to, aby vyřešil složitý úkol rychle, pak je na místě pořídit nový výkonný HW. Ale pokud HW řeší stále stejný úkol, který je jen "pokrokem" zesložitěn natolik, že ho současný HW řešit nestíhá (úkol jako přepnutí mezi dvěma okny), pak se ve mě všechno příčí, když mám kvůli něčemu takovému upgradovat.
22.2.2012 15:29 kavol | skóre: 28
Rozbalit Rozbalit vše Re: KWin a postarší hardware
Stále vyhazovat hardware, nakupovat nový...
krásný příklad tiskárna ... pravda, nekupoval jsem ji jako novou, nicméně proč to, když tehdy aktuální modely nabízely tytéž parametry za trojnásobek peněz

než jsem dojel první toner, tak jsem musel dokoupit USB-LPT převodník

a druhý toner už asi nedojedu, neb prostě s novějšími jádry to přestalo fungovat, bugy jsou nahlášené, a nic se neděje, akorát čas od času se najde další nasraný uživatel, kterému po upgradu přestal fungovat tisk

takže mám vyhodit plně funkční kus hardware, a vrážet prachy do nového, jen proto, že se nějaký exot rozhodl, že je to moc staré, a že bych měl podpořit chudáčky výrobce nákupem něčeho novějšího?

popř. jestli jsem to dobře pochopil, mám obratem vyhodit noťas, co jsem koupil minulý týden, protože má grafiku v procesoru => intel => morálně zastaralé? WTF?

dovede si to někdo představit, že by si tohle dovolil někdo jinej, než kokoti develové - že bych si třeba pozval na barák kominíka, ať mi vyčistí komín, a on mi místo toho celej barák zboural, že se mu nelíbí, jak je ten komín starej, a že si mám nechat postavit novej barák???
Ilfirin avatar 22.2.2012 15:55 Ilfirin | skóre: 32 | blog: ilfblog | Liberec
Rozbalit Rozbalit vše Re: KWin a postarší hardware
hd2000/3000 má Open GL 3.0
22.2.2012 16:12 kavol | skóre: 28
Rozbalit Rozbalit vše Re: KWin a postarší hardware
ok, a teď mi ještě řekni, jestli se to týká B950 - ať koukám, jak koukám, tak tam nic o HD2000 nebo HD3000 nevidím?
22.2.2012 16:37 blbec
Rozbalit Rozbalit vše Re: KWin a postarší hardware
Hardwarově by to mělo být HD2000 - quicksync; otázka je co vám dovolí ovladač
22.2.2012 17:47 kavol | skóre: 28
Rozbalit Rozbalit vše Re: KWin a postarší hardware
Hardwarově by to mělo být HD2000 - quicksync;
dík
otázka je co vám dovolí ovladač
a odpověď asi nikdo neví ...?
23.2.2012 01:13 Liborek | skóre: 17 | blog: Liborkovo | (momentálně) Praha
Rozbalit Rozbalit vše Re: KWin a postarší hardware
Formálně to je HD2000, ale se sníženou pracovní frekvencí a vypnutými některými akceleračními funkcemi. Ale zdá se, že i Intel na svém webu v tém má trošku bordel. V některých datasheetech to označuje jako Intel HD Graphics a v jiných přehledech jen jako Intel Graphics.
22.2.2012 17:16 mimi.vx | skóre: 35 | blog: Mimi.VX | Praha
Rozbalit Rozbalit vše Re: KWin a postarší hardware

a dokonce uz i v Mesa3D ...

USE="-gnome";turris
Saljack avatar 22.2.2012 16:39 Saljack | skóre: 28 | blog: Saljack | Praha
Rozbalit Rozbalit vše Re: KWin a postarší hardware
Sorry ale tiskárnu s LPT jsem viděl naposledy před 10 lety. Myslím si, že 10 let podpory HW, který se nevyrábí je naprosto dostačující. Navíc nikdo tě nenutí aktualizovat na super cool novou verzi.
Sex, Drugs & Rock´n Roll. !!!!!!!Prosím nevykat!!!!!!! Neumím psát česky
22.2.2012 17:16 mimi.vx | skóre: 35 | blog: Mimi.VX | Praha
Rozbalit Rozbalit vše Re: KWin a postarší hardware

+1

USE="-gnome";turris
22.2.2012 17:55 kavol | skóre: 28
Rozbalit Rozbalit vše Re: KWin a postarší hardware
Sorry ale tiskárnu s LPT jsem viděl naposledy před 10 lety.
no a?

já jsem spoustu věcí neviděl vůbec nikdy, jak je to relevantní?
Myslím si, že 10 let podpory HW, který se nevyrábí je naprosto dostačující.
já si zase myslím, že seš idiot pokud to takto poměřuješ na jen na čas, a také kvůli další větě, citované níže

věc buď funguje a plní svůj účel, pak nevidím důvod ji měnit, anebo nefunguje či neplní svůj účel dostatečně dobře, a pak si výměnu zaslouží

nebo ty snad například v celém domě měníš žárovky v pevně daném časovém intervalu, bez ohledu na to, že v pohodě svítí, jen protože svítí už moc dlouho?
Navíc nikdo tě nenutí aktualizovat na super cool novou verzi.
vskutku? - naposled to fungovalo tuším někdy okolo Fedory 13, je ta stále podporovaná, anebo je to spíše tak, že mě vývojáři nutí přejít na novější verzi tím, že starou již nepodporují?

btw, bavíme se o věci, která fungovala, a nějakej kripl ji rozbil, aniž by se obtěžoval to zase spravit, nikoli o tom, že by se musel naprogramovat nový ovladač pro deset let starou věc
24.2.2012 00:24 mhepp
Rozbalit Rozbalit vše Re: KWin a postarší hardware
Podivej se, ono je strasne hezke podporovat stary HW tak, aby supr trupr kuuul chodil.

Kolik lidi zde realne pouziva procesor 486? Ale je mi jasne, ze kdyby nekdo ukoncili podporu pro 386-ku, tak se tu zvedne vlna odporu, ze je to nesmysl a ze to strasne vsichni potrebuji. To nemluvim o podpore stareho HW v aktualnich verzich jisteho komercniho OS...

Koukni se na to ale z pohledu vyvojare: vyvijim jadro, ktere nutne musi podporovat novy HW, potrebuje umet nove veci a celkove se meni. Potom kazdy stary kousek HW se musi menit kontinualne taky. Kdyz se zmeni komunikacni rozhrani na strane jadra, tak se musi zmenit i na strane ovladacu. Problem je v tom, ze v soucasnosti uz malokdo ma ten spravny stary kousek HW, aby vyzkousel, ze vse opravdu funguje... Jako vyvojar mam tedy dve moznosti: budto to risknu a upravim podporu pro stary a tedy nyni jiz exoticky HW, odzkousim to na svem a budu doufat, ze se nenajde nikdo s exotictejsim HW a ze to vubec jeste nekdo pouziva. Nebo se na tu podporu uplne vykaslu, venuji svuj cas a usili do neceho smysluplnejsiho == podpora noveho a zadaneho HW a hold nekdo prijde o moznost pouzivat svuj zastaraly a temer nikym jinym nepouzivany HW, ktery jiz minimalne o 5 let prekracuje svoji planovanou zivotnost.

Zkuste se nad tim zamyslet takhle...

Stejne tak podpora stareho OpenGL -- Kdo potrebuje aktualni KWin na stary HW je nevyvazena osobnost, ktera by si mela ujasnit sve zivotni postouje a priority. Mimochodem, ono zahozeni podpory pro OpenGL 1.x bude jeste nejakou dobu trvat, takze pokud to rozhodnuti padne, tak jeste minimalne rok tu podpora bude.

24.2.2012 09:35 Michal Vyskočil | skóre: 60 | blog: miblog | Praha
Rozbalit Rozbalit vše Re: KWin a postarší hardware
Kdo potrebuje aktualni KWin na stary HW je nevyvazena osobnost, ktera by si mela ujasnit sve zivotni postouje a priority.
Tak ono tohle zase souvisí s životním cyklem distribucí, takže po čase člověk nemá jinou rozumnou možnost, než udělat update. Na druhou stranu, pokud se nepletu, tak tohle jenom znamená, že na starém HW nepoběží kompozitor, což mi nepřijde jako taková tragédie.
When your hammer is C++, everything begins to look like a thumb.
24.2.2012 12:14 kavol | skóre: 28
Rozbalit Rozbalit vše Re: KWin a postarší hardware
Koukni se na to ale z pohledu vyvojare: vyvijim jadro, ktere nutne musi podporovat novy HW, potrebuje umet nove veci a celkove se meni. Potom kazdy stary kousek HW se musi menit kontinualne taky.
ano vidím

JÁ něco vyvíjím, tak ostatní ať buď slintaj blahem a nosí mě na rukou, jak jsem dobrej, nebo ať táhnou doprdele

typická frikulínksá arogance
little.owl avatar 24.2.2012 12:36 little.owl | skóre: 20 | Brighton
Rozbalit Rozbalit vše Re: KWin a postarší hardware
Tak takhle to urcite nebylo mysleno. Zadny jiny OS nepodporuje stary HW jako Linux, coz se ukazalo ted kdy plno zarizeni nema 64bit Windows drivery a Linux ano. Nevim jestli vyvijite drivery, ale pokud ano, pak byste tomu mel rozumet. Stoji to hodne usili, stary HW casto neni vubec k dispozici a veci se delaji naslepo a pokud to poziva minimum lidi, nemusi to byt proste priorita.
Jendа avatar 22.2.2012 15:36 Jendа | skóre: 68 | blog: Výlevníček | JO70FB
Rozbalit Rozbalit vše Re: KWin a postarší hardware
Já jsem tohle vyřešil přechodem na Xfwm. Ale zároveň to znamená, že nevím o použitelném prostředí pro lamy. Zdá se mi, že linuxový desktop za posledních 5 let, co ho používám, degraduje :-(.

Viz též článek v patičce.
22.2.2012 15:54 Petr
Rozbalit Rozbalit vše Re: KWin a postarší hardware
Jojo, zlomovým bodem bylo KDE4 a pak se to už jen vezlo... :-( Linuxový desktop umřel. :-((((
22.2.2012 16:30 Zopper | skóre: 12
Rozbalit Rozbalit vše Re: KWin a postarší hardware
Nejlépe na mě zatím působí cinnamon. Našlápnuto má pěkně a pokud se nezamotají do zesložiťování, nebo to z nějakého důvodu neumře, mohlo by to být nejpoužitelnější prostředí. Postavené je nad gtk3 (gnome3) knihovnami, takže zatím nehrozí ukončení vývoje, jako gtk2.

Zatím jej používám a jsem nejspokojenější od vynuceného odchodu z gnome2 (no, instalovat si legacy gnome2, když už stejně všechny aplikace využívající gtk přechází na gtk3 mi přijde jako komplikace).

Někde jsem četl i něco o portu gnome2 na gtk3, ale nevím, jak to vypadá teď.
"Dlouho ještě chcete soudit proti právu, stranit svévolníkům?" Ž 82,2
24.2.2012 14:54 radix
Rozbalit Rozbalit vše Re: KWin a postarší hardware
Myslim, ze bylo hur. KDE 4.8 mne beha slusne a snad uz bude jen lip ...
22.2.2012 23:55 Vin
Rozbalit Rozbalit vše Re: KWin a postarší hardware
Uh... v tom článku je zmíněn XRender, který je další volbou pro starší HW, a ten je kolem 1000 řádků. Problém je spíš s udržováním OpenGL 1.x, o kterém se uvažuje, že by šel do kopru úplně. (Navíc OpenGL je spíš pro ty hejblata, nevím o tom, že by kwin3 musel používat OpenGL)
little.owl avatar 23.2.2012 14:28 little.owl | skóre: 20 | Brighton
Rozbalit Rozbalit vše Re: KWin a postarší hardware
"práci zbylo co nejméně zdrojů"

Naroky Gnome3 jsou v podstate srovnatelne s predchozi verzi a neni duvod nevyuzit HW moznosti karet jimiz jsou vybaveny vsechna PC novejsi nez sest let, pokud to pomuze zlepsit UI a zaroven vyrazne zjednodusit vnitrni architekturu.
22.2.2012 16:34 GR
Rozbalit Rozbalit vše Re: KWin a postarší hardware
No, rozčarovaný jsem též, ale tu zprávičku chápu spíš že "jestli půjde KDE na starých grafikách provozovat jednoduše s LLVM (whatev), zahodíme kód pro grafické ovladače starých karet", tudíž že kód budou zahazovat pouze v případě, že to na těch starých strojích rozjedou alternativním způsobem. V tom případě s tím souhlasím a nevadí mi to.

Nebo jsem pochopil něco špatně?
22.2.2012 16:41 Zopper | skóre: 12
Rozbalit Rozbalit vše Re: KWin a postarší hardware
Já to pochopil taky tak... Přijde mi, že někteří diskutující to vidí stylem "co si někdo dovoluje stěžovat, že musí udržovat kompatibilitu pro HW, co se už deset let neprodává? Mají být rádi, že si musí tyhle historické kousky shánět!" :-)
"Dlouho ještě chcete soudit proti právu, stranit svévolníkům?" Ž 82,2
22.2.2012 16:56 l4m4
Rozbalit Rozbalit vše Re: KWin a postarší hardware
A teď ještě prosím vysvětlit, proč by tvůrce window manageru měl řešit kompatibilitu s hardwarem. Window manager je ta věc, která dovolí okna přesouvat po desktopu, nakreslí kolem nich rámečky a nahoře titulek. Kdy zjistím, že s mou grafickou kartou není kompatibilní ls?
22.2.2012 17:04 Zopper | skóre: 12
Rozbalit Rozbalit vše Re: KWin a postarší hardware
Jenže KDE 4 není jen window manager, ale desktopové prostředí se vším kolem - a taky Qt knihovny a ty už kompatibilitu s HW řešit prostě musí.

Ad ls: jde aktuální ls zkompilovat bez úprav třeba na intel 8080? Nejde o nic nového, prostě se nevyplatí udržovat podporu pro všechen HW, který kdy někdo vyrobil.
"Dlouho ještě chcete soudit proti právu, stranit svévolníkům?" Ž 82,2
22.2.2012 17:07 Lol Phirae | skóre: 21
Rozbalit Rozbalit vše Re: KWin a postarší hardware
Ad ls: jde aktuální ls zkompilovat bez úprav třeba na intel 8080?
http://z80gcc.sourceforge.net/
23.2.2012 01:22 Liborek | skóre: 17 | blog: Liborkovo | (momentálně) Praha
Rozbalit Rozbalit vše Re: KWin a postarší hardware
Že by krok k linuxu na ZX Spectru?
22.2.2012 20:27 l4m4
Rozbalit Rozbalit vše Re: KWin a postarší hardware
Odbíháš od tématu. KWin není celé desktopové prostředí.

Ale když jsi s tím začal... Kromě popsaného window manageru obsahuke desktopové prostředí věc, která nakreslí na kraji obrazovky lištu, několik věcí, které do té lišy nakreslí různé ikonky a pár démonů realizujících provázání jednotlivých částí a udržujících stav prostředí coby celku, a pod. Takže prosím opět vysvětlit, kde se tu musejí řešit jaké kompatibility s grafickými kartami -- to je na úplně špatné úrovni abstrakce.
23.2.2012 00:25 Vin
Rozbalit Rozbalit vše Re: KWin a postarší hardware
Řešit se musí, pokud chceš využívat akceleraci a/nebo efekty.
little.owl avatar 23.2.2012 14:43 little.owl | skóre: 20 | Brighton
Rozbalit Rozbalit vše Re: KWin a postarší hardware
Kdyz chcete efektivne dosahnout nejakeho cile, resite jake mate prostredky k dispozici. Pokud chcete vykopat prikop, vas pristup se bude jiny kdyz budete mit bagr a nebo jen lopatku na pisek.

Slozite pochopit?
22.2.2012 17:33 Rada | skóre: 14
Rozbalit Rozbalit vše Re: KWin a postarší hardware
Ano, chápu to stejně. Problém ale je, že LLVM pipe je softwarový rasterizér - tedy čip grafické karty je tímto krokem k ničemu, i když to výkonově často bez potíží zvládne. O to méně CPU času pak ale mají aplikace. Navíc to pravděpodobně bude znamenat, že X server, nebo to, co tam místo něj jednou bude, bude muset jako OpenGL renderer inicializovat LLVM pipe. Tím pádem se ale k čipu grafické karty nedostanou ani aplikace, které by ho chtěly použít. Pokud je tomu tak (a tím si skutečně nejsem jistý), pak tato drobná změna dramaticky degraduje použitelnost počítače. Navíc se obávám, že právě na těch starých strojích bude LLVM pomalé, protože staré stroje mají kromě starých grafických karet také pomalé CPU. Ale mohu se mýlit a budu rád, když mě někdo opraví:-)
vlastikroot avatar 22.2.2012 19:28 vlastikroot | skóre: 22 | blog: vlastikovo | Milevsko
Rozbalit Rozbalit vše Re: KWin a postarší hardware
Na tech starych strojich je KDE stejne za trest ... Takze bych to vubec neresil a nahodil neco vhodnejsiho (XFCE,E17,fluxbox,DWM apod.). Ja mam 3.3GHz Prescott, 1GB a nvidii 8500 a KDE bych si nedal, protoze na takovym stroji je to proste utrpeni. Na modernim rychlym nekolikajadrovym procesoru s kupou rychly DDR3 RAM bych s tim problem nemel, obetovat trochu vykonu za komfort KDE je v pohode, ale plytvat vykonem na pomalem stroji je nesmysl.
Sg1-game | We will destroys the Christian's legion ... and the cross, will be inverted | IP 88.83.187.5
22.2.2012 21:03 mimi.vx | skóre: 35 | blog: Mimi.VX | Praha
Rozbalit Rozbalit vše Re: KWin a postarší hardware

tak zrovna na takovem stroji jede bez problemu ....

USE="-gnome";turris
vlastikroot avatar 23.2.2012 06:52 vlastikroot | skóre: 22 | blog: vlastikovo | Milevsko
Rozbalit Rozbalit vše Re: KWin a postarší hardware
Tak spustit se da, ale pracovat se v tom poradne neda. To je jako s windows 7 ...
Sg1-game | We will destroys the Christian's legion ... and the cross, will be inverted | IP 88.83.187.5
22.2.2012 22:37 w4rr10r
Rozbalit Rozbalit vše Re: KWin a postarší hardware
Jak to tu tak čtu... jak je, sakra, možné, že normálně provozuju KDE Workspaces na hardwaru, který výkonově odpovídá podprůměru z doby před pěti lety?
22.2.2012 23:55 Vin
Rozbalit Rozbalit vše Re: KWin a postarší hardware
Asi nepoužíváš OpenGL.
23.2.2012 00:04 Vin
Rozbalit Rozbalit vše Re: KWin a postarší hardware
Nepoužívám OpenGL a grafický efekty, kwin4 na nich nestojí a nepadá. Takže reakci Lol Phirae nechápu.
23.2.2012 00:14 Vin
Rozbalit Rozbalit vše Komunikace upstream/downstream
Trochu OT, ale zajímavý komentář od vývojáře Fedory:
Back when we made the decision, you were all boasting about the great new features to expect in the next stable release and there was no talk at all about 4.0 being essentially a beta branch.

In addition, those messages implied (or at least didn’t clearly deny) that 4.1 would be the end user release, and we knew that we were going to ship 4.1 as an update to Fedora 9 as soon as it became available. (...) Fedora 8 was still supported then, so nothing was forcing users to upgrade to Fedora 9 before 4.1. You only started talking about waiting for 4.2 weeks after Fedora 9′s release.

Blaming Fedora for your poor communication is ridiculous.
Rezza avatar 23.2.2012 09:45 Rezza | skóre: 25 | blog: rezza | Brno
Rozbalit Rozbalit vše Re: Komunikace upstream/downstream
Tak to bylo to prepisovani historie - nadsene 4.0 je skvele, distributujte a nakonec s kazdou verzi psal aseigo, ze to vlastne byla beta a ze to rikali od zacatku. Na druhou stranu - nebyt 4.0 v F9 (a ti co chteli 3.5 meli F8), tak 4.8 neni tam, kde je. Proste komunitni vyvoj je i o tom, ze se zapojuji i uzivatele. Jina vec byla, ze distribuovat 3.x a 4.x zaraz znamenalo hackovat (viz. ostatni distra, co to zkusila).

Založit nové vláknoNahoru


ISSN 1214-1267   Powered by Hosting 90 Server hosting
© 1999-2013 Argonit s. r. o. Všechna práva vyhrazena.