Portál AbcLinuxu, 23. ledna 2022 19:12




Dotaz: LVM na root oddíle v Debianu

22.12.2005 22:11 tomas84 | skóre: 30
LVM na root oddíle v Debianu
Přečteno: 155×
Odpovědět | Admin
Zdravíčko,

zhruba podle postupu Michala Číhaře jsem na novém disku vytvořil degradovaný RAID1.

/dev/md0 připojil jako nový /boot a na /dev/md1 vytvořil LVM s ostatnímy oddíly více méně podle howto.

Do /boot/grub/menu.lst na prvím disku - zatím bez RAIDu jsem přidal další zápis:
title           Novy-RAID
root            (hd1,0)
kernel          /vmlinuz-2.6.8-2-686 root=/dev/ram0 lvm2root=/dev/vg_base/root
initrd          /initrd.img-2.6.8-2-686
savedefault
boot
Po každé změně jsem spustil grub-install /dev/hda a hdc.

Zkoušel jsem různé kombinace parametrů (také jsem zkusil LILO), ale vždy se jako root připojil původní disk.

Zkusil jsem tedy disk s RAIDem připojit jako primární (v menu.lst jsem upravil root) a boot po chvíli zkončil na Kernel panic.

Napadá někoho kde dělám chybu? Je potřeba vytvářet speciální initrd image? Já používám jádro z distribuce - Debian Sarge.
Nástroje: Začni sledovat (1) ?Zašle upozornění na váš email při vložení nového komentáře.

Odpovědi

23.12.2005 09:42 tomas84 | skóre: 30
Rozbalit Rozbalit vše Re: LVM na RAID1 nechce bootovat
Odpovědět | | Sbalit | Link | Blokovat | Admin
Podíval jsem se do initrd od distribučního jádra a do initrd stroje, kde LVM běží na root oddíle a opravdu v distribučním initrd chybí podpora LVM.

Je nějaký jednoduchý způsob jak udělat ramdisk, obsahující původní - distribuční soubory i LVM?

Příkaz lvm2create_initrd totiš vytváří pouze ramdisk pro LVM a distribuční jádro s ním nenaběhne - je ve formátu ext2 a chybí tam veškeré moduly.

Nebo myslíte, že jednodušší bude skompilovat vlastní jádro?

Na internetu v souvislosti s LVM a initrd na Debianu jsem našel pouze zmínku v Linuxexpres, kde se píše tohle:

Debian GNU/Linux a jeho balíček initrd-tools, který stále využívá DevFS v initial ramdisku při kořenovém souborovém systému na LVM)

To by znamenalo, že někde ve skriptech/konfiguraci debianu musí přeci být nějaká možnost vytvořit initrd, který bude podporovat root na LVM... lvm2create_initrd totiš není Debianní skript - pouze je u lvm2 doc adresáři.

Opravdu s tím nemá nikdo zkušenost?
23.12.2005 15:43 Michal Čihař | skóre: 61 | blog: Bláboly | Praha
Rozbalit Rozbalit vše Re: LVM na RAID1 nechce bootovat
Odpovědět | | Sbalit | Link | Blokovat | Admin
Asi by to chtělo znovu vygenerovat initrd, nechce se mi vymýšlet přímo příkaz pro mkinitrd, ale dpgk-reconfigure kernel-image-2.6.8-2-686 by mělo zafungovat.
Weblate - překládání přes web | Gammu SMSD - posílání SMS | Blog
23.12.2005 18:04 tomas84 | skóre: 30
Rozbalit Rozbalit vše Re: LVM na RAID1 nechce bootovat
Díky za odpověď, ale bohužel dpkg-reconfigure nezabralo. Zkusil jsem ho i v chrootu do nového disku a také ne. V initrd vůbec není adresář /lib/lvm-200 a další, které se tam přidají při použití lvm2create_initrd.

Je nějaká možnost připsat to do konfigurace mkinitrd? To by ale asi taky nebylo jednoduché, protože v ramdisku vytvořeným lvm2create_initrd jsou některé programy (v podstatě celý /bin) nahrazeny utilitou busybox.

Už mi pomalu docházejí nápady:-(

Najde se tady někdo, komu funguje LVM na kořenovém oddíle s jádrem z Debianu Sarge?
23.12.2005 18:21 Michal Čihař | skóre: 61 | blog: Bláboly | Praha
Rozbalit Rozbalit vše Re: LVM na RAID1 nechce bootovat
Jo mě to fungovalo ... Teď už mám unstable s initramfs a yaird, takže se nemůžu podívat do nastavení, ale AFAIR jsem nic zvláštního nenastavoval.
23.12.2005 18:25 Michal Čihař | skóre: 61 | blog: Bláboly | Praha
Rozbalit Rozbalit vše Re: LVM na RAID1 nechce bootovat
Problém bude asi v tom, že mkinitrd zkoumá aktuální stav systému a podle něho vytváří initrd. Bohužel na tento příklad to nefunguje a bude potřeba mu to nějak vnutit.
23.12.2005 20:10 tomas84 | skóre: 30
Rozbalit Rozbalit vše Re: LVM na RAID1 nechce bootovat
Mno skompiloval jsem jádro a použil ramdisk vytvořený pomocí lvm2create_initrd a jede to. Takže zítra vyzkouším už na fungujícím LVM vytvořit ramdisk k distribučnímu jádru... přeci jen to distribuční bude asi více odladěděné:-)
24.12.2005 15:03 tomas84 | skóre: 30
Rozbalit Rozbalit vše Re: LVM na RAID1 nechce bootovat
Dnes na již funkčím LVM jsem zkusil znovu vytvořit initrd k distribučnímu jádru. Nyní se do něj opravdu přidaly všechny soubory potřebné pro LVM, ale jádro opět nenaběhne. Skončí na kernel panic. Při připojování LVM vypíše hlášku:
No program "vgchange" found for your current LVM version.
Přitom program vgchange v ramdisku je a mám nainstalované jenom LVM2, takže nechápu jaký jiný vgchange by tam měl být:-(

Nakonec tam asi nechám to vlastní jádro a bude.

Založit nové vláknoNahoru

Tiskni Sdílej: Linkuj Jaggni to Vybrali.sme.sk Google Del.icio.us Facebook

ISSN 1214-1267, (c) 1999-2007 Stickfish s.r.o.