Portál AbcLinuxu, 24. října 2021 19:41




Dotaz: arch JDK konflikt po upgrade

8.4.2007 18:19 mlp
arch JDK konflikt po upgrade
Přečteno: 133×
Odpovědět | Admin
Dobry den , nevim si rady, po upgrade systemu mam konflikt s javou: po aktualizaci repozitaru:
:: java-gcj-compat conflicts with jre. Remove jre?
kdyz potvrdim vymazat , vypise
error: this will break the following dependencies:  
jre: is required by swt
jre: is required by azureus
(nechci ale prijit o azureus). Jdk (6.2) jsem smazal (JRE smazat nejde) a pak ho znova nainstaloval , ale problem porad stejny, muzete mi dat ,prosim, cennou radu?
Nástroje: Začni sledovat (0) ?Zašle upozornění na váš email při vložení nového komentáře.

Odpovědi

kozzi avatar 8.4.2007 19:03 kozzi | skóre: 55 | blog: vse_o_vsem | Pacman (Bratrušov)
Rozbalit Rozbalit vše Re: arch JDK konflikt po upgrade
Odpovědět | | Sbalit | Link | Blokovat | Admin
nevim ale me to nedela a mam nainstalovano jre ale je pravda ze kdysi se mi stao neco podobneho proste si tam nech jre i jdk a to java-gcj-compat si neinstaluj. To udelas tak ze zadas pacman -Syu --ignore java-gcj-compat
Linux je jako mušketýři "jeden za všechny, všichni za jednoho"
kouby avatar 8.4.2007 21:47 kouby | skóre: 27 | blog: init | Praha
Rozbalit Rozbalit vše Re: arch JDK konflikt po upgrade
Odpovědět | | Sbalit | Link | Blokovat | Admin
No nevim tedy jak presne je to v archu reseno se zavislostmi, ale napriklad v Debianu staci pridat k baliku znacku, ze nahrazuje ten a ten balik. Pokud to arch nema, tak staci balicek jednoduse ignorovat jelikoz java-gcj-compat poskytuje v podstate totez co jre. Takze staci u pacmana pridat balik k ignoraci, bud v konfiguracnim souboru nebo primo.
That's thirty minutes away. I'll be there in ten.

Založit nové vláknoNahoru

Tiskni Sdílej: Linkuj Jaggni to Vybrali.sme.sk Google Del.icio.us Facebook

ISSN 1214-1267, (c) 1999-2007 Stickfish s.r.o.