Portál AbcLinuxu, 2. března 2021 03:15

Dotaz: Mounting devfs on /dev failed

15.4.2005 18:45 joey
Mounting devfs on /dev failed
Přečteno: 81×
Odpovědět | Admin
Nainstaloval jsem podle handbooku Gentoo, restartoval jsem a při "Mounting filesystems" se vyskytla chyba:

mount: Mounting devfs on /dev failed: No such device Error opening file: ".devfsd" No such file directory

dále následuje

>>Determining root device... >> Block device /dev/hda6 is not a valid root device... >> The root block device is unspecified or not detected

což, hádám, má nějakou souvislost s tím prvním :)

Instaloval jsem z universal cd, stage 3, genkernel. Linuxová partition je hda6. Z live cd přimountuju hda6 bez problémů.

Víte někdo co s tím?

Děkuji
Nástroje: Začni sledovat (0) ?Zašle upozornění na váš email při vložení nového komentáře.

Odpovědi

15.4.2005 19:56 Radek Podgorny | skóre: 16
Rozbalit Rozbalit vše Re: Mounting devfs on /dev failed
Odpovědět | | Sbalit | Link | Blokovat | Admin
No, hned ze zacatku uvedu, ze by sis usetril starosti, kdybys devfs nepouzival (stejne je obsolete) a zacal si hrad s udev.

Jinak k tvemu problemu, zkus vytvorit adresar /dev a v nem touchnout .devfsd

Pokud to nepomuze, prohlidni /etc/rc.conf a hlavne /etc/conf.d/rc a trochu si s tim pohraj...
http://podgorny.cz
15.4.2005 19:57 Radek Podgorny | skóre: 16
Rozbalit Rozbalit vše Re: Mounting devfs on /dev failed
hrad -> hrat :-)))

(taky si to po sobe v tom nahledu nectete?)
16.4.2005 11:56 joey
Rozbalit Rozbalit vše Re: Mounting devfs on /dev failed
Odpovědět | | Sbalit | Link | Blokovat | Admin

Adresář /dev tam již je. když jsem udělal touch, tak se nic nestalo (zase o jeden příkaz víc, co jsem se naučil :) ).

Zkoušel jsem se dívat do těch rc.conf a rc, ale nic jsem tam nenašel, kromě RC_DEVFSD_STARTUP, což jsem zkusil nastavit na "no", ale nic se nestalo :( . Jsem v linuxu něco jako batole, asi jsem si dal laťku tentokrát příliš vysoko :).

Jinak, já bych si rád ušetřil starosti....ale o udev nebo devfsd nemám vlastně ani moc páru, prostě jsem instaloval podle návodu, tu nejjednodušší možnou instalaci :) (což samozřejmě nebrání tomu, abych si o tom něo přečetl :) ).
16.4.2005 16:22 jm
Rozbalit Rozbalit vše Re: Mounting devfs on /dev failed
Odpovědět | | Sbalit | Link | Blokovat | Admin
Gentoo defaultne pouziva udev. Pokud jsi zakompiloval devfs do jadra a navic zaskrtnul, aby se automaticky mountoval pri bootu, tak si znova precti handbook a oprav to. Taky necpi devfs do /etc/fstab.
16.4.2005 19:41 joey
Rozbalit Rozbalit vše Re: Mounting devfs on /dev failed
Odpovědět | | Sbalit | Link | Blokovat | Admin

Díky za odpovědi :)

Prošel jsem si znovu handbook, a přesně jsem nastavil všechny věci, překompiloval jádro, tentokrát už manuálně, bez použití genkernelu a ejhle, už to funguje a dokonce s udev :)

Ještě jednou dík za tipy.Ještě mě čeká hodně práce, zatím fungují jenom X-ka ;)

Založit nové vláknoNahoru

Tiskni Sdílej: Linkuj Jaggni to Vybrali.sme.sk Google Del.icio.us Facebook

ISSN 1214-1267, (c) 1999-2007 Stickfish s.r.o.