Portál AbcLinuxu, 20. ledna 2021 11:01

Dotaz: GCC - závislosti při instalaci GCC na Debianu

1.9.2005 12:32 Martin-22
GCC - závislosti při instalaci GCC na Debianu
Přečteno: 82×
Odpovědět | Admin
Ahoj, nedari se mi nainstalovat gcc

tohle mi pise
apt-get -o Debug::pkgProblemResolver=yesinstall gcc

Reading Package Lists... Done
Building Dependency Tree... Done
Starting
Starting 2
Investigating cpp-3.3
Package cpp-3.3 has broken dep on gcc-3.3-base
  Considering gcc-3.3-base 29 as a solution to cpp-3.3 12
  Holding Back cpp-3.3 rather than change gcc-3.3-base
Investigating gcc-3.3
Package gcc-3.3 has broken dep on cpp-3.3
  Considering cpp-3.3 12 as a solution to gcc-3.3 3
  Holding Back gcc-3.3 rather than change cpp-3.3
Investigating cpp
Package cpp has broken dep on cpp-3.3
  Considering cpp-3.3 12 as a solution to cpp 3
  Holding Back cpp rather than change cpp-3.3
Investigating gcc
Package gcc has broken dep on cpp
  Considering cpp 3 as a solution to gcc 10001
    Reinst Failed early because of gcc-3.3-base
    Reinst Failed because of cpp-3.3
Package gcc has broken dep on gcc-3.3
  Considering gcc-3.3 3 as a solution to gcc 10001
    Reinst Failed because of cpp-3.3
Package gcc has broken dep on cpp-3.3
  Considering cpp-3.3 12 as a solution to gcc 10001
Done

Some packages could not be installed. This may mean that
 you have requested an impossible situation or if you are
 using the unstable distribution that some required
 packages have not yet been created or been moved out of
 Incoming.

Since you only requested a single operation it is
 extremely likely that the package is simply not
 installable and a bug report against that package should
 be filed. The following information may help to resolve
 the situation:

The following packages have unmet dependencies:
  gcc: Depends: cpp (>= 4:3.3.5-3) but it is not going to be installed
       Depends: gcc-3.3 (>= 1:3.3.5-1) but it is not going to be installed
       Depends: cpp-3.3 (>= 1:3.3.5-1) but it is not going to be installed
E: Broken packages
Nástroje: Začni sledovat (0) ?Zašle upozornění na váš email při vložení nového komentáře.

Odpovědi

1.9.2005 13:45 trekker.dk | skóre: 71
Rozbalit Rozbalit vše Re: GCC
Odpovědět | | Sbalit | Link | Blokovat | Admin
Zkus instalovat některý z těch tří balíčků (cpp, gcc-3.3, cpp-3.3), mohl by ses dozvědět, proč se nebudou instalovat
Quando omni flunkus moritati
1.9.2005 20:00 Martin-22
Rozbalit Rozbalit vše Re: GCC
Odpovědět | | Sbalit | Link | Blokovat | Admin
Uz jsem to vyresil. Diky
2.9.2005 00:13 trekker.dk | skóre: 71
Rozbalit Rozbalit vše Re: GCC
Možná by se hodilo říct jak. Přece jenom tuhle diskuzi může najít někdo se stejným problémem a ušetří se jeden dotaz ;-)
Quando omni flunkus moritati

Založit nové vláknoNahoru

Tiskni Sdílej: Linkuj Jaggni to Vybrali.sme.sk Google Del.icio.us Facebook

ISSN 1214-1267, (c) 1999-2007 Stickfish s.r.o.