Portál AbcLinuxu, 2. duben 2020 05:58


www.AutoDoc.Cz

Dotaz: poradit s phpmyadmin installace v debian10 php7.3

2.2. 16:44 xabrhamm | skóre: 2
poradit s phpmyadmin installace v debian10 php7.3
Přečteno: 468×
Odpovědět | Admin
Ahojte

po installaci phpmyadmin ktera zdanlive probehla zcela uspesne, po zadani . http:localhost/phpmyadmin

se ukaze tohle:

get(Response::class); /** @var DatabaseInterface $dbi */ $dbi = $containerBuilder->get(DatabaseInterface::class); /** @var HomeController $controller */ $controller = $containerBuilder->get(HomeController::class); if (isset($_REQUEST['ajax_request']) && ! empty($_REQUEST['access_time'])) { exit; } if (isset($_POST['set_theme'])) { $controller->setTheme([ 'set_theme' => $_POST['set_theme'], ]); header('Location: index.php' . Url::getCommonRaw()); } elseif (isset($_POST['collation_connection'])) { $controller->setCollationConnection([ 'collation_connection' => $_POST['collation_connection'], ]); header('Location: index.php' . Url::getCommonRaw()); } elseif (! empty($_REQUEST['db'])) { // See FAQ 1.34 $page = null; if (! empty($_REQUEST['table'])) { $page = Util::getScriptNameForOption( $GLOBALS['cfg']['DefaultTabTable'], 'table' ); } else { $page = Util::getScriptNameForOption( $GLOBALS['cfg']['DefaultTabDatabase'], 'database' ); } include ROOT_PATH . $page; } elseif ($response->isAjax() && ! empty($_REQUEST['recent_table'])) { $response->addJSON($controller->reloadRecentTablesList()); } elseif ($GLOBALS['PMA_Config']->isGitRevision() && isset($_REQUEST['git_revision']) && $response->isAjax() ) { $response->addHTML($controller->gitRevision()); } else { // Handles some variables that may have been sent by the calling script $GLOBALS['db'] = ''; $GLOBALS['table'] = ''; $show_query = '1'; if ($server > 0) { include ROOT_PATH . 'libraries/server_common.inc.php'; } $response->addHTML($controller->index()); }

co to znamena? co s tim?

dekuji
Nástroje: Začni sledovat (0) ?Zašle upozornění na váš email při vložení nového komentáře.

Odpovědi

2.2. 17:14 NN
Rozbalit Rozbalit vše Re: poradit s phpmyadmin installace v debian10 php7.3
Odpovědět | | Sbalit | Link | Blokovat | Admin
To znamena, ze HTTP server neinterpretuje PHP kod, ale zobrazuje plaintext. Bud nema zavedeny/ povoleny patricny modul, nebo neni instalovane PHP vubec.
2.2. 18:34 xabrhamm | skóre: 2
Rozbalit Rozbalit vše Re: poradit s phpmyadmin installace v debian10 php7.3
php 7.3 je nainstalovane a bezi
2.2. 19:06 Peter Golis | skóre: 60 | blog: Bežné záležitosti | Bratislava
Rozbalit Rozbalit vše Re: poradit s phpmyadmin installace v debian10 php7.3
A ten web server (asi apache) už bol reštartovaný?
3.2. 11:42 alkoholik | skóre: 38 | blog: Alkoholik
Rozbalit Rozbalit vše Re: poradit s phpmyadmin installace v debian10 php7.3
Potrebujes nainstalovany a zapnuty modul pro Apache:
apt install libapache2-mod-php7.3
a2enmod libapache2-mod-php7.3
systemctl restart apache2
Pripadne nastavit short_open_tag = On v /etc/php/7.3/apache2/php.ini
3.2. 11:43 alkoholik | skóre: 38 | blog: Alkoholik
Rozbalit Rozbalit vše Re: poradit s phpmyadmin installace v debian10 php7.3
Sorry, je to jenom a2enmod php7.3
6.2. 11:55 xabrhamm | skóre: 2
Rozbalit Rozbalit vše Re: poradit s phpmyadmin installace v debian10 php7.3
Odpovědět | | Sbalit | Link | Blokovat | Admin
Asi jsem na to prisel.

Phpmyadmin od verse 4.9.0.1 neni s php7.3 kompatibilni

verse 4.9.0 s php7.3 mi funguje, phpmyadmin 4.9.0.1 uz jen s php7.4. phpmyadmin stable je momentalne verse 5.0.1

pouzivam nextcloud a ten s php7.4 take kompatibilni neni.

Takze PHP7.3 only.

7.2. 23:33 alkoholik | skóre: 38 | blog: Alkoholik
Rozbalit Rozbalit vše Re: poradit s phpmyadmin installace v debian10 php7.3
Podle Release Notes neprisel.
Older version compatible with PHP 5.5 to 7.4

Založit nové vláknoNahoru

Tiskni Sdílej: Linkuj Jaggni to Vybrali.sme.sk Google Del.icio.us Facebook

ISSN 1214-1267, (c) 1999-2007 Stickfish s.r.o.