Portál AbcLinuxu, 11. května 2021 22:55


Dotaz: Problem s routingem v RC3

6.2.2005 22:49 Jan Horak
Problem s routingem v RC3
Přečteno: 25×
Odpovědět | Admin
Zdar borci, mam problem se kterym si uz vazne nevim rady :-(

Mam v kompu dve sitovky a RC3. Jedna integrovana gigabitova Intel, druha pridana Realtek, ale zkousena i 3COMka. eth0 s pevnou IP nemuze delat vubec nic, ani ve vlastnim subnetu nevidi ani jedno PC okolo.

Takze jsem provedl nekolik testu s temito vysledky: Pokud je eth1 nahore, vse slape. Ma adresu 192.168.1.2, masku 255.255.255.0 a gateway 192.168.1.1 - vse slape... Vyndam z ni kabel, pripichnu to do eth0, vypnu eth1, zapnu eth0 a nastavim IP 192.168.1.2, maska 255.255.255.0, gateway 192.168.1.1 - NEJEDE... :-( Oba dva adaptery maji stejne nastaveni, stejne adresy, stejny subnet, stejnou gateway. Jedna jede, druha ne. ping na 192.168.1.1 = Destination Host Unreachable na switchi mi normalne sviti... ( mam-li sitovku v jinem kompu, jede vse jak ma )

pokud vypisu "route -n" tak kdyz je nahore eth1, vypada takto:
[root@router ~]# route -n
Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
192.168.1.0     0.0.0.0         255.255.255.0   U     0      0        0 eth1
169.254.0.0     0.0.0.0         255.255.0.0     U     0      0        0 eth1
0.0.0.0         192.168.1.1     0.0.0.0         UG    0      0        0 eth1
a kdyz vypnu eth1, prendam kabel do eth0 a zapnu ji, tak opet uplne stejnej vypis "route -n"... dokonale stejnej... uplne presne stejnej.. a presto mi ta sitovka na gateway nepingne a ani nikam jinam. sama na sebe ano, ale to mi je prdu :-)

Vyzkousel jsem uz tri sitovky, vsechno marny... ve Winech slapou jak vino, ale dam-li je sem, je to v kyblu... vzdycky stejnej problem.

Myslel jsem si, ze o sitich, routovani a chovani paketu neco vim... ale tohle mi neleze na mozek. Oba dva adaptery maji totozne nastaveni, ale slape jen jeden. a ten vadnej muze bejt treba se zlatejma konektorama ( rozumej vymenil jsem misto toho uz tri sitovky ) a stejne porad stejny. A doplnim, ze zadnej firewall mi tam nebezi.

Poradite ?
Nástroje: Začni sledovat (1) ?Zašle upozornění na váš email při vložení nového komentáře.

Odpovědi

6.2.2005 23:50 Petr Šobáň | skóre: 80 | blog: soban | Olomouc
Rozbalit Rozbalit vše Re: Problem s routingem v RC3
Odpovědět | | Sbalit | Link | Blokovat | Admin
No a restartoval jsi síť ?

Nemá ta síťovka nějak blbě nastavený parametry tj neprovozuješ ji na něčem co druhá strana neumí atd....10M/100M half-full atd.....

A resetls ten switch na té druhé straně ? On si zapamatoval že IP patří sítovce s mac adresou xxxx a ty jsi mu ji změnil na yyyy protože jsi tam píchnul jinou sítovku.

Založit nové vláknoNahoru

Tiskni Sdílej: Linkuj Jaggni to Vybrali.sme.sk Google Del.icio.us Facebook

ISSN 1214-1267, (c) 1999-2007 Stickfish s.r.o.