abclinuxu.cz AbcLinuxu.cz itbiz.cz ITBiz.cz HDmag.cz HDmag.cz abcprace.cz AbcPráce.cz
AbcLinuxu hledá autory!
Inzerujte na AbcPráce.cz od 950 Kč
Rozšířené hledání
×
    dnes 02:16 | Bezpečnostní upozornění

    Zranitelnost CVE-2026-98432 s CVSS 9.8 odhalila AI od společnosti Anthropic. Jedná se o kritickou chybu v implementaci MPTCP (multipath TCP). Debian vydal patche 16.10. a 22.10., ale např. Ubuntu je zatím bez opravy. Více informací na The Hacker News.

    Max | Komentářů: 1
    včera 23:22 | Zajímavý software

    Na Slovensku vznikla úplne nová rally hra, ktorá je zadarmo a funguje vo Windowse, Linuxe či na Macu. Greenie Rally má viac ako 50 tratí a vozidiel, šampionáty či turnaje. Má retro feeling a imituje automobilové hry z prelomu tisícročí. Vyskúšate prejsť všetky mapy na Škode 130RS?

    Stanislav Hoferek | Komentářů: 1
    včera 14:33 | Komunita

    Do základního systému NetBSD -current byl přidán nový editor atto jako alternativa k editorům vi a xedit.

    Ladislav Hagara | Komentářů: 2
    včera 14:11 | IT novinky

    Společnost System76 představila kompaktní 11litrový Thelio Prime Desktop. S procesorem AMD Ryzen 9000. S Pop!_OS 24.04 LTS s desktopovým prostředím COSMIC nebo Ubuntu 24.04 LTS.

    Ladislav Hagara | Komentářů: 1
    včera 13:44 | Humor

    Čínská státní televize pozastavila vysílání španělské La Ligy a čínské internetové platformy omezily obsah s Kylianem Mbappém poté, co slavný fotbalista ve francouzském pořadu The Bridge mluvil o svém oblíbeném memu, v němž je jeho tvář vložena do portrétu zobrazujícího diktátora Mao Ce-tunga. 'Můj oblíbený mem je ten, na kterém dali můj obličej na čínského diktátora. To mě opravdu rozesmívá. S přáteli ho používám pořád' řekl,

    … více »
    Pendrekama do nich❗ | Komentářů: 5
    včera 13:22 | IT novinky

    Při příležitosti oslav Dne vzniku samostatného československého státu (28. října) byly uděleny medaile Za zásluhy tvůrci aplikace Záchranka Filipu Maleňákovi, vědci v oblasti umělé inteligence Tomáši Mikolovovi a Olze Štěpánkové, vědkyni zabývající se kybernetikou, robotikou a strojovým učením, průkopnici v oblastech výuky a využití umělé inteligence v medicínském inženýrství.

    Pendrekama do nich❗ | Komentářů: 3
    včera 01:33 | IT novinky

    Apple představil nový iPad mini, iMac s čipem M6, 14palcový MacBook Pro s čipem M6 a MacBook Pro s PROLED XDR displejem – první Mac s dotykovým ovládáním.

    Ladislav Hagara | Komentářů: 5
    28.10. 23:22 | Zajímavý projekt

    Nedávno představený projekt mapSTL.com řeší budoucnost. 𝕏: "Netušil jsem, kolik patentů na generování map existuje. Existují patenty na generování fantasy map 🫣. Cokoliv je na 3D tiskárnu a tvoří to produkt, bude to mít patenty. Tak bacha na to!" … více »

    Ladislav Hagara | Komentářů: 3
    28.10. 18:55 | Nová verze

    Multiplatformní emulátor terminálu Ghostty byl vydán ve verzi 1.4 (𝕏). Přehled novinek a vylepšení v poznámkách k vydání.

    Ladislav Hagara | Komentářů: 0
    28.10. 18:22 | Bezpečnostní upozornění

    Byla objevena zranitelnost Tailworm v Tailscale a Headscale umožňující lokální eskalaci práv přihlášeného uživatele. Následně byla v Tailscale v opravené verzi 1.104.4+ změněna architektura aplikace. Viz příspěvek na blogu Tailscale.

    vencour | Komentářů: 0
    Které desktopové prostředí na Linuxu používáte?
     (9%)
     (7%)
     (4%)
     (20%)
     (30%)
     (9%)
     (5%)
     (2%)
     (14%)
     (20%)
    Celkem 2941 hlasů
     Komentářů: 34, poslední 26.10. 08:24
    Rozcestník

    Jaderné noviny 202

    3. 2. 2003 | Leoš Literák | Jaderné noviny | 3121×

    Status řady 2.5 - dočkáme se řady 2.6? Bezpečná autentizace pro NFS. TTY nemá správce. Kompilace kernelu ne-gcc překladačem.

    Do konference přišlo celkem 2320 emailů, nejvíce jich poslali "Martin J. Bligh", William Lee Irwin III, Andrew Morton.

    Status řady 2.5, 202 e-mailů

    William Lee Irwin III si myslel, že řada 2.5 si vede dobře, takže nastal čas přeřadit na vyšší otáčky a vykopnout řadu 2.6 ven. Zeptal se, které problémy zdržují tento proces. Dave Jones odpověděl, že je zde plno modulů, které nejdou zkompilovat, tuny neportovaného kódu od jádra 2.4.18 a spousty triviálních patchů, které se zratily cestou. Podle něj jsme od jádra '2.6-test' velmi vzdáleni, ale přechod na tvrdší zmražení kódu by byl dobrý nápad. Alan Cox napsal vlastní seznam:

    IDE stále není v pořádku a oprava bude trvat aspoň tři měsíce, než vůbec můžeme začít s vylepšováním. Celé zamykání TTY je kompletně špatné a nikdo se ani nepokusil začít s jeho opravou. Prostě vyzkoušejte masivní paralelní aktivitu na tty/pty. Problémy byly už před tím, ale pre-empt jej zničil a pohřbil. Většina ovladačů není možné ani zkompilovat.

    Podle mně je důležité dostat se do stavu, kdy můžeme říci:

    • je možné jej zkompilovat
    • funguje to (aspoň v hlavních aspektech)
    • je nepravděpodobná ztáta dat
    • jede na jednoprocesorovém a SMP počítači s i bez pre-empt

    Jinak si všichni budou myslet, že ".0-pre" znamená ".0 jako ve Windows", což by znamenalo ztrátu základny testerů.

    Když vezmeme v úvahu, že nové věci je nutné začlenit, měl by Linus dostat dovnitř opravy z řady 2.4 a opravy chyb při kompilaci modulů a pokud by to nepomohlo, měl by být vyřazen.

    Prosím, už žádné přepisy "ISAPnP TNG" a modulů

    Ohledně posledního bodu panoval obecný souhlas a Jochen Friedrich přidal, že framebuffer je také smetí, stejně jako ISDN a (trochu méně) USB.

    Bezpečná autentizace pro NFS, 9 e-mailů

    Trond Myklebust implementoval části RFC 2203 a oznámil:

    Následujících šest patchů implementuje podporu bezpečnostního protokolu RPCSEC_GSS (pouze autentifikace) a bezpečnostního mechanismu Kerberos V5.

    RPCSEC_GSS je bezpečnostní mechanismus vyžadovaný pro všechny implementace NFSv4. Poskytuje protokol pro bezpečné přihlášení a přenos dat na bázi pro jednotlivé uživatele. Funguje takovým způsobem, že nezávisí na aktuálně použitém bezpečnostním mechanismu, ale podporuje jich širokou řadu. Mechanismy požadované RFC 3010 pro NFSv4 jsou Kerberos V5 (viz RFC 1964), SPKM-3 (RFC2025) a LIPKEY (RFC2847).

    Naší snahou je poskytnout základní kernelovou RPC klientskou podporu pro RPCSEC_GSS protokol a pro komunikaci s démonem, který provádí vlastní výměnu bezpečnostního kontextu s RPC serverem. Komunikace mezi kernelem a uživatelským prostorem se uskutečňuje skrze skupinu pojmenovaných rour [named pipe] v soukromém souborovém systému podobném ramfs.

    Dax Kelson odpověděl:

    Jako uživatel a administrátor jsem na toto čekal po DLOUHOU dobu. Standardní bezpečnost/autentizace NFS stojí za starou belu [sucks]. Bez této podpory NFS servery s domovskými adresáři jen čekají na vyloupení ze strany škodolibého (nebo kompromitovaného) roota na klientském počítači.

    NFSv4 s RPSEC_GSS je konečně nativní unixovské řešení sdílení souborů, za které se nestydím při konverzaci s administrátory těch ostatních operačních systémů.

    Paul Jakma poznamenal, že root z klienta může stále vyloupit server, ale Dax Kelson vysvětlil, že zlý root může s RPSEC_GSS přistupovat / měnit / mazat soubory na serveru jen uživatelům, kteří jsou na klientovi přihlášeni. Takže dobrým zvykem by mělo být odstranění cachovaných osobních údajů [credentials] při odhlášení. Trond však napsal, že pokud byl root kompromitován, hra skončila, takže je zbytečné se bát, co by mohl provést. Bezpečnostní model RPSEC_GSS není míněn jako ochrana před rootem, ale jako ochrana před třetí stranou podhazující RPC požadavky vašim jménem (silná autentifikace), poškozování či úpravě platných RPC požadavků (kryptografická kontrola integrity dat) nebo odposloucháváním komunikace mezi serverem a klientem (soukromí dat).

    TTY nemá správce, 1 e-mail

    Russell King zjevně dostával příliš hodně emailů týkajících se TTY a měl toho dost. Vysvětlil:

    Rád bych vyjasnil následující bod:

    Nejsem, opakuji nejsem správce TTY subsystému. Mám příliš mnoho jiných povinnosti na to, abych se jim stal.

    Nicméně, čas od času si prohlédnu patche z TTY vrstvy a poskytnu (doufám že) užitečný názor. Patche si však budu vybírat sám a bude to záležet na tom, čeho se týkají, jak jsou komplexní a jak moc jsem zaneprázdněn.

    A pro úplnost, neposílejte mi žádné záplaty pro TTY.

    Kompilace kernelu ne-gcc překladačem, 7 e-mailů

    Henrik Andersen se zeptal, zda je možné zkompilovat jádro překladačem C++ od Intelu. John Bradford o tom pochyboval, neboť Linux výrazně používá rozšíření GCC. Nicméně Jeff Garzik napsal, že zmíněný překladač funguje pěkně na jádru. Jun Nakajima to potvrdil. Ville Herva dodal, že Intel se snaží o maximální kompatibilitu s gcc.

           

    Hodnocení: 33 %

            špatné • dobré        

    Nástroje: Tisk bez diskuse

    Tiskni Sdílej: Linkuj Jaggni to Vybrali.sme.sk Google Del.icio.us Facebook

    Komentáře

    Vložit další komentář

    ISSN 1214-1267   www.czech-server.cz
    © 1999-2015 Nitemedia s. r. o. Všechna práva vyhrazena.