abclinuxu.cz AbcLinuxu.cz itbiz.cz ITBiz.cz HDmag.cz HDmag.cz abcprace.cz AbcPráce.cz
AbcLinuxu hledá autory!
Inzerujte na AbcPráce.cz od 950 Kč
Rozšířené hledání
×
dnes 01:00 | Nová verze

Známý šifrovaný komunikátor Signal od verze 3.30.0 již nevyžaduje Google Play Services. Autoři tak po letech vyslyšeli volání komunity, která dala vzniknout Google-free forku LibreSignal (dnes již neudržovaný). Oficiální binárky jsou stále distribuované pouze přes Google Play, ale lze použít neoficiální F-Droid repozitář fdroid.eutopia.cz s nezávislými buildy Signalu nebo oficiální binárku stáhnout z Google Play i bez Google účtu

… více »
xm | Komentářů: 1
včera 23:14 | Nová verze

Po třech týdnech od vydání první RC verze byla vydána první stabilní verze 17.01.0 linuxové distribuce pro routery a vestavěné systémy LEDE (Linux Embedded Development Environment), forku linuxové distribuce OpenWrt. Přehled novinek v poznámkách k vydání. Dotazy v diskusním fóru.

Ladislav Hagara | Komentářů: 2
včera 17:28 | Bezpečnostní upozornění

Byly zveřejněny informace o bezpečnostní chybě CVE-2017-6074 v Linuxu zneužitelné k lokální eskalaci práv. Jde o chybu v podpoře DCCP (Datagram Congestion Control Protocol). Do linuxového jádra se dostala v říjnu 2005. V upstreamu byla opravena 17. února (commit). Bezpečnostní chyba byla nalezena pomocí nástroje syzkaller [Hacker News].

Ladislav Hagara | Komentářů: 2
včera 15:00 | Zajímavý software

Společnost Valve vydala novou beta verzi SteamVR. Z novinek lze zdůraznit oficiální podporu Linuxu. Další informace o podpoře této platformy pro vývoj virtuální reality v Linuxu v diskusním fóru. Hlášení chyb na GitHubu.

Ladislav Hagara | Komentářů: 0
včera 06:00 | Nová verze

Po necelém roce od vydání verze 0.67 byla vydána verze 0.68 populárního telnet a ssh klienta PuTTY. Podrobnosti v přehledu změn. Řešeny jsou také bezpečnostní chyby.

Ladislav Hagara | Komentářů: 0
21.2. 21:32 | Nasazení Linuxu

Canonical představuje nejnovější verzi chytré helmy DAQRI s Ubuntu pro rozšířenou realitu. K vidění bude příští týden v Barceloně na veletrhu Mobile World Congress 2017.

Ladislav Hagara | Komentářů: 0
21.2. 21:31 | Pozvánky

Pro zájemce o hlubší znalosti fungování operačních systémů připravila MFF UK nový předmět Pokročilé operační systémy, v rámci něhož se vystřídají přednášející nejen z řad pracovníků fakulty, ale dorazí také odborníci ze společností AVAST, Oracle, Red Hat a SUSE. Tento předmět volně navazuje na kurz Operační systémy ze zimního semestru, ale pokud máte praktické zkušenosti odjinud (například z přispívání do jádra Linuxu) a chcete si

… více »
Martin Děcký | Komentářů: 6
21.2. 21:30 | Pozvánky

Czech JBoss User Group Vás srdečně zve na setkání JBUG v Brně, které se koná ve středu 1. března 2017 v prostorách Fakulty Informatiky Masarykovy Univerzity v místnosti A318 od 18:00. Přednáší Tomáš Remeš a Matěj Novotný na téma CDI 2.0 - New and Noteworthy. Více informací na Facebooku a na Twitteru #jbugcz.

mjedlick | Komentářů: 0
20.2. 23:45 | Zajímavý software

Na blogu Qt bylo představeno Qt 3D Studio. Jedná se o produkt dosud známý pod názvem NVIDIA DRIVE™ Design Studio. NVIDIA jej věnovala Qt. Jedná se o několik set tisíc řádků zdrojového kódu. Qt 3D Studio bude stejně jako Qt k dispozici jak pod open source, tak pod komerční licencí. Ukázka práce s Qt 3D Studiem na YouTube.

Ladislav Hagara | Komentářů: 10
20.2. 17:50 | Komunita

Nadace The Document Foundation (TDF) zastřešující vývoj svobodného kancelářského balíku LibreOffice slaví 5 let od svého oficiálního vzniku. Nadace byla představena 28. září 2010. Formálně byla založena ale až 17. února 2012.

Ladislav Hagara | Komentářů: 0
Jak se stavíte k trendu ztenčování přenosných zařízení (smartphony, notebooky)?
 (13%)
 (2%)
 (71%)
 (3%)
 (10%)
Celkem 686 hlasů
 Komentářů: 66, poslední včera 18:57
    Rozcestník

    Dotaz: SVN - library version mismatch

    16.4.2010 14:13 Kamil Hruska
    SVN - library version mismatch
    Přečteno: 309×
    Dobry den,

    nedavno jsem na svem systemu updatoval balicky openssl a heimdal a dnes jsem zjistil, ze svn mi pri pokusu o jakoukoliv aktualizaci pres https pise toto:
    $ svn up
    svn: OPTIONS of 'https://svn.sqlmap.org/sqlmap/trunk/sqlmap': SSL negotiation failed: SSL disabled due to library version mismatch (https://svn.sqlmap.org)
    
    verze pouzitych knihoven jsou videt zde:
    $ ldd /usr/bin/svn
            linux-gate.so.1 =>  (0xb7f7c000)
            /usr/lib/libtrash.so.3.2 (0xb7f72000)
            libsvn_client-1.so.0 => /usr/lib/libsvn_client-1.so.0 (0xb7f32000)
            libsvn_wc-1.so.0 => /usr/lib/libsvn_wc-1.so.0 (0xb7eef000)
            libsvn_ra-1.so.0 => /usr/lib/libsvn_ra-1.so.0 (0xb7ee7000)
            libsvn_diff-1.so.0 => /usr/lib/libsvn_diff-1.so.0 (0xb7edc000)
            libsvn_delta-1.so.0 => /usr/lib/libsvn_delta-1.so.0 (0xb7ed1000)
            libsvn_subr-1.so.0 => /usr/lib/libsvn_subr-1.so.0 (0xb7e8b000)
            libapr-1.so.0 => /usr/lib/libapr-1.so.0 (0xb7e66000)
            libpthread.so.0 => /lib/libpthread.so.0 (0xb7e27000)
            libc.so.6 => /lib/libc.so.6 (0xb7ce1000)
            libdl.so.2 => /lib/libdl.so.2 (0xb7cdd000)
            libaprutil-1.so.0 => /usr/lib/libaprutil-1.so.0 (0xb7cbe000)
            libldap-2.4.so.2 => /usr/lib/libldap-2.4.so.2 (0xb7c81000)
            liblber-2.4.so.2 => /usr/lib/liblber-2.4.so.2 (0xb7c75000)
            libdb-4.8.so => /usr/lib/libdb-4.8.so (0xb7b15000)
            libgdbm.so.3 => /usr/lib/libgdbm.so.3 (0xb7b0f000)
            libexpat.so.1 => /usr/lib/libexpat.so.1 (0xb7ae8000)
            libuuid.so.1 => /lib/libuuid.so.1 (0xb7ae4000)
            librt.so.1 => /lib/librt.so.1 (0xb7adb000)
            libcrypt.so.1 => /lib/libcrypt.so.1 (0xb7aa9000)
            libsvn_ra_local-1.so.0 => /usr/lib/libsvn_ra_local-1.so.0 (0xb7aa2000)
            libsvn_repos-1.so.0 => /usr/lib/libsvn_repos-1.so.0 (0xb7a7b000)
            libsvn_fs-1.so.0 => /usr/lib/libsvn_fs-1.so.0 (0xb7a75000)
            libsvn_ra_svn-1.so.0 => /usr/lib/libsvn_ra_svn-1.so.0 (0xb7a61000)
            libsvn_ra_neon-1.so.0 => /usr/lib/libsvn_ra_neon-1.so.0 (0xb7a41000)
            libz.so.1 => /usr/lib/libz.so.1 (0xb7a2d000)
            libsqlite3.so.0 => /usr/lib/libsqlite3.so.0 (0xb79b4000)
            /lib/ld-linux.so.2 (0xb7f7d000)
            libresolv.so.2 => /lib/libresolv.so.2 (0xb79a0000)
            libsasl2.so.2 => /usr/lib/libsasl2.so.2 (0xb7989000)
            libssl.so.0.9.8 => /usr/lib/libssl.so.0.9.8 (0xb7938000)
            libcrypto.so.0.9.8 => /usr/lib/libcrypto.so.0.9.8 (0xb77bc000)
            libsvn_fs_fs-1.so.0 => /usr/lib/libsvn_fs_fs-1.so.0 (0xb7797000)
            libsvn_fs_base-1.so.0 => /usr/lib/libsvn_fs_base-1.so.0 (0xb776d000)
            libsvn_fs_util-1.so.0 => /usr/lib/libsvn_fs_util-1.so.0 (0xb776b000)
            libneon.so.27 => /usr/lib/libneon.so.27 (0xb774b000)
            libgssapi.so.2 => /usr/lib/libgssapi.so.2 (0xb771c000)
            libheimntlm.so.0 => /usr/lib/libheimntlm.so.0 (0xb7717000)
            libkrb5.so.26 => /usr/lib/libkrb5.so.26 (0xb76ae000)
            libhx509.so.5 => /usr/lib/libhx509.so.5 (0xb7672000)
            libcom_err.so.2 => /lib/libcom_err.so.2 (0xb766f000)
            libasn1.so.8 => /usr/lib/libasn1.so.8 (0xb75eb000)
            libwind.so.0 => /usr/lib/libwind.so.0 (0xb75c2000)
            libroken.so.18 => /usr/lib/libroken.so.18 (0xb75b0000)
    
    Verzi svn mam tuto:
    $ svn --version
    svn, version 1.6.9 (r901367)
       compiled Apr 11 2010, 16:01:01
    ...
    
    Problem je, ze program nenapise kterou knihovnu presne ma na mysli. Muzete mi prosim poradit co s tim?

    Odpovědi

    16.4.2010 14:26 Zdenek 'Mst. Spider' Sedlak | skóre: 37 | blog: xMstSpider
    Rozbalit Rozbalit vše Re: SVN - library version mismatch
    Podle the hlasky pouziva SVN nekompatibilni SSL knihovnu. Zkus upgradovat SVN (nevim, co mas za system, takze bud balik nebo kompilace)
    16.4.2010 14:33 Kamil Hruska
    Rozbalit Rozbalit vše Re: SVN - library version mismatch
    Jeste bych pripal upresneni. SVN mi nejdriv hazelo tuto hlasku:
    $ svn up
    svn: error while loading shared libraries: libkrb5.so.25: cannot open shared object file: No such file or directory
    
    tak coz jsem vyresil takto:
    cd /usr/lib/
    sudo ln -s libkrb5.so libkrb5.so.25
    
    po dalsi zkousce svn up jsem dostal toto:
    $ svn up
    svn: error while loading shared libraries: libhx509.so.4: cannot open shared object file: No such file or directory
    
    Tak jsem to tedy znovu vyresil takto:
    cd /usr/lib/
    sudo ln -s libhx509.so libhx509.so.4
    
    a az pote mi to zacalo hazet to co jsem psal v prnim prispevku.

    Kdyz se podivam na vypis ldd, tak tam je uvedeno, ze binarka svn pouziva
    libkrb5.so.26 => /usr/lib/libkrb5.so.26 (0xb76ae000)
    
    Proc si tedy hned na zacatku stezoval ze nemuze otevrit libkrb5.so.25?

    Potreboval bych to co nejrychleji vyresit, budu vdecny za jakekoliv rady.

    PS: Jedna se o Arch Linux (avsak uz asi pul roku jsem neudelal Pacman -Syu, updatuju pouze balicky, ktere updatovat potrebuji.)
    16.4.2010 14:49 Zdenek 'Mst. Spider' Sedlak | skóre: 37 | blog: xMstSpider
    Rozbalit Rozbalit vše Re: SVN - library version mismatch
    SVN je linkovana ocividne proti novejsi verzi libkrb5 a libx509, symbolicky link je sazka, ktera nemusi vyjit, pokud se mezi verzemi zmenilo ABI.
    16.4.2010 15:01 Kamil Hruska
    Rozbalit Rozbalit vše Re: SVN - library version mismatch
    Ano, ta sazka v tomto pripade asi nevysla, jenze ja mam nejnovejsi subversion, openssl i heimdal balicky z repozitare...
    16.4.2010 15:09 Zdenek 'Mst. Spider' Sedlak | skóre: 37 | blog: xMstSpider
    Rozbalit Rozbalit vše Re: SVN - library version mismatch
    Jakou verzi SVN mas v repositari?
    16.4.2010 15:11 Kamil Hruska
    Rozbalit Rozbalit vše Re: SVN - library version mismatch
    subversion 1.6.9-5
    16.4.2010 15:17 Kamil Hruska
    Rozbalit Rozbalit vše Re: SVN - library version mismatch
    Jeste pro uplnost:
    openssl 1.0.0-2
    heimdal 1.3.2-1
    
    16.4.2010 15:27 chrono
    Rozbalit Rozbalit vše Re: SVN - library version mismatch
    Svn program, podľa toho výpisu, používa knižnicu OpenSSL 0.9.8
    16.4.2010 23:11 Kamil Hruska
    Rozbalit Rozbalit vše Re: SVN - library version mismatch
    Myslite, ze to bude pricinou problemu?
    17.4.2010 00:56 chrono
    Rozbalit Rozbalit vše Re: SVN - library version mismatch
    Tá knižnica verzie 0.9.8 tam pravdepodobne je, takže to by problém byť nemal (teda ak to tiež nie je len ručne vytvorený odkaz).
    17.4.2010 11:37 Kamil Hruska
    Rozbalit Rozbalit vše Re: SVN - library version mismatch
    Je to rucne vytvoreny odkaz:) Nainstalovanou mam verzi 1.0.0-2
    17.4.2010 11:41 chrono
    Rozbalit Rozbalit vše Re: SVN - library version mismatch
    Tak musíš nainštalovať aj 0.9.8 (tie knižnice majú iný názov, takže môžu byť nainštalované spoločne s 1.0.0) alebo budeš musieť nainštalovať správnu verziu SVN (prípadne si ju skompilovať). :)
    17.4.2010 12:13 Kamil Hruska
    Rozbalit Rozbalit vše Re: SVN - library version mismatch
    No co vim, tak v archu nemuzu mit zaroven nainstalovane dve verze jednoho balicku. Nejnovejsi verze SVN by ale mela umet pracovat s nejnovejsi verzi openssl (coz je 1.0.0), ne?
    17.4.2010 12:42 chrono
    Rozbalit Rozbalit vše Re: SVN - library version mismatch
    Update celého systému by malo nainštalovať nové verzie programov a knižníc (a aj SVN).

    Inak to, že v Arch nemôžu byť dve rôzne verzie knižnice (napriek tomu, že majú rôzne API/ABI) som nevedel a pripíšem si to na zoznam dôvodov, prečo nepoužívať Arch. :)
    17.4.2010 13:42 Kamil Hruska
    Rozbalit Rozbalit vše Re: SVN - library version mismatch
    Mozna to mozne je, jen ja nevim jak na to:-P

    Založit nové vláknoNahoru

    Tiskni Sdílej: Linkuj Jaggni to Vybrali.sme.sk Google Del.icio.us Facebook

    ISSN 1214-1267   www.czech-server.cz
    © 1999-2015 Nitemedia s. r. o. Všechna práva vyhrazena.