abclinuxu.cz AbcLinuxu.cz itbiz.cz ITBiz.cz HDmag.cz HDmag.cz abcprace.cz AbcPráce.cz
AbcLinuxu hledá autory!
Inzerujte na AbcPráce.cz od 950 Kč
Rozšířené hledání
×
eParkomat, startup z ČR, postoupil mezi finalisty evropského akcelerátoru ChallengeUp!
Robot na pivo mu otevřel dveře k opravdovému byznysu
Internet věcí: Propojený svět? Už se to blíží...
dnes 01:23 | Nová verze

Oficiálně bylo oznámeno vydání verze 3.0 multiplatformního balíku svobodných kancelářských a grafických aplikací Calligra (Wikipedie). Větev 3 je postavena na KDE Frameworks 5 a Qt 5. Krita se osamostatnila. Z balíku byly dále odstraněny aplikace Author, Brainstorm, Flow a Stage. U Flow a Stage se předpokládá jejich návrat v některé z budoucích verzí Calligry.

Ladislav Hagara | Komentářů: 0
včera 15:25 | Nová verze

Bylo oznámeno vydání první RC (release candidate) verze instalátoru pro Debian 9 s kódovým názvem Stretch. Odloženo bylo sloučení /usr jako výchozí nastavení v debootstrap. Vydán byl také Debian 8.7, tj. sedmá opravná verze Debianu 8 s kódovým názvem Jessie.

Ladislav Hagara | Komentářů: 5
včera 13:37 | Zajímavý projekt

1. ledna byl představen projekt Liri (GitHub). Jedná se o spojení projektů Hawaii, Papyros a původního projektu Liri s cílem vyvíjet operační systém (linuxovou distribuci) a aplikace s moderním designem a funkcemi. Včera byl představen Fluid 0.9.0 a také Vibe 0.9.0. Jedná se o toolkit a knihovnu pro vývoj multiplatformních a responzivních aplikací podporující Material Design (Wikipedie) a volitelně také Microsoft Design Language (designový jazyk Microsoft) [reddit].

Ladislav Hagara | Komentářů: 2
14.1. 00:33 | Zajímavý software

Google na svém blogu věnovaném open source představil knihovnu pro komprimaci a dekomprimaci 3D grafiky s názvem Draco. Knihovna bude využívána například v aplikacích pro virtuální a rozšířenou realitu. Porovnání Draco s gzip na YouTube. Zdrojové kódy Draco jsou k dispozici na GitHubu pod licencí Apache 2.0.

Ladislav Hagara | Komentářů: 5
13.1. 17:27 | IT novinky

V loňském roce proběhla úspěšná kampaň na Indiegogo na podporu GPD Win. Jedná se o malý 5,5 palcový notebook a přenosnou herní konzoli v jednom. Předinstalované Windows 10 lze nahradit Linuxem. V únoru by se na Indiegogo měla objevit kampaň na podporu 7 palcového notebooku GPD Pocket.

Ladislav Hagara | Komentářů: 28
13.1. 02:00 | Nová verze

Po pěti měsících od vydání verze 1.0.0 (zprávička) byla vydána verze 2.0.0 frameworku Kirigami (HIG) pro vytváření uživatelských rozhraní mobilních a konvergentních aplikací nad toolkitem Qt. Pro vyzkoušení je určena aplikace pro Android Kirigami gallery.

Ladislav Hagara | Komentářů: 0
12.1. 23:28 | Zajímavý software

Akční hra Lugaru HD od Wolfire Games (recenze) byla uvolněna jako svobodný software, a to včetně dat (pod licencí Creative Commons Attribution – Share Alike). Linuxový port byl v roce 2010 součástí první akce Humble Indie Bundle a engine byl krátce poté uvolněn pod licencí GNU GPL, což vedlo mj. k portu na AmigaOS. Autor mezitím pracuje na pokračování nazvaném Overgrowth.

Fluttershy, yay! | Komentářů: 0
12.1. 14:49 | Bezpečnostní upozornění

Na serveru Jabb.im bylo zveřejněno vyjádření k úniku dat z Jabbim Archive (pastebin). Dump databáze obsahuje komunikaci uživatelů, jejich IP adresy a logy aplikace od října 2015 do března 2016. Celkově se jedná o 8 GB dat, převažujícím jazykem zpráv je čeština a slovenština. O úniku informoval jako první server Motherboard. Jabbim Archive byla službou volitelnou, dostupnou pouze pro VIP uživatele. Podle provozovatele serveru Jabb.im k

… více »
Michal Makovec | Komentářů: 68
12.1. 12:55 | Nová verze

Telegram Desktop, klient služby pro rychlé psaní zpráv Telegram (Wikipedie, zdrojové kódy) pro počítače, byl představen v roce 2013. Dnes byla vydána verze 1.0. Podrobnosti v oznámení na blogu.

Ladislav Hagara | Komentářů: 11
12.1. 11:22 | Bezpečnostní upozornění

Byla nalezena a v upstreamu opravena bezpečnostní chyba CVE-2016-9587 (CT-2017-0109) ve svobodném softwaru vytvářejícím platformu pro konfigurační správu a řízení počítačů Ansible (Wikipedie). Spravování kompromitovaného uzlu pomocí Ansible může vést ke spuštění příkazů na řídícím počítači [LWN.net].

Ladislav Hagara | Komentářů: 0
Jak se stavíte k trendu ztenčování přenosných zařízení (smartphony, notebooky)?
 (10%)
 (2%)
 (74%)
 (3%)
 (10%)
Celkem 289 hlasů
 Komentářů: 19, poslední 13.1. 22:02
    Rozcestník
    Reklama

    Dotaz: chybná instalace GCC - pořád dokola

    10.9.2010 21:00 Adamos
    chybná instalace GCC - pořád dokola
    Přečteno: 224×
    Dostal jsem se do nečekaného problému, z kterého jsem po 24 hodinách nedokázal vybruslit. Instaloval jsem C++ kompilátor GCC na Debianu ale instalace se z nějakého důvodu nezdařila :-( Po chvíli řešení jsem se dostal do situace kdy mám v systému následující balíčky s chybnou instalací:
    Desired=Unknown/Install/Remove/Purge/Hold
    | Status=Not/Inst/Cfg-files/Unpacked/Failed-cfg/Half-inst/trig-aWait/Trig-pend
    |/ Err?=(none)/Hold/Reinst-required/X=both-problems (Status,Err: uppercase=bad)
    ||/ Name                            Version                         Description
    +++-===============================-===============================-============================================
    rc  fakeroot                        1.14.4-1                        Gives a fake root environment
    iU  libc6                           2.7-18lenny4                    GNU C Library: Shared libraries
    iF  libgcc1                         1:4.4.4-8                       GCC support library
    rc  libldap2                        2.1.30-13.2                     OpenLDAP libraries
    rc  locales                         2.11.2-2                        Embedded GNU C Library: National Language
    
    pokud chci spustit příkaz apt-get -f install vypíše se následující:
    The following packages were automatically installed and are no longer required:
      libmpfr1ldbl
    Use 'apt-get autoremove' to remove them.
    The following extra packages will be installed:
      dpkg libcompress-raw-zlib-perl libcompress-zlib-perl libio-compress-base-perl libio-compress-zlib-perl perl
      perl-base perl-modules
    Suggested packages:
      perl-doc libterm-readline-gnu-perl libterm-readline-perl-perl
    The following packages will be REMOVED:
      libc-bin
    The following NEW packages will be installed:
      libcompress-raw-zlib-perl libcompress-zlib-perl libio-compress-base-perl libio-compress-zlib-perl
    The following packages will be upgraded:
      dpkg perl perl-base perl-modules
    4 upgraded, 4 newly installed, 1 to remove and 208 not upgraded.
    2 not fully installed or removed.
    Need to get 0B/12.2MB of archives.
    After this operation, 528kB disk space will be freed.
    Do you want to continue [Y/n]? y
    E: Internal Error, Could not perform immediate configuration (1) on libc6
    
    Poslední řádek tedy říká, že libc6 není configurován. Tak spustím příkaz dpkg --configure libc6 ale vypíše to následující chybu:
    dpkg: dependency problems prevent configuration of libc6:
     libc6 depends on libgcc1; however:
      Package libgcc1 is not configured yet.
     libc-bin (2.11.2-2) breaks libc6 (<< 2.10) and is installed.
      Version of libc6 to be configured is 2.7-18lenny4.
    dpkg: error processing libc6 (--configure):
     dependency problems - leaving unconfigured
    Errors were encountered while processing:
     libc6
    
    Tak tedy skusím konfigurovat libgcc1 příkazem dpkg --configure libgcc1 ale ten skončí s chybou:
    dpkg: dependency problems prevent configuration of libgcc1:
     libgcc1 depends on libc6 (>= 2.2.5); however:
      Package libc6 is not configured yet.
    dpkg: error processing libgcc1 (--configure):
     dependency problems - leaving unconfigured
    Errors were encountered while processing:
     libgcc1
    
    Balíčky nejdou ani smazat ani přeinstalovat :-( Poradí mi někdo co s tím? :-)

    Odpovědi

    10.9.2010 22:26 Jindřich
    Rozbalit Rozbalit vše Re: chybná instalace GCC - pořád dokola
    A co zkusit to pomocí aptitude? Střílím od boku, ale tento program mi někdy pomohl vyřešit situaci se závislostmi při instalaci, kterou apt-get nezvládl.
    11.9.2010 00:41 Adamos
    Rozbalit Rozbalit vše Re: chybná instalace GCC - pořád dokola
    To už jsem zkoušel a výsledek byl totožny jako s apt-get :-(
    11.9.2010 01:18 romank | skóre: 10 | blog: romank
    Rozbalit Rozbalit vše Re: chybná instalace GCC - pořád dokola
    Skuste dpkg -P libgcc1 libc6, alebo dpkg -P balicek, a ked vyhodi chybu hladajte zavislosti. dpkg -P vymaze vsetko co sa daneho balicka tyka aj jeho konfiguraky .... cize dpkg -P postfix odinstaluje balicek postfix a vymaze /etc/postfix .... vela zdaru.
    11.9.2010 03:40 Adamos
    Rozbalit Rozbalit vše Re: chybná instalace GCC - pořád dokola
    tak ani toto nepomohlo :-( Zde je výsledek:
      Package libc6 is to be removed.
     libpng12-0 depends on libc6 (>= 2.7-1).
     libsm6 depends on libc6 (>= 2.5-5).
     courier-authlib depends on libc6 (>= 2.3.5-1).
     openssh-client depends on libc6 (>= 2.3.5-1).
     libfam0 depends on libc6 (>= 2.3.5-1).
     libselinux1 depends on libc6 (>= 2.7-1).
     libice6 depends on libc6 (>= 2.6-1).
     nano depends on libc6 (>= 2.3.5-1).
     libedit2 depends on libc6 (>= 2.3.5-1).
     imagemagick depends on libc6 (>= 2.3.5-1).
     cron depends on libc6 (>= 2.3.5-1).
     php5-xsl depends on libc6 (>= 2.3.5-1).
     sysvinit-utils depends on libc6 (>= 2.7-1).
     libmhash2 depends on libc6 (>= 2.3.5-1).
     libldap-2.4-2 depends on libc6 (>= 2.7-1).
     libapache2-mod-php5 depends on libc6 (>= 2.3.5-1).
     dselect depends on libc6 (>= 2.3.5-1).
     php5-cli depends on libc6 (>= 2.3.5-1).
     php5-mcrypt depends on libc6 (>= 2.3.5-1).
     apache2.2-common depends on libc6 (>= 2.7-1).
     libio-pty-perl depends on libc6 (>= 2.7-1).
     procmail depends on libc6 (>= 2.3.5-1).
     libhtml-parser-perl depends on libc6 (>= 2.7-1); however:
      Package libc6 is to be removed.
     perl depends on libc6 (>= 2.7-1).
     libbz2-1.0 depends on libc6 (>= 2.7-1).
     diff depends on libc6 (>= 2.5).
     liblcms1 depends on libc6 (>= 2.3.5-1).
     iputils-ping depends on libc6 (>= 2.3.5-1).
     libmcrypt4 depends on libc6 (>= 2.3.5-1).
     libopencdk8 depends on libc6 (>= 2.3.5-1).
     info depends on libc6 (>= 2.3.5-1).
     mysql-server-5.0 depends on libc6 (>= 2.3.5-1).
     liblocale-gettext-perl depends on libc6 (>= 2.7-1).
     libc-client2002edebian depends on libc6 (>= 2.3.5-1).
     libncursesw5 depends on libc6 (>= 2.7-1).
     postgresql-8.1 depends on libc6 (>= 2.3.5-1).
     libept0 depends on libc6 (>= 2.7-1); however:
      Package libc6 is to be removed.
     aptitude depends on libc6 (>= 2.7-1); however:
      Package libc6 is to be removed.
     libpcre3 depends on libc6 (>= 2.7-1).
     libnet-ssleay-perl depends on libc6 (>= 2.7-1); however:
      Package libc6 is to be removed.
     libgpmg1 depends on libc6 (>= 2.3.5-1).
     dpkg depends on libc6 (>= 2.7-1).
     gzip depends on libc6 (>= 2.7-1).
     libgnutls26 depends on libc6 (>= 2.7-1).
     openssh-server depends on libc6 (>= 2.3.5-1).
     libsigc++-2.0-0c2a depends on libc6 (>= 2.7-1).
     e2fsprogs depends on libc6 (>= 2.7-1).
     php5-pspell depends on libc6 (>= 2.3.5-1).
     libx11-6 depends on libc6 (>= 2.3.5-1).
     libtidy-0.99-0 depends on libc6 (>= 2.3.5-1).
     libxft2 depends on libc6 (>= 2.3.5-1).
     librrd2 depends on libc6 (>= 2.7-1).
     findutils depends on libc6 (>= 2.7-1).
     apache2-utils depends on libc6 (>= 2.7-1).
     libblkid1 depends on libc6 (>= 2.3.5-1).
     initscripts depends on libc6 (>= 2.3.5-1).
     libslang2 depends on libc6 (>= 2.7-1).
     postgresql-client-8.1 depends on libc6 (>= 2.3.5-1).
     sysvinit depends on libc6 (>= 2.7-1).
     screen depends on libc6 (>= 2.3.5-1).
     qmailadmin depends on libc6 (>= 2.3.5-1).
     libacl1 depends on libc6 (>= 2.3.5-1).
     hostname depends on libc6 (>= 2.7-1).
     bsdmainutils depends on libc6 (>= 2.3.5-1).
     passwd depends on libc6 (>= 2.7-1).
     libsasl2-2 depends on libc6 (>= 2.7-1).
     courier-authlib-userdb depends on libc6 (>= 2.3.5-1).
     libcwidget3 depends on libc6 (>= 2.7-1).
     libcurl3 depends on libc6 (>= 2.3.5-1).
     grep depends on libc6 (>= 2.7-1).
     unrar depends on libc6 (>= 2.7-1).
     libxfixes3 depends on libc6 (>= 2.5).
     net-tools depends on libc6 (>= 2.7-1).
     x11-common depends on libc6 (>= 2.7-1).
     libdb4.4 depends on libc6 (>= 2.6.1-1).
     libdb4.6 depends on libc6 (>= 2.7-1).
     libdb4.3 depends on libc6 (>= 2.3.5-1).
     libdb4.2 depends on libc6 (>= 2.3.5-1).
     libnewt0.52 depends on libc6 (>= 2.7-1).
     courier-pop depends on libc6 (>= 2.3.5-1).
     gnupg depends on libc6 (>= 2.7-1).
     groff-base depends on libc6 (>= 2.3.5-1).
     links depends on libc6 (>= 2.3.5-1).
     mawk depends on libc6 (>= 2.7-1).
     libcomerr2 depends on libc6 (>= 2.7-1).
     libaprutil1 depends on libc6 (>= 2.7-1).
     libsqlite0 depends on libc6 (>= 2.3.5-1).
     base-passwd depends on libc6 (>= 2.7-1).
     wget depends on libc6 (>= 2.3.5-1).
     apache2-mpm-prefork depends on libc6 (>= 2.7-1).
     ruby1.8 depends on libc6 (>= 2.3.5-1).
     e2fslibs depends on libc6 (>= 2.7-1).
     libtiff4 depends on libc6 (>= 2.3.5-1).
     liblzo1 depends on libc6 (>= 2.3.5-1).
     clamav-freshclam depends on libc6 (>= 2.7-1).
     courier-ssl depends on libc6 (>= 2.3.5-1).
     libidn11 depends on libc6 (>= 2.3.5-1).
     sed depends on libc6 (>= 2.7-1).
     libattr1 depends on libc6 (>= 2.3.5-1).
     libauthen-pam-perl depends on libc6 (>= 2.7-1); however:
      Package libc6 is to be removed.
     libruby1.8 depends on libc6 (>= 2.3.5-1).
     libdbd-mysql-perl depends on libc6 (>= 2.7-1).
     webalizer depends on libc6 (>= 2.3.5-1).
     courier-imap depends on libc6 (>= 2.3.5-1).
     php5-curl depends on libc6 (>= 2.3.5-1).
     libnet-dns-perl depends on libc6 (>= 2.7-1); however:
      Package libc6 is to be removed.
     libjasper-1.701-1 depends on libc6 (>= 2.3.5-1).
     libltdl3 depends on libc6 (>= 2.3.5-1).
     libexpat1 depends on libc6 (>= 2.6-1).
     libltdl7 depends on libc6 (>= 2.3).
     logrotate depends on libc6 (>= 2.3.5-1).
     libclamav1 depends on libc6 (>= 2.3.5-1).
     libclamav6 depends on libc6 (>= 2.7).
     libclamav4 depends on libc6 (>= 2.7-1).
     libkeyutils1 depends on libc6 (>= 2.7-1).
     mailx depends on libc6 (>= 2.3.5-1).
     rsync depends on libc6 (>= 2.3.5-1).
     vim depends on libc6 (>= 2.3.5-1).
     librrds-perl depends on libc6 (>= 2.7-1); however:
      Package libc6 is to be removed.
     libncurses5 depends on libc6 (>= 2.7-1).
     libreadline5 depends on libc6 (>= 2.5-5).
     syslog-ng depends on libc6 (>= 2.3.5-1).
     php5-xmlrpc depends on libc6 (>= 2.3.5-1).
     libtext-iconv-perl depends on libc6 (>= 2.7-1).
     libsqlite3-0 depends on libc6 (>= 2.7-1).
     mount depends on libc6 (>= 2.7-1).
     php5-sqlite depends on libc6 (>= 2.3.5-1).
     php5-gd depends on libc6 (>= 2.3.5-1).
     htop depends on libc6 (>= 2.3.5-1).
     vsftpd depends on libc6 (>= 2.3.5-1).
     ed depends on libc6 (>= 2.3.5-1).
     libtommath0 depends on libc6 (>= 2.7-1).
     libdbd-pg-perl depends on libc6 (>= 2.7-1).
     traceroute depends on libc6 (>= 2.3.5-1).
     zlib1g depends on libc6 (>= 2.7-1).
     qmail depends on libc6 (>= 2.3.5-1).
     vpopmail depends on libc6 (>= 2.3.5-1).
     openbsd-inetd depends on libc6 (>= 2.3.5-1).
     file depends on libc6 (>= 2.7-1).
     tar depends on libc6 (>= 2.7-1).
     ucspi-tcp depends on libc6 (>= 2.3.5-1).
     libxpm4 depends on libc6 (>= 2.3.5-1).
     clamav depends on libc6 (>= 2.7).
     razor depends on libc6 (>= 2.7-1).
     libmagick9 depends on libc6 (>= 2.3.5-1).
     libxrender1 depends on libc6 (>= 2.6.1-1).
     libxext6 depends on libc6 (>= 2.3.5-1).
     ifupdown depends on libc6 (>= 2.7-1).
     libfontconfig1 depends on libc6 (>= 2.6.1-1).
     libpam-modules depends on libc6 (>= 2.7-1).
     libaspell15 depends on libc6 (>= 2.3.5-1).
     libsepol1 depends on libc6 (>= 2.7-1).
     libxapian15 depends on libc6 (>= 2.7-1).
     whiptail depends on libc6 (>= 2.7-1).
     libmagic1 depends on libc6 (>= 2.7-1).
     libdigest-sha1-perl depends on libc6 (>= 2.7-1); however:
      Package libc6 is to be removed.
     rrdtool depends on libc6 (>= 2.3.5-1).
     libxslt1.1 depends on libc6 (>= 2.3.5-1).
     apg depends on libc6 (>= 2.3.5-1).
     dcc-client depends on libc6 (>= 2.3.5-1).
     libmysqlclient15off depends on libc6 (>= 2.7-1).
     apt depends on libc6 (>= 2.7-1).
     perl-base depends on libc6 (>= 2.7-1).
     ncurses-bin depends on libc6 (>= 2.7-1).
     openssl depends on libc6 (>= 2.3.5-1).
     vim-common depends on libc6 (>= 2.3.5-1).
     bzip2 depends on libc6 (>= 2.7-1).
     libssl0.9.8 depends on libc6 (>= 2.7-1).
     bsdutils depends on libc6 (>= 2.7-1).
     lftp depends on libc6 (>= 2.3.5-1).
     psmisc depends on libc6 (>= 2.6.1-1).
     libgpg-error0 depends on libc6 (>= 2.3.5-1).
     libusb-0.1-4 depends on libc6 (>= 2.7-1).
     libpam0g depends on libc6 (>= 2.7-1).
     libpopt0 depends on libc6 (>= 2.3.5-1).
     php5-pgsql depends on libc6 (>= 2.3.5-1).
     libgeoip1 depends on libc6 (>= 2.3.5-1).
     procps depends on libc6 (>= 2.7-1).
     mlock depends on libc6 (>= 2.3.5-1).
     libjpeg62 depends on libc6 (>= 2.3.5-1).
     libtasn1-3 depends on libc6 (>= 2.7-1).
     libgd2-xpm depends on libc6 (>= 2.3.5-1).
     libuuid1 depends on libc6 (>= 2.7-1).
     lzma depends on libc6 (>= 2.7-1).
     libgcrypt11 depends on libc6 (>= 2.7-1).
     libgdbm3 depends on libc6 (>= 2.3.5-1).
     man-db depends on libc6 (>= 2.3.5-1).
     module-init-tools depends on libc6 (>= 2.3.5-1).
     libgmp3c2 depends on libc6 (>= 2.3.5-1).
     gpgv depends on libc6 (>= 2.7-1).
     login depends on libc6 (>= 2.7-1).
     libxml2 depends on libc6 (>= 2.3.5-1).
     dcc-common depends on libc6 (>= 2.3.5-1).
     libdbi-perl depends on libc6 (>= 2.7-1); however:
      Package libc6 is to be removed.
     debianutils depends on libc6 (>= 2.7-1).
     libfreetype6 depends on libc6 (>= 2.6-1).
     coreutils depends on libc6 (>= 2.7-1).
     libxdmcp6 depends on libc6 (>= 2.7-1).
     libmpfr1ldbl depends on libc6 (>= 2.3).
     libpq4 depends on libc6 (>= 2.3.5-1).
     libpq5 depends on libc6 (>= 2.7-1).
     libt1-5 depends on libc6 (>= 2.3.5-1).
     mktemp depends on libc6 (>= 2.7-1).
     libart-2.0-2 depends on libc6 (>= 2.7-1).
     php5-tidy depends on libc6 (>= 2.3.5-1).
     libsocket6-perl depends on libc6 (>= 2.7-1); however:
      Package libc6 is to be removed.
     tcpd depends on libc6 (>= 2.3.5-1).
    dpkg: error processing libc6 (--purge):
     dependency problems - not removing
    Errors were encountered while processing:
     libgcc1
     libc6
    
    11.9.2010 22:13 HrabalVojta
    Rozbalit Rozbalit vše Re: chybná instalace GCC - pořád dokola
    a co použít starší GCC a zkusit to znovu doinstalovat

    Založit nové vláknoNahoru

    Tiskni Sdílej: Linkuj Jaggni to Vybrali.sme.sk Google Del.icio.us Facebook

    ISSN 1214-1267   www.czech-server.cz
    © 1999-2015 Nitemedia s. r. o. Všechna práva vyhrazena.