abclinuxu.cz AbcLinuxu.cz itbiz.cz ITBiz.cz HDmag.cz HDmag.cz abcprace.cz AbcPráce.cz
AbcLinuxu hledá autory!
Inzerujte na AbcPráce.cz od 950 Kč
Rozšířené hledání
×
    dnes 22:44 | Nová verze

    Programovací jazyk Python byl vydán v nové major verzi 3.15.0. Podrobný přehled novinek v aktualizované dokumentaci.

    Ladislav Hagara | Komentářů: 0
    dnes 22:33 | Zajímavý projekt

    BIGWORDS.PAGE je open-source webová aplikace, která po otevření odkazu v prohlížeči vykreslí přes celou obrazovku jednoduché informační sdělení. Zpráva i její nastavení jsou uložené v části URL za znakem #, například odkaz https://bigwords.page/#abclinuxu zobrazí jako velký bílý nápis 'abclinuxu' na černém pozadí. Obsah odkazu lze upravovat i vestavěným editorem, ten umožňuje nastavovat formátování a vizuální efekty textu, časovače, QR kódy a obrázky. Zdrojový kód je dostupný pod licencí MIT na GitHubu.

    ❗Červivý Hřib krade❗ | Komentářů: 2
    dnes 11:55 | Upozornění

    V neděli 11. října proběhne rotace klíče kořenové zóny. Podruhé v historii. Ondřej Filip na blogu CZ.NIC: "Pokud je pro Vás DNS protokol spíše výzva, ale přesto spravujete nějakou síť či DNS resolver, zkuste si jednoduchý test, který připravila firma Cloudflare na této adrese. Obzvláště zbystřit byste měli, pokud uvidíte nějaká červená políčka."

    Ladislav Hagara | Komentářů: 6
    dnes 09:55 | IT novinky

    Vláda Spojených států se rozhodla vyřadit americkou softwarovou společnost Microsoft a několik dalších velkých technologických podniků z programu, který umožňuje kvalifikovaným zahraničním pracovníkům získat povolení k trvalému pobytu. Oznámila to včera administrativa amerického prezidenta Donalda Trumpa. Opatření zdůvodnila rozsáhlým zneužíváním programu, který je dlouhodobě terčem kritiky ze strany Trumpových příznivců, neboť prý znevýhodňuje americké pracovníky.

    Ladislav Hagara | Komentářů: 11
    dnes 09:44 | IT novinky

    Datové centrum největší ruské technologické společnosti Jandex v Rjazaňské oblasti se stalo cílem dronového útoku a zastavilo provoz. Jandexu se někdy přezdívá „ruský Google“. Provozuje nejoblíbenější internetový vyhledávač v Rusku nebo aplikace pro objednávky jídla a taxi. Využívají jej desítky milionů lidí v rusky mluvících zemích.

    Ladislav Hagara | Komentářů: 11
    dnes 09:33 | Nová verze

    Francouzská společnost Mistral AI představila Mistral Large 4 (interně přezdívaný 'le Chonk', volně přeloženo 'pořádný macek'), 'open-weight multimodální hybridní instruct-and-reasoning model s architekturou granulárního MoE, nativně podporující více jak 160 jazyků'. Model má přes jeden bilión parametrů, z nichž při práci využívá 49 miliard, kontextové okno o délce milion tokenů a obrazový enkodér o 1,6 miliardách parametrů.

    … více »
    ❗Červivý Hřib krade❗ | Komentářů: 2
    dnes 03:22 | Nová verze

    Svobodný multiplatformní herní engine Bevy napsaný v Rustu byl vydán ve verzi 0.20. Díky 227 přispěvatelům.

    Ladislav Hagara | Komentářů: 0
    dnes 03:11 | Komunita

    Simon Long oznámil Raspberry Pi Desktop pro PC a Mac s Intelem postavený na aktualizovaném Debianu 13 Trixie. S klientem Raspberry Pi Connect pro vzdálenou správu. Ke stažení je vedle Raspberry Pi OS pro Raspberry Pi.

    Ladislav Hagara | Komentářů: 1
    včera 21:33 | Zajímavý projekt

    ESP32-C3 adblock přemění lacinou vývojovou desku ESP32‑C3 na samostatný DNS blokovač nejenom reklamních domén, minimalistickou alternativu k populárnímu Pi-hole. ESP32-C3 adblock místo objemných názvů domén ukládá jejich 40-bitové FNV-1a hashe do flash paměti, které pak binárně prohledává, kontrola jedné domény trvá přibližně 10 milisekund. Blocklist pojme až 537 tisíc domén a lze jej spravovat přes webové rozhraní. Projekt zatím

    … více »
    ❗Červivý Hřib krade❗ | Komentářů: 0
    včera 21:00 | Zajímavý software

    ArtCraft je sada open source aplikací pro práci s obrázky a videi "inspirovaných" aplikacemi od Adobe. Napsaných v Rustu. Pro MacOS, Windows i Linux. Běží také ve webovém prohlížeči. Aktuálně se jedná o 7 aplikací: PhotoCraft (Photoshop), VectorCraft (Illustrator), FilmCraft (Premiere Pro), LightCraft (Lightroom), PdfCraft (Acrobat), EffectCraft (After Effects) a DesignCraft (InDesign). Zdrojové kódy jsou k dispozici na GitHubu.

    Ladislav Hagara | Komentářů: 8
    Které desktopové prostředí na Linuxu používáte?
     (9%)
     (7%)
     (4%)
     (21%)
     (29%)
     (8%)
     (5%)
     (2%)
     (14%)
     (20%)
    Celkem 2820 hlasů
     Komentářů: 31, poslední 13.8. 00:27
    Rozcestník

    Dotaz: SOGo proxy error při uložení nastavení

    2.8.2011 12:56 Kall Ell | skóre: 15
    SOGo proxy error při uložení nastavení
    Přečteno: 1656×
    Ahoj všem, mám problém s webmailem SOGo. Na doporučení jsem ho instalnul na zkoušku na testovacím serveru a musím říct, že je super. Mám tam ale někde chybu. Prostředí, kalendář, webmail, kontakty, to vše funguje perfektně. Když ale vstoupím do nastavení a provedu nějaké změny, při pokusu o uložení mě to vyhodí následující chybu.
    Proxy Error
    
    The proxy server received an invalid response from an upstream server.
    The proxy server could not handle the request POST /SOGo/so/tomas/preferences.
    
    Reason: Error reading from remote server
    

    Mám debian squeezee. v logu apache2 je následující:
    [Mon Aug 01 23:12:38 2001] [error] [client ..] 20014 Internal error: proxy: error reading
    status line from remote server 127.0.0.1:2000, referer: http://sogo.mojedomena.cz/SOGo/so/
    tomas/preferences
    
    Nastavení, které se ukládá do db tak se uloží, třeba nastavení výchozí karty(kalendář, pošta, kontakty), ale neuloží se vocation a forward, což je problém a jediná věc, která mě brání ho dát na ostrý server. Máte tušení v čem může být problém? Je to čistá instalace serveru, jako MTA je postfix a MDA je maildrop. Běží na něm apache2, php5, mysql5, sogo a nezbytné součásti. Instalaci jsem prováděl dle tohoto návodu http://wiki.debian.org/SOGo


    Řešení dotazu:


    Odpovědi

    2.8.2011 13:19 timeos | skóre: 32
    Rozbalit Rozbalit vše Re: SOGo proxy error při uložení nastavení
    odporucam pozret log opacnej strany proxy spojenia - teda SOGo servera. Asi to bude /var/log/sogo/sogo.log alebo tak podobne.
    2.8.2011 15:13 Kall Ell | skóre: 15
    Rozbalit Rozbalit vše Re: SOGo proxy error při uložení nastavení
    Tady je log protistrany.
    
    Aug 02 14:26:49 sogod [4060]: SOGoRootPage successful login for user 'tomas' - expire = -1  grace = -1
    Aug 02 14:26:49 sogod [4060]: [WARN] <0x0xa0cd4b0[SOGoWebDAVAclManager]> entry '{DAV:}write' already exists in DAV permissions table
    Aug 02 14:26:49 sogod [4060]: [WARN] <0x0xa0cd4b0[SOGoWebDAVAclManager]> entry '{DAV:}write-properties' already exists in DAV permissions table
    Aug 02 14:26:49 sogod [4060]: [WARN] <0x0xa0cd4b0[SOGoWebDAVAclManager]> entry '{DAV:}write-content' already exists in DAV permissions table
    192.168.0.4 - - [02/Aug/2011:14:26:49 GMT] "POST /SOGo/connect HTTP/1.1" 200 27/41 0.043 - - 884K
    192.168.0.4 - - [02/Aug/2011:14:26:49 GMT] "GET /SOGo/so/tomas HTTP/1.1" 302 0/0 0.003 - - 4K
    192.168.0.4 - - [02/Aug/2011:14:26:49 GMT] "GET /SOGo/so/tomas/view HTTP/1.1" 302 0/0 0.005 - - 12K
    192.168.0.4 - - [02/Aug/2011:14:26:49 GMT] "GET /SOGo/so/tomas/Mail HTTP/1.1" 302 0/0 0.003 - - 0
    2011-08-02 14:26:50.009 sogod[4060] Note: using 'UCS-2LE' on Linux.
    Aug 02 14:26:50 sogod [4060]: <0x0xb710e040[NSString]> Got incomplete multibyte sequence. ToEncode: UCS-2LE FromEncode: UTF-8
    Aug 02 14:26:50 sogod [4060]: <0x0xb710e040[NSString]> Got invalid multibyte sequence. ToEncode: UCS-2LE FromEncode: UTF-8.
    Aug 02 14:26:50 sogod [4060]: [WARN] <0x0xa197918[UIxEnvelopeAddressFormatter]> unexpected envelope address: <0x0xa289c18[NGImap4EnvelopeAddress]:>
    192.168.0.4 - - [02/Aug/2011:14:26:50 GMT] "GET /SOGo/so/tomas/Mail/view HTTP/1.1" 200 22583/0 0.772 101959 77% 29M
    192.168.0.4 - - [02/Aug/2011:14:26:50 GMT] "POST /SOGo/so/tomas/Calendar/alarmslist?browserTime=1312287878 HTTP/1.1" 200 2/0 0.008 - - 104K
    192.168.0.4 - - [02/Aug/2011:14:26:50 GMT] "POST /SOGo/so/tomas/Mail/0/mailboxes HTTP/1.1" 200 928/0 0.179 - - 8K
    192.168.0.4 - - [02/Aug/2011:14:26:51 GMT] "POST /SOGo/so/tomas/Mail//0/folderINBOX/unseenCount HTTP/1.1" 200 13/0 0.265 - - 0
    192.168.0.4 - - [02/Aug/2011:14:26:51 GMT] "POST /SOGo/so/tomas/Mail/foldersState HTTP/1.1" 200 40/0 0.005 - - 0
    192.168.0.4 - - [02/Aug/2011:14:28:11 GMT] "GET /SOGo/so/tomas/preferences HTTP/1.1" 200 13668/0 0.103 54424 74% 148K
    192.168.0.4 - - [02/Aug/2011:14:28:23 GMT] "POST /SOGo/so/tomas/Mail//0/folderINBOX/uids HTTP/1.1" 200 6294/44 0.329 18595 66% 0
    192.168.0.4 - - [02/Aug/2011:14:28:23 GMT] "POST /SOGo/so/tomas/Mail//0/folderINBOX/unseenCount HTTP/1.1" 200 13/0 0.214 - - 0
    EXCEPTION: (NGCouldNotConnectException: 0xa2ca270) NAME:NGCouldNotConnectException REASON:Could not connect to address <0x0xa012b10[NGInternetSocketAddress]: host=localhost port=4190>: connection refused INFO:(nil)
    Aug 02 14:28:26 sogod [2312]: <0x0x9ead388[WOWatchDogChild]> child 4060 exited
    Aug 02 14:28:26 sogod [2312]: <0x0x9ead388[WOWatchDogChild]>  (terminated due to signal 6)
    Aug 02 14:28:26 sogod [2312]: <0x0x9dd7868[WOWatchDog]> child spawned with pid 4396
    2011-08-02 14:28:26.501 sogod[4396] Note: Using UTF-8 as URL encoding in NGExtensions.
    Aug 02 14:28:26 sogod [4396]: <0x0x9ed5608[SOGoCache]> Cache cleanup interval set every 300.000000 seconds
    Aug 02 14:28:26 sogod [4396]: <0x0x9ed5608[SOGoCache]> Using host(s) 'localhost' as server(s)
    2011-08-02 14:28:26.506 sogod[4396] Note(SoObject): SoDebugKeyLookup is enabled!
    2011-08-02 14:28:26.506 sogod[4396] Note(SoObject): SoDebugBaseURL is enabled!
    2011-08-02 14:28:26.506 sogod[4396] Note(SoObject): relative base URLs are enabled.
    2011-08-02 14:28:26.509 sogod[4396] ERROR(-[NGBundleManager bundleWithPath:]): could not create bundle for path: '/usr/share/GNUstep/Libraries/gnustep-base/Versions/1.20/Resources/SSL.bundle'
    2011-08-02 14:28:26.526 sogod[4396] WOCompoundElement: pool embedding is on.
    2011-08-02 14:28:26.526 sogod[4396] WOCompoundElement: id logging is on.
    EXCEPTION: (NGCouldNotConnectException: 0xa1a19e8) NAME:NGCouldNotConnectException REASON:Could not connect to address <0x0xa19e938[NGInternetSocketAddress]: host=localhost port=4190>: connection refused INFO:(nil)
    Aug 02 14:28:26 sogod [2312]: <0x0x9ead388[WOWatchDogChild]> child 4396 exited
    Aug 02 14:28:26 sogod [2312]: <0x0x9ead388[WOWatchDogChild]>  (terminated due to signal 6)
    Aug 02 14:28:26 sogod [2312]: <0x0x9ead388[WOWatchDogChild]> avoiding to respawn child before 2011-08-02 14:28:31 +0200
    Aug 02 14:28:31 sogod [2312]: <0x0x9dd7868[WOWatchDog]> child spawned with pid 4397
    2011-08-02 14:28:31.059 sogod[4397] Note: Using UTF-8 as URL encoding in NGExtensions.
    Aug 02 14:28:31 sogod [4397]: <0x0x9ed5608[SOGoCache]> Cache cleanup interval set every 300.000000 seconds
    Aug 02 14:28:31 sogod [4397]: <0x0x9ed5608[SOGoCache]> Using host(s) 'localhost' as server(s)
    2011-08-02 14:28:31.064 sogod[4397] Note(SoObject): SoDebugKeyLookup is enabled!
    2011-08-02 14:28:31.064 sogod[4397] Note(SoObject): SoDebugBaseURL is enabled!
    2011-08-02 14:28:31.064 sogod[4397] Note(SoObject): relative base URLs are enabled.
    2011-08-02 14:28:31.067 sogod[4397] ERROR(-[NGBundleManager bundleWithPath:]): could not create bundle for path: '/usr/share/GNUstep/Libraries/gnustep-base/Versions/1.20/Resources/SSL.bundle'
    2011-08-02 14:28:31.083 sogod[4397] WOCompoundElement: pool embedding is on.
    2011-08-02 14:28:31.083 sogod[4397] WOCompoundElement: id logging is on.
    EXCEPTION: (NGCouldNotConnectException: 0xa1a1870) NAME:NGCouldNotConnectException REASON:Could not connect to address <0x0xa19e7c0[NGInternetSocketAddress]: host=localhost port=4190>: connection refused INFO:(nil)
    Aug 02 14:28:31 sogod [2312]: <0x0x9ead388[WOWatchDogChild]> child 4397 exited
    Aug 02 14:28:31 sogod [2312]: <0x0x9ead388[WOWatchDogChild]>  (terminated due to signal 6)
    Aug 02 14:28:31 sogod [2312]: <0x0x9ead388[WOWatchDogChild]> avoiding to respawn child before 2011-08-02 14:28:36 +0200
    Aug 02 14:28:36 sogod [2312]: <0x0x9dd7868[WOWatchDog]> child spawned with pid 4400
    2011-08-02 14:31:50.497 sogod[4400] Note: Using UTF-8 as URL encoding in NGExtensions.
    Aug 02 14:31:50 sogod [4400]: <0x0x9e8e538[SOGoCache]> Cache cleanup interval set every 300.000000 seconds
    Aug 02 14:31:50 sogod [4400]: <0x0x9e8e538[SOGoCache]> Using host(s) 'localhost' as server(s)
    2011-08-02 14:31:50.523 sogod[4400] Note(SoObject): SoDebugKeyLookup is enabled!
    2011-08-02 14:31:50.523 sogod[4400] Note(SoObject): SoDebugBaseURL is enabled!
    2011-08-02 14:31:50.523 sogod[4400] Note(SoObject): relative base URLs are enabled.
    2011-08-02 14:31:50.531 sogod[4400] WARNING: IMAP4 connection pooling is disabled!
    2011-08-02 14:31:50.619 sogod[4400] Note(NGImap4Connection): using '/' as the IMAP4 folder separator.
    
    
    Začíná to úspěšným přihlášením, následují tři varování, kterým nerozumím. Tučne jsem označil místo kde jsem otevřel nastavení, těsně před uložením. U toho NGCouldNotConnectException: byla ostrá závorka, ale nešlo to odeslat, tak jsem ji nahradil kulatou. Tu chybu označenou EXCEPTION nechápu. V nastavení SOGo je na ten port nastavené sieve, je uvedené i v services.
    2.8.2011 15:20 NN
    Rozbalit Rozbalit vše Re: SOGo proxy error při uložení nastavení
    Neblokujes si toto firewallem, posloucha na tom portu neco ?
    host=localhost port=4190 connection refused
    NN
    2.8.2011 15:53 Kall Ell | skóre: 15
    Rozbalit Rozbalit vše Re: SOGo proxy error při uložení nastavení
    podle netstat -nato na tom portu nic neposlouchá. :-(. Jak najdu, kde je to blokovaný? S firewallem jsem se na linuxu nikdy nehrál.

    2.8.2011 18:21 Kall Ell | skóre: 15
    Rozbalit Rozbalit vše Re: SOGo proxy error při uložení nastavení
    No tak jsem na to přišel. Neměl jsem v dovecotu zapnuté sieve. Teď už mě sice SOGo nevyhazuje žádnou chybu, ale přeposílání stále nefunguje. Nic méně vím proč. Jako doručovacího agenta používám maildrop. V domovském adresáři se mě uloží daná složka s automatickou odpovědí, ale maildrop ji ignoruje. Takže teď mám dvě možnosti, buď nějakým způsobem přinutit maildrop, aby akceptoval formát sieve, nebo změnit LDA na dovecot. Co bude lepší?
    2.8.2011 19:31 timeos | skóre: 32
    Rozbalit Rozbalit vše Re: SOGo proxy error při uložení nastavení
    pochopitelne - zmenit LDA na dovecot. maildrop nevie sieve a je skoda ho nevyuzit.
    3.8.2011 11:00 Kall Ell | skóre: 15
    Rozbalit Rozbalit vše Re: SOGo proxy error při uložení nastavení
    použil jsem dovecot jako LDA a vše funguje jak má.

    Založit nové vlákno • Nahoru

    Tiskni Sdílej: Linkuj Jaggni to Vybrali.sme.sk Google Del.icio.us Facebook

    ISSN 1214-1267   www.czech-server.cz
    © 1999-2015 Nitemedia s. r. o. Všechna práva vyhrazena.