abclinuxu.cz AbcLinuxu.cz itbiz.cz ITBiz.cz HDmag.cz HDmag.cz abcprace.cz AbcPráce.cz
AbcLinuxu hledá autory!
Inzerujte na AbcPráce.cz od 950 Kč
Rozšířené hledání
×
dnes 16:22 | Nová verze

Byl vydán Cool-Retro-Term ve verzi 1.1.1. Jedná se o emulátor terminálu, který napodobuje vzhled a chování starých CRT terminálů. Ukázka vlastností a nastavení předchozí verze na YouTube. Cool-Retro-Term je nově k dispozici také jako balíček ve formátu AppImage. Stačí je stáhnout, nastavit právo ke spuštění a spustit.

Ladislav Hagara | Komentářů: 0
dnes 12:11 | IT novinky

Web gHacks upozorňuje na draft nové specifikace rozhraní pro rozšíření webového prohlížeče Google Chrome. Pozoruhodný je plán odstranit část API webRequest pro blokování – což by omezilo doplňky jako uBlock Origin určený pro blokování obsahu včetně reklam. Nadále by byl použitelný doplněk Adblock Plus, který provozuje whitelist reklam mj. právě Google.

Fluttershy, yay! | Komentářů: 3
dnes 00:33 | Zajímavý projekt

Byl spuštěn Humble Caffeine Bundle. V balíčku počítačových her jsou také hry běžící na Linuxu: GoNNER BLüEBERRY EDiTION, This War of Mine, Ken Follett's The Pillars of the Earth, Tyranny a Shadow Tactics: Blades of the Shogun.

Ladislav Hagara | Komentářů: 1
dnes 00:11 | Nová verze

Po roce vývoje od vydání verze 3.0 a více než 6 000 změnách byla vydána nová stabilní verze 4.0 softwaru, který vytváří aplikační rozhraní umožňující chod aplikací pro Microsoft Windows také pod GNU/Linuxem, Wine (Wikipedie). Z novinek lze zdůraznit například podporu Vulkanu nebo Direct3D 12. Podrobnosti v poznámkách k vydání.

Ladislav Hagara | Komentářů: 5
včera 20:44 | Nová verze

Byla vydána verze 11.7 open source alternativy GitHubu, tj. softwarového nástroje s webovým rozhraním umožňujícího spolupráci na zdrojových kódech, GitLab (Wikipedie). Představení nových vlastností i s náhledy v příspěvku na blogu.

Ladislav Hagara | Komentářů: 2
včera 17:22 | Bezpečnostní upozornění

V balíčkovacím systému APT používaném v Debianu a z něj vycházejících linuxových distribucích byla nalezena bezpečnostní chyba CVE-2019-3462. Útočník může vzdáleně spustit libovolný příkaz pod právy roota.

Ladislav Hagara | Komentářů: 6
včera 17:00 | Nová verze

Canonical oznámil vydání Ubuntu Core 18. Nová verze Ubuntu Core vychází z Ubuntu 18.04 LTS a podporována bude 10 let. Jedná se o placenou podporu. Ubuntu Core je určeno pro IoT (internet věcí) a vestavěné systémy.

Ladislav Hagara | Komentářů: 0
včera 15:31 | Nová verze

Vyšlo Pharo 7.0 (otevřená implementace Smalltalku). Nyní je kompletně bootstrapováno ze zdrojových kódů spravovaných Gitem, má nové nástroje na procházení a editaci kódu a přináší mnoho dalších změn a oprav. Popis novinek v češtině.

Pavel Křivánek | Komentářů: 0
včera 02:22 | Nová verze

Byla vydána verze 4.5 linuxové distribuce Parrot (Wikipedie). Jedná se o linuxovou distribuci založenou na Debianu a zaměřenou na penetrační testování, digitální forenzní analýzu, reverzní inženýrství, hacking, anonymitu nebo kryptografii.

Ladislav Hagara | Komentářů: 2
21.1. 17:22 | Pozvánky

V sobotu 23. února se uskuteční 6. ročník WordCampu – největší konferenci o WordPressu v ČR. Ke konferenci probíhá i soutěž typu CTF (Capture The Flag) o volné vstupenky, kde si lze zkusit zneužít běžné bezpečnostní chyby.

smíťa | Komentářů: 0
Používáte USB Type-C?
 (20%)
 (16%)
 (11%)
 (12%)
 (38%)
 (4%)
 (44%)
Celkem 477 hlasů
 Komentářů: 0
Rozcestník

Dotaz: Update nástroje autoconf

7.2.2004 10:30 Karel Krema
Update nástroje autoconf
Přečteno: 43×
Chtěl jsem si nainstalovat KFTE, podle rad z ostatních fór jsem zadal ./configure a make. Configure proběhlo v pořádku, ale make mi nahlásilo, že k provedení skriptu je třeba Autoconf verze 2.52 nebo novější. Pokusil jsem se tedy nainstalovat autoconf 2.58, zadal jsem opět ./configure, make a make install. Nikde žádná chyba, ale autoconf --version stále hlásí verzi 2.13. Kde dělám chybu? Díky, elk.

Odpovědi

7.2.2004 14:35 unchallenger | skóre: 69 | blog: unchallenger
Rozbalit Rozbalit vše Update nástroje autoconf
Tipuji, že máš v teď systému více autoconfů. To je celkem běžný stav, protože 2.1x a 2.5x jsou nekompatilbilní a spousta programů stále používá 2.1x. Takže autoconf-2.58 se nejspíš spouští příkazem autoconf-2.58...
7.2.2004 16:37 Karel Krema
Rozbalit Rozbalit vše Update nástroje autoconf
Vypadá to, že mám v systému "autoconf" a "autoconf-2.13". Proč se mi ale nedoinstalovala ta verze 2.58? Jsem začátečník a pochopil jsem, že výše zmíněným postupem se nástroje instalují...
7.2.2004 16:44 unchallenger | skóre: 69 | blog: unchallenger
Rozbalit Rozbalit vše Update nástroje autoconf
A obě na --version vypisují 2.13? V tom případě -- jak (a kam) jsi ten 2.58 instaloval? Myslel jsem, že z balíčku...
7.2.2004 17:22 Karel Krema
Rozbalit Rozbalit vše Update nástroje autoconf
Obě vypisují 2.13.

Instaloval jsem je příkazy ./config make make install

Měl jsem za to, že tahle procedura se postará o zbytek. No, asi ne...
7.2.2004 17:24 Karel Krema
Rozbalit Rozbalit vše Update nástroje autoconf
Samozřejmě
./config
make
make install
7.2.2004 17:36 unchallenger | skóre: 69 | blog: unchallenger
Rozbalit Rozbalit vše Update nástroje autoconf
Asi spíš ./configure...

Nicméně pokud /usr/local/bin/autoconf není autoconf-2.58, tak ti to muselo vypsat nějako chybovou hlášku. BTW proč nenainstaluješ autoconf-2.5x z balíčku? Máš nějaký obskurní/prehistorický systém?
7.2.2004 18:17 Karel Krema
Rozbalit Rozbalit vše Update nástroje autoconf
To né, mám mandrake 9.1.

RPMko jsem nenašel (hledal jsem na freshmeat.net), ale stejně mě to zajímá z principu... Takže jestli to dobře chápu, tak postup byl správný, ale někde jsem musel přehlédnout chybu. Já se na to tedy podívám - pečlivěji...
8.2.2004 08:37 unchallenger | skóre: 69 | blog: unchallenger
Rozbalit Rozbalit vše Update nástroje autoconf
V MDK 9.1 je autoconf-2.57, konkrétně v balíčku autoconf2.5-2.57-3mdk.noarch, a spouští se [poněkud nelogickým] autoconf-2.5x. RPM bys našel jednak na rpmfind.net a jednak tím klikacím instalátorem balíčků, co je v MDK a co už nevím, jak se jmenuje...

Pokud teď v /usr/local/bin nemáš žádný autoconf*, tak se někde muselo řvát celkem hodně...
8.2.2004 09:35 Karel Krema
Rozbalit Rozbalit vše Update nástroje autoconf
Nakonec jsem si skutečně musel stáhnout RPMko :( Každopádně dík za tipy.
5.6.2004 23:51 vaga
Rozbalit Rozbalit vše Re: Update nástroje autoconf
DD. Chtel jsem se zeptat, pokud by nekdo vedel. Mam taky dva autoconfy. Jeden puvodni a jeden novy (nebalickovy) 2.59. Ten novy je opravdu v /usr/local/bin/ ale pri instalaci SIMu -> "make -f admin/Makefile.common" = pouzije starou verzi autoconfu a stara mu nevoni, chce novejsi. Da se mu nejak ten novy vnutit? Dekuji.
6.6.2004 00:06 unchallenger | skóre: 69 | blog: unchallenger
Rozbalit Rozbalit vše Re: Update nástroje autoconf
Asi máš /usr/local/bin v cestě až za /usr/bin (změň PATH). Nebo se ten nový nainstaloval jen jako autoconf-2.59, nikoli i jako autoconf (udělej link).

Kromě toho při instalaci nemá být autoconf zapotřebí, to je naprosté popření jeho smyslu. autoconf potřebuješ akorát, když se v tom vrtáš a chceš rebuildnout configure (nebo když program napsal nějaký tydýt a bez rebuildu configure nejede).
6.6.2004 00:17 vaga
Rozbalit Rozbalit vše Re: Update nástroje autoconf
nechci otravovat, jenom si chci nainstalovat SIM. stravil jsem nad tim pul dne a bezuspesne :-/

[tomas@baron sim-0.9.3]$ make -f admin/Makefile.common Autoconf version 2.13 *** YOU'RE USING Autoconf version 2.13. *** SIM requires autoconf 2.52 or higher make: *** [cvs] Error 1

Vyzkousim to co pisete, dekuji za odpoved.
Stanislav Brabec avatar 9.6.2004 13:07 Stanislav Brabec | skóre: 45 | Praha
Rozbalit Rozbalit vše Re: Update nástroje autoconf
Jde o špadně udělaný distribuční soubor. Dobře udělaný nemá co chtít autoconf (leda, když zadáte --enable-maintainer-mode).

Zkuste autoreconf -f -i. Podle admin/Makefile.common jde o KDE aplikaci, tam možná budete potřebovat:
. /etc/opt/kde3/common_options # cesta závisí na distribuci
update_admin
Nebo zkuste touch na soubor, který se pokouší přegenerovat.

Nebo explicitně --disable-maintainer-mode.

Některé distribuce mají ještě "vychytávku" - autoreconf volá stejnou verzi, jakou byl balík udělán (a to čte z některého z generovaných souborů). Pak to chce autoreconf-{verze} -f -i. Nebo také ručně aclocal-{verze}, libtoolize-{verze}, gettextize-{verze} atd.

Založit nové vláknoNahoru

Tiskni Sdílej: Linkuj Jaggni to Vybrali.sme.sk Google Del.icio.us Facebook

ISSN 1214-1267   www.czech-server.cz
© 1999-2015 Nitemedia s. r. o. Všechna práva vyhrazena.