abclinuxu.cz AbcLinuxu.cz itbiz.cz ITBiz.cz HDmag.cz HDmag.cz abcprace.cz AbcPráce.cz
AbcLinuxu hledá autory!
Inzerujte na AbcPráce.cz od 950 Kč
Rozšířené hledání
×

dnes 06:00 | Nová verze

Byla vydána verze 1.3.0 odlehčeného desktopového prostředí Lumina (Wikipedie, GitHub) postaveného nad toolkitem Qt. Z novinek lze zmínit nový motiv ikon nahrazující Oxygen (material-design-[light/dark]) nebo vlastní multimediální přehrávač (lumina-mediaplayer).

Ladislav Hagara | Komentářů: 0
včera 17:33 | Bezpečnostní upozornění

Před šesti týdny byly publikovány výsledky bezpečnostního auditu zdrojových kódů OpenVPN a nalezené bezpečnostní chyby byly opraveny ve verzi OpenVPN 2.4.2. Guido Vranken minulý týden oznámil, že v OpenVPN nalezl další čtyři bezpečnostní chyby (CVE-2017-7520, CVE-2017-7521, CVE-2017-7522 a CVE-2017-7508). Nejzávažnější z nich se týká způsobu, jakým aplikace zachází s SSL certifikáty. Vzdálený útočník může pomocí speciálně

… více »
Ladislav Hagara | Komentářů: 0
včera 06:55 | Zajímavý projekt

V Edici CZ.NIC vyšla kniha Průvodce labyrintem algoritmů. Kniha je ke stažení zcela zdarma (pdf) nebo lze objednat tištěnou verzi za 339 Kč (připojení přes IPv4) nebo 289 Kč (připojení přes IPv6).

Ladislav Hagara | Komentářů: 6
včera 06:33 | Zajímavý software

Byla vydána verze 2.2.0 svobodného správce hesel KeePassXC (Wikipedie). Jedná se o komunitní fork správce hesel KeePassX s řadou vylepšení.

Ladislav Hagara | Komentářů: 0
včera 06:11 | IT novinky

Vývojář Debianu Henrique de Moraes Holschuh upozorňuje v diskusním listu debian-devel na chybu v Hyper-Threadingu v procesorech Skylake a Kaby Lake od Intelu. Za určitých okolností může chyba způsobit nepředvídatelné chování systému. Doporučuje se aktualizace mikrokódu CPU nebo vypnutí Hyper-Threadingu v BIOSu nebo UEFI [reddit].

Ladislav Hagara | Komentářů: 0
24.6. 01:23 | Komunita

Phoronix spustil 2017 Linux Laptop Survey. Tento dotazník s otázkami zaměřenými na parametry ideálního notebooku s Linuxem lze vyplnit do 6. července.

Ladislav Hagara | Komentářů: 3
23.6. 22:44 | Nová verze

Po třech měsících vývoje od vydání verze 5.5.0 byla vydána verze 5.6.0 správce digitálních fotografií digiKam (digiKam Software Collection). Do digiKamu se mimo jiné vrátila HTML galerie a nástroj pro vytváření videa z fotografií. V Bugzille bylo uzavřeno více než 81 záznamů.

Ladislav Hagara | Komentářů: 1
23.6. 17:44 | Nová verze

Byla vydána verze 9.3 open source alternativy GitHubu, tj. softwarového nástroje s webovým rozhraním umožňujícího spolupráci na zdrojových kódech, GitLab. Představení nových vlastností v příspěvku na blogu a na YouTube.

Ladislav Hagara | Komentářů: 3
23.6. 13:53 | Nová verze

Simon Long představil na blogu Raspberry Pi novou verzi 2017-06-21 linuxové distribuce Raspbian určené především pro jednodeskové miniaturní počítače Raspberry Pi. Společně s Raspbianem byl aktualizován také instalační nástroj NOOBS (New Out Of the Box Software). Z novinek lze zdůraznit IDE Thonny pro vývoj v programovacím jazyce Python a především offline verzi Scratche 2.0. Ten bylo dosud možné používat pouze online. Offline bylo možné používat pouze Scratch ve verzi 1.4. Z nového Scratchu lze ovládat také GPIO piny. Scratch 2.0 vyžaduje Flash.

Ladislav Hagara | Komentářů: 1
22.6. 14:24 | Nová verze

Opera 46, verze 46.0.2597.26, byla prohlášena za stabilní. Nejnovější verze tohoto webového prohlížeče je postavena na Chromiu 59. Z novinek lze zmínit například podporu APNG (Animated Portable Network Graphics). Přehled novinek pro vývojáře na blogu Dev.Opera. Oznámení o vydání zmiňuje také první televizní reklamu.

Ladislav Hagara | Komentářů: 0
Chystáte se pořídit CPU AMD Ryzen?
 (6%)
 (31%)
 (1%)
 (9%)
 (44%)
 (9%)
Celkem 842 hlasů
 Komentářů: 65, poslední 1.6. 19:16
    Rozcestník

    Dotaz: wxGTK a neuspesna kompilace pluckeru

    penguin666 avatar 5.3.2006 23:05 penguin666 | skóre: 26 | blog: Slacked_Life | Praha
    wxGTK a neuspesna kompilace pluckeru
    Přečteno: 102×
    dobry vecer.
    snazim se nainstalovat plucker na muj Slackware current a stale se mi to nedari. ke kompilaci plucker desktopu potrebuji wxGTK - to jsem stahnul (verzi 2.6.2), zkompiloval, udelal balicek (checkinstall) a nainstaloval. vse v poradku.
    kduz spustim pluckerovo "./configure" (probehne v poradku) a nasledne "make" tak skoncim na tomto erroru (omlouvam se za tak dlouhy vypis):
    make[1]: Entering directory `/home/lukas/downloads/plucker-1.8/plucker_desktop'
    g++ -g -O2 `wx-config --cflags` -c -o editor_dialog.o editor_dialog.cpp
    In file included from editor_dialog.cpp:53:
    editor_dialog.h:51:64: wx/stc/stc.h: není souborem ani adresářem
    In file included from editor_dialog.cpp:53:
    editor_dialog.h:163: error: ISO C++ forbids declaration of `wxStyledTextCtrl' with no type
    editor_dialog.h:163: error: expected `;' before '*' token
    editor_dialog.cpp: In constructor `editor_dialog::editor_dialog(wxWindow*, wxString)':
    editor_dialog.cpp:206: error: `m_editor_stc' was not declared in this scope
    editor_dialog.cpp:206: error: `wxStyledTextCtrl' has not been declared
    editor_dialog.cpp: In destructor `virtual editor_dialog::~editor_dialog()':
    editor_dialog.cpp:248: error: `m_editor_stc' was not declared in this scope
    editor_dialog.cpp: In member function `void editor_dialog::stc_or_textctrl_init()':
    editor_dialog.cpp:282: error: `m_editor_stc' was not declared in this scope
    editor_dialog.cpp:282: error: `wxSTC_STYLE_DEFAULT' was not declared in this scope
    editor_dialog.cpp:285: error: `m_editor_stc' was not declared in this scope
    editor_dialog.cpp:290: error: `wxSTC_H_DEFAULT' was not declared in this scope
    editor_dialog.cpp:293: error: `wxSTC_H_TAG' was not declared in this scope
    editor_dialog.cpp:297: error: `wxSTC_H_ATTRIBUTE' was not declared in this scope
    editor_dialog.cpp:301: error: `wxSTC_H_NUMBER' was not declared in this scope
    editor_dialog.cpp:304: error: `wxSTC_H_DOUBLESTRING' was not declared in this scope
    editor_dialog.cpp:307: error: `wxSTC_H_SINGLESTRING' was not declared in this scope
    editor_dialog.cpp:310: error: `wxSTC_H_OTHER' was not declared in this scope
    editor_dialog.cpp:313: error: `wxSTC_H_COMMENT' was not declared in this scope
    editor_dialog.cpp:317: error: `wxSTC_H_ENTITY' was not declared in this scope
    editor_dialog.cpp:324: warning: `GetSystemColour' is deprecated (declared at /usr/local/include/wx-2.6/wx/settin
    gs.h:203)
    editor_dialog.cpp:326: warning: `GetSystemColour' is deprecated (declared at /usr/local/include/wx-2.6/wx/settin
    gs.h:203)
    editor_dialog.cpp:329: error: `wxSTC_MARGIN_NUMBER' was not declared in this scope
    editor_dialog.cpp:336: error: `wxSTC_STYLE_LINENUMBER' was not declared in this scope
    editor_dialog.cpp: In member function `void editor_dialog::stc_or_textctrl_load_file(wxString)':
    editor_dialog.cpp:364: error: `m_editor_stc' was not declared in this scope
    editor_dialog.cpp:369: error: `wxSTC_LEX_HTML' was not declared in this scope
    editor_dialog.cpp: In member function `void editor_dialog::stc_or_textctrl_insert_text(wxString, wxString, bool)
    ':
    editor_dialog.cpp:404: error: `m_editor_stc' was not declared in this scope
    editor_dialog.cpp: In member function `void editor_dialog::stc_or_textctrl_send_text_to_preview()':
    editor_dialog.cpp:482: error: `m_editor_stc' was not declared in this scope
    editor_dialog.cpp: In member function `void editor_dialog::stc_or_textctrl_save_file()':
    editor_dialog.cpp:514: error: `m_editor_stc' was not declared in this scope
    make[1]: *** [editor_dialog.o] Error 1
    make[1]: Leaving directory `/home/lukas/downloads/plucker-1.8/plucker_desktop'
    make: *** [plucker-desktop] Error 2
    

    tusite nekdo, co je spatne? zkousel jsem i wxGTK verzi 2.4.2 a 2.6.1 a stale stejne...
    diky za pripadnou radu.
    penguin666
    Registered Linux user #307373. Keep Slackin'!

    Odpovědi

    6.3.2006 09:00 razor | skóre: 32
    Rozbalit Rozbalit vše Re: wxGTK a neuspesna kompilace pluckeru
    A Vámi vytvořený balíček wxGTK obsahuje soubor wx/stc/stc.h ? Jestliže ano (já ho tam na gentoo mám), pak bych se mrknul na ./configure pluckera, jestli se tam cesty k hlavičkovým souborům wx nedaji nastavit.
    penguin666 avatar 6.3.2006 11:45 penguin666 | skóre: 26 | blog: Slacked_Life | Praha
    Rozbalit Rozbalit vše Re: wxGTK a neuspesna kompilace pluckeru
    no, puvodne ten soubor chybel, ale doinstaloval jsem ho a ted uz zase chybi neco jineho... at delam, co delam, koncim chybou. nejnovejsi postup, ktery jsem zkousel, byl:
    nainstalovat wxGTK
    nainstalovat stc a xrt z baliku wxGTK
    nainstalovat plucker desktop
    vse presne dle navodu, jak nainstalovat plucker-desktop a opet dalsi chyba. tu ale ted nepopisu, protoze nejsem doma. take jsem se snazil najit na netu slackwarovsky balicek pluckera, ale bezuspesne... tenhle kousek software me pekne nici. :o] oblibil jsem si ho v praci ve woknech, ale doma ne a ne uspet.
    kazdopadne dik za reakci
    Registered Linux user #307373. Keep Slackin'!
    penguin666 avatar 6.3.2006 19:32 penguin666 | skóre: 26 | blog: Slacked_Life | Praha
    Rozbalit Rozbalit vše Re: wxGTK a neuspesna kompilace pluckeru
    nevyresil jsem sice problem s instalaci (a to ani kdyz jsem se snazil nainstalovat pouze plucker bez graf. rozhrani), nicmene jsem nasel neco, co funguje. jedna se o java pokracovatele pluckeru, funguje naprosto bez potizi. jen mi neni jasne, proc jsem to neobjevil uz drive...
    sunrise desktop
    Registered Linux user #307373. Keep Slackin'!

    Založit nové vláknoNahoru

    Tiskni Sdílej: Linkuj Jaggni to Vybrali.sme.sk Google Del.icio.us Facebook

    ISSN 1214-1267   www.czech-server.cz
    © 1999-2015 Nitemedia s. r. o. Všechna práva vyhrazena.