abclinuxu.cz AbcLinuxu.cz itbiz.cz ITBiz.cz HDmag.cz HDmag.cz abcprace.cz AbcPráce.cz
AbcLinuxu hledá autory!
Inzerujte na AbcPráce.cz od 950 Kč
Rozšířené hledání
×

včera 22:33 | IT novinky

Společnosti Adobe, Apple, Facebook, Google, Microsoft a Mozilla společně oznámily konec Flashe. Podpora Flashe oficiálně skončí na konci roku 2020.

Ladislav Hagara | Komentářů: 9
včera 05:55 | Komunita

Před 10 lety, v červenci 2007, se začal prodávat svobodný chytrý telefon Neo 1973 (vnitřní označení GTA01). Za jeho vývojem stáli vývojáři projektu Openmoko (Wikipedie). O rok později bylo možné koupit jejich druhý telefon Neo FreeRunner (GTA02). V roce 2011 byl představena platforma GTA04. Tuto platformu využívá také projekt Neo900, jehož cílem je vývoj nástupce telefonu Nokia N900. Nahlédnutí do historie Openmoko a další informace v článku na Vanille.de [Hacker News].

Ladislav Hagara | Komentářů: 22
včera 04:44 | Komunita

Tým Debianu zabývající se reprodukovatelnými sestaveními (Reproducible Builds), tj. kdokoli může nezávisle ověřit, že daný binární .deb balíček vznikl překladem daných zdrojových kódů, oznámil, že 94 % balíčků Debianu lze přeložit a sestavit reprodukovatelně. V únory 2015 to bylo 83 % [reddit].

Ladislav Hagara | Komentářů: 4
24.7. 11:22 | Komunita

Mozilla.cz informuje, že na blogu Mozilly věnovaném bezpečnosti byly zveřejněny výsledky bezpečnostního auditu služby Firefox Accounts, v českých překladech účet Firefoxu, sloužící hlavně k přihlašování k synchronizaci Firefox Sync. Nalezeno bylo celkem 15 bezpečnostních chyb, z toho jedna byla označena jako kritická a tři jako vážné.

Ladislav Hagara | Komentářů: 0
24.7. 11:00 | Nová verze

Byla vydána první stabilní verze 1.0 svobodného komunikačního softwaru Ring (Wikipedie). Ring, původně SFLphone, je součástí projektu GNU [reddit].

Ladislav Hagara | Komentářů: 3
24.7. 06:00 | Zajímavý projekt

Warner Skoch na svých stránkách zveřejnil návod (YouTube) na zhotovení kapesní herní konzole MintyPi. Konzole MintyPi je postavena na Raspberry Pi Zero W a RetroPie. Jako obal slouží plechová krabička od mentolek.

Ladislav Hagara | Komentářů: 0
23.7. 02:00 | Nová verze

Byl vydán Debian 9.1, tj. první opravná verze Debianu 9 s kódovým názvem Stretch a Debian 8.9, tj. devátá opravná verze Debianu 8 s kódovým názvem Jessie. Řešeny jsou především bezpečnostní problémy, ale také několik vážných chyb. Instalační média Debianu 9 a Debianu 8 lze samozřejmě nadále k instalaci používat. Po instalaci stačí systém aktualizovat.

Ladislav Hagara | Komentářů: 37
22.7. 15:50 | Zajímavý článek

Nadace The Document Foundation (TDF) zastřešující vývoj svobodného kancelářského balíku LibreOffice zveřejnila čtyřiačtyřicetistránkovou výroční zprávu za rok 2016. K dispozici je ve formátu pdf ve vysokém (21,68 MB) a nízkém (7,1 MB) rozlišení. Zpráva byla vytvořena ve Scribusu.

Ladislav Hagara | Komentářů: 0
22.7. 14:40 | Zajímavý software

Mozilla.cz informuje, že Firefox Focus pro Android, velmi jednoduchý prohlížeč zaměřený na anonymní prohlížení, dosáhl milionu stažení. Firefox Focus blokuje sledující prvky a reklamy a při ukončení automaticky smaže všechna uložená data stránek, historii prohlížení a cookies.

Ladislav Hagara | Komentářů: 41
22.7. 14:20 | Komunita

Vyplněním dotazníku na Formuláře Google lze ovlivnit výběr výchozích aplikací v Ubuntu 18.04 LTS. Podrobnosti v příspěvku Dustina Kirklanda na Ubuntu Insights [reddit].

Ladislav Hagara | Komentářů: 13
Těžíte nějakou kryptoměnu?
 (4%)
 (2%)
 (18%)
 (76%)
Celkem 94 hlasů
 Komentářů: 5, poslední dnes 08:26
    Rozcestník

    Dotaz: Kylix 3 pod RH9 tuhne

    25.12.2003 13:58 Howard | skóre: 17
    Kylix 3 pod RH9 tuhne
    Přečteno: 312×
    Zdravím, z webu borland.com jsem si stahnul enterprise verzi Kylixu 3 trial, instalace pod mým RH9 byla v pohodě, všechno funguje do té doby, kdy se snažím spustit nějaký program vytvořený v Kylixu, byť je to jenom prázdné formulářové okno. I kompilace proběhne, ale jakmile dam Run, tak zatuhne celý Kylix (program nenaběhne) a musím ho killnout. Nelze ani spustit vytvořený program ručně. Nuže, čím to může být?
    openSUSE 13.1, 13.2, 42.1

    Odpovědi

    25.12.2003 14:53 JSX
    Rozbalit Rozbalit vše Kylix 3 pod RH9 tuhne
    Zdar, mno Kylix ma problem s tym, ze bezal v pohode na RedHAT-och do verzie 7.2 (tusim) pretoze je v nom stary kompilator. Skus sa mrknut po produkte C++Builder X, kde sa kompiluje so systemom dodavanym kompilatorom... Bye, JSX
    25.12.2003 15:50 Howard | skóre: 17
    Rozbalit Rozbalit vše Kylix 3 pod RH9 tuhne
    Ja bych raději programoval v Kylixu (a Delphi) a né v C++Destructoru:-) S tim RH7.x vím, že funguje,ale přece nebudu přecházet na starší verzí.
    openSUSE 13.1, 13.2, 42.1
    Tomáš Bžatek avatar 25.12.2003 17:55 Tomáš Bžatek | skóre: 29 | Brno
    Rozbalit Rozbalit vše Kylix 3 pod RH9 tuhne
    To nevim, mne fungoval Kylix vzdycky pod jakoukoliv distribuci (SuSE nekolik verzi, gentoo momentalne). Spis to vidim na spatne nastaveny debugger nebo promenne prostredi.
    Koupim litajiciho tucnaka
    25.12.2003 19:09 Jirka S
    Rozbalit Rozbalit vše Kylix 3 pod RH9 tuhne
    Zrovna myslím tady kdosi kdysi psal, že Kylix pod RH8 a nevim jestli i RH9 nejde kvuli nějakému bugu a že mu to potvrdili i z Borland podpory. Zkusit Fedoru?
    27.12.2003 10:22 Howard | skóre: 17
    Rozbalit Rozbalit vše Kylix 3 pod RH9 tuhne
    Ja vim ze to psal. Ale zase někdo jinej píše, že mu to funguje i v RH9, tak co s tim? Ježišíííímarjááá Fedora...dobře dobře, ale přece nemůžu instalovat každých půl roku novej linux, vždyť to je ještě horší než wokna, vždyť w98 tu mam už 2 roky a XPčka rok, přece životnost linuxu musí bejt většíííííí :-))))
    openSUSE 13.1, 13.2, 42.1
    8.1.2004 15:37 Howard | skóre: 17
    Rozbalit Rozbalit vše Kylix 3 pod RH9 tuhne
    Planuju apgrejdovat na Fedoru. Mohlo by to pomoct aby Kylix netuhnul? Podařilo se vám někomu vyřešit to tuhnutí? Dost nutně bych kylix potřeboval a nevim co s tim. diq
    openSUSE 13.1, 13.2, 42.1
    17.9.2004 23:28 atr14
    Rozbalit Rozbalit vše Re: Kylix 3 pod RH9 tuhne
    Pouzivam Fedora Core 2 a na jednej masine mi Kylix 3 (open ani trial) nechcel ani nainstalovat --> zacyklil sa pri "Running script" tak, ze bolo treba killnut proces.

    Na druhej masine, tiez s FC2 mi Kylix 3 open nainstaloval, ale prezmenu sa v nom neda nic skompilovat, lebo kazdy druhy header vrati error (aspon v bcb, neviem ako je to v delphi).

    Zatial to s touto kompatibilitou vyzera biedne, takze prajem pevne nervy pri instalaci ak sa do toho niekto chce pustit. :0
    5.1.2004 12:25 Samael
    Rozbalit Rozbalit vše Kylix 3 pod RH9 tuhne
    No ja mam SuSE 8.2 a taky me to tuhne...Nevim cim to muze byt...Muzu delat co chci ale kdyz chci neco open nebo save tak jak se obevi dialog kam to ulozit nebo odkud otevrit tak se to kousne a musim to taky killnout...
    8.1.2004 16:02 Martin Krauskopf | skóre: 9
    Rozbalit Rozbalit vše Kylix 3 pod RH9 tuhne
    Dnes jsme instalovali Kylix 3 (open edition) kolegovi na Mandrake 9.2. Kylix neumi pracovat s glibc 2.2 a vyssi, tudiz je treba doinstalovat balicek compat-glibc pro verzi 2.1 a pak to sdelit kompilatoru (aby pouzival 2.1 namisto 2.2). Nevim jestli to vyresi tvuj problem a jestli si cet readme, tak uz si to stejne absolvoval ;)
    8.1.2004 18:41 kamil
    Rozbalit Rozbalit vše Kylix 3 pod RH9 tuhne
    S R.H jsem měl taky problem. Po dlouhém bádání jsem přešel na Mandrake 9.0. Není problém..... Kama
    8.1.2004 23:07 Howard | skóre: 17
    Rozbalit Rozbalit vše Kylix 3 pod RH9 tuhne
    Nejprve mam dotaz. Jsou v Kylixu 3 open edition take INDY komponenty ? Jestli ano, jake verze? Mohl bych poprosit o trochu pomoci nezkusenemu linuxovemu uzivateli? :-) Opravdu ten Kylix potrebuju nutne rozchodit. 1) Pochopil jsem, ze tam zrejme mam glibc naky verze > 2.1, jak to zjistim? Doufam ze to neni moc stupidni dotaz. Hledal jsem to po vsech certech (na linuxovym oddilu sem hledal Searchem v Krusaderu). Na 1.cd RH9 jsem nasel soubor glibc-2.3.2-11.9.i386.rpm, takze mam zrejme verzi 2.3.2 ? 2a) Kde vezmu tu starsi verzi a jak ji nainstaluju? Na cd RH7.3 jsem nasel glibc-2.2.5-34.i686.rpm, to asi ne. 2b) Kde vezmu to compat-glibc ? 3) Jak "sdelim" kompilatorovi, ze ma pouzivat starsi verzi? Je nutne Kylix znova nainstalovat? predem diq
    openSUSE 13.1, 13.2, 42.1
    9.1.2004 09:34 Martin Krauskopf | skóre: 9
    Rozbalit Rozbalit vše Kylix 3 pod RH9 tuhne
    Predem poznamenam, ze jsem hlavne Javar majici rad Linux a Cecko delam pouze okrajove a este k tomu pouze to "linuxove" ;). Kylix jsem pouze pomahal nainstalovat. 1) Tudiz jestli jsou v OE komponenty INDY, necham nekomu Kylixu znalemu. 2) My jsme to mozna resili moc slozite, protoze jsem se docet, ze existuje patch, ktery vse (a jeste neco navic ;) ) resi bez nutnosti instalace compat-glibc. Takze by ti melo stacit mrknout se na http://www.kylix-patch.de.vu/ 3) Nainstalovanou verzi glibc zjistis treba: "ls /lib/libc*" nebo "/lib/libc.so.6 | grep "GNU C Lib"" nebo tak jak si to zjistil ty sam ;)
    10.1.2004 18:01 Howard | skóre: 17
    Rozbalit Rozbalit vše Kylix 3 pod RH9 tuhne
    Diky za stranku o patchu, stahnul jsem si k3fix.tgz, rozbalil a spustil ./install, ale bohuzel at delam co delam, furt to hazi No Kylix installation directory found. You can start the install script with the kylix install directory. example: ./install /home/yourname/kylix3 Zkoumal jsem ty skripty, ktere se provadeji, vsiml jsem si, ze v souboru functions.sh je na zacatku funkce, ktera kontroluje pritomnost adresaru v adresari Kylixu, hleda tam adresare bin, lib, source/clx. Kdyz se kouknu do adresare Kylixu, tak bin a lib tam mam, ale source ne. Zkousel sem Kylix znova nainstalovat, ale moznost instalovat zdrojaky tam nebyla. Mam verzi enterprise. Tak jak mam ten patch nainstalovat? Narazil jsem na dalsi problem. Kdyz spustim Kylix (C++ IDE), zalozim novou aplikaci - prazdny formular - a necham ho prelozit, tak to nahlasi chybu, jako kdyz mam chybu ve zdrojovym kodu, pritom sem este nezacal programovat. Chyba je v nakym /usr/include/time.h na lajne 60,63,79,... Message catalog not found. To je opravdu fajn.
    openSUSE 13.1, 13.2, 42.1
    12.1.2004 09:15 Howard | skóre: 17
    Rozbalit Rozbalit vše Kylix 3 pod RH9 tuhne
    Stále nevím....prosím pomozte mi. Jakej je vůbec rozdíl mezi verzí enterprise a open? Já myslel, že v enterprise je toho víc, cožpak jsou v open i source ?
    openSUSE 13.1, 13.2, 42.1
    Tomáš Bžatek avatar 12.1.2004 12:22 Tomáš Bžatek | skóre: 29 | Brno
    Rozbalit Rozbalit vše Kylix 3 pod RH9 tuhne
    Samozrejme ze jsou, proto se to taky jmenuje Open Edition, kterazto pokud je licencovana pod GNU GPL musi obsahovat vsechny zdrojove kody. V Enterprise toho je mozna vic, ale Open Edition pro nektere jednodussi veci dostacuje. Pokud me pamet neklame, Borland dodava ve vsech placenych verzich i zdrojaky (pocinaje verzemi Professional), v Personal edicich samozrejme nejsou, v Open Edition byt musi. Nevim, myslim si ze v instalatoru Enterprise verze urcite budou, kdyztak nekde na CD. Zdrojaky jsou potreba k uspesnemu aplikovani patchu, nasledne je potreba rekompilace.
    Koupim litajiciho tucnaka
    12.1.2004 15:30 Howard | skóre: 17
    Rozbalit Rozbalit vše Kylix 3 pod RH9 tuhne
    Ja nemam zadny cd, ja jsem si enterprise verzi stahnul z webu borlandu (http://www.borland.com/products/downloads/download_kylix.html), instalovalo se to v konzoli, zadny zdrojaky mi to nenabidlo. Nainstalovalo se to do jednoho adresare /kylix3 (jenz sem napsal) a zadny source tam nebyly. Ma cenu tahat Open edition? Asi ne, co?
    openSUSE 13.1, 13.2, 42.1
    Tomáš Bžatek avatar 9.1.2004 12:58 Tomáš Bžatek | skóre: 29 | Brno
    Rozbalit Rozbalit vše Kylix 3 pod RH9 tuhne
    Divne... Mam original nepatchovanou verzi Kylix 3 OE a v systemu mam glibc 2.3.3_pre20031222, zadne jine verze (jako compat) tam nejsou a Kylix funguje naprosto bez problemu... (pouzivam gentoo ale to je jedno).
    Koupim litajiciho tucnaka
    13.1.2004 08:43 Howard | skóre: 17
    Rozbalit Rozbalit vše Kylix 3 pod RH9 tuhne
    Zkousel jste nekdo ve Fedore, jestli nejakej Kylix funguje? Prosim vas, vite nekdo jak nainstalovat ten patch? (resp.kde sehnat zdrojaky)
    openSUSE 13.1, 13.2, 42.1
    14.1.2004 08:09 Howard | skóre: 17
    Rozbalit Rozbalit vše Kylix 3 pod RH9 tuhne
    Zase jsem neco zkousel...stale nevim :-) pls help me
    openSUSE 13.1, 13.2, 42.1
    16.1.2004 14:50 Howard | skóre: 17
    Rozbalit Rozbalit vše Kylix 3 pod RH9 tuhne
    Rozhodl jsem se stahnout Kylix 3 open edition. Uvidime, jestli to bude fungovat.
    openSUSE 13.1, 13.2, 42.1
    16.1.2004 15:31 Martin Krauskopf | skóre: 9
    Rozbalit Rozbalit vše Kylix 3 pod RH9 tuhne
    Ten patch se stahne (patch) a spusti (./install) ;) Ted jsem to zkousel na Slackwaru a je to mnohem pohodlnejsi nez instalovat compat-glibc. Neni treba rootovskych prav a "neznecisti" to system. Tudiz doporucuju tuto cestu. Jinak hodne stesti! ;)
    16.1.2004 15:57 Howard | skóre: 17
    Rozbalit Rozbalit vše Kylix 3 pod RH9 tuhne
    Jo, ja ten patch uz mam. Ale o kousek vys jsem popsal, ze ho nemohu nainstalovat, protoze nemam zdrojaky, soucasne se ptam, kde je sezenu. At delam co delam, furt to hazi: No Kylix installation directory found. You can start the install script with the kylix install directory. example: ./install /home/yourname/kylix3 Zkoumal jsem ty skripty, ktere se provadeji, vsiml jsem si, ze v souboru functions.sh je na zacatku funkce, ktera kontroluje pritomnost adresaru v adresari Kylixu, hleda tam adresare bin, lib, source/clx. Kdyz se kouknu do adresare Kylixu, tak bin a lib tam mam, ale source ne. Zkousel sem Kylix znova nainstalovat, ale moznost instalovat zdrojaky tam nebyla. Mam verzi enterprise stazenou z borland.com. Tak jak mam ten patch nainstalovat?
    openSUSE 13.1, 13.2, 42.1
    16.1.2004 16:18 Martin Krauskopf | skóre: 9
    Rozbalit Rozbalit vše Kylix 3 pod RH9 tuhne
    Odpovidal jsem v threadu, kde pises, ze se pokusis instalovat Open Ed. a tam onen adresar je ;). S instalaci verze EE nemam zkusenosti. Patch je podle vseho pouze pro OE. Pro EE asi neni treba ;)
    Tomáš Bžatek avatar 16.1.2004 21:17 Tomáš Bžatek | skóre: 29 | Brno
    Rozbalit Rozbalit vše Kylix 3 pod RH9 tuhne
    To si nemyslim, treba problem s execve bude asi vsude stejny neb preklad Libc je jenom jeden.
    Koupim litajiciho tucnaka
    19.1.2004 20:56 Howard | skóre: 17
    Rozbalit Rozbalit vše Kylix 3 pod RH9 tuhne
    Tak jsem si nainstaloval Open Edition. Bohuzel tam nejsou INDY komponenty ani dbExpres, doufam, ze je tam nak domlatim. Source tam jsou !!! Bohuzel mi nejde Kylix OE zaregistrovat, ja bych do toho kopnul.
    openSUSE 13.1, 13.2, 42.1
    19.1.2004 21:25 Howard | skóre: 17
    Rozbalit Rozbalit vše Kylix 3 pod RH9 tuhne
    Nuze, Open Edition Kylix 3 uz lze spustit, bohuzel PROBLEMY se spoustenim aplikaci ZUSTAVAJI. Ani nejakej patch stazenej z borlandu nepomohl (ale mam pocit ze opravoval neco jinyho). Zkousim instalovat naky neoficialni patchy, bohuzel nedari se. Ja se z toho po...
    openSUSE 13.1, 13.2, 42.1
    19.1.2004 21:48 Howard | skóre: 17
    Rozbalit Rozbalit vše Kylix 3 pod RH9 tuhne
    Takze ani neoficialni patchy k3fix.tgz a k3patchesnc.tgz, jak mi poradil nekdo vyse, NEZABRALI. Mel jsem potize s jejich instalaci, nechteli nalezt adresar kylixu, zajimavy, ze kdyz jsou v rozbalenem stavu zakopany hloubeji nez v 2 adresarove urovni, tak kylix nenajdou. Tak jsem to zkopiroval do rootu a uz to jelo. Lec zel bohu, nic to nevyresilo. Mate nekdo nejakej napad? Je tu nekdo, kdo pouziva Fedoru a beha mu to v ni?
    openSUSE 13.1, 13.2, 42.1
    22.1.2004 22:06 Howard | skóre: 17
    Rozbalit Rozbalit vše Kylix 3 pod RH9 tuhne
    Zkusil sem reinstal kylixu, nic nezabralo. Stale nikdo nevite?
    openSUSE 13.1, 13.2, 42.1
    23.1.2004 09:00 Lubosh
    Rozbalit Rozbalit vše Kylix 3 pod RH9 tuhne
    Jelikoz jsem absolvoval podobne muka jako ty, muzu poradit: RH9 ma problemy s Kylixem predevsim z duvodu rozdilnych nastaveni systemovych promenych a glibc. I po překonani techto problemu by si narazil na problemy se zobrazovanim cestiny, protoze RH9 defautne pouziva UTF-8. Knihovna Compat-glib.... se instaluje jak jiz nekdo psal kvuli nekompatibilite Kylixu s novou verzi, takze ji vlastne downgradujes na starsi verzi. Pozor! Tohle ale plati pouze pro Kylix C++ (viz. chyba "..Time.h..."pri kompilaci). Pascalovska cast Kylixu muze kompilovat bez problemu. Ty kecy, ze kylix je oficialne testovan na RH7.2 Suse8 atd. jsou jen alibismus Borlandu, aby se nemusel starat o svuj produkt při kazde nove distribuci Linuxu. Mimochodem bych to taky nechtel delat.
    Stojim si za tim, ze momentalne nejlepsi distribuce vhodna pro Vyvoj v Kylix3 je Mandrake 9.2. Mam Kylix 3 Professional, ale zkousel jsem i Open verzi. Všechny vyse uvedene problemy vcetne cestiny, krome Compat-glibc (pokud pouzijes KylixC++) jsou tam vyreseny. staci nainstalovat a spustit.
    Pozn.:Indy komponenty se daji stahnout a obdoba dbExpress taky.
    23.1.2004 10:24 Howard | skóre: 17
    Rozbalit Rozbalit vše Kylix 3 pod RH9 tuhne

    Hmm, hmm. Dekuju mnohokrat za informace !
    Ja mam takovy pocit, ze me uz to dal nebavi, navic bych se v tuto chvili musel zeptat:

    • Jak nainstalovat starsi Compat-glib ?
    • Co to vubec je?
    • Kde to sezenu?

    Mate nekdo jeste naladu odpovedet mi na tyhle otazky jako pro blbce? :-)

    Jestlize by mi fungovalo jenom C++ IDE Kylixu, tak to by mi uuuuplne stacilo.

    Nejspis to udelam tak, ze si sezenu ten Mandrake 9.2, kamos ho pouziva a vychvaluje ho kudy chodi :-), aspon uvidim i neco jinyho nez RedHaty a jestli v tom ten Kylix pojede bez problemu....... tak neni co resit.

    Jinak, pro informaci.
    Pred chvili jsem se snazil Kylix nainstalovat Pod FC1 ... katastrofa, instalator hazi nakou chybu, chybi mu nakej gjpeg nebo co, mozna ze jsem to tam zapomnel nainstalovat, ja uz nevim. V RH9 sem to aspon nainstaloval, ve FC vubec ne.
    Chtel bych vas znovu poprosit, mate nekdo FC1 ? Zkuste prosim nainstalovat Open verzi Kylixu, zda vam to bude fungovat.


    Diky vsem za snazeni, jeste se ozvu jak s tim Mandrake.
    openSUSE 13.1, 13.2, 42.1
    24.1.2004 19:23 Howard | skóre: 17
    Rozbalit Rozbalit vše Kylix 3 pod RH9 tuhne
    Mozna pomuze tohle... http://forums.devshed.com/t69934/s.html dam vedet.
    openSUSE 13.1, 13.2, 42.1
    25.1.2004 23:30 Howard | skóre: 17
    Rozbalit Rozbalit vše Kylix 3 pod RH9 tuhne
    Takze jestli to jeste nekoho zajima, povedlo se mi rozjet Delphi IDE v Kylixu 3 Open edition, to vypada, jako ze funguje. Postupoval jsem podle navodu ve vyse uvedenem odkazu, nainstaloval starsi compat-glibc, donutil kylix aby to starsi pouzival. Bohuzel C++ IDE stale nefunguje, ale uz to nepise chybu v time.h, ale pise nasledujici: [Linker Error] Unresolved external '__fastcall Qforms::TCustomForm::ChangeBounds(int, int, int, int)' referenced from Unit1.o [Linker Error] Unresolved external '__fastcall Qforms::TCustomForm::GetGeometry(Types::TRect *)' referenced from Unit1.o [Linker Error] Unresolved external '__fastcall Qforms::TCustomForm::SetGeometry(int, int, int, int)' referenced from Unit1.o Prozatim nevim co s tim dal. V dohledne dobe planuju nainstalovat ted Mandrake 9.2.
    openSUSE 13.1, 13.2, 42.1
    25.1.2004 23:55 Howard | skóre: 17
    Rozbalit Rozbalit vše Kylix 3 pod RH9 tuhne
    Ted sem nainstaloval enterprise verzi a v te pro zmenu funguje c++ ide ale zase nefunguje Delphi (sice to nezamrza, ale nic se nespusti)
    openSUSE 13.1, 13.2, 42.1
    29.1.2004 10:03 Howard | skóre: 17
    Rozbalit Rozbalit vše Kylix 3 pod RH9 tuhne
    Ve Fedora Core 1 to blbne stejně, jako v RH9.
    Navíc jsem při instalaci musel spustit setup.sh s parametrem -m.
    Snad to pude spravit stejně, jako RH9. Zítra snad už konečně nainstaluku mdk 9.2, uvidíme, jak to pude tam.
    openSUSE 13.1, 13.2, 42.1
    16.1.2004 18:06 Jiří Blahovský
    Rozbalit Rozbalit vše Kylix 3 pod RH9 tuhne
    Nevím, ja nainstalovat patch, ale Kylix používám doma na Slacku 9.1 a v práci na Aurox9, což je vlastně RH9. V auroxu mi to taky tuhlo po zkompilování projektu a ještě někde, tak jsem dost dlouho pročítal návody k Auroxu a našel jsem, že v jádře je nějaká nová podpora ntpl či co a že s tím můžou mít nějaké programy problémy. Tak jsem napsal export nějaké proměnné do startovacího skriptu kylixu a najednou to začalo fungovat. Nicméně nemohu skutečně říct, zda to bylo tím, ale asi jo. Do práce jdu zejtra, takže co exportnout můžu napsat až v neděli. Jinak jsem zatím "vykylixoval" toto: http://www.hi-net.cz/blaza/bfcommander/bfc1.png
    30.1.2004 18:04 Howard | skóre: 17
    Rozbalit Rozbalit vše Kylix 3 pod RH9 tuhne
    Nainstaloval jsem Mandrake 9.2. Nainstaloval Kylix 3 enterprise, Delphi IDE se spusti, programy jdou kompilovat, ale kdyz neco spustim, tak se to neobjevi a rovnou se to vrati zpet do prostredi kylixu. C++ IDE se mi vubec nespusti.
    openSUSE 13.1, 13.2, 42.1
    30.1.2004 18:22 Howard | skóre: 17
    Rozbalit Rozbalit vše Kylix 3 pod RH9 tuhne
    Kylix 3 open vypada lip...lze spustit program, ale pri spousteni Delphi IDE to hlasilo milion erroru typu "cant load package" to je hrozny. C++ ide opet nefunguje. Nekdo mi tu radil, ze pro kylix je nejlepsi Mandrake 9.2 a ze to funguje dobre... tak asi ne.
    openSUSE 13.1, 13.2, 42.1
    13.2.2004 14:54 Howard | skóre: 17
    Rozbalit Rozbalit vše HOTOVO, VYRESENO

    Takze diky vsem co mi radili
    (zejmena uzivateli Lubosh a odkazu http://forums.devshed.com/t69934/s.html ktery jsem si nasel sam :-) a v nemz jsem nasel nejvice informaci )

    Konecne se mi dnes podarilo rozchodit Kylix 3 Open (Delphi i C++ IDE) pod Fedora Core 1 a i pod Mandrake 9.2, popisu vam jak.

    • (rozbalit a )nainstalovat Kylix 3 open prikazem
      ./setup.sh -m
      kdyz tam neni -m tak to hodi chybu.

    • Sledovat pri instalaci, nekde veprostred to muze hodit nasledujici chybu :
       100% - /usr/local/kylix3/privacy.txt
       100% - /usr/local/kylix3/oe.slip
         0% - Running script
      ls: /usr/lib/libstdc++-3*.so: No such file or directory
      Installing Help Files ...
       100% - /usr/local/kylix3/delphi_help.xpm
       100% - /usr/local/kylix3/documentation/K3CLXposter.pdf 
      
      Ono se to sice normalne doinstaluje, ale tu knihovnu musite nainstalovat, jinak nebude fungovat C++ IDE. U Mandrake i u Fedory jsem ji nasel na 3. instalacnim cdcku, instalace samozrejme rpm -Uvh (nakej rpm s tim nazvem)
      Nejjednoduseji se to da udelat tak, ze najedete Krusaderem na soubor
      kylix3_main_program_files-1.0-1.i386.rpm, kterej je v setup.data/packages v tom adresari, kam jste rozbalil kylix 3 open a "odenterujete" nebo date pravy tlacitko a "nainstalovat" spusti se nakej grafickej program na instalaci RPM balicku a ten vas vyzve k vlozeni tretiho instalacniho cdcka od vasi distribuce. Stalo se mi, ze to nejak z cd nechtel najit, tak to lze nainstalovat rucne tim prikazem rpm -Uvh presny nazev rpm baliku ten grafickej program napise a na tom cd bude.

    • Jakmile tam bude nainstalovana tahle knihovna, tak se C++ IDE normalne spusti. Problem je, ze pri pokusu zkompilovat prazdny formular to hodi chybu ve zdrojacich konkrente
      v /usr/include/time.h
      To se da spravit instalaci starsi verze compat-glibc (najdete a stahnete):
      Pro RedHat:
      http://rpmfind.net/linux/RPM/   - hledat compat-glibc-6.2-2.1.3.2.i386.rpm
      Pro Mandrake:
      http://www.google.com    - hledat "compat-glibc mandrake" ( compat-glibc-7.2-2.1.3.3mdk.i586.rpm )
      
      Nainstalovat prikazem rpm -Uvh compat-glibc.....
      
      Dale je nutne spustit Kylix c++ ide, kouknout se do Project -> Options -> Directories/conditionals.
      V poli Include smazat /usr/include a dat na zacatek /usr/i386-glibc21-linux/include
      V poli Library smazat /usr/lib a dat na zacatek /usr/i386-glibc21-linux/lib Pak uz jenom zaskrtnout dole Default aby tohle nastaveni bylo i v nove zalozenych projektech.

      Pote pujde nejen spustit Kylix 3 c++ ide, ale dokonce i prelozit program, bohuzel po spusteni treba prazdneho formulare se komplet cely Kylix zasekne, coz byl muj problem uplne na zacatku.


    • To se da spravit dopsanim jedne radky do spoustecich skriptu Kylixu.
      Editujte nasledujici soubory:
      /bin/startdelphi
      /bin/startbcb 
      
      A dopiste tam na druhy radek, primo za #!/bin/bash:
      
      export LD_ASSUME_KERNEL=2.2.5 
      
      

    • Zkuste znova spustit Kylix C++ ide a melo by to v pohode chodit!!! Pokud jeste neco nebude fungovat, zkuste si procist
      http://forums.devshed.com/t69934/s.html
      popripade cely tento prispevek, o kus vyse mi nekdo poradil 2 patchy, ktery mi ale nepomohli, mozna v necim pripade pomuzou.

    Nuze, takto jsem nyni vyresil problemy s Kylixem 3 open v FC1 a MDK9.2, necht tento navod poslouzi dalsim. ;-)
    Howard
    openSUSE 13.1, 13.2, 42.1
    29.4.2004 18:46 Howard | skóre: 17
    Rozbalit Rozbalit vše Re: HOTOVO, VYRESENO
    Jeste jeden detail.

    Aby bylo mozne spoustet prekompilovane programy i odjinud, nez z kylixu, tak je nutne zkopirovat knihovnu

    libborqt-6.9.0-qt2.3.so

    ktera se nachazi v cesta_kylix3/bin, do adresare

    /usr/lib
    openSUSE 13.1, 13.2, 42.1
    16.5.2004 10:29 karlok
    Rozbalit Rozbalit vše Re: HOTOVO, VYRESENO
    Man Fedoru Core 1 a Kylix 3 OE, nejdriv jsem instaloval path z http://www.kylix-patch.de.vu/ ,ale nepomohl, tak jsem do spousteciho skriptu (.../kylix3/bin/startdelphi) na zacatek pridal nasledujici radek

    export LD_ASSUME_KERNEL=2.4.1

    a uz je vse OK.
    1.6.2004 14:39 Howard | skóre: 17
    Rozbalit Rozbalit vše Re: HOTOVO, VYRESENO
    Je to mozne, ale asi si nezkousel c++ ide. A ja potreboval rozchodit verzi enterprase.
    openSUSE 13.1, 13.2, 42.1
    19.11.2004 10:12 Howard | skóre: 17
    Rozbalit Rozbalit vše Re: Kylix 3 pod RH9 tuhne
    Dnes se snazim nainstalovat Kylix 3 enterprase na Fedora Core 2, narazim na chybu pri spousteni C++ ide:

    /usr/local/kylix3/bin/bcblin: error while loading shared libraries: libstdc++-libc6.1-1.so.2: cannot open shared object file: No such file or directory

    Snazim se googlit tu vec, co chybi, nemuzu ji presne najit, par veci sem uz postahoval a nainstaloval ale stejne to nepomaha.
    openSUSE 13.1, 13.2, 42.1
    Tomáš Bžatek avatar 19.11.2004 10:17 Tomáš Bžatek | skóre: 29 | Brno
    Rozbalit Rozbalit vše Re: Kylix 3 pod RH9 tuhne
    No... par lidi mne reportuje problemy, ze pri pokusu o spusteni na FC2 nebo FC3 program ohlasi runtime error a spadne. Mozna to s timto bude souviset.

    1. Jedou zkompilovane Kylixovske aplikace?

    2. Je v systemu podpora pro NPTL?

    3. zkusit najit v distribuci jeste jine balicky s glibc - bez nptl podpory
    Koupim litajiciho tucnaka
    19.11.2004 10:22 Howard | skóre: 17
    Rozbalit Rozbalit vše Re: Kylix 3 pod RH9 tuhne
    No vida, konecne sem ji nasel.

    http://www.sqldesktop.com/download/libstdc++-2-libc6.1-1-2.9.0.so

    Pote se musi napsat prikaz:

    ln -s libstdc++-2-libc6.1-1-2.9.0.so libstdc++-libc6.1-1.so.2

    a C++ IDE se spusti.
    openSUSE 13.1, 13.2, 42.1
    19.11.2004 10:31 Howard | skóre: 17
    Rozbalit Rozbalit vše Re: Kylix 3 pod RH9 tuhne
    Sice se spustil, ale kdyz jsem nastavil ty Include a Library, jak popisuji v tom dlouhem prispevku, tak C++ IDE pri kompilaci vybouchne, kdyz kompiluje, tak najednou zmizi a je pryc. Ach jo.
    openSUSE 13.1, 13.2, 42.1
    Tomáš Bžatek avatar 19.11.2004 12:32 Tomáš Bžatek | skóre: 29 | Brno
    Rozbalit Rozbalit vše Re: Kylix 3 pod RH9 tuhne
    No se divis kdyz tam roubujes jakousi binarku z pochybne distribuce. Prvni bych zkusil najit neco primo od Fedory - staci hledat libstdc++-2-libc6.1.so
    Koupim litajiciho tucnaka
    15.1.2005 20:32 rowman
    Rozbalit Rozbalit vše Kylix3 Open, Fedora3 - nelze spustit
    ahoj, ja jsem asi uplne blbej, navic linuxovej zacatecnik, mam fedora3 a stahnul jsem si kylix3, instalace se tvarila normalne spokojene, ale kdyz pustim startdelphi, tak to par vterin premejsli a neudela naprosto nic - ani hlasku. Cim to muze byt - je faktem, ze ten jejich patch co je na borlandu na downloadu jsem si zatim nenainstaloval, zkusim to ted a kdyz nic pak to asi vsechno smazu :-( Diky za pomoc.
    Tomáš Bžatek avatar 15.1.2005 20:46 Tomáš Bžatek | skóre: 29 | Brno
    Rozbalit Rozbalit vše Re: Kylix3 Open, Fedora3 - nelze spustit
    Cau, zkus to pustit v terminalu, melo by to neco napsat. Jinak Google, tusim ze tam bude problem s ld --> pak staci nastavit promennou LD_ASSUME_KERNEL=2.4 treba
    Koupim litajiciho tucnaka

    Založit nové vláknoNahoru

    Tiskni Sdílej: Linkuj Jaggni to Vybrali.sme.sk Google Del.icio.us Facebook

    ISSN 1214-1267   www.czech-server.cz
    © 1999-2015 Nitemedia s. r. o. Všechna práva vyhrazena.