abclinuxu.cz AbcLinuxu.cz itbiz.cz ITBiz.cz HDmag.cz HDmag.cz abcprace.cz AbcPráce.cz
AbcLinuxu hledá autory!
Inzerujte na AbcPráce.cz od 950 Kč
Rozšířené hledání
×
eParkomat, startup z ČR, postoupil mezi finalisty evropského akcelerátoru ChallengeUp!
Robot na pivo mu otevřel dveře k opravdovému byznysu
Internet věcí: Propojený svět? Už se to blíží...
dnes 06:00 | Komunita

Na YouTube byl publikován Blender Institute Reel 2016, ani ne dvouminutový sestřih z filmů, které vznikly za posledních 10 let díky Blender Institutu. V institutu aktuálně pracují na novém filmu Agent 327. Dění kolem filmu lze sledovat na Blender Cloudu. Videoukázka Agenta 327 z června letošního roku na YouTube.

Ladislav Hagara | Komentářů: 0
dnes 01:02 | Zajímavý článek

Minulý týden byly vydány verze 1.2.3 a 1.1.7 webového poštovního klienta Roundcube. V oznámení o vydání bylo zmíněno řešení bezpečnostního problému nalezeného společností RIPS a souvisejícího s voláním funkce mail() v PHP. Tento týden byly zveřejněny podrobnosti. Útočník mohl pomocí speciálně připraveného emailu spustit na serveru libovolný příkaz. Stejně, jak je popsáno v článku Exploit PHP’s mail() to get remote code execution z roku 2014.

Ladislav Hagara | Komentářů: 0
včera 16:00 | Nová verze

Byla vydána verze 0.98 svobodného nelineárního video editoru Pitivi. Z novinek lze zmínit například přizpůsobitelné klávesové zkratky. Videoukázka práce s nejnovější verzí Pitivi na YouTube.

Ladislav Hagara | Komentářů: 1
včera 15:00 | Zajímavý software

Stop motion je technika animace, při níž je reálný objekt mezi jednotlivými snímky ručně upravován a posouván o malé úseky, tak aby po spojení vyvolala animace dojem spojitosti. Jaký software lze pro stop motion použít na Linuxu? Článek na OMG! Ubuntu! představuje Heron Animation. Ten bohužel podporuje pouze webové kamery. Podpora digitálních zrcadlovek je začleněna například v programu qStopMotion.

Ladislav Hagara | Komentářů: 3
7.12. 21:21 | Nová verze Ladislav Hagara | Komentářů: 0
7.12. 11:44 | Zajímavý projekt

Na Indiegogo byla spuštěna kampaň na podporu herní mini konzole a multimediálního centra RetroEngine Sigma od Doyodo. Předobjednat ji lze již od 49 dolarů. Požadovaná částka 20 000 dolarů byla překonána již 6 krát. Majitelé mini konzole si budou moci zahrát hry pro Atari VCS 2600, Sega Genesis nebo NES. Předinstalováno bude multimediální centrum Kodi.

Ladislav Hagara | Komentářů: 2
7.12. 00:10 | Nová verze

Byla vydána verze 4.7 redakčního systému WordPress. Kódové označením Vaughan bylo vybráno na počest americké jazzové zpěvačky Sarah "Sassy" Vaughan. Z novinek lze zmínit například novou výchozí šablonu Twenty Seventeen, náhledy pdf souborů nebo WordPress REST API.

Ladislav Hagara | Komentářů: 8
6.12. 12:00 | Zajímavý projekt

Projekt Termbox umožňuje vyzkoušet si linuxové distribuce Ubuntu, Debian, Fedora, CentOS a Arch Linux ve webovém prohlížeči. Řešení je postaveno na projektu HyperContainer. Podrobnosti v často kladených dotazech (FAQ). Zdrojové kódy jsou k dispozici na GitHubu [reddit].

Ladislav Hagara | Komentářů: 27
6.12. 11:00 | Bezpečnostní upozornění

Byly zveřejněny informace o bezpečnostní chybě CVE-2016-8655 v Linuxu zneužitelné k lokální eskalaci práv. Chyba se dostala do linuxového jádra v srpnu 2011. V upstreamu byla opravena minulý týden [Hacker News].

Ladislav Hagara | Komentářů: 2
5.12. 22:00 | Komunita

Přibližně před měsícem bylo oznámeno, že linuxová distribuce SUSE Linux Enterprise Server (SLES) běží nově také Raspberry Pi 3 (dokumentace). Obraz verze 12 SP2 pro Raspberry Pi 3 je ke stažení zdarma. Pro registrované jsou po dobu jednoho roku zdarma také aktualizace. Dnes bylo oznámeno, že pro Raspberry Pi 3 je k dispozici také nové openSUSE Leap 42.2 (zprávička). K dispozici je hned několik obrazů.

Ladislav Hagara | Komentářů: 6
Kolik máte dat ve svém domovském adresáři na svém primárním osobním počítači?
 (32%)
 (24%)
 (29%)
 (8%)
 (5%)
 (3%)
Celkem 799 hlasů
 Komentářů: 50, poslední 29.11. 15:50
Rozcestník
Reklama

Dotaz: glibc 3.2.3 nekompatibilitas glibc 3.2.2

1.4.2005 19:44 psYcOder | skóre: 5
glibc 3.2.3 nekompatibilitas glibc 3.2.2
Přečteno: 42×
Mam problem s kompilaci zdrojoveho kodu,konkretne knihovny inti, s verzi glibc 3.2.3 ...s glibc 3.2.2 to jeste jde,ale s novejsi dostavma chyby typu
/usr/include/bits/stdio.h: In function `int getchar()':
/usr/include/bits/stdio.h:42: declaration of `int getchar()'
throws different exceptions /usr/lib/gcc-lib/i486-slackware-linux/3.2.3/include/stdio.h:394:
than previous declaration `int getchar() throw ()'
/usr/include/bits/stdio.h: In function `int
getc_unlocked(FILE*)':
/usr/include/bits/stdio.h:51: declaration of `int
getc_unlocked(FILE*)' throws different exceptions
....
je mozne docilit nejak kompatibily bezprepisovani zdrojaku? aniz bych musel degradova t z glibc 3.2.3 na 3.2.2 ? eventuelne nainstalovat obe verze a pak pres nejakou sys.promennou switchnout,ale to by zas bylopeklo s prepisovanim makefilu,a do toho se mi mocnechce,protoze jich v celem projektu je docela dost;/ Neaka idea jak zkompilovat knihovnu psanou ve starsi glibc s glibc 3.2.3?
jedna se o to ze downgeade glibc byznamenal downgrade minimalne pulky celeho meho linux os J

Odpovědi

1.4.2005 19:52 zabza | skóre: 52 | blog: Nad_sklenkou_cerveneho
Rozbalit Rozbalit vše Re: glibc 3.2.3 nekompatibilitas glibc 3.2.2
Pletete dohromady gcc a glibc. Co dělá stdio.h v includes gcc-éčka? Máte popletený nejen pojmy, ale i hlavičkové soubory!
1.4.2005 20:07 psYcOder | skóre: 5
Rozbalit Rozbalit vše Re: glibc 3.2.3 nekompatibilitas glibc 3.2.2
mam i nemam...tamto je vypis make, a dokud jsem mel na slacku 9.1 s puvodni gcc(ted neivm jaka tam je verze z hlavy),kazdopadne ji tam mam porad, protoze novejsimi dela jeste vetsi bordel, tak to zkompilovat slo...ale po upgrade na glibc 3.2.3 to uz proste nejde,tak proto se odvolavam na glibc a ne na gcc...upgrade gcc mi je na nic protoze to uz vim ze zkusenosti ze to znamena poupravit z originalni knihovny docela dost kodu a ve finale to ztraci vyznam s nekompatibilou systemu,kam je aplikace urcena..proste potrebuju mit puvodni gcc ze slacka 9.1 a novejsi glibc...po instalaci novejsi glibc to proste zkompilovat nejde a z vypisu make nevim kde napravit chybu ve zdroji...idelani by bylo mit obe verze glibc a nejak se mezi nimi switchnout res nejakou systemovou promennou,ale to fakt netusim a myslim ze byto bylo dost prace a zaroven dost naslednych problemu...tak jestli je zpusob jak s novejsiglibczkompilovat "starsi" zdrojak???
1.4.2005 20:24 zabza | skóre: 52 | blog: Nad_sklenkou_cerveneho
Rozbalit Rozbalit vše Re: glibc 3.2.3 nekompatibilitas glibc 3.2.2
Máte to popletený, já si na první přečtění nevšiml, ale glibc je verze 2.3.4, kdežto gcc je už 3.4.3 (ty verze jsou teda tak jak to mám nainstalované já, ale rozdíl snad vidíte). Takže by stálo zato se zamyslet, o co vlastně jde, a napsat ten dotaz znova (pokud se to nevyřeší tím zamyšlením tedy ... :-) )
2.4.2005 13:32 psYcOder | skóre: 5
Rozbalit Rozbalit vše Re: glibc 3.2.3 nekompatibilitas glibc 3.2.2
ano mate pravdu,trochu sem ty verze popletl,tak budu dotaz formulovat jinak: ke svemu sw potrebuji knihovnu inti,kterou zkompiluji s glibc nejvys 2.3.2,pri vyssi verzi uz inti zkompilovat nejde. Pro kompilaci aplikace vyuzivajici inti mohu pouzit vyssi glibc bez problemu,ale nefunguje kompilace s gcc > 3.2.3 ,kterou na systemu potrebuji z tohoto duvodu zachovat a tak pripadny upgrade na vyssi verzi nepripada v uvahu. Bohuzel potrebuji v systemu kvuli kompatibile s programy glibc 2.3.4,kterou mam nainstalovanou a tak potrebuju vedet jak zkompilovat inti s verzi glibc 2.3.4, ktera fungovala nejvys s verzi 2.3.2. Takze vlastne gcc mi tu zas takovou roli v problemu nehraje,ale pouze novejsi verze glibc dela problemy.
2.4.2005 14:15 unchallenger | skóre: 69 | blog: unchallenger
Rozbalit Rozbalit vše Re: glibc 3.2.3 nekompatibilitas glibc 3.2.2
ke svemu sw potrebuji knihovnu inti

Inti nikdy nebude fungovat s Gtk+ 2.4 a novějším, které je dnes prakticky všude, a kde není, tam brzy bude. Tedy pokud někdo nepřepíše části, které chybně hrabou na interní funkce a data Gtk+.

Tudíž to je od začátku beznadějná situace, a že se případně nezkompiluje, to jen taková třešnička na dortu...
2.4.2005 15:22 psYcOder | skóre: 5
Rozbalit Rozbalit vše Re: glibc 3.2.3 nekompatibilitas glibc 3.2.2
to pravda...nicmene z techto duvodu musim pouzivat starsi versi slacku 9.1 kde jejeste starsi gtk...ale i tak,inti obsahuje pouze par funkci ktere jsou oproti gtk 2.4 deprecated,a jejich odstraneni ze zdroju na funkcnosti inti nic nemeni,tohle jsem defakto vyresil..jedna se cca o 5 funkc ktere uz dnes stejne nejsou nikde vyuzivany ani uvnitr inti. Inti je uz dnes zastarala, a jeji vyvoj pokracuje pod novym projektem GFC. Jenze prepsat docela rozsahly projekt zalozeny na inti pro me neni ve finale reseni. Proto bych to rad zkompiloval na podminkach o kterych jsem se zminoval. Nacpat si do slacka glibc 2.3.2, kterej defakto byl puvodne na slacku 9.1,ale tomu upgradu na novou glibc se dnes vyhnout neda,by pro me znamenalo downgrade skoro pulky meho slacku.Proto hledam reseni jak to zkompilovat s novejsi glibc. Nejaka zpetna kompatibilita ci tak. Nejaky prepinac pro kompilator,sys promenne,nebo mit treba na os nainstalovane obe verze glibc a pouze pri kompilaci pouzivat starsi verzi,ale to nevim jak,protoze v programovani na linuxove platforme zas tak zbehly jeste nejsem...

Založit nové vláknoNahoru

Tiskni Sdílej: Linkuj Jaggni to Vybrali.sme.sk Google Del.icio.us Facebook

ISSN 1214-1267   www.czech-server.cz
© 1999-2015 Nitemedia s. r. o. Všechna práva vyhrazena.