abclinuxu.cz AbcLinuxu.cz itbiz.cz ITBiz.cz HDmag.cz HDmag.cz abcprace.cz AbcPráce.cz
AbcLinuxu hledá autory!
Inzerujte na AbcPráce.cz od 950 Kč
Rozšířené hledání
×
    dnes 10:33 | IT novinky

    Rodina produktů Raspberry Pi se rozšířila o Raspberry Pi Smart Display Module. Deska pro Raspberry Pi Compute Module 5 se zasouvá přímo do displejů dle specifikace Intel SDM. Cena desky je 30 dolarů.

    Ladislav Hagara | Komentářů: 1
    včera 23:44 | Nová verze

    Byla vydána nová verze 2.56.0 distribuovaného systému správy verzí Git. Přispělo 104 vývojářů, z toho 39 nových. Přehled novinek v příspěvku na blogu GitHubu a v poznámkách k vydání.

    Ladislav Hagara | Komentářů: 1
    včera 21:22 | Bezpečnostní upozornění

    Hackerská skupina ShinyHunters oznámila průnik do informačních systémů FBI, prostřednictvím zero-day zranitelnosti v platformě Oracle PeopleSoft, kterou úřad využívá mimo jiné pro náborový portál FBIJobs.gov. Útočníci tvrdí, že získali až 3 TB dat o současných i bývalých zaměstnancích a uchazečích o práci. Jako důkaz zveřejnili vzorek přibližně 5 000 záznamů obsahující jména, adresy, telefonní čísla, data narození, čísla

    … více »
    AfD 💙 | Komentářů: 2
    včera 21:11 | Zajímavý článek

    Doba kompilace linuxového jádra se díky rychlejšímu hardwaru a optimalizacím kbuildu snižuje k deseti sekundám. Nejnovější patche Lorenza Stoakse (vznikají i s pomocí SI) zkrátily na testovacím stroji dobu sestavení z dlouhých 22 vteřin na pouhých 15, a to bez použití RAMdisku. Testovací systém tvořily dva procesory AMD EPYC 9575F (oba dohromady poskytují celkem 128 jader a 256 vláken), čtyřiadvacet 64GB DDR5-6400 paměťových modulů a

    … více »
    AfD 💙 | Komentářů: 10
    včera 01:33 | Komunita

    Před rokem a půl vývojáři postmarketOS informovali, že pro projekt hledají nové jméno. Včera bylo oznámeno: postmarketOS se nově jmenuje Nura.

    Ladislav Hagara | Komentářů: 6
    27.9. 13:44 | Zajímavý projekt

    Hra Factorio dorazila na Printables. Hned teď si můžete stáhnout 65 různých modelů a nechat celou mimozemskou planetu oživnout na svém stole.

    Ladislav Hagara | Komentářů: 13
    26.9. 19:22 | Nová verze

    GNU Project Debugger aneb GDB byl vydán ve verzi 18.1. Podrobný přehled novinek v souboru NEWS.

    Ladislav Hagara | Komentářů: 0
    25.9. 23:33 | Humor

    Prezident USA Donald Trump během svého projevu na valném shromáždění OSN 22. září 2026 prohlásil, že umělá inteligence 'bude dále oficiálně nazývána superinteligencí', zkráceně SI. Svůj návrh zdůvodnil takto: 'Použití slova artificial činí inteligenci falešnou. Ona falešná není, ve skutečnosti je úžasná'. Zároveň ve svém proslovu prohlásil, že Spojené státy kategoricky odmítají jakékoliv pokusy o vytvoření 'globalistického

    … více »
    AfD 💙 | Komentářů: 26
    25.9. 23:22 | Nová verze

    Čínská technologická firma Xiaomi představila novou verzi 2.6 svého modelu MiMo, váhy modelů MiMo‑V2.6‑Pro‑RL a MiMo‑V2.6‑Flash‑RL jsou dostupné na HuggingFace pod licencí MIT. Výkonnější varianta Pro má přes bilion parametrů, z toho 42 miliard aktivních, úspornější Flash 309 miliard parametrů, z nichž se při generování aktivuje přibližně 15 miliard. Oba modely mají délku kontextového okna milion tokenů. Tyto MoE modely zvládají

    … více »
    AfD 💙 | Komentářů: 1
    25.9. 03:33 | Komunita

    Proběhl Snapdragon Summit 2026. Společnost Qualcomm se mimo jiné pochlubila během Linuxu na čipech Snapdragon X2. Zatím pouze v ranní verzi vhodné pro vývojáře linuxových distribucí a přispěvatele do jádra Linux.

    Ladislav Hagara | Komentářů: 0
    Které desktopové prostředí na Linuxu používáte?
     (9%)
     (7%)
     (4%)
     (21%)
     (29%)
     (8%)
     (5%)
     (2%)
     (14%)
     (20%)
    Celkem 2748 hlasů
     Komentářů: 31, poslední 13.8. 00:27
    Rozcestník

    Dotaz: Unable to establish connection to MySQL

    23.2.2012 07:07 jany2 | skóre: 30 | blog: jany_blog
    Unable to establish connection to MySQL
    Přečteno: 1024×

    Zdravim.

    Na lokalnom stroji mam ubuntu server a nainstalovany aj LAMP a asi 4 roky funguje bezproblemovo. V /var/www mam ulozene subory (php fusion) a bezi mi na servery aj cacti. Vcera php fusion este normalne behalo, ale ak som chcel pozret cacti, tak vyskocilo len okno na prihlasenie a po zadani mena a hesla sa nic nedialo. Skusil som reboot, ale uz som sa nedostal ani na phpfusion, samozrejme ani na cacti a ani na phpmyadmin.

    Ak chcem ist na php fusion dostanem hlasku

    Unable to establish connection to MySQL
    2002 : Can't connect to local MySQL server through socket '/var/run/mysqld/mysqld.sock' (2)
    Ak chcem ist na cacti, tak
    FATAL: Cannot connect to MySQL server on ''. Please make sure you have  specified a valid MySQL database name in 'include/config.php'
    A ak chcem na phpmyadmin, tak vyskoci aspon tabulka na prihlasenie, ale po zadani mena a hesla sa nic nedeje (nevypise ani chybu, ale ani sa neprihlasi).
    Pozrel som cez ps ax v konzole, ale mysql som nevidel, aby bezalo. Je ho potrebne zapnut ? a ako ? :)
    upozornujem, ze v linuxe som vecny zaciatocnik ...

    Řešení dotazu:


    Odpovědi

    23.2.2012 07:19 jany2 | skóre: 30 | blog: jany_blog
    Rozbalit Rozbalit vše Re: Unable to establish connection to MySQL

    Este nieco pridam :)

    Ako laik mam nainstalovany aj webmin a tam vidim

    MySQL is not running on your system - database list could not be retrieved.
    Ak sa pokusim zapnut cez button, taktiez sa nic neudeje. A skusal som aj cez konzolu
    /etc/init.d/mysql start >/dev/null 2>&1 &

    ale tak isto neuspesne

    upozornujem, ze v linuxe som vecny zaciatocnik ...
    23.2.2012 09:04 NN
    Rozbalit Rozbalit vše Re: Unable to establish connection to MySQL
    Dake logy nemame ?

    NN
    23.2.2012 09:50 jany2 | skóre: 30 | blog: jany_blog
    Rozbalit Rozbalit vše Re: Unable to establish connection to MySQL

    z /var/log/mysql/error.log je toto, dam sem len par poslednych riadkov, pretoze predosle riadky su datumovo stare

    120212  6:51:10 [Note] Plugin 'FEDERATED' is disabled.
    120212  6:51:10  InnoDB: Started; log sequence number 0 43685
    120212  6:51:10 [Note] Event Scheduler: Loaded 0 events
    120212  6:51:10 [Note] /usr/sbin/mysqld: ready for connections.
    Version: '5.1.41-3ubuntu12.10'  socket: '/var/run/mysqld/mysqld.sock'  port: 3306  (Ubuntu)
    120212  7:02:01 [Note] /usr/sbin/mysqld: Normal shutdown

    120212  7:02:01 [Note] Event Scheduler: Purging the queue. 0 events
    120212  7:02:01  InnoDB: Starting shutdown...
    120212  7:02:01  InnoDB: Shutdown completed; log sequence number 0 43685
    120212  7:02:01 [Note] /usr/sbin/mysqld: Shutdown complete

    120212  7:02:49 [Note] Plugin 'FEDERATED' is disabled.
    120212  7:02:49  InnoDB: Started; log sequence number 0 43685
    120212  7:02:49 [Note] Event Scheduler: Loaded 0 events
    120212  7:02:49 [Note] /usr/sbin/mysqld: ready for connections.
    Version: '5.1.41-3ubuntu12.10'  socket: '/var/run/mysqld/mysqld.sock'  port: 3306  (Ubuntu)
    120222 17:31:56 [ERROR] /usr/sbin/mysqld: Disk is full writing './cacti/user_log.MYD' (Errcode: 28). Waiting for someone to free space... (Expect up to 60 secs delay for server to continue after freeing disk space)
    120222 17:31:56 [ERROR] /usr/sbin/mysqld: Retry in 60 secs. Message reprinted in 600 secs
    120222 17:41:56 [ERROR] /usr/sbin/mysqld: Retry in 60 secs. Message reprinted in 600 secs
    120222 17:51:56 [ERROR] /usr/sbin/mysqld: Retry in 60 secs. Message reprinted in 600 secs
    120222 18:01:56 [ERR
    upozornujem, ze v linuxe som vecny zaciatocnik ...
    23.2.2012 10:04 jany2 | skóre: 30 | blog: jany_blog
    Rozbalit Rozbalit vše Re: Unable to establish connection to MySQL
    takze podla logu to vypada na to ze disk je plny, len ako ho teraz uvolnit ./cacti/user_log.MYD
    upozornujem, ze v linuxe som vecny zaciatocnik ...
    Řešení 1× (MMMMMMMMM)
    23.2.2012 12:00 jany2 | skóre: 30 | blog: jany_blog
    Rozbalit Rozbalit vše Re: Unable to establish connection to MySQL
    pre "/" mam vyhradene len 10GB a volne bolo 0 Bajtov, tak som vymazal jeden 5GB film co bol v "/" a uz to vsetko znova funguje. Myslel som si, ze problem je v tom, ze pre mysql je vyhradeny urcity priestor, ale to sa jednalo o cely "/" . Este budem musiet asi aj /var/log premazat
    upozornujem, ze v linuxe som vecny zaciatocnik ...
    Jesus Jimenez avatar 28.2.2012 23:31 Jesus Jimenez | skóre: 29
    Rozbalit Rozbalit vše Re: Unable to establish connection to MySQL
    A co ten mysql datadir presunout na nejaky volnejsi oddil?
    Doaenův zákon průtahů: Čím pomaleji pracuješ, tím méně naděláš chyb. -- Murphy
    29.2.2012 13:04 jany2 | skóre: 30 | blog: jany_blog
    Rozbalit Rozbalit vše Re: Unable to establish connection to MySQL
    Uz mam tam teraz dost miesta (ale zisiel by sa asi novy vacsi HDD, lebo 120GB je malo, mam na nom aj NFS s filmamy)
    upozornujem, ze v linuxe som vecny zaciatocnik ...

    Založit nové vlákno • Nahoru

    Tiskni Sdílej: Linkuj Jaggni to Vybrali.sme.sk Google Del.icio.us Facebook

    ISSN 1214-1267   www.czech-server.cz
    © 1999-2015 Nitemedia s. r. o. Všechna práva vyhrazena.