abclinuxu.cz AbcLinuxu.cz itbiz.cz ITBiz.cz HDmag.cz HDmag.cz abcprace.cz AbcPráce.cz
AbcLinuxu hledá autory!
Inzerujte na AbcPráce.cz od 950 Kč
Rozšířené hledání
×
dnes 17:11 | Komunita

Byl proveden bezpečnostní audit svobodného IMAP a POP3 serveru Dovecot (Wikipedie). Audit byl zaplacen z programu Mozilla Secure Open Source a provedla jej společnost Cure53. Společnost Cure53 byla velice spokojena s kvalitou zdrojových kódu. V závěrečné zprávě (pdf) jsou zmíněny pouze 3 drobné a v upstreamu již opravené bezpečnostní chyby.

Ladislav Hagara | Komentářů: 0
dnes 15:30 | IT novinky

Nadace Raspberry Pi představila na svém blogu Raspberry Pi Compute Module 3 (CM3 a CM3L), tj. zmenšené Raspberry Pi vhodné nejenom pro průmyslové využití. Jedná se o nástupce Raspberry Pi Compute Module (CM1) představeného v dubnu 2014. Nový CM3 vychází z Raspberry Pi 3 a má tedy dvakrát více paměti a desetkrát větší výkon než CM1. Verze CM3L (Lite) je dodávána bez 4 GB eMMC flash paměti. Uživatel si může připojit svou vlastní. Představena byla

… více »
Ladislav Hagara | Komentářů: 0
dnes 01:23 | Nová verze

Oficiálně bylo oznámeno vydání verze 3.0 multiplatformního balíku svobodných kancelářských a grafických aplikací Calligra (Wikipedie). Větev 3 je postavena na KDE Frameworks 5 a Qt 5. Krita se osamostatnila. Z balíku byly dále odstraněny aplikace Author, Brainstorm, Flow a Stage. U Flow a Stage se předpokládá jejich návrat v některé z budoucích verzí Calligry.

Ladislav Hagara | Komentářů: 4
včera 15:25 | Nová verze

Bylo oznámeno vydání první RC (release candidate) verze instalátoru pro Debian 9 s kódovým názvem Stretch. Odloženo bylo sloučení /usr jako výchozí nastavení v debootstrap. Vydán byl také Debian 8.7, tj. sedmá opravná verze Debianu 8 s kódovým názvem Jessie.

Ladislav Hagara | Komentářů: 6
včera 13:37 | Zajímavý projekt

1. ledna byl představen projekt Liri (GitHub). Jedná se o spojení projektů Hawaii, Papyros a původního projektu Liri s cílem vyvíjet operační systém (linuxovou distribuci) a aplikace s moderním designem a funkcemi. Včera byl představen Fluid 0.9.0 a také Vibe 0.9.0. Jedná se o toolkit a knihovnu pro vývoj multiplatformních a responzivních aplikací podporující Material Design (Wikipedie) a volitelně také Microsoft Design Language (designový jazyk Microsoft) [reddit].

Ladislav Hagara | Komentářů: 5
14.1. 00:33 | Zajímavý software

Google na svém blogu věnovaném open source představil knihovnu pro komprimaci a dekomprimaci 3D grafiky s názvem Draco. Knihovna bude využívána například v aplikacích pro virtuální a rozšířenou realitu. Porovnání Draco s gzip na YouTube. Zdrojové kódy Draco jsou k dispozici na GitHubu pod licencí Apache 2.0.

Ladislav Hagara | Komentářů: 5
13.1. 17:27 | IT novinky

V loňském roce proběhla úspěšná kampaň na Indiegogo na podporu GPD Win. Jedná se o malý 5,5 palcový notebook a přenosnou herní konzoli v jednom. Předinstalované Windows 10 lze nahradit Linuxem. V únoru by se na Indiegogo měla objevit kampaň na podporu 7 palcového notebooku GPD Pocket.

Ladislav Hagara | Komentářů: 30
13.1. 02:00 | Nová verze

Po pěti měsících od vydání verze 1.0.0 (zprávička) byla vydána verze 2.0.0 frameworku Kirigami (HIG) pro vytváření uživatelských rozhraní mobilních a konvergentních aplikací nad toolkitem Qt. Pro vyzkoušení je určena aplikace pro Android Kirigami gallery.

Ladislav Hagara | Komentářů: 0
12.1. 23:28 | Zajímavý software

Akční hra Lugaru HD od Wolfire Games (recenze) byla uvolněna jako svobodný software, a to včetně dat (pod licencí Creative Commons Attribution – Share Alike). Linuxový port byl v roce 2010 součástí první akce Humble Indie Bundle a engine byl krátce poté uvolněn pod licencí GNU GPL, což vedlo mj. k portu na AmigaOS. Autor mezitím pracuje na pokračování nazvaném Overgrowth.

Fluttershy, yay! | Komentářů: 0
12.1. 14:49 | Bezpečnostní upozornění

Na serveru Jabb.im bylo zveřejněno vyjádření k úniku dat z Jabbim Archive (pastebin). Dump databáze obsahuje komunikaci uživatelů, jejich IP adresy a logy aplikace od října 2015 do března 2016. Celkově se jedná o 8 GB dat, převažujícím jazykem zpráv je čeština a slovenština. O úniku informoval jako první server Motherboard. Jabbim Archive byla službou volitelnou, dostupnou pouze pro VIP uživatele. Podle provozovatele serveru Jabb.im k

… více »
Michal Makovec | Komentářů: 68
Jak se stavíte k trendu ztenčování přenosných zařízení (smartphony, notebooky)?
 (10%)
 (2%)
 (74%)
 (3%)
 (10%)
Celkem 294 hlasů
 Komentářů: 19, poslední 13.1. 22:02
    Rozcestník
    Reklama

    Dotaz: Mikrotik: Agregace odchozich OSPF route do supernetu

    20.10.2011 18:04 jaroslav
    Mikrotik: Agregace odchozich OSPF route do supernetu
    Přečteno: 773×

    Ahoj, je zde nejaky makac na OSPF v mikrotiku? Snazim se agregovat odchozi routy OSPF na mikrotiku, cilem je aby aby z mhona statickych router napr. /30 vylezla jen jedna routra /24 protoze stejne cely subnet /24 slouzi jen pro tuto cast site, ale nejak se mi to nedari najit.

    Zkousel jsem area range, ale bez uspechu, pak jsou zde nejake /routing filter, ktere zrejme lze aplikovat na OSPF (v instace vidim parametry in/out-filter) ale nejak se mi ty filtry nedari pouzivat.

    Dokaze nekdo poradit? Diky Jarda

    Odpovědi

    20.10.2011 20:30 NN
    Rozbalit Rozbalit vše Re: Mikrotik: Agregace odchozich OSPF route do supernetu
    Inter-area route summarization(neni route redistribution..) se podle dokumentace resi pomoci area range.

    NN
    20.10.2011 20:35 NN
    Rozbalit Rozbalit vše Re: Mikrotik: Agregace odchozich OSPF route do supernetu
    For example you have many/32 ip addresses 
    
    /interface bridge add name=lo0
    /ip address
    add address=172.16.1.1/32 interface=lo0
    add address=172.16.1.2/32 interface=lo0
    add address=172.16.1.3/32 interface=lo0
    
    add address=10.1.1.1/24 interface=ether1
    
    configure ospf as passive on lo0 interface
    /routing ospf interface
    add interface=lo0 passive=yes
    
    add area and area range
    /routing ospf area add name=test
    /routing ospf area range add area=test range=172.16.1.0/24
    
    now add ospf networks
    /routing ospf network
    add network=10.1.1.0/24 area=backbone
    add network=172.16.0.1/24 area=test
    
    
    Now on other backbone routers you will see aggregated 172.16.1.0/24 route instead of three /32 routes
    
    NN
    21.10.2011 16:37 jaroslav
    Rozbalit Rozbalit vše Re: Mikrotik: Agregace odchozich OSPF route do supernetu

    Diky, vypada to dobre.

    Rovnou se zeptat jeste na jeden problem, aby nedelal novou diskuzi.

    ---

    Mam mikrotik na platforme x86, upgradovany na verzi 5.7 (posledni stable) tento box ma jako jediny problem s OSPF, vidim ostatni routery v /router ospf neighbor ve stavu Init, nikam dal se to neposune v logu se ukazuje hlaska

     

    route,ospf,info Ignoring Link State Acknowledgment packet: wrong peer state

    route,ospf,info     state=Init

     

    Pokud vedle pripojim jiny box (RB433) nakonfiguruji ji identicky tak vse jede OK.

    Nejprve jsem si myslel, ze problem je v natech, protoze je jich na x86 boxu opravdu hodne, s velkou bolesti jsem je vsechny ostavil, taktez /ip firewall filter jsem potlacil, ale bez efektu.

    Nekde jsem cetl, ze problem dela ruzny cas na boxem, ten mam srovnany z jednoho zdroje (NTP serveru).

    Vyzkousel jsem i prehozeni na jinou sitovku (rozumej, prehodil jsem vlanu na druhy interface), komunikace v ramci vlan (ping chodi bez potizi), ano vim, ze OSPF pouziva defaultne multicast.

    Zajimave je, ze pokud udelam na tomto boxu traffic monitor /tool torch interface=vlanXYZ ip-protocol=ospf tak vidim, ze na box prichazeji pakety ospf, ale zadne neodchazeji pryc, co je spatne, tim si to cele vysvetluji, ale bohuzel uz netusim kde hledat a jak hledat problem a proc OSPF neochazi (citace na jinych boxech ukazuji prijate packety od tohoho neibra 0).

    Nevedel by nekde jak to diagnostikovat?

    Jarda

    21.10.2011 23:17 Jaroslav
    Rozbalit Rozbalit vše Re: Mikrotik: Agregace odchozich OSPF route do supernetu
    Takhle vypada podrobnejsi log, 172.31.15.66 je inkriminovany postizeny router, ktery zlobi, jak je videt, temer vubec nevysila, za celou dobu vidim jen par hello packetu ale zadnou naslednou komunikaci pro vyjednavaci stavu.
    route,ospf,debug RECV: Hello <- 172.31.15.67 on vlan101 (172.31.15.66)
    route,ospf,debug   received options: E 
    route,ospf,debug RECV: Hello <- 172.31.15.69 on vlan101 (172.31.15.66)
    route,ospf,debug   received options: E 
    route,ospf,debug SEND: Hello 172.31.15.66 -> 224.0.0.5 on vlan101 
    route,ospf,debug RECV: Hello <- 172.31.15.70 on vlan101 (172.31.15.66)
    route,ospf,debug   received options: E 
    route,ospf,debug RECV: Hello <- 172.31.15.65 on vlan101 (172.31.15.66)
    route,ospf,debug   received options: E 
    route,ospf,debug Received packet from an unknown network: 
    route,ospf,debug     source=172.31.15.18 
    route,ospf,debug RECV: Hello <- 172.31.15.67 on vlan101 (172.31.15.66)
    route,ospf,debug   received options: E 
    route,ospf,debug RECV: Hello <- 172.31.15.69 on vlan101 (172.31.15.66)
    route,ospf,debug   received options: E 
    route,ospf,debug SEND: Hello 172.31.15.66 -> 224.0.0.5 on vlan101 
    route,ospf,debug RECV: Hello <- 172.31.15.70 on vlan101 (172.31.15.66)
    route,ospf,debug   received options: E 
    route,ospf,debug RECV: Hello <- 172.31.15.65 on vlan101 (172.31.15.66)
    route,ospf,debug   received options: E 
    route,ospf,debug Received packet from an unknown network: 
    route,ospf,debug     source=172.31.15.18 
    route,ospf,debug RECV: Hello <- 172.31.15.67 on vlan101 (172.31.15.66)
    route,ospf,debug   received options: E 
    route,ospf,debug RECV: Hello <- 172.31.15.69 on vlan101 (172.31.15.66)
    route,ospf,debug   received options: E 
    route,ospf,debug SEND: Hello 172.31.15.66 -> 224.0.0.5 on vlan101 
    route,ospf,debug RECV: Hello <- 172.31.15.70 on vlan101 (172.31.15.66)
    route,ospf,debug   received options: E 
    route,ospf,debug RECV: Hello <- 172.31.15.65 on vlan101 (172.31.15.66)
    route,ospf,debug   received options: E 
    
    
    21.10.2011 23:53 NN
    Rozbalit Rozbalit vše Re: Mikrotik: Agregace odchozich OSPF route do supernetu
    Nasel jsem toto reseni na ten NAT:
    /ip firewall nat add action=accept chain=srcnat protocol=89
    pravidlo patri pred vsechny ostatni NAT-y.

    Jses si opravdu jisty, ze si neblokujes OSPF pakety firewallem ?

    NN
    22.10.2011 08:33 jaroslav
    Rozbalit Rozbalit vše Re: Mikrotik: Agregace odchozich OSPF route do supernetu

    Diky zkusim,

    jak jsem psal na postizenem boxu jsem zakazal vse co bylo /ip firewall filter + /ip firewall nat , mezi boxi neni nic jineho nez switche, ktere tahaji vlanu 101 mezi sebou vyusti ji do trunk na portu smerem k routeru, problem trasy vylucuji, jinak by nefungoval druhy box, ktery je vedle (433ka) a ten jede ok.

    Jarda

    Založit nové vláknoNahoru

    Tiskni Sdílej: Linkuj Jaggni to Vybrali.sme.sk Google Del.icio.us Facebook

    ISSN 1214-1267   www.czech-server.cz
    © 1999-2015 Nitemedia s. r. o. Všechna práva vyhrazena.