abclinuxu.cz AbcLinuxu.cz itbiz.cz ITBiz.cz HDmag.cz HDmag.cz abcprace.cz AbcPráce.cz
AbcLinuxu hledá autory!
Inzerujte na AbcPráce.cz od 950 Kč
Rozšířené hledání
×

dnes 13:40 | Pozvánky

Cílem Social Good Hackathonu, který se uskuteční 21. a 22. října v Brně, je vymyslet a zrealizovat projekty, které pomůžou zlepšit svět kolem nás. Je to unikátní příležitost, jak představit nejrůznější sociální projekty a zrealizovat je, propojit aktivní lidi, zástupce a zástupkyně nevládních organizací a lidi z prostředí IT a designu. Hackathon pořádá brněnská neziskovka Nesehnutí.

… více »
Barbora | Komentářů: 0
dnes 00:44 | Pozvánky

V sobotu 21. října 2017 se na půdě Elektrotechnické fakulty ČVUT v Praze uskuteční RT-Summit – setkání vývojářů linuxového jádra a uživatelů jeho real-time verze označované jako preempt-rt.

… více »
Pavel Píša | Komentářů: 4
včera 23:44 | Bezpečnostní upozornění

V Linuxu byla nalezena bezpečnostní chyba CVE-2017-15265 zneužitelná k lokální eskalaci práv. Jedná se o chybu v části ALSA (Advanced Linux Sound Architecture).

Ladislav Hagara | Komentářů: 1
včera 22:44 | Komunita

Greg Kroah-Hartman informuje na svém blogu, že do zdrojových kódu linuxového jádra bylo přidáno (commit) prohlášení Linux Kernel Enforcement Statement. Zdrojové kódy Linuxu jsou k dispozici pod licencí GPL-2.0. Prohlášení přidává ustanovení z GPL-3.0. Cílem je chránit Linux před patentovými trolly, viz například problém s bývalým vedoucím týmu Netfilter Patrickem McHardym. Více v často kladených otázkách (FAQ).

Ladislav Hagara | Komentářů: 4
včera 22:04 | Pozvánky

Rádi bychom vás pozvali na přednášku o frameworku Avocado. Jedná se o testovací framework další generace, inspirovaný Autotestem a moderními vývojovými nástroji, jako je třeba git. Přednáška se bude konat 23. října od 17 hodin na FEL ČVUT (Karlovo náměstí, budova E, auditorium K9 – KN:E 301). Více informací na Facebooku.

… více »
mjedlick | Komentářů: 0
včera 21:44 | Bezpečnostní upozornění

Nový útok na WPA2 se nazývá KRACK a postihuje prakticky všechna Wi-Fi zařízení / operační systémy. Využívá manipulace s úvodním handshake. Chyba by měla být softwarově opravitelná, je nutné nainstalovat záplaty operačních systémů a aktualizovat firmware zařízení (až budou). Mezitím je doporučeno používat HTTPS a VPN jako další stupeň ochrany.

Václav HFechs Švirga | Komentářů: 2
15.10. 00:11 | Zajímavý projekt

Server Hackaday představuje projekt RainMan 2.0, aneb jak naučit Raspberry Pi 3 s kamerovým modulem pomocí Pythonu a knihovny pro rozpoznávání obrazu OpenCV hrát karetní hru Blackjack. Ukázka rozpoznávání karet na YouTube. Zdrojové kódy jsou k dispozici na GitHubu.

Ladislav Hagara | Komentářů: 0
14.10. 15:11 | IT novinky

Online obchod s počítačovými hrami a elektronickými knihami Humble Bundle byl koupen společností IGN. Dle oficiálních prohlášení by měl Humble Bundle dále fungovat stejně jako dosud.

Ladislav Hagara | Komentářů: 8
14.10. 06:00 | Zajímavý článek

Brendan Gregg již v roce 2008 upozornil (YouTube), že na pevné disky se nemá křičet, že jim to nedělá dobře. Plotny disku se mohou rozkmitat a tím se mohou prodloužit časy odezvy pevného disku. V září letošního roku proběhla v Buenos Aires konference věnovaná počítačové bezpečnosti ekoparty. Alfredo Ortega zde demonstroval (YouTube, pdf), že díky tomu lze pevný disk použít také jako nekvalitní mikrofon. Stačí přesně měřit časy odezvy

… více »
Ladislav Hagara | Komentářů: 8
13.10. 14:33 | Komunita

Společnost SUSE natočila a na YouTube zveřejnila dva nové videoklipy: 25 Years - SUSE Music Video (7 Years parody) a Linus Said - Music Parody (Momma Said).

Ladislav Hagara | Komentářů: 6
Těžíte nějakou kryptoměnu?
 (6%)
 (2%)
 (15%)
 (76%)
Celkem 718 hlasů
 Komentářů: 24, poslední 27.9. 08:30
    Rozcestník

    Dotaz: Nelze aktualizovat systém (Debian testing)

    Dalibor Smolík avatar 29.12.2005 09:36 Dalibor Smolík | skóre: 54 | blog: Postrehy_ze_zivota | 50°5'31.93"N,14°19'35.51"E
    Nelze aktualizovat systém (Debian testing)
    Přečteno: 158×
    Při zadání apt-get dist-upgrade se mi objeví tato hláška:
    apt-get dist-upgrade
    ..
    Pro opravení můžete spustit `apt-get -f install'.
    Následující balíky mají nesplněné závislosti:
      libxt-dev: Závisí na: libxt6 (= 6.8.2.dfsg.1-11) ale 6.8.2.dfsg.1-7 je nainstalován
    E: Nesplněné závislosti. Zkuste použít -f.
    
    Pokud použiji apt-get =f install, hlásí to, že bude instalován balík libxt6 a pak při instalaci hláška:
    dpkg: chyba při zpracovávání /var/cache/apt/archives/libxt6_6.8.2.dfsg.1-11_i386.deb (--unpack):
     podproces pre-installation script vrátil chybový status 1
    Při zpracování nastaly chyby:
     /var/cache/apt/archives/libxt6_6.8.2.dfsg.1-11_i386.deb
    E: Sub-process /usr/bin/dpkg returned an error code (1)
    
    Pak je jakákoliv aktualizace systému zablokována. Vím, že jsou někde nesplněné závilosti, ale nomohu přijít na to, co bych měl doinstalovat. Předem díky za radu.
    Rozdíly v řeči a ve zvyklostech neznamenají vůbec nic, budeme-li mít stejné cíle a otevřená srdce.

    Odpovědi

    29.12.2005 13:03 tomasgn | skóre: 23 | JN89GE
    Rozbalit Rozbalit vše Re: Nelze aktualizovat systém (Debian testing)
    no mozna bude potreba spis neco odinstalovat. zkus odebrat ten balicek co zpusobuje chybu, pripadne balicky na nem zavisejici. nekdy pri tom odpochoduje kus systemu...
    Dalibor Smolík avatar 29.12.2005 13:53 Dalibor Smolík | skóre: 54 | blog: Postrehy_ze_zivota | 50°5'31.93"N,14°19'35.51"E
    Rozbalit Rozbalit vše Re: Nelze aktualizovat systém (Debian testing)
    Zdá se, že problém dělá balíček libxt6. Chci-li jej odinstalovat, získám:
    root@server:/home/instal# apt-get --purge remove libxt6
    Čtu seznamy balíků... Hotovo
    Vytvářím strom závislostí... Hotovo
    Pro opravení následujících můžete spustit `apt-get -f install':
    Následující balíky mají nesplněné závislosti:
      libdps1: Závisí na: libxt6 ale nebude se instalovat
      libxaw7: Závisí na: libxt6 ale nebude se instalovat
      libxaw8: Závisí na: libxt6 ale nebude se instalovat
      libxmu6: Závisí na: libxt6 ale nebude se instalovat
      libxt-dev: Závisí na: libxt6 (= 6.8.2.dfsg.1-11) ale nebude se instalovat
      libxt6-dbg: Závisí na: libxt6 (= 6.8.2.dfsg.1-11) ale nebude se instalovat
      libxtrap6: Závisí na: libxt6 ale nebude se instalovat
      proxymngr: Závisí na: libxt6 ale nebude se instalovat
      transcode: Závisí na: libxt6 ale nebude se instalovat
      twm: Závisí na: libxt6 ale nebude se instalovat
      xbase-clients: Závisí na: libxt6 ale nebude se instalovat
      xdm: Závisí na: libxt6 ale nebude se instalovat
      xlibs: Závisí na: libxt6 ale nebude se instalovat
      xterm: Závisí na: libxt6 ale nebude se instalovat
    
    Nevím tedy, co a hlavně jak to mám odinstalovat ..Příkaz apt-get -f install nepomůže. Nahlásí mi to
    dpkg: chyba při zpracovávání /var/cache/apt/archives/libxt6_6.8.2.dfsg.1-11_i386.deb (--unpack):
     podproces pre-installation script vrátil chybový status 1
    Při zpracování nastaly chyby:
     /var/cache/apt/archives/libxt6_6.8.2.dfsg.1-11_i386.deb
    E: Sub-process /usr/bin/dpkg returned an error code (1)
    
    Rozdíly v řeči a ve zvyklostech neznamenají vůbec nic, budeme-li mít stejné cíle a otevřená srdce.
    Dalibor Smolík avatar 29.12.2005 14:00 Dalibor Smolík | skóre: 54 | blog: Postrehy_ze_zivota | 50°5'31.93"N,14°19'35.51"E
    Rozbalit Rozbalit vše Re: Nelze aktualizovat systém (Debian testing)
    Ještě připojuji výpis instalovaných balíčků libxt6:
    root@server:/home/instal# dpkg -l | grep libxt6
    ii  libxt6                             6.8.2.dfsg.1-7                X Toolkit Intrinsics
    iU  libxt6-dbg                         6.8.2.dfsg.1-11               X Toolkit Intrinsics (unstripped)
    
    Na jiném počítači v síti (kde tento problém není), je uvedeno
    root@mironet:~# dpkg -l | grep libxt6
    ii  libxt6                           6.8.2.dfsg.1-11             X Toolkit Intrinsics
    
    Asi jde o to se zbavit verze 1-7 a naintalovat 1-11, ale to právě nejde ..
    Rozdíly v řeči a ve zvyklostech neznamenají vůbec nic, budeme-li mít stejné cíle a otevřená srdce.
    29.12.2005 14:13 Libor Klepac | skóre: 45 | Mýto
    Rozbalit Rozbalit vše Re: Nelze aktualizovat systém (Debian testing)
    apt-get update pred upgradem nepomuze? zrejme mate stare zdroje
    Urine should only be green if you're Mr. Spock.
    Dalibor Smolík avatar 29.12.2005 14:21 Dalibor Smolík | skóre: 54 | blog: Postrehy_ze_zivota | 50°5'31.93"N,14°19'35.51"E
    Rozbalit Rozbalit vše Re: Nelze aktualizovat systém (Debian testing)
    apt-get update bohužel také nepomůže. Stále stejná hláška. Zkusím si ještě pohrát se zdroji.
    Rozdíly v řeči a ve zvyklostech neznamenají vůbec nic, budeme-li mít stejné cíle a otevřená srdce.
    29.12.2005 14:29 hrobar | skóre: 13
    Rozbalit Rozbalit vše Re: Nelze aktualizovat systém (Debian testing)
    Skus aptitude upgrade, vacsinou ponuka niekolko rieseni staci pri nevyhovujucom rieseni vzdy dat No a ponukne dalsie. A mozno by nebolo od veci vliezt do /var/cache/apt/archives a cez dpkg -i skusit ten balik nahodit "rucne".
    29.12.2005 14:30 Libor Klepac | skóre: 45 | Mýto
    Rozbalit Rozbalit vše Re: Nelze aktualizovat systém (Debian testing)
    divne , prave jsem koukal na packages.debian.org a v testingu je opravdu ta revize 11
    Urine should only be green if you're Mr. Spock.
    Pravák Bob avatar 29.12.2005 14:32 Pravák Bob | skóre: 13 | Praha
    Rozbalit Rozbalit vše Re: Nelze aktualizovat systém (Debian testing)
    Když jsem upgradeoval z woodyho na sarge, tak doporučený postup byl pomocí aptitude místo apt. Aptitude líp řeší závislosti.
    knowledge brings fear
    Josef Kufner avatar 29.12.2005 15:35 Josef Kufner | skóre: 67
    Rozbalit Rozbalit vše Re: Nelze aktualizovat systém (Debian testing)
    ...a taky se to dá v aptitude dokopat ručně, když automatika dělá bejkárny... (na to je fajn si někde v menu vypnout automatické řešení závislostí)
    Hello world ! Segmentation fault (core dumped)
    Dalibor Smolík avatar 29.12.2005 15:49 Dalibor Smolík | skóre: 54 | blog: Postrehy_ze_zivota | 50°5'31.93"N,14°19'35.51"E
    Rozbalit Rozbalit vše Re: Nelze aktualizovat systém (Debian testing)
    Díky všem za radu. Problém bude asi vážnější, protože příkaz aptitude vyhodil hodně chyb a hlášku "zpracování zastaveno", ale stále se to všechno točí kolem libxt6. Zkusím ručně aptitude.
    Rozdíly v řeči a ve zvyklostech neznamenají vůbec nic, budeme-li mít stejné cíle a otevřená srdce.

    Založit nové vláknoNahoru

    Tiskni Sdílej: Linkuj Jaggni to Vybrali.sme.sk Google Del.icio.us Facebook

    ISSN 1214-1267   www.czech-server.cz
    © 1999-2015 Nitemedia s. r. o. Všechna práva vyhrazena.