abclinuxu.cz AbcLinuxu.cz itbiz.cz ITBiz.cz HDmag.cz HDmag.cz abcprace.cz AbcPráce.cz
AbcLinuxu hledá autory!
Inzerujte na AbcPráce.cz od 950 Kč
Rozšířené hledání
×

dnes 02:00 | Nová verze

Byla vydána stabilní verze 2.0 linuxové distribuce Lakka, jež umožňuje transformovat podporované počítače v herní konzole. Lakka 2.0 obsahuje například LibreELEC 8.0 nebo RetroArch 1.5.0.

Ladislav Hagara | Komentářů: 2
včera 23:44 | Pozvánky

24. 5. 2017 od 9:00 proběhne v Brně na Fakultě informatiky MU (Botanická 68a) v místnosti D2 jednodenní konference Industry Cocktail (Facebook), na které máš šanci nahlédnout do způsobů využití nových technologií v aktuálních projektech z různých průmyslových odvětví. To, že složité problémy se neřeší jen v laboratořích a způsoby, jakými se s nimi vypořádat v praxi, rozeberou přednášející z jednotlivých firem.

mjedlick | Komentářů: 0
včera 23:33 | Nová verze

Byla vydána verze 0.69 populárního telnet a ssh klienta PuTTY. Podrobnosti v přehledu změn. Řešen je také bezpečnostní problém ve verzi pro Windows.

Ladislav Hagara | Komentářů: 0
28.4. 13:11 | Nová verze

Po téměř dvou letech byla vydána nová verze 4.0 linuxové distribuce Audiophile Linux (též AP-Linux-V4). Tato distribuce vychází z Arch Linuxu, používá systemd, správce oken Fluxbox a vlastní real-time jádro pro nižší latence. Z novinek můžeme jmenovat podporu nových procesorů Intel Skylake a Kaby Lake nebo možnost instalace vedle jiných OS na stejný disk. Pokud se zajímáte o přehrávání hudby v Linuxu, doporučuji návštěvu webu této

… více »
Blaazen | Komentářů: 7
27.4. 18:55 | Nová verze

Byla vydána nová stabilní verze 1.9 (1.9.818.44) webového prohlížeče Vivaldi (Wikipedie). Z novinek vývojáři zdůrazňují podporu nového vyhledávače Ecosia. Ten z příjmů z reklam podporuje výsadbu stromů po celém světě (YouTube). Nově lze přeskupovat ikonky rozšíření nebo řadit poznámky. Nejnovější Vivaldi je postaveno na Chromiu 58.0.3029.82.

Ladislav Hagara | Komentářů: 20
27.4. 17:00 | Nová verze

Byla vydána verze 3.7.0 svobodného systému pro správu obsahu (CMS) Joomla!. V oznámení o vydání (YouTube) se píše o 700 vylepšeních. Opraveno bylo také 8 bezpečnostních chyb.

Ladislav Hagara | Komentářů: 1
27.4. 08:22 | Komunita

Grsecurity (Wikipedie) je sada bezpečnostních patchů pro linuxové jádro (porovnání se SELinuxem, AppArmorem a KSPP). Od září 2015 nejsou stabilní verze těchto patchů volně k dispozici. Dle včerejšího oznámení (FAQ) nejsou s okamžitou platností volně k dispozici už ani jejich testovací verze.

Ladislav Hagara | Komentářů: 80
26.4. 23:33 | Komunita

OpenBSD 6.1 vyšlo již 11. dubna. Po dvou týdnech byla vydána i oficiální píseň. Její název je Winter of 95 a k dispozici je ve formátech MP3 a OGG.

Ladislav Hagara | Komentářů: 0
26.4. 18:55 | Nová verze

Byla vydána verze 2017.1 linuxové distribuce navržené pro digitální forenzní analýzu a penetrační testování Kali Linux. S vydáním verze 2016.1 se Kali Linux stal průběžně aktualizovanou distribucí. Aktualizovat jej lze pomocí příkazů "apt update; apt dist-upgrade; reboot".

Ladislav Hagara | Komentářů: 0
26.4. 18:22 | Nová verze

Po téměř pěti letech od vydání verze 2.00 byla vydána nová stabilní verze 2.02 systémového zavaděče GNU GRUB (GRand Unified Bootloader). Přehled novinek v souboru NEWS.

Ladislav Hagara | Komentářů: 28
Chystáte se pořídit CPU AMD Ryzen?
 (4%)
 (35%)
 (1%)
 (6%)
 (45%)
 (9%)
Celkem 349 hlasů
 Komentářů: 50, poslední 27.4. 04:06
    Rozcestník

    Dotaz: [fglrx] Internal AGP is not supported in 2.6 kernel.

    1.10.2006 12:29 fglrx
    [fglrx] Internal AGP is not supported in 2.6 kernel.
    Přečteno: 145×

    Zdravim, po včerejší aktualizaci systému mi přestala fungovat 3D akcelreace, dmesg hlasí:

    dmesg | grep fglrx
    fglrx: module license 'Proprietary. (C) 2002 - ATI Technologies, Starnberg, GERMANY' taints kernel.
    [fglrx] Maximum main memory to use for locked dma buffers: 431 MBytes.
    [fglrx] module loaded - fglrx 8.27.10 [Jul 27 2006] on minor 0
    [fglrx] Internal AGP is not supported in 2.6 kernel.
    [fglrx:firegl_unlock] *ERROR* Process 3274 using kernel context 0
    

    O HW by vám mělo stačit následující info:

    00:00.0 Host bridge: VIA Technologies, Inc. VT8366/A/7 [Apollo KT266/A/333]
            Subsystem: Elitegroup Computer Systems Unknown device 1841
            Flags: bus master, 66MHz, medium devsel, latency 0
            Memory at d0000000 (32-bit, prefetchable) [size=128M]
            Capabilities: [a0] AGP version 2.0
            Capabilities: [c0] Power Management version 2
    
    01:00.0 VGA compatible controller: ATI Technologies Inc Radeon RV250 If [Radeon 9000] (rev 01) (prog-if 00 [VGA])
            Subsystem: Hightech Information System Ltd. RV250 If [Excalibur Radeon 9000]
            Flags: bus master, stepping, 66MHz, medium devsel, latency 255, IRQ 11
            Memory at d8000000 (32-bit, prefetchable) [size=128M]
            I/O ports at c000 [size=256]
            Memory at e9000000 (32-bit, non-prefetchable) [size=64K]
            [virtual] Expansion ROM at e8000000 [disabled] [size=128K]
            Capabilities: [58] AGP version 2.0
            Capabilities: [50] Power Management version 2
    
    01:00.1 Display controller: ATI Technologies Inc Radeon RV250 [Radeon 9000] (Secondary) (rev 01)
            Subsystem: Hightech Information System Ltd. Unknown device 2007
            Flags: stepping, 66MHz, medium devsel
            Memory at e0000000 (32-bit, prefetchable) [disabled] [size=128M]
            Memory at e9010000 (32-bit, non-prefetchable) [disabled] [size=64K]
            Capabilities: [50] Power Management version 2
    

    Použité drivery: x11-drivers/ati-drivers-8.27.10-r1
    Kernel: Linux 2.6.17-gentoo-r8
    Distribuce: Gentoo 2006.0

    Odpovědi

    1.10.2006 16:49 Jarek Čecho | skóre: 13 | blog: Jarcec_Zone | Koprivnice
    Rozbalit Rozbalit vše Re: [fglrx] Internal AGP is not supported in 2.6 kernel.
    Dalsi blazen s ATI grafikou :-D

    No mate AGP podporu a veci jako agpart primo v jadre nebo v modulech? Zkusil bych se podivat a eventualne je vyhodit do modulu. Mozna bych zkusil i reemerge ati-drivers, jestli jste treba ugradoval mesu, tak by to teoreticky mohlo pomoct.
    1.10.2006 17:12 fglrx
    Rozbalit Rozbalit vše Re: [fglrx] Internal AGP is not supported in 2.6 kernel.
    agpgart mám v modulu, reemergovat ati-drivers jsem již zkoušel, bez úspěchu.
    BTW, napřed mě nazvete bláznem a pak mi vykáte? Zajímavé.
    1.10.2006 17:21 Jarek Čecho | skóre: 13 | blog: Jarcec_Zone | Koprivnice
    Rozbalit Rozbalit vše Re: [fglrx] Internal AGP is not supported in 2.6 kernel.
    Za blazna se omlouvam, ale po mych osobnich zkusenosti s temito grafikami pod linuxem a mnozstvim zde jiz resenych problemu se divim, ze si je jeste muze nekdo kupovat...

    Jinak k Vasemu problemu me uz bohuzel nic nenapada :-(
    michich avatar 1.10.2006 18:20 michich | skóre: 50 | blog: ohrivane_parky
    Rozbalit Rozbalit vše Re: [fglrx] Internal AGP is not supported in 2.6 kernel.
    No zrovna Radeon 9000 bývá celkem bezproblémová za předpokladu, že se nepoužije fglrx, ale free ovladač z X.org.
    Max avatar 1.10.2006 18:37 Max | skóre: 65 | blog: Max_Devaine
    Rozbalit Rozbalit vše Re: [fglrx] Internal AGP is not supported in 2.6 kernel.
    Spíš bych to tipoval na amatérismus. Mám zkušenosti s x grafikama od ati i nvidie na různých systémech (i 64bit) a nikdy jsem nezaznamenal problém s rozchozením. Nepopíratelné je, že nvidie má lepší ovladače, který podporujou více věcí a jsou vhodnější pro gamesáky, ale na obyč kancl PC, nebo na paření nativních her pod linuxem apod. dostačuje v klidu i ati. TV-out taky nejni problém aj. věci. Dalším problémem s chybějícíma funkcema v ati ovladačích jsou ještě e17 a jeho GL rozšíření + pár věcí okolo compiz.
    Momentálně jedu na R9700Pro AIW, nepopírám však, že příští karta, kterou koupím bude nvidia vzhledem k hrám pod wine, používání e17 apod. věcem ...
    Zdar Max
    PS: ohledně toho nakupování : Co když jí chlapec měl už před přechodem na linux ;-) jako ostatně dost lidí ...
    Měl jsem sen ... :(
    1.10.2006 18:48 Jarek Čecho | skóre: 13 | blog: Jarcec_Zone | Koprivnice
    Rozbalit Rozbalit vše Re: [fglrx] Internal AGP is not supported in 2.6 kernel.
    Jo ja jim - ne vsichni ji maji dobrovolne :-P

    Ovsem s tvrzenim, ze staci k bezne praci bohuzel musim nesouhlasit. Tusim, ze to byl Radeon 8500, u ktereho proprietarni ovladace na oko behaly, ovsem po par minutach sekly periferie - prestala reagovat klavesnice a mys. System jako takovy dale bezel v poradku - PC sitove odpovidalo, cas na taskbaru bezel nerusene dale...
    1.10.2006 18:49 Jarek Čecho | skóre: 13 | blog: Jarcec_Zone | Koprivnice
    Rozbalit Rozbalit vše Re: [fglrx] Internal AGP is not supported in 2.6 kernel.
    Jo ja vim

    Zase se nedivam co pisu :-(
    1.10.2006 20:38 fglrx
    Rozbalit Rozbalit vše Re: [fglrx] Internal AGP is not supported in 2.6 kernel.
    Ale i tak dobrou chu´t.
    Max avatar 1.10.2006 20:05 Max | skóre: 65 | blog: Max_Devaine
    Rozbalit Rozbalit vše Re: [fglrx] Internal AGP is not supported in 2.6 kernel.
    Tak náhodou jsem měl 8500 series 275/275 tv in/out 64MB verzi a 128bit(aspoň myslím) sběrnicí. Byla to omezená serie, prodávala se jen pár měsíců a pak zůstaly na trhu jen LE verze. Neměl jsem s ní problém, nejdřívě jsem používal oss ovladače, ale vzhledem k jejich pomalosti jsem přešel na ty binárky od ati a pohoda jazz, tv out taky jel v pohodě (tv in jsem nikdy nezkoušel). První problém, co jsem zazanamenal byl Doom3, u kterého se muselo čekat na opravu bugu v ovladačích od ati. To byly ovšem doby, kdy ati na ty linuxový ovladače plně kašlala. Od té doby se toho hodně změnilo. Jinak co jsem teď koukal, tak nový ovladače od ati už nepodporují R200 a starší čipy :-/, takže vše 91xx 92xx 8xxx apod. už pod new ovl. nepojedou :-/.
    Zdar Max
    PS:tu kartu jsem měl v mých začátcích s linuxem, cca rok 2002 - 2003
    Měl jsem sen ... :(
    1.10.2006 18:51 Peter Golis | skóre: 54 | Bratislava
    Rozbalit Rozbalit vše Re: [fglrx] Internal AGP is not supported in 2.6 kernel.
    :se divim, ze si je jeste muze nekdo kupovat...
    som uzivatel mac mini ktory obsahuje Radeon 9200. vzhladom na platformu PPC pouzivam opensource ovladace a som plne spokojny. mohol by ste prosim specifikovat o ake problemy sa jedna?
    1.10.2006 18:55 Jarek Čecho | skóre: 13 | blog: Jarcec_Zone | Koprivnice
    Rozbalit Rozbalit vše Re: [fglrx] Internal AGP is not supported in 2.6 kernel.
    S opensource ovladacemi jsem nemel problem - jen s temi primo od ATI!
    1.10.2006 20:13 mimi.vx | skóre: 37 | blog: Mimi.VX | Praha
    Rozbalit Rozbalit vše Re: [fglrx] Internal AGP is not supported in 2.6 kernel.
    ja nemam problemy ani s temi od ati .... btw k te chybe .... je spatne nastaven xorg conf aby pouzil interni agpgart ... ale ati ovladace neobsahuji gart pro via chipsety ..... musi se pouzit jaderny modul pro agpgart od via + nastavit v xorgconfig v sekci device pouziti externiho agpgart ...
    jinak celkem dobre info je na forech rage3d.com
    USE="-gnome -kde";turris
    1.10.2006 20:37 fglrx
    Rozbalit Rozbalit vše Re: [fglrx] Internal AGP is not supported in 2.6 kernel.
    Nevím jak to říct, abych nevypadal jako úplný blbec, ale víte, já neumím zas až tak dobře anlicky tak bych vám byl vděčný za přesměrování přímo do diskuze kde se daný problém řeší nebo aspo´n za stručné HOWTO. Děkuji.
    1.10.2006 20:47 Jarek Čecho | skóre: 13 | blog: Jarcec_Zone | Koprivnice
    Rozbalit Rozbalit vše Re: [fglrx] Internal AGP is not supported in 2.6 kernel.
    Hmmm... Nejak jsem si s temi agpgarty hral, ale uz nevim jak a proc, takze nemuzu oponovat jestli jsem toto zkousel a fungovalo ci ne :-(
    1.10.2006 20:19 svaca | skóre: 38
    Rozbalit Rozbalit vše Re: [fglrx] Internal AGP is not supported in 2.6 kernel.
    1. Ubohe OpenGL s OS ovladace 2. Slaby vykon OpelGL 3. Chyby v ruznem akcelerovanem obraze.

    ATI + Linux = smrt ..... Opak muze tvrdit, jen clovek co neokusil nVidii .... Vim co rikam. Mam ATI rad a v linuxu bych ji mel radsi, ale nejde to.

    K danemu problemu: fungujici ovladace ATI bych nemel odvahu upgradovat ...
    Never give up ! Stay ATARI !
    1.10.2006 20:36 fglrx
    Rozbalit Rozbalit vše Re: [fglrx] Internal AGP is not supported in 2.6 kernel.
    Já nad tím zda upgradovat/neupgradovat uvažoval poměrně dlouho, protože gentoo stáhnul starší drivery z mirrorů, měl jsem problém se zamaskováním a tak jsem si řekl proč to nezkusit, pro příště už důvod mám. Stejně brzo vystřídá ATI grafka od nVidie :-)
    1.10.2006 22:21 Peter Golis | skóre: 54 | Bratislava
    Rozbalit Rozbalit vše Re: [fglrx] Internal AGP is not supported in 2.6 kernel.
    viete mi zodpovedat dve otazky:
    1) da sa kupit mac mini s inou grafickou kartou?
    2) bude niekedy podporovat ati.com platformu PowerPC?

    k poznamkam ohladne ubohosti a chybovosti opensource ovladacov sa nevyjadrujem. pripada mi to nielen neprofesionalne, ale aj nepravdive. mam opacne skusenosti, ale to bude tym ze som si tento pocitac neskladal na kolene z nahradnych dielov ako to maju vo zvyku ostatny.
    1.10.2006 22:40 svaca | skóre: 38
    Rozbalit Rozbalit vše Re: [fglrx] Internal AGP is not supported in 2.6 kernel.
    1. Pravdepodobne ne. 2. Ne.

    ATI kasle na ovladace odjakziva (to je jeji slabina). Narazite, ze PC je stavebnice ? Ano, taky mam moc rad Maca a hlavne Atari, ale PC patri k moji praci a nejsem nicim limitovan ... Nebo myslite, ze je rozdil mezi grafikou od Ati v Macu a v PC ? tezko.

    Jediny problem co by se mel resit, ze ATi pod linuxem sucks. A to je bohuzel pravda.

    A pokud jsou ovladace open closed (3D pro R9500 a vyssi) MUSITE mit kvalitni ovladace od vyrobce a ty v podobe ATi NEEXISTUJI. A dnes maji v PC R9200 a nissi nej nostalgici a tem muze opensource stacit.....
    Never give up ! Stay ATARI !
    2.10.2006 01:23 Peter Golis | skóre: 54 | Bratislava
    Rozbalit Rozbalit vše Re: [fglrx] Internal AGP is not supported in 2.6 kernel.
    u mna sa tvari ati v mac a pc trosku odlisne. mozno je to architekturou, mozno starym monitorom ktory neposkytuje info cez DDC kanal. macintosh odjakziva preferoval stroje bez textoveho modu a ak sa prepnem z xwindows do _textoveho (ehm framebuffer) modu, tak si karta zmysli ze ide na frekvencii cca 180Hz. monitor zapne pud sebazachovy a vypne sa. tato chyba u mna nenastavala na podobnej konfiguracii x86 (radeon 9200, rovnaky monitor od apple, platforma intel - centrino) nakolko tam som framebuffer nepouzival. takze si skutocne myslim ze je rozdiel medzi grafikou od ati v macintoshi a v pc, samozrejme mam aj dokaz. ale pouzitym chipom alebo firmware/ovladacom to nemusi byt, moze to byt inym inicializacnym retazcom ktory poskytuje open firmware. tato chyba mi vsak v praci nebrani. ak uz raz nastartujem grafiku, tak ju nemam preco vypnut :-)

    inac zaujimalo by ma co znamena veta "A dnes maji v PC R9200 a nissi nej nostalgici a tem muze opensource stacit....." jej prva cast vety opisuje uzivatelov tichej, malej a postacujucej pracovnej stanice ako nostalgikov. zaujimalo by ma ci je pre uzivatela vhodnejsia graficka karta i950 (ktoru davaju momentalne do mac mini s procesormi od intelu) a ci ma vyssi hardwerovy vykon v 3d. samozrejme myslim vykon grafickeho hardware a nie tej hovadiny co kradne vykon cpu a prezentuje to ako vykon gpu co je bezna vlastnost binarnych ovladacov. samozrejme aj tych od nvidie, nostalgici co mali vantu pochopia.
    2.10.2006 09:07 svaca | skóre: 38
    Rozbalit Rozbalit vše Re: [fglrx] Internal AGP is not supported in 2.6 kernel.
    Promin, ale moc dobre vis jak jsem to myslel s temi nostalgiky....

    Prumerna ceskoslovenska rodina ma PC i na zabavu, to je taky duvod proc pouziva novejsi HW - velke procento uzivattelu ...

    Ale jinak: Nekdo si kupuje novy HW, R9200 a nis uz pomalu nesezene + kupovat dnes AGP stroj = vrazda, OK koupi za pakatel X1300Proa vis a linux je v KELU .....

    Nebo koupi nVidii 7950GX2 a je vysmaty jak leco.

    To je skutecnost.

    integrovane grafiky jsou vsem jasny .... Jak muzu presvedsit sveho zakaznika aby zkusil linux, kdyz mu prakticky nefunguje ani grafika ????

    Dokud to takhle bude, rozvoj linux se rovna = malinkato nahoru ... ale jen malinkato.
    Never give up ! Stay ATARI !
    Max avatar 2.10.2006 15:08 Max | skóre: 65 | blog: Max_Devaine
    Rozbalit Rozbalit vše Re: [fglrx] Internal AGP is not supported in 2.6 kernel.
    koupi za pakatel X1300Proa vis a linux je v KELU

    To je přehnaný, jak už jsem napsal výše, krom většiny her pod wine(hlavně těch novějších) a nějakých grafických vychytávek v linuxu jede ati dobře. Věř nebo ne, hodně uživatelům to dostačuje a když přecházejí na linux, tak nemají důvod přecházet na nvidii. To, co ty tvrdíš se odehrávalo před třema rokama, teď je situace krapet jiná ;-).

    Jinak ještě k tématu : atiňácký agp podporuje některé starší verze via agp, aspoň mě to kdysi jelo na stařičký základce A7V333 s R8500. Asi už si teď řekli, že nebudou podporovat nic a spoléhají se na kernel.

    Zdar Max
    Měl jsem sen ... :(
    2.10.2006 15:17 zabza | skóre: 52 | blog: Nad_sklenkou_cerveneho
    Rozbalit Rozbalit vše Re: [fglrx] Internal AGP is not supported in 2.6 kernel.
    S touhle chybou ([fglrx:firegl_unlock] *ERROR* Process 3274 using kernel context 0, to [fglrx] Internal AGP ... není chyba, ale prostě konstatování) jsem se potkal taky, a řešení je jednoduché - (shodit X-ka), unloadnout modul fglrx (včetně modulu pro AGP) a pak spustit X-ka znovu...
    2.10.2006 20:09 fglrx
    Rozbalit Rozbalit vše Re: [fglrx] Internal AGP is not supported in 2.6 kernel.
    Tento postup mi bohužel nefunguje.

    Založit nové vláknoNahoru

    Tiskni Sdílej: Linkuj Jaggni to Vybrali.sme.sk Google Del.icio.us Facebook

    ISSN 1214-1267   www.czech-server.cz
    © 1999-2015 Nitemedia s. r. o. Všechna práva vyhrazena.