abclinuxu.cz AbcLinuxu.cz itbiz.cz ITBiz.cz HDmag.cz HDmag.cz abcprace.cz AbcPráce.cz
AbcLinuxu hledá autory!
Inzerujte na AbcPráce.cz od 950 Kč
Rozšířené hledání
×
dnes 17:00 | Nová verze

Byl vydán Docker 1.13. Přehled novinek na YouTube a v poznámkách k vydání na GitHubu. Docker umožňuje běh aplikací v softwarových kontejnerech (Wikipedia).

Ladislav Hagara | Komentářů: 0
dnes 15:51 | Komunita

Mozilla.cz informuje, že nástroje pro webové vývojáře se možná oddělí od Firefoxu a stanou doplňkem. Nástroje pro webové vývojáře prošly velkým přepisem a tým, který se stará o jejich vývoj, by uvítal možnost jejich častějších aktualizacích nezávisle na vydávání nových verzí Firefoxu.

Ladislav Hagara | Komentářů: 1
dnes 07:00 | Humor

Čtenářům AbcLinuxu vše nejlepší k dnešnímu Dni zvýšení povědomí o tučňácích (Penguin Awareness Day).

Ladislav Hagara | Komentářů: 0
dnes 06:00 | Komunita

Bylo spuštěno hlasování o přednáškách a workshopech pro letošní InstallFest, jenž proběhne o víkendu 4. a 5. března v Praze. Současně byla oznámena změna místa. InstallFest se letos vrací zpět na Karlovo náměstí do budovy E.

Ladislav Hagara | Komentářů: 0
dnes 02:48 | Komunita

Greg Kroah-Hartman potvrdil, že Linux 4.9 je jádrem s prodlouženou upstream podporou (LTS, Long Term Support). Podpora je plánována do ledna 2019. Aktuální jádra s prodlouženou podporou jsou tedy 3.2, 3.4, 3.10, 3.12, 3.16, 3.18, 4.1, 4.4 a 4.9.

Ladislav Hagara | Komentářů: 0
dnes 00:11 | Zajímavý článek

Výrobce síťových prvků, společnost Netgear, spustila nový program, který slibuje vývojářům, expertům, ale i běžným uživatelům vyplacení finanční odměny za nalezení bezpečnostních chyby v jejich produktech. Za nalezení zranitelnosti v hardware, API nebo mobilní aplikaci nabízí odměnu od 150 do 15 tisíc dolarů (dle závažnosti).

Michal Makovec | Komentářů: 0
dnes 00:08 | Pozvánky

V sobotu 18. 2. se v Praze v prostorách VŠE uskuteční od 9:30 již 4. ročník největší české konference o open source redakčním systému WordPress (WP) - WordCamp Praha 2017.

… více »
smíťa | Komentářů: 0
včera 23:58 | Komunita

Kryptoměnová komunita zahájila nový rok spuštěním projektu Blockchain.cz, jehož cílem je kolektivně nalézt ideální překlad pro čím dál frekventovanější slovo „blockchain“. Přispět návrhem může kdokoli. Sběr bude trvat až do konce září 2017. Následně bude probíhat dvoutýdenní veřejné hlasování, které bude zakončeno výběrem toho nejlepšího návrhu.

xHire | Komentářů: 8
včera 15:55 | Bezpečnostní upozornění

Společnost Oracle vydala čtvrtletní bezpečnostní aktualizaci svých softwarových produktů (CPU, Critical Patch Update). Opraveno je celkově 270 bezpečnostních chyb. V Oracle Java SE je například opraveno 17 bezpečnostních chyb. Vzdáleně zneužitelných bez autentizace je 16 z nich. V Oracle MySQL je opraveno 27 bezpečnostních chyb. Vzdáleně zneužitelných bez autentizace je 5 z nich.

Ladislav Hagara | Komentářů: 0
včera 02:48 | Nová verze

Po půl roce od vydání verze 9.0 (zprávička) byla vydána verze 10.0 zvukového serveru PulseAudio. Přehled novinek v poznámkách k vydání.

Ladislav Hagara | Komentářů: 35
Jak se stavíte k trendu ztenčování přenosných zařízení (smartphony, notebooky)?
 (10%)
 (2%)
 (74%)
 (3%)
 (10%)
Celkem 340 hlasů
 Komentářů: 24, poslední 17.1. 10:14
    Rozcestník
    Reklama

    Dotaz: Nejdou nainstalovat ovladace nvidia

    15.10.2006 10:42 Brumla01 | skóre: 7
    Nejdou nainstalovat ovladace nvidia
    Přečteno: 649×
    Nejdou mi nainstalovat ovladace na nvidii 7600 GS. Pouzivam Fedoru Core 5.92.

    V pripade instalace kmod-nvidia z repozitare livna mi to vypise Error: Missing Dependency: kernel-i686 = 2.6.18-1.2747.fc6 is needed by package kmod-nvidia.

    Kdyz jsem zkousel kompilaci ovladacu, probehne kompilace, ale na konci mi to vypise hlasku:Unable to build the NVIDIA kernel module. Zkousel jsem jak verzi 8774 tak i betu 9625, vzdy se stejnym vysledkem.

    verze kernelu:2.6.18.-1.2784 verze kernel-develu:2.6.18-1.2784

    Predem diky za pomoc

    Odpovědi

    15.10.2006 12:08 Petr Šobáň | skóre: 79 | blog: soban | Olomouc
    Rozbalit Rozbalit vše Re: Nejdou nainstalovat ovladace nvidia
    Jakou verzi ? x86_64 ?

    U té je asi nějaká zrada nejnovější kernel s nvidii mě taky nejde přeložit.

    Ale 2.6.18-1.2726.fc6 originál nvidia ovladače

    NVRM version: NVIDIA Linux x86_64 Kernel Module 1.0-8774 Tue Aug 1 21:42:17 PDT 2006 GCC version: gcc version 4.1.1 20060928 (Red Hat 4.1.1-28)

    jdou bez problému.

    Asi nějaká chybička zatím to neřeším však je to testovadí distribuce.
    15.10.2006 15:04 Brumla01 | skóre: 7
    Rozbalit Rozbalit vše Re: Nejdou nainstalovat ovladace nvidia
    je to i386 a mne by to taky nevadilo kdybych na tom nemel nahozeny sledovani druhe plochy, na kterou mam pripojenou tv... ;-)
    15.10.2006 15:12 Petr Šobáň | skóre: 79 | blog: soban | Olomouc
    Rozbalit Rozbalit vše Re: Nejdou nainstalovat ovladace nvidia
    Mě to nevadí protože používám to starší jádro kde to funguje.

    Teď tahám další updaty kde je novější jádro tak tam už to snad půjde nainstalovat, snad to opravily.
    15.10.2006 16:19 Petr Šobáň | skóre: 79 | blog: soban | Olomouc
    Rozbalit Rozbalit vše Re: Nejdou nainstalovat ovladace nvidia
    No tak novější jádra taky KO.

    Tak jsem po tom pátral a problém je že v nových hlavičkovských souborech (*.h) jádra chybí soubor "linux/config.h" který jako zastaralý byl vyhozen a nikdo ještě neupravil ovladače od nvidie.

    Takže řešení je ten soubor tam vytvořit.

    V FC patří na místo /usr/src/kernels/verze_kernelu/include/linux/config.h (příklad "/usr/src/kernels/2.6.18-1.2784.fc6-x86_64/include/linux/config.h")

    Takže ho tam vytvoříme s obsahem:


    #ifndef _LINUX_CONFIG_H
    #define _LINUX_CONFIG_H
    /* This file is no longer in use and kept only for backward compatibility.
     * autoconf.h is now included via -imacros on the commandline
     */
    #warning Including config.h is deprecated.
    #include <linux/autoconf.h>
    #if !defined (__KERNEL__) && !defined(__KERNGLUE__)
    #error including kernel header in userspace; use the glibc headers instead!
    #endif
    #endif
    

    A překlad nvidia ovladačů funguje.
    15.10.2006 17:19 Brumla01 | skóre: 7
    Rozbalit Rozbalit vše Re: Nejdou nainstalovat ovladace nvidia
    Opravdu bezi moc diky, ale jak uz to byva kdyz je jeden problem vyresen nastane dalsi. Upravil jsem xorg podle navodu z netu, bohuzel mi po uprave mi nenabehnou x-ka. zda se ze xorg nema spravme zadefinovanou cestu k modulum. Mohl bych pozadat o zaslani vaseho xorg.conf?
    15.10.2006 17:23 Petr Šobáň | skóre: 79 | blog: soban | Olomouc
    Rozbalit Rozbalit vše Re: Nejdou nainstalovat ovladace nvidia
    Mohl ale tím si moc nepomůžete :-)
    
    [petr@soban ~]$ cat /etc/X11/xorg.conf
    # nvidia-xconfig: X configuration file generated by nvidia-xconfig
    # nvidia-xconfig:  version 1.0  (buildmeister@builder26)  Tue Aug  1 22:01:29 PDT 2006
    
    Section "ServerLayout"
        Identifier     "single head configuration"
        Screen      0  "Screen0" 0 0
        InputDevice    "Keyboard0" "CoreKeyboard"
        InputDevice    "Mouse1" "CorePointer"
    EndSection
    
    Section "Module"
        Load           "dbe"
        # Load the glx module.
        Load           "glx"
        Load           "extmod"
        Load           "type1"
        Load           "freetype"
    EndSection
    
    Section "InputDevice"
        Identifier     "Keyboard0"
        Driver         "kbd"
        Option         "XkbModel" "pc105"
        Option         "XkbLayout" "cz"
        Option         "XkbVariant" "qwerty"
    EndSection
    
    Section "InputDevice"
        Identifier     "Mouse1"
        Driver         "mouse"
        Option         "Protocol" "auto"
        Option         "Device" "/dev/input/mouse0"
    EndSection
    
    Section "Device"
        Identifier     "Videocard0"
        Driver         "nvidia"
    EndSection
    
    Section "Screen"
        Identifier     "Screen0"
        Device         "Videocard0"
        DefaultDepth    24
        Option         "NoLogo"
        SubSection     "Display"
            Depth       24
            Modes      "1024x768" "800x600"
        EndSubSection
    EndSection
    
    Spíše to chce napsat chybovou hlášku a pohledat zda vše máte jak má být a co to nenašlo.
    15.10.2006 17:45 Brumla01 | skóre: 7
    Rozbalit Rozbalit vše Re: Nejdou nainstalovat ovladace nvidia
    No nepomohl jsem si :-D, rikal jsem si jestl jsem jen nezapomel zapsat nejakou sek ci nebo tak.

    Vypis chyb pris startu x, staci v xorgu predelat nvidia na nv a dostanu se do x naprosto bez problemu

    X Window System Version 7.1.1 Release Date: 12 May 2006 X Protocol Version 11, Revision 0, Release 7.1.1 Build Operating System: Linux 2.6.9-34.ELsmp i686 Red Hat, Inc. Current Operating System: Linux Warbird 2.6.18-1.2784.fc6 #1 SMP Thu Oct 12 18:49:59 EDT 2006 i686 Build Date: 04 October 2006 Build ID: xorg-x11-server 1.1.1-47.fc6 Before reporting problems, check http://wiki.x.org to make sure that you have the latest version. Module Loader present Markers: (--) probed, (**) from config file, (==) default setting, (++) from command line, (!!) notice, (II) informational, (WW) warning, (EE) error, (NI) not implemented, (??) unknown. (++) Log file: "/dev/null", Time: Sun Oct 15 17:34:18 2006 (++) Using config file: "/tmp/tmpqDD4X_xorg.config" dlopen: /usr/lib/tls/libnvidia-tls.so.1: cannot restore segment prot after reloc: Permission denied (EE) Failed to load /usr/lib/xorg/modules/extensions/libglx.so (EE) Failed to load module "glx" (loader failed, 7) dlopen: /usr/lib/xorg/modules/drivers/nvidia_drv.so: cannot restore segment prot after reloc: Permission denied (EE) Failed to load /usr/lib/xorg/modules/drivers/nvidia_drv.so (EE) Failed to load module "nvidia" (loader failed, 7) (EE) No drivers available.

    Fatal server error: no screens found
    15.10.2006 18:09 Petr Šobáň | skóre: 79 | blog: soban | Olomouc
    Rozbalit Rozbalit vše Re: Nejdou nainstalovat ovladace nvidia
    Kdo to má číst grrrr.

    Permission denied (EE) Failed to load

    Že by práva a zase práva :-)

    Nepoužíváš selinux ?
    16.10.2006 20:35 Brumla01 | skóre: 7
    Rozbalit Rozbalit vše Re: Nejdou nainstalovat ovladace nvidia
    Nj, kdyz ja tomu nerozumim :-D Byl to vskutku SElinux. Mnohkrat diky za pomoc a trpelivost.

    Založit nové vláknoNahoru

    Tiskni Sdílej: Linkuj Jaggni to Vybrali.sme.sk Google Del.icio.us Facebook

    ISSN 1214-1267   www.czech-server.cz
    © 1999-2015 Nitemedia s. r. o. Všechna práva vyhrazena.