abclinuxu.cz AbcLinuxu.cz itbiz.cz ITBiz.cz HDmag.cz HDmag.cz abcprace.cz AbcPráce.cz
AbcLinuxu hledá autory!
Inzerujte na AbcPráce.cz od 950 Kč
Rozšířené hledání
×
eParkomat, startup z ČR, postoupil mezi finalisty evropského akcelerátoru ChallengeUp!
Robot na pivo mu otevřel dveře k opravdovému byznysu
Internet věcí: Propojený svět? Už se to blíží...
dnes 01:02 | Zajímavý článek

Minulý týden byly vydány verze 1.2.3 a 1.1.7 webového poštovního klienta Roundcube. V oznámení o vydání bylo zmíněno řešení bezpečnostního problému nalezeného společností RIPS a souvisejícího s voláním funkce mail() v PHP. Tento týden byly zveřejněny podrobnosti. Útočník mohl pomocí speciálně připraveného emailu spustit na serveru libovolný příkaz. Stejně, jak je popsáno v článku Exploit PHP’s mail() to get remote code execution z roku 2014.

Ladislav Hagara | Komentářů: 0
včera 16:00 | Nová verze

Byla vydána verze 0.98 svobodného nelineárního video editoru Pitivi. Z novinek lze zmínit například přizpůsobitelné klávesové zkratky. Videoukázka práce s nejnovější verzí Pitivi na YouTube.

Ladislav Hagara | Komentářů: 1
včera 15:00 | Zajímavý software

Stop motion je technika animace, při níž je reálný objekt mezi jednotlivými snímky ručně upravován a posouván o malé úseky, tak aby po spojení vyvolala animace dojem spojitosti. Jaký software lze pro stop motion použít na Linuxu? Článek na OMG! Ubuntu! představuje Heron Animation. Ten bohužel podporuje pouze webové kamery. Podpora digitálních zrcadlovek je začleněna například v programu qStopMotion.

Ladislav Hagara | Komentářů: 3
7.12. 21:21 | Nová verze Ladislav Hagara | Komentářů: 0
7.12. 11:44 | Zajímavý projekt

Na Indiegogo byla spuštěna kampaň na podporu herní mini konzole a multimediálního centra RetroEngine Sigma od Doyodo. Předobjednat ji lze již od 49 dolarů. Požadovaná částka 20 000 dolarů byla překonána již 6 krát. Majitelé mini konzole si budou moci zahrát hry pro Atari VCS 2600, Sega Genesis nebo NES. Předinstalováno bude multimediální centrum Kodi.

Ladislav Hagara | Komentářů: 2
7.12. 00:10 | Nová verze

Byla vydána verze 4.7 redakčního systému WordPress. Kódové označením Vaughan bylo vybráno na počest americké jazzové zpěvačky Sarah "Sassy" Vaughan. Z novinek lze zmínit například novou výchozí šablonu Twenty Seventeen, náhledy pdf souborů nebo WordPress REST API.

Ladislav Hagara | Komentářů: 6
6.12. 12:00 | Zajímavý projekt

Projekt Termbox umožňuje vyzkoušet si linuxové distribuce Ubuntu, Debian, Fedora, CentOS a Arch Linux ve webovém prohlížeči. Řešení je postaveno na projektu HyperContainer. Podrobnosti v často kladených dotazech (FAQ). Zdrojové kódy jsou k dispozici na GitHubu [reddit].

Ladislav Hagara | Komentářů: 27
6.12. 11:00 | Bezpečnostní upozornění

Byly zveřejněny informace o bezpečnostní chybě CVE-2016-8655 v Linuxu zneužitelné k lokální eskalaci práv. Chyba se dostala do linuxového jádra v srpnu 2011. V upstreamu byla opravena minulý týden [Hacker News].

Ladislav Hagara | Komentářů: 2
5.12. 22:00 | Komunita

Přibližně před měsícem bylo oznámeno, že linuxová distribuce SUSE Linux Enterprise Server (SLES) běží nově také Raspberry Pi 3 (dokumentace). Obraz verze 12 SP2 pro Raspberry Pi 3 je ke stažení zdarma. Pro registrované jsou po dobu jednoho roku zdarma také aktualizace. Dnes bylo oznámeno, že pro Raspberry Pi 3 je k dispozici také nové openSUSE Leap 42.2 (zprávička). K dispozici je hned několik obrazů.

Ladislav Hagara | Komentářů: 6
5.12. 06:00 | Zajímavý software

OMG! Ubuntu! představuje emulátor terminálu Hyper (GitHub) postavený na webových technologiích (HTML, CSS a JavaScript). V diskusi k článku je zmíněn podobný emulátor terminálu Black Screen. Hyper i Black Screen používají framework Electron, stejně jako editor Atom nebo vývojové prostředí Visual Studio Code.

Ladislav Hagara | Komentářů: 50
Kolik máte dat ve svém domovském adresáři na svém primárním osobním počítači?
 (32%)
 (24%)
 (29%)
 (8%)
 (5%)
 (3%)
Celkem 798 hlasů
 Komentářů: 50, poslední 29.11. 15:50
Rozcestník
Reklama

Dotaz: Problem se sky2 - lze pouzit sky2.c z noveho 2.6.19rc3 jadra?

26.10.2006 10:21 Andy | skóre: 17 | NMnMet
Problem se sky2 - lze pouzit sky2.c z noveho 2.6.19rc3 jadra?
Přečteno: 188×
ahoj,

muj gentoo router mi hazi ze je kernel panic. obrazovku bohuzel sejmutou nemam, ale vim ze se tam pise neco o sky2 a ath_hal (vic teda o sky2) jen co se mi to zase stane tak se to pokusim sejmout

mam tento lama dotaz: lze nejak pouzit sky2.c z 2.6.19rc3 jadra? vim z changelogu ze je tam opravenejch fura chyb, tak si rikam jestli moji chybu nejakej patch neopravil?

co vy na to? nemate nekdo nejakou zkusenost?

nechce se mi nasazovat vanilla a jeste k tomu rc, pritom by stacily dva soubory

Gentoo 2.6.17-r8

chip Marvell 88E8053 na desce Gigabyte GA-K8VT890-9

3x atheros karta Sparklan WL760 s madwifi 0.9.2
Válka je vůl ... a já taky ;) | Chaotic state of my influence.

Odpovědi

26.10.2006 12:45 Petr Šobáň | skóre: 79 | blog: soban | Olomouc
Rozbalit Rozbalit vše Re: Problem se sky2 - lze pouzit sky2.c z noveho 2.6.19rc3 jadra?
A co ti brání to skusit ?
26.10.2006 14:26 Andy | skóre: 17 | NMnMet
Rozbalit Rozbalit vše Re: Problem se sky2 - lze pouzit sky2.c z noveho 2.6.19rc3 jadra?
tak sem nakopiroval sky2.c a sky2.h a nedari se mi...

drivers/net/sky2.c: In function 'sky2_rx_alloc':

drivers/net/sky2.c:1023: warning: implicit declaration of function 'netdev_alloc_skb'

drivers/net/sky2.c:1023: warning: assignment makes pointer from integer without a cast

drivers/net/sky2.c: In function 'tx_le_req':

drivers/net/sky2.c:1272: warning: implicit declaration of function 'skb_is_gso'

drivers/net/sky2.c:1275: error: 'CHECKSUM_PARTIAL' undeclared (first use in this function)

drivers/net/sky2.c:1275: error: (Each undeclared identifier is reported only once

drivers/net/sky2.c:1275: error: for each function it appears in.)

drivers/net/sky2.c: In function 'sky2_xmit_frame':

drivers/net/sky2.c:1319: error: 'struct skb_shared_info' has no member named 'gso_size'

drivers/net/sky2.c:1349: error: 'CHECKSUM_PARTIAL' undeclared (first use in this function)

drivers/net/sky2.c: In function 'sky2_tx_clean':

drivers/net/sky2.c:1473: warning: implicit declaration of function 'netif_tx_lock_bh'

drivers/net/sky2.c:1475: warning: implicit declaration of function 'netif_tx_unlock_bh'

drivers/net/sky2.c: In function 'receive_copy':

drivers/net/sky2.c:1888: warning: assignment makes pointer from integer without a cast

drivers/net/sky2.c: In function 'sky2_tx_done':

drivers/net/sky2.c:2033: warning: implicit declaration of function 'netif_tx_lock'

drivers/net/sky2.c:2035: warning: implicit declaration of function 'netif_tx_unlock'

drivers/net/sky2.c: In function 'sky2_status_intr':

drivers/net/sky2.c:2106: error: 'CHECKSUM_COMPLETE' undeclared (first use in this function)

drivers/net/sky2.c: In function 'sky2_init_netdev':

drivers/net/sky2.c:3235: warning: assignment discards qualifiers from pointer target type

drivers/net/sky2.c: In function 'sky2_test_msi':

drivers/net/sky2.c:3330: error: 'IRQF_SHARED' undeclared (first use in this function)

drivers/net/sky2.c:3330: warning: passing argument 2 of 'request_irq' from incompatible pointer type

drivers/net/sky2.c: In function 'sky2_probe':

drivers/net/sky2.c:3475: error: 'IRQF_SHARED' undeclared (first use in this function)

drivers/net/sky2.c:3475: warning: passing argument 2 of 'request_irq' from incompatible pointer type

make[2]: *** [drivers/net/sky2.o] Error 1

make[1]: *** [drivers/net] Error 2

make: *** [drivers] Error 2
Válka je vůl ... a já taky ;) | Chaotic state of my influence.
26.10.2006 14:38 Petr Šobáň | skóre: 79 | blog: soban | Olomouc
Rozbalit Rozbalit vše Re: Problem se sky2 - lze pouzit sky2.c z noveho 2.6.19rc3 jadra?
Provedls po té vyměně make mrproper ?

Porovnej na začátku souboru jaké hlavičkové soubory zavádí ten starý a nový soubor, možná bude třeba vyměnit i nějaký další soubory.

Možná bych skusil celý adresář drivers/net překopírovat s toho nového.

Jinak co vám brání použít novější jádro oproti tomu starému.
CIJOML avatar 26.10.2006 18:46 CIJOML | skóre: 58 | Praha
Rozbalit Rozbalit vše Re: Problem se sky2 - lze pouzit sky2.c z noveho 2.6.19rc3 jadra?
Vlez na http://linuxtv.org/hg/v4l-dvb klikni na tree a potom bz2 a stahne se ti cela cast co se tyka v4l a dvb v linuxu. Tu nakompiluj proti hlavickam jadra co pouzivas.
26.10.2006 20:43 Anatheman | skóre: 9 | Ostrava
Rozbalit Rozbalit vše Re: Problem se sky2 - lze pouzit sky2.c z noveho 2.6.19rc3 jadra?
Zdravim, s panikarenim jadra pri zatezi na tehle sitovce se sky2 ovladacem jsem bojoval minuly mesic. Chyba byla opravena v 2.6.18
27.10.2006 07:35 Andy | skóre: 17 | NMnMet
Rozbalit Rozbalit vše Re: Problem se sky2 - lze pouzit sky2.c z noveho 2.6.19rc3 jadra?
praveze je problem ze ani tak zatizena neni... ale kazdopadne diky moc, zkusim tu 2.6.18, do ty 2.6.19rc3 se mi nejak nechce
Válka je vůl ... a já taky ;) | Chaotic state of my influence.
18.11.2006 07:42 Andy | skóre: 17 | NMnMet
Rozbalit Rozbalit vše Re: Problem se sky2 - lze pouzit sky2.c z noveho 2.6.19rc3 jadra?
tak po nejakym delsim testovani v gentoo 2.6.18r2 funguje.. pri velkem zatizeni to stale jeste neni ono a pada spojeni na nejakej rx error
Válka je vůl ... a já taky ;) | Chaotic state of my influence.
Thunder.m avatar 18.11.2006 14:24 Thunder.m | skóre: 35 | blog: e17
Rozbalit Rozbalit vše Re: Problem se sky2 - lze pouzit sky2.c z noveho 2.6.19rc3 jadra?
Mě tyhle karty odmítají chodit na gigabit, když je přepnu do 100Mbit tak chodí perfektně v jádře 2.6.18.2
18.11.2006 21:57 Andy | skóre: 17 | NMnMet
Rozbalit Rozbalit vše Re: Problem se sky2 - lze pouzit sky2.c z noveho 2.6.19rc3 jadra?
gigabit sem jeste nezkousel
Válka je vůl ... a já taky ;) | Chaotic state of my influence.

Založit nové vláknoNahoru

Tiskni Sdílej: Linkuj Jaggni to Vybrali.sme.sk Google Del.icio.us Facebook

ISSN 1214-1267   www.czech-server.cz
© 1999-2015 Nitemedia s. r. o. Všechna práva vyhrazena.