abclinuxu.cz AbcLinuxu.cz itbiz.cz ITBiz.cz HDmag.cz HDmag.cz abcprace.cz AbcPráce.cz
AbcLinuxu hledá autory!
Inzerujte na AbcPráce.cz od 950 Kč
Rozšířené hledání
×
dnes 00:55 | Komunita

Pocket (dříve Read It Later) (Wikipedie) je oblíbená služba umožňující uložit si článek z webu na později. V červnu 2015 s vydáním Firefoxu 38.0.5 se do té doby doplněk Pocket stal integrovanou součásti Firefoxu, a to i přes odpor celé řady uživatelů tohoto webového prohlížeče. Mozilla po měsících ustoupila a z integrované součásti se stal opět doplněk. Včera bylo oznámeno, že Mozilla službu Pocket kupila (Mozilla Blog, Pocket Blog).

Ladislav Hagara | Komentářů: 0
včera 23:55 | Pozvánky

Tentokrát jsme si pro vás připravili neobvyklou akci. Ve středu 1. 3. v 17:30 nás přivítá sdružení CZ.NIC ve svých prostorách v Milešovské ulici číslo 5 na Praze 3, kde si pro nás připravili krátkou prezentaci jejich činnosti. Následně navštívíme jejich datacentrum pod Žižkovskou věží. Provedou nás prostory, které jsou běžnému smrtelníkovi nedostupné!

… více »
xkucf03 | Komentářů: 0
včera 18:30 | Komunita

Jednodeskový počítač Raspberry Pi slaví již 5 let. Prodej byl spuštěn 29. února 2012. O víkendu proběhne v Cambridgi velká narozeninová party. Na YouTube bylo při této příležitosti zveřejněno video představující zajímavé projekty postavené na Raspberry Pi.

Ladislav Hagara | Komentářů: 0
včera 18:30 | Nová verze

Byla vydána verze 2017.1.1 svobodného multiplatformního leteckého simulátoru FlightGear. Kódový název a výchozí letiště této verze je Bergen. Přehled novinek v Changelogu.

Ladislav Hagara | Komentářů: 0
včera 10:50 | Zajímavý software

Mozilla.cz informuje o dvou nových experimentálních funkcích v programu Firefox Test Pilot (zprávička). Snooze Tabs slouží k odkládání panelů na později. Pokud vám někdo pošle odkaz, ale vy nemáte čas si stránku hned přečíst, můžete si naplánovat otevření panelu na později. Stačí kliknout na tlačítko a vybrat, kdy chcete panel otevřít. Firefox panel schová a ve vybraný čas znovu otevře. Pulse umožňuje ohodnotit, jak dobře stránka funguje, např. jak rychle se ve Firefoxu načetla. Podle nasbíraných hodnocení pak bude Mozilla prohlížeč ladit.

Ladislav Hagara | Komentářů: 6
včera 02:00 | IT novinky

V Barceloně probíhá veletrh Mobile World Congress 2017. Nokia na něm například představila (360° video na YouTube) novou Nokii 3310 (YouTube). BlackBerry představilo BlackBerry KEYone (YouTube) s QWERTY klávesnicí. LG představilo LG G6 (YouTube). Huawei HUAWEI P10 a P10 Plus. Samsung představil tablet Galaxy Tab S3.

Ladislav Hagara | Komentářů: 1
26.2. 14:00 | Nová verze

Komunita kolem Linuxu From Scratch (LFS) vydala Linux Linux From Scratch 8.0 a Linux From Scratch 8.0 se systemd. Nové verze knih s návody na instalaci vlastního linuxového systému ze zdrojových kódů přichází především s Glibc 2.25 a GCC 6.3.0. Současně bylo oznámeno vydání verze 8.0 knih Beyond Linux From Scratch (BLFS) a Beyond Linux From Scratch se systemd.

Ladislav Hagara | Komentářů: 0
26.2. 11:11 | Nová verze

Byla vydána verze 0.10.0 webového prohlížeče qutebrowser (Wikipedie). Přehled novinek v příspěvku na blogu. Vývojáři qutebrowseru kladou důraz na ovladatelnost pomocí klávesnice a minimální GUI. Inspirovali se prohlížečem dwb a rozšířeními pro Firefox Vimperator a Pentadactyl. Prohlížeč qutebrowser je naprogramován v Pythonu a využívá PyQt5. Zdrojové kódy jsou k dispozici na GitHubu pod licencí GNU GPL 3.

Ladislav Hagara | Komentářů: 34
25.2. 16:22 | Nová verze

Po pěti měsících od vydání Waylandu a Westonu 1.12.0 oznámil Bryce Harrington (Samsung) vydání Waylandu 1.13.0 a Westonu 2.0.0.

Ladislav Hagara | Komentářů: 6
24.2. 13:37 | Bezpečnostní upozornění

Společnost Cloudflare (Wikipedie) na svém blogu potvrdila bezpečnostní problém s její službou. V požadovaných odpovědích od reverzní proxy byla odesílána také data z neinicializované paměti. Útočník tak mohl získat cookies, autentizační tokeny, data posílaná přes HTTP POST a další citlivé informace. Jednalo se o chybu v parsování HTML. Zneužitelná byla od 22. září 2016 do 18. února 2017. Seznam webů, kterých se bezpečnostní problém potenciálně týká na GitHubu.

Ladislav Hagara | Komentářů: 1
Jak se stavíte k trendu ztenčování přenosných zařízení (smartphony, notebooky)?
 (13%)
 (2%)
 (72%)
 (3%)
 (10%)
Celkem 728 hlasů
 Komentářů: 69, poslední dnes 01:02
    Rozcestník

    Dotaz: commons-net a eclipse

    26.10.2006 15:03 Jookyn | skóre: 6 | blog: Jookyn | Mariánské Lázně
    commons-net a eclipse
    Přečteno: 192×
    Mam problém s instalovánim některejch java věcí. Mam nainstalovanou JDK 1.5 i 1.4 od Sunu, jako výchozí VM je 1.5. Při kompilaci např. dev-java/commons-net (jde mi hlavně o eclipse (verze 3.2 - testing)) to ale vůbec nedojede, hodí to chybu. java-check-environment proběhne v pořádku, všechno je ok. Celej výpis instalace přikládam.

    Zkoušel jsem i předtim i blackdown, ale je to stejný... pravděpodobně jde ale o to, že commons-net potřebujou na kompilaci generation 1, tak se to přepne, ale pak je potřeba v tom něco překompilovat v generation 2. Nevíte někdo, jak to vyřešit?
    >>> Emerging (2 of 9) dev-java/commons-net-1.2.2-r1 to / 
     * commons-net-1.2.2-src.tar.gz MD5 ;-) ...                               [ ok ] 
     * commons-net-1.2.2-src.tar.gz size ;-) ...                              [ ok ]
     * checking ebuild checksums ;-) ...                                      [ ok ]
     * checking auxfile checksums ;-) ...                                     [ ok ]
     * checking miscfile checksums ;-) ...                                    [ ok ]
     * checking commons-net-1.2.2-src.tar.gz ;-) ...                          [ ok ]
     * Using Generation-1 System VM: blackdown-jdk-1.4.2 
    >>> Unpacking source... 
    >>> Unpacking commons-net-1.2.2-src.tar.gz to /var/tmp/portage/commons-net-1.2.2-r1/work 
    tar: A lone zero block at 2567 
     * Applying gentoo-1.2.diff ...                                           [ ok ]
    >>> Source unpacked. 
    >>> Compiling source in /var/tmp/portage/commons-net-1.2.2-r1/work/commons-net-1.2.2 ... 
    Buildfile: build.xml 
    
    BUILD FAILED 
    java.lang.UnsupportedClassVersionError: com/jcraft/jsch/UserInfo (Unsupported major.minor version 49.0) 
            at java.lang.ClassLoader.defineClass0(Native Method) 
            at java.lang.ClassLoader.defineClass(ClassLoader.java:539) 
            at java.security.SecureClassLoader.defineClass(SecureClassLoader.java:123) 
            at java.net.URLClassLoader.defineClass(URLClassLoader.java:251) 
            at java.net.URLClassLoader.access$100(URLClassLoader.java:55) 
            at java.net.URLClassLoader$1.run(URLClassLoader.java:194) 
            at java.security.AccessController.doPrivileged(Native Method) 
            at java.net.URLClassLoader.findClass(URLClassLoader.java:187) 
            at java.lang.ClassLoader.loadClass(ClassLoader.java:289) 
            at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:274) 
            at java.lang.ClassLoader.loadClass(ClassLoader.java:282) 
            at java.lang.ClassLoader.loadClass(ClassLoader.java:235) 
            at java.lang.ClassLoader.loadClassInternal(ClassLoader.java:302) 
            at java.lang.Class.forName0(Native Method) 
            at java.lang.Class.forName(Class.java:141) 
            at org.apache.tools.ant.AntTypeDefinition.getTypeClass(AntTypeDefinition.java:161) 
            at org.apache.tools.ant.AntTypeDefinition.getExposedClass(AntTypeDefinition.java:135) 
            at org.apache.tools.ant.ComponentHelper.getElementName(ComponentHelper.java:557) 
            at org.apache.tools.ant.Project.getElementName(Project.java:1819) 
            at org.apache.tools.ant.IntrospectionHelper.getElementName(IntrospectionHelper.java:1060) 
            at org.apache.tools.ant.IntrospectionHelper.setAttribute(IntrospectionHelper.java:386) 
            at org.apache.tools.ant.RuntimeConfigurable.maybeConfigure(RuntimeConfigurable.java:370) 
            at org.apache.tools.ant.RuntimeConfigurable.maybeConfigure(RuntimeConfigurable.java:324) 
            at org.apache.tools.ant.UnknownElement.configure(UnknownElement.java:191) 
            at org.apache.tools.ant.UnknownElement.maybeConfigure(UnknownElement.java:158) 
            at org.apache.tools.ant.Task.perform(Task.java:363) 
            at org.apache.tools.ant.Target.execute(Target.java:341) 
            at org.apache.tools.ant.helper.ProjectHelper2.parse(ProjectHelper2.java:142) 
            at org.apache.tools.ant.ProjectHelper.configureProject(ProjectHelper.java:91) 
            at org.apache.tools.ant.Main.runBuild(Main.java:653) 
            at org.apache.tools.ant.Main.startAnt(Main.java:187) 
            at org.apache.tools.ant.launch.Launcher.run(Launcher.java:246) 
            at org.apache.tools.ant.launch.Launcher.main(Launcher.java:67) 
    
    Total time: 1 second 
    java.lang.UnsupportedClassVersionError: com/jcraft/jsch/UserInfo (Unsupported major.minor version 49.0) 
            at java.lang.ClassLoader.defineClass0(Native Method) 
            at java.lang.ClassLoader.defineClass(ClassLoader.java:539) 
            at java.security.SecureClassLoader.defineClass(SecureClassLoader.java:123) 
            at java.net.URLClassLoader.defineClass(URLClassLoader.java:251) 
            at java.net.URLClassLoader.access$100(URLClassLoader.java:55) 
            at java.net.URLClassLoader$1.run(URLClassLoader.java:194) 
            at java.security.AccessController.doPrivileged(Native Method) 
            at java.net.URLClassLoader.findClass(URLClassLoader.java:187) 
            at java.lang.ClassLoader.loadClass(ClassLoader.java:289) 
            at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:274) 
            at java.lang.ClassLoader.loadClass(ClassLoader.java:282) 
            at java.lang.ClassLoader.loadClass(ClassLoader.java:235) 
            at java.lang.ClassLoader.loadClassInternal(ClassLoader.java:302) 
            at java.lang.Class.forName0(Native Method) 
            at java.lang.Class.forName(Class.java:141) 
            at org.apache.tools.ant.AntTypeDefinition.getTypeClass(AntTypeDefinition.java:161) 
            at org.apache.tools.ant.AntTypeDefinition.getExposedClass(AntTypeDefinition.java:135) 
            at org.apache.tools.ant.ComponentHelper.getElementName(ComponentHelper.java:557) 
            at org.apache.tools.ant.Project.getElementName(Project.java:1819) 
            at org.apache.tools.ant.IntrospectionHelper.getElementName(IntrospectionHelper.java:1060) 
            at org.apache.tools.ant.IntrospectionHelper.setAttribute(IntrospectionHelper.java:386) 
            at org.apache.tools.ant.RuntimeConfigurable.maybeConfigure(RuntimeConfigurable.java:370) 
            at org.apache.tools.ant.RuntimeConfigurable.maybeConfigure(RuntimeConfigurable.java:324) 
            at org.apache.tools.ant.UnknownElement.configure(UnknownElement.java:191) 
            at org.apache.tools.ant.UnknownElement.maybeConfigure(UnknownElement.java:158) 
            at org.apache.tools.ant.Task.perform(Task.java:363) 
            at org.apache.tools.ant.Target.execute(Target.java:341) 
            at org.apache.tools.ant.helper.ProjectHelper2.parse(ProjectHelper2.java:142) 
            at org.apache.tools.ant.ProjectHelper.configureProject(ProjectHelper.java:91) 
            at org.apache.tools.ant.Main.runBuild(Main.java:653) 
            at org.apache.tools.ant.Main.startAnt(Main.java:187) 
            at org.apache.tools.ant.launch.Launcher.run(Launcher.java:246) 
            at org.apache.tools.ant.launch.Launcher.main(Launcher.java:67) 
    com/jcraft/jsch/UserInfo (Unsupported major.minor version 49.0) 
    
    !!! ERROR: dev-java/commons-net-1.2.2-r1 failed. 
    Call stack: 
      ebuild.sh, line 1546:   Called dyn_compile 
      ebuild.sh, line 937:   Called src_compile 
      commons-net-1.2.2-r1.ebuild, line 35:   Called die

    Odpovědi

    26.10.2006 15:35 miro | skóre: 18 | blog: miro
    Rozbalit Rozbalit vše Re: commons-net a eclipse
    Problem je v tom, ze pri kompilacii volas javu z JDK 1.4 a potrebujes volat JDK 1.5 (mas tam uz kniznice skompilovane v 1.5 - jcraft)

    Skus si nastavit premennu PATH tak, aby prikaz
    > java -version
    vratil java 1.5....
    26.10.2006 16:12 Jookyn | skóre: 6 | blog: Jookyn | Mariánské Lázně
    Rozbalit Rozbalit vše Re: commons-net a eclipse
    Tak už to mam, java -version vrátí 1.5, to co je jako výchozí system VM. Ale na začátku emerge se to právě přepne do 1.4 a to je asi ten problém...

    Založit nové vláknoNahoru

    Tiskni Sdílej: Linkuj Jaggni to Vybrali.sme.sk Google Del.icio.us Facebook

    ISSN 1214-1267   www.czech-server.cz
    © 1999-2015 Nitemedia s. r. o. Všechna práva vyhrazena.