abclinuxu.cz AbcLinuxu.cz itbiz.cz ITBiz.cz HDmag.cz HDmag.cz abcprace.cz AbcPráce.cz
AbcLinuxu hledá autory!
Inzerujte na AbcPráce.cz od 950 Kč
Rozšířené hledání
×
dnes 09:44 | Pozvánky

Již tento víkend 4. a 5. března proběhne v Praze na Karlově náměstí 13 konference InstallFest 2017. Na programu je celá řada zajímavých přednášek a workshopů. Jaké linuxové distribuce používají návštěvníci chystající se na konferenci? Odpověď na Twitteru.

Ladislav Hagara | Komentářů: 1
dnes 08:44 | Nová verze

Minulý týden byla vydána verze 8.0.0 minimalistické linuxové distribuce (JeOS, Just enough Operating System) pro Kodi (dříve XBMC) a multimediálního centra LibreELEC (Libre Embedded Linux Entertainment Center). Jedná se o fork linuxové distribuce OpenELEC (Open Embedded Linux Entertainment Center). LibreELEC 8.0.0 přichází s Kodi 17.0 Krypton.

Ladislav Hagara | Komentářů: 0
včera 12:30 | IT novinky

Nadace Raspberry Pi představila (YouTube) Raspberry Pi Zero W. Jedná se o vylepšenou verzi miniaturního počítače Raspberry Pi Zero s Wi-Fi a Bluetooth. Koupit jej lze za 10 dolarů. V prodeji je také oficiální krabička.

Ladislav Hagara | Komentářů: 16
včera 00:55 | Komunita

Pocket (dříve Read It Later) (Wikipedie) je oblíbená služba umožňující uložit si článek z webu na později. V červnu 2015 s vydáním Firefoxu 38.0.5 se do té doby doplněk Pocket stal integrovanou součásti Firefoxu, a to i přes odpor celé řady uživatelů tohoto webového prohlížeče. Mozilla po měsících ustoupila a z integrované součásti se stal opět doplněk. Včera bylo oznámeno, že Mozilla službu Pocket kupila (Mozilla Blog, Pocket Blog).

Ladislav Hagara | Komentářů: 20
27.2. 23:55 | Pozvánky

Tentokrát jsme si pro vás připravili neobvyklou akci. Ve středu 1. 3. v 17:30 nás přivítá sdružení CZ.NIC ve svých prostorách v Milešovské ulici číslo 5 na Praze 3, kde si pro nás připravili krátkou prezentaci jejich činnosti.

… více »
xkucf03 | Komentářů: 0
27.2. 18:30 | Komunita

Jednodeskový počítač Raspberry Pi slaví již 5 let. Prodej byl spuštěn 29. února 2012. O víkendu proběhne v Cambridgi velká narozeninová party. Na YouTube bylo při této příležitosti zveřejněno video představující zajímavé projekty postavené na Raspberry Pi.

Ladislav Hagara | Komentářů: 3
27.2. 18:30 | Nová verze

Byla vydána verze 2017.1.1 svobodného multiplatformního leteckého simulátoru FlightGear. Kódový název a výchozí letiště této verze je Bergen. Přehled novinek v Changelogu.

Ladislav Hagara | Komentářů: 0
27.2. 10:50 | Zajímavý software

Mozilla.cz informuje o dvou nových experimentálních funkcích v programu Firefox Test Pilot (zprávička). Snooze Tabs slouží k odkládání panelů na později. Pokud vám někdo pošle odkaz, ale vy nemáte čas si stránku hned přečíst, můžete si naplánovat otevření panelu na později. Stačí kliknout na tlačítko a vybrat, kdy chcete panel otevřít. Firefox panel schová a ve vybraný čas znovu otevře. Pulse umožňuje ohodnotit, jak dobře stránka funguje, např. jak rychle se ve Firefoxu načetla. Podle nasbíraných hodnocení pak bude Mozilla prohlížeč ladit.

Ladislav Hagara | Komentářů: 10
27.2. 02:00 | IT novinky

V Barceloně probíhá veletrh Mobile World Congress 2017. Nokia na něm například představila (360° video na YouTube) novou Nokii 3310 (YouTube). BlackBerry představilo BlackBerry KEYone (YouTube) s QWERTY klávesnicí. LG představilo LG G6 (YouTube). Huawei HUAWEI P10 a P10 Plus. Samsung představil tablet Galaxy Tab S3.

Ladislav Hagara | Komentářů: 3
26.2. 14:00 | Nová verze

Komunita kolem Linuxu From Scratch (LFS) vydala Linux Linux From Scratch 8.0 a Linux From Scratch 8.0 se systemd. Nové verze knih s návody na instalaci vlastního linuxového systému ze zdrojových kódů přichází především s Glibc 2.25 a GCC 6.3.0. Současně bylo oznámeno vydání verze 8.0 knih Beyond Linux From Scratch (BLFS) a Beyond Linux From Scratch se systemd.

Ladislav Hagara | Komentářů: 0
Jak se stavíte k trendu ztenčování přenosných zařízení (smartphony, notebooky)?
 (13%)
 (2%)
 (72%)
 (3%)
 (10%)
Celkem 743 hlasů
 Komentářů: 72, poslední dnes 11:16
    Rozcestník

    Dotaz: lirc 0.8.0 make: error

    2.1.2007 14:48 Finkky
    lirc 0.8.0 make: error
    Přečteno: 166×
    po doufam uspesne configuraci zdrojaku lirc jsem spustil prikaz make a zda se, ze nekde nastala chyba, bohuzel naprosto netusim kde, viz:

    [root@localhost lirc-0.8.0]# make
    make all-recursive
    make[1]: Entering directory `/home/Finkky/lirc-0.8.0'
    Making all in drivers
    make[2]: Entering directory `/home/Finkky/lirc-0.8.0/drivers'
    Making all in lirc_dev make[3]: Entering directory `/home/Finkky/lirc-0.8.0/drivers/lirc_dev'
    mv Makefile Makefile.automake
    cp ../Makefile.kernel Makefile
    make -C /lib/modules/2.6.18-1.2868.fc6/build/ SUBDIRS=/home/Finkky/lirc-0.8.0/drivers/lirc_dev modules \
    KBUILD_VERBOSE=1
    make[4]: Entering directory `/usr/src/kernels/2.6.18-1.2868.fc6-i686'
    test -e include/linux/autoconf.h -a -e include/config/auto.conf || ( \
    echo; \
    echo " ERROR: Kernel configuration is invalid."; \
    echo " include/linux/autoconf.h or include/config/auto.conf are missing."; \
    echo " Run 'make oldconfig && make prepare' on kernel src to fix it."; \
    echo; \
    /bin/false)
    mkdir -p /home/Finkky/lirc-0.8.0/drivers/lirc_dev/.tmp_versions
    rm -f /home/Finkky/lirc-0.8.0/drivers/lirc_dev/.tmp_versions/*
    make -f scripts/Makefile.build obj=/home/Finkky/lirc-0.8.0/drivers/lirc_dev
    gcc -m32 -Wp,-MD,/home/Finkky/lirc-0.8.0/drivers/lirc_dev/.lirc_dev.o.d -nostdinc -isystem /usr/lib/gcc/i386-redhat-linux/4.1.1/include -D__KERNEL__ -Iinclude -include include/linux/autoconf.h -Wall -Wundef -Wstrict-prototypes -Wno-trigraphs -fno-strict-aliasing -fno-common -Wstrict-prototypes -Wundef -Werror-implicit-function-declaration -Os -pipe -msoft-float -fno-builtin-sprintf -fno-builtin-log2 -fno-builtin-puts -mpreferred-stack-boundary=2 -march=i686 -mtune=generic -mtune=generic -mregparm=3 -ffreestanding -Iinclude/asm-i386/mach-generic -Iinclude/asm-i386/mach-default -fomit-frame-pointer -fasynchronous-unwind-tables -g -fno-stack-protector -Wdeclaration-after-statement -Wno-pointer-sign -DIRCTL_DEV_MAJOR=61 -DEXPORT_SYMTAB -DHAVE_CONFIG_H -I. -I. -I../.. -I/home/Finkky/lirc-0.8.0/drivers/lirc_dev/../.. -I/lib/modules/2.6.18-1.2868.fc6/build//include/ -DMODULE -D"KBUILD_STR(s)=#s" -D"KBUILD_BASENAME=KBUILD_STR(lirc_dev)" -D"KBUILD_MODNAME=KBUILD_STR(lirc_dev)" -c -o /home/Finkky/lirc-0.8.0/drivers/lirc_dev/.tmp_lirc_dev.o /home/Finkky/lirc-0.8.0/drivers/lirc_dev/lirc_dev.c /home/Finkky/lirc-0.8.0/drivers/lirc_dev/lirc_dev.c:35:26: error: linux/config.h: není souborem ani adresářem
    /home/Finkky/lirc-0.8.0/drivers/lirc_dev/lirc_dev.c:54:35: error: linux/devfs_fs_kernel.h: není souborem ani adresářem
    /home/Finkky/lirc-0.8.0/drivers/lirc_dev/lirc_dev.c: In function ‘cleanup’:
    /home/Finkky/lirc-0.8.0/drivers/lirc_dev/lirc_dev.c:132: error: implicit declaration of function ‘devfs_remove’
    /home/Finkky/lirc-0.8.0/drivers/lirc_dev/lirc_dev.c: In function ‘lirc_thread’:
    /home/Finkky/lirc-0.8.0/drivers/lirc_dev/lirc_dev.c:207: warning: ‘interruptible_sleep_on’ is deprecated (declared at include/linux/wait.h:366)
    /home/Finkky/lirc-0.8.0/drivers/lirc_dev/lirc_dev.c: In function ‘lirc_register_plugin’: /home/Finkky/lirc-0.8.0/drivers/lirc_dev/lirc_dev.c:381: error: implicit declaration of function ‘devfs_mk_cdev’
    make[5]: *** [/home/Finkky/lirc-0.8.0/drivers/lirc_dev/lirc_dev.o] Error 1 make[4]: *** [_module_/home/Finkky/lirc-0.8.0/drivers/lirc_dev] Error 2 make[4]: Leaving directory `/usr/src/kernels/2.6.18-1.2868.fc6-i686' make[3]: *** [lirc_dev.o] Error 2 make[3]: Leaving directory `/home/Finkky/lirc-0.8.0/drivers/lirc_dev' make[2]: *** [all-recursive] Error 1 make[2]: Leaving directory `/home/Finkky/lirc-0.8.0/drivers' make[1]: *** [all-recursive] Error 1 make[1]: Leaving directory `/home/Finkky/lirc-0.8.0' make: *** [all] Error 2


    omlouvam se za zmatecny vypis, ale jak mi to povedela konzole tak to preposilam, diky za pripadne rady

    Odpovědi

    2.1.2007 15:00 Andrej Herceg | skóre: 43
    Rozbalit Rozbalit vše Re: lirc 0.8.0 make: error
    Je nainštalovaný balík glibc-devel (poprípade kernel-headers)?
    2.1.2007 15:28 Finkky
    Rozbalit Rozbalit vše Re: lirc 0.8.0 make: error
    Ano, jsou oba, aspon Yum mi hlasi ze glibc 2.5-3 ano a kernel-headers take.
    2.1.2007 15:30 Finkky
    Rozbalit Rozbalit vše Re: lirc 0.8.0 make: error
    teda mam tam glibc, glibc-devel, glibc-utils, glibc-common, glibc-headers
    2.1.2007 15:33 Andrej Herceg | skóre: 43
    Rozbalit Rozbalit vše Re: lirc 0.8.0 make: error
    A súbo /usr/include/linux/config.h a /usr/include/linux/devfs_fs_kernel.h existujú? A je tam aj niečo ako glibc-devel-2.5.3?
    2.1.2007 15:43 Finkky
    Rozbalit Rozbalit vše Re: lirc 0.8.0 make: error
    ty dva soubory, viz vyse, v /usr/include/linux nejsou (zkousel sem i skryte), glibc-devel-2.5.3 je podle Yum nainstalovany
    2.1.2007 15:49 Andrej Herceg | skóre: 43
    Rozbalit Rozbalit vše Re: lirc 0.8.0 make: error
    U mňa sú tie dva súbory v glibc-devel-2.5.3 (ale mám Mandrivu). Ak máš zdrojové kódy kernelu, skús pozrieť tam (include/linux).
    2.1.2007 15:57 Finkky
    Rozbalit Rozbalit vše Re: lirc 0.8.0 make: error
    ted si nejsem uplne jisty co jste myslel, ale koukal jsem do /usr/src/kernels/2.6.18-1.2868.fc6-i686/include/linux a nasel sem tam jen nejblizsi configfs.h a devpts_fs.h ale to predpokladam bude asi uplne neco jineho.
    2.1.2007 16:00 Andrej Herceg | skóre: 43
    Rozbalit Rozbalit vše Re: lirc 0.8.0 make: error
    Tak je problém asi v tom, že boli odstránené (môj kernel 2.6.15 ich ešte obsahuje). Takže treba novšiu verziu lirc.
    2.1.2007 16:06 Andrej Herceg | skóre: 43
    Rozbalit Rozbalit vše Re: lirc 0.8.0 make: error
    2.1.2007 16:08 Andrej Herceg | skóre: 43
    Rozbalit Rozbalit vše Re: lirc 0.8.0 make: error
    Asi nie, už máš novší kernel.
    2.1.2007 16:13 Finkky
    Rozbalit Rozbalit vše Re: lirc 0.8.0 make: error
    Ja uz sme to mel pres balicky (nejaka verze 0.8.1.xx), ale nejak to nefungovalo napriklad s IRKick a ani sem nemohl zavadest modul lirc_gpio (preoste nebyl) tak sem myslel, ze to takhle vyresim :/
    2.1.2007 16:17 Andrej Herceg | skóre: 43
    Rozbalit Rozbalit vše Re: lirc 0.8.0 make: error
    Pozri aj iné verzie rpm. rpm.pbone.net daj hľadať "lirc-kmdl-2.6.18-1.2868"

    Alebo vyskúšaj stiahnuť novšie zdrojové kódy lirc-snapshots
    2.1.2007 16:43 Finkky
    Rozbalit Rozbalit vše Re: lirc 0.8.0 make: error
    Zda se ze ten problem je vyresen pouzitin novejsich zdrojovych kodu, nicmene se mi tu objevil dalsi problem ktery je uz trochu z jine jamky. Ale to uz bude novy thread. Moc diky za pomoc ;)

    Založit nové vláknoNahoru

    Tiskni Sdílej: Linkuj Jaggni to Vybrali.sme.sk Google Del.icio.us Facebook

    ISSN 1214-1267   www.czech-server.cz
    © 1999-2015 Nitemedia s. r. o. Všechna práva vyhrazena.