abclinuxu.cz AbcLinuxu.cz itbiz.cz ITBiz.cz HDmag.cz HDmag.cz abcprace.cz AbcPráce.cz
AbcLinuxu hledá autory!
Inzerujte na AbcPráce.cz od 950 Kč
Rozšířené hledání
×
včera 13:37 | Bezpečnostní upozornění

Společnost Cloudflare (Wikipedie) na svém blogu potvrdila bezpečnostní problém s její službou. V požadovaných odpovědích od reverzní proxy byla odesílána také data z neinicializované paměti. Útočník tak mohl získat cookies, autentizační tokeny, data posílaná přes HTTP POST a další citlivé informace. Jednalo se o chybu v parsování HTML. Zneužitelná byla od 22. září 2016 do 18. února 2017. Seznam webů, kterých se bezpečnostní problém potenciálně týká na GitHubu.

Ladislav Hagara | Komentářů: 1
včera 08:22 | Nová verze

Byla vydána první beta verze Ubuntu 17.04 s kódovým názvem Zesty Zapus. Ke stažení jsou obrazy Kubuntu, Lubuntu, Ubuntu Budgie, Ubuntu GNOME, Ubuntu Kylin, Ubuntu Studio a Xubuntu. Dle plánu by Ubuntu 17.04 mělo vyjít 13. dubna 2017.

Ladislav Hagara | Komentářů: 18
23.2. 17:53 | Bezpečnostní upozornění

Google na svém blogu věnovaném počítačové bezpečnost informuje o nalezení "reálného" způsobu generování kolizí hašovací funkce SHA-1. Podrobnosti a zdrojové kódy budou zveřejněny do 90 dnů. Již dnes lze ale na stránce SHAttered nalézt 2 pdf soubory, jejichž obsah se liší a SHA-1 otisk je stejný (infografika).

Ladislav Hagara | Komentářů: 27
23.2. 17:51 | Nová verze

Vyšla nová verzia open source software na správu a automatizáciu cloudových datacentier Danube Cloud 2.4. Danube Cloud je riešenie postavené na SmartOS, ZFS, KVM a zónach. Obsahuje vlastnosti ako integrovaný monitoring, DNS manažment, zálohy, a samozrejme rozsiahlu dokumentáciu.

dano | Komentářů: 6
23.2. 17:46 | Pozvánky

V Plzni se 3. až 5. března 2017 uskuteční AIMTEChackathon. Je to akce pro vývojáře, grafiky, webdesignéry i veřejnost. Akci provází zajímavé přednášky IT odborníků. Více o programu a možnosti přihlášení na stránkách akce.

cuba | Komentářů: 0
23.2. 01:00 | Nová verze

Známý šifrovaný komunikátor Signal od verze 3.30.0 již nevyžaduje Google Play Services. Autoři tak po letech vyslyšeli volání komunity, která dala vzniknout Google-free forku LibreSignal (dnes již neudržovaný). Oficiální binárky jsou stále distribuované pouze přes Google Play, ale lze použít neoficiální F-Droid repozitář fdroid.eutopia.cz s nezávislými buildy Signalu nebo oficiální binárku stáhnout z Google Play i bez Google účtu

… více »
xm | Komentářů: 8
22.2. 23:14 | Nová verze

Po třech týdnech od vydání první RC verze byla vydána první stabilní verze 17.01.0 linuxové distribuce pro routery a vestavěné systémy LEDE (Linux Embedded Development Environment), forku linuxové distribuce OpenWrt. Přehled novinek v poznámkách k vydání. Dotazy v diskusním fóru.

Ladislav Hagara | Komentářů: 7
22.2. 17:28 | Bezpečnostní upozornění

Byly zveřejněny informace o bezpečnostní chybě CVE-2017-6074 v Linuxu zneužitelné k lokální eskalaci práv. Jde o chybu v podpoře DCCP (Datagram Congestion Control Protocol). Do linuxového jádra se dostala v říjnu 2005. V upstreamu byla opravena 17. února (commit). Bezpečnostní chyba byla nalezena pomocí nástroje syzkaller [Hacker News].

Ladislav Hagara | Komentářů: 16
22.2. 15:00 | Zajímavý software

Společnost Valve vydala novou beta verzi SteamVR. Z novinek lze zdůraznit oficiální podporu Linuxu. Další informace o podpoře této platformy pro vývoj virtuální reality v Linuxu v diskusním fóru. Hlášení chyb na GitHubu.

Ladislav Hagara | Komentářů: 0
22.2. 06:00 | Nová verze

Po necelém roce od vydání verze 0.67 byla vydána verze 0.68 populárního telnet a ssh klienta PuTTY. Podrobnosti v přehledu změn. Řešeny jsou také bezpečnostní chyby.

Ladislav Hagara | Komentářů: 0
Jak se stavíte k trendu ztenčování přenosných zařízení (smartphony, notebooky)?
 (13%)
 (2%)
 (72%)
 (3%)
 (10%)
Celkem 705 hlasů
 Komentářů: 66, poslední 22.2. 18:57
    Rozcestník

    Dotaz: Gentoo, kompilacia stage2 - fail [perl]

    srigi avatar 2.1.2007 14:55 srigi | skóre: 10 | blog: sricont
    Gentoo, kompilacia stage2 - fail [perl]
    Přečteno: 138×
    Hello, kcel som si zkompilovat Gentoo 2006.1 od stage1. Postupoval som nasledovne:

    - boot Slax 5.1.8.1

    - mount /mnt/gentoo

    - bind mount /dev a /proc

    - mount /home a /usr/local

    - copy /etc/resolv.conf

    - chroot, env-update a pod.

    - untar stage1 a portage.latest

    - emerge --sync

    - nasmerovanie /make.profile na /usr/portage/profiles/default-linux/x86/2006.1/desktop

    - emerge portage

    - zapisanie novych konfigov (/etc/._0000 ...)

    - export USE="-java"

    - bootstrap.sh

    - unset USE

    - env-update a pod.

    - emerge -e system

    - FAIL

    moj /etc/make.conf: AUTOCLEAN="yes"

    FEATURES="parallel-fetch"

    CHOST="i686-pc-linux-gnu"

    CFLAGS="-march=pentium3 -O2 -pipe -fomit-frame-pointer"

    CXXFLAGS="${CFLAGS}"

    MAKEOPTS="-j2"

    SYNC="rsync://rsync.europe.gentoo.org/gentoo-portage"

    USE="-aalib acpi alsa apache2 bluetooth cdr -cups dvd dvdr -gnome -gtk -gtk2 \

    -gstreamer -ipv6 kde libcaca mysql mysqli mp3 gif jpeg png tiff pcmcia openal \

    opengl oss -scanner sdl sockets sqlite unicode usb wifi"

    Chybova hlaska:

    >>> Emerging (16 of 115) perl-core/Test-Simple-0.64 to / * Test-Simple-0.64.tar.gz MD5 ;-) ... [ ok ]

    * Test-Simple-0.64.tar.gz RMD160 ;-) ... [ ok ]

    * Test-Simple-0.64.tar.gz SHA1 ;-) ... [ ok ]

    * Test-Simple-0.64.tar.gz SHA256 ;-) ... [ ok ]

    * Test-Simple-0.64.tar.gz size ;-) ... [ ok ]

    * checking ebuild checksums ;-) ... [ ok ]

    * checking auxfile checksums ;-) ... [ ok ]

    * checking miscfile checksums ;-) ... [ ok ]

    * checking Test-Simple-0.64.tar.gz ;-) ... [ ok ]

    >>> Unpacking source...

    >>> Unpacking Test-Simple-0.64.tar.gz to /var/tmp/portage/Test-Simple-0.64/work

    >>> Source unpacked.

    >>> Compiling source in /var/tmp/portage/Test-Simple-0.64/work/Test-Simple-0.64 ... /var/tmp/portage/Test-Simple-0.64/work/Test-Simple-0.64

    * Using ExtUtils::MakeMaker Can't locate ExtUtils/MakeMaker/Config.pm in @INC (@INC contains: /etc/perl /usr/lib/perl5/vendor_perl/5.8.8/i386-linux /usr/lib/perl5/vendor_perl/5.8.8 /usr/lib/perl5/vendor_perl /usr/lib/perl5/site_perl/5.8.8/i386-linux /usr/lib/perl5/site_perl/5.8.8 /usr/lib/perl5/site_perl /usr/lib/perl5/5.8.8/i386-linux /usr/lib/perl5/5.8.8 /usr/local/lib/site_perl .) at /usr/lib/perl5/5.8.8/ExtUtils/MakeMaker.pm line 7. BEGIN failed--compilation aborted at /usr/lib/perl5/5.8.8/ExtUtils/MakeMaker.pm line 7. Compilation failed in require at Makefile.PL line 11. BEGIN failed--compilation aborted at Makefile.PL line 11.

    !!! ERROR: perl-core/Test-Simple-0.64 failed.

    Call stack:

    ebuild.sh, line 1546: Called dyn_compile

    ebuild.sh, line 937: Called src_compile

    ebuild.sh, line 1255: Called perl-module_src_compile

    perl-module.eclass, line 136: Called perl-module_src_prep

    perl-module.eclass, line 125: Called die

    !!! Unable to build! (are you using USE="build"?)

    !!! If you need support, post the topmost build error, and the call stack if relevant.

    Mate nejake navrhy? THX
    Be kind to newbies.

    Odpovědi

    Vojta Drbohlav avatar 2.1.2007 14:58 Vojta Drbohlav | skóre: 26 | blog: Blog | Strahov
    Rozbalit Rozbalit vše Re: Gentoo, kompilacia stage2 - fail [perl]
    Proč to nenainstaluješ ze stage3 a potom nepřekompiluješ system a world? To by mělo vyjít nastejno, ne?
    srigi avatar 2.1.2007 15:20 srigi | skóre: 10 | blog: sricont
    Rozbalit Rozbalit vše Re: Gentoo, kompilacia stage2 - fail [perl]
    Mno taha ma myslienka FROM SCRATCH, ale takto sa bojim, ze emerge world vobec prebehne. Ale asi pojdem od stage3. Flag build nepouzivam.
    Be kind to newbies.
    Vojta Drbohlav avatar 2.1.2007 15:26 Vojta Drbohlav | skóre: 26 | blog: Blog | Strahov
    Rozbalit Rozbalit vše Re: Gentoo, kompilacia stage2 - fail [perl]
    AKAIK je jedno jestli jedeš ze stage1 nebo stage3, když ve stage3 všechno překompiluješ ;-).
    Vojta Drbohlav avatar 2.1.2007 15:00 Vojta Drbohlav | skóre: 26 | blog: Blog | Strahov
    Rozbalit Rozbalit vše Re: Gentoo, kompilacia stage2 - fail [perl]
    !!! Unable to build! (are you using USE="build"?)
    Používáš flag build?
    2.1.2007 17:08 Nail
    Rozbalit Rozbalit vše Re: Gentoo, kompilacia stage2 - fail [perl]
    Měl jsem úplně stejný problém, vyřešil jsem to emerge -e Test-Simple a až poté emerge -e system. Snad to pomůže i tobě...
    srigi avatar 3.1.2007 12:28 srigi | skóre: 10 | blog: sricont
    Rozbalit Rozbalit vše Re: Gentoo, kompilacia stage2 - fail [perl]
    Aj, kurnava nepomohlo, uplne rovnaky problem. No co uz, idem do stage3. Ale ak by niekto vedel ...
    Be kind to newbies.

    Založit nové vláknoNahoru

    Tiskni Sdílej: Linkuj Jaggni to Vybrali.sme.sk Google Del.icio.us Facebook

    ISSN 1214-1267   www.czech-server.cz
    © 1999-2015 Nitemedia s. r. o. Všechna práva vyhrazena.