abclinuxu.cz AbcLinuxu.cz itbiz.cz ITBiz.cz HDmag.cz HDmag.cz abcprace.cz AbcPráce.cz
AbcLinuxu hledá autory!
Inzerujte na AbcPráce.cz od 950 Kč
Rozšířené hledání
×
eParkomat, startup z ČR, postoupil mezi finalisty evropského akcelerátoru ChallengeUp!
Robot na pivo mu otevřel dveře k opravdovému byznysu
Internet věcí: Propojený svět? Už se to blíží...
včera 21:21 | Nová verze Ladislav Hagara | Komentářů: 0
včera 11:44 | Zajímavý projekt

Na Indiegogo byla spuštěna kampaň na podporu herní mini konzole a multimediálního centra RetroEngine Sigma od Doyodo. Předobjednat ji lze již od 49 dolarů. Požadovaná částka 20 000 dolarů byla překonána již 6 krát. Majitelé mini konzole si budou moci zahrát hry pro Atari VCS 2600, Sega Genesis nebo NES. Předinstalováno bude multimediální centrum Kodi.

Ladislav Hagara | Komentářů: 0
včera 00:10 | Nová verze

Byla vydána verze 4.7 redakčního systému WordPress. Kódové označením Vaughan bylo vybráno na počest americké jazzové zpěvačky Sarah "Sassy" Vaughan. Z novinek lze zmínit například novou výchozí šablonu Twenty Seventeen, náhledy pdf souborů nebo WordPress REST API.

Ladislav Hagara | Komentářů: 1
6.12. 12:00 | Zajímavý projekt

Projekt Termbox umožňuje vyzkoušet si linuxové distribuce Ubuntu, Debian, Fedora, CentOS a Arch Linux ve webovém prohlížeči. Řešení je postaveno na projektu HyperContainer. Podrobnosti v často kladených dotazech (FAQ). Zdrojové kódy jsou k dispozici na GitHubu [reddit].

Ladislav Hagara | Komentářů: 25
6.12. 11:00 | Bezpečnostní upozornění

Byly zveřejněny informace o bezpečnostní chybě CVE-2016-8655 v Linuxu zneužitelné k lokální eskalaci práv. Chyba se dostala do linuxového jádra v srpnu 2011. V upstreamu byla opravena minulý týden [Hacker News].

Ladislav Hagara | Komentářů: 2
5.12. 22:00 | Komunita

Přibližně před měsícem bylo oznámeno, že linuxová distribuce SUSE Linux Enterprise Server (SLES) běží nově také Raspberry Pi 3 (dokumentace). Obraz verze 12 SP2 pro Raspberry Pi 3 je ke stažení zdarma. Pro registrované jsou po dobu jednoho roku zdarma také aktualizace. Dnes bylo oznámeno, že pro Raspberry Pi 3 je k dispozici také nové openSUSE Leap 42.2 (zprávička). K dispozici je hned několik obrazů.

Ladislav Hagara | Komentářů: 6
5.12. 06:00 | Zajímavý software

OMG! Ubuntu! představuje emulátor terminálu Hyper (GitHub) postavený na webových technologiích (HTML, CSS a JavaScript). V diskusi k článku je zmíněn podobný emulátor terminálu Black Screen. Hyper i Black Screen používají framework Electron, stejně jako editor Atom nebo vývojové prostředí Visual Studio Code.

Ladislav Hagara | Komentářů: 50
5.12. 06:00 | Zajímavý článek

I letos vychází řada ajťáckých adventních kalendářů. QEMU Advent Calendar 2016 přináší každý den nový obraz disku pro QEMU. Programátoři se mohou potrápit při řešení úloh z kalendáře Advent of Code 2016. Kalendáře Perl Advent Calendar 2016 a Perl 6 Advent Calendar přinášejí každý den zajímavé informace o programovacím jazyce Perl. Stranou nezůstává ani programovací jazyk Go.

Ladislav Hagara | Komentářů: 10
3.12. 16:24 | Nová verze

Byla vydána Mageia 5.1. Jedná se o první opravné vydání verze 5, jež vyšla v červnu loňského roku (zprávička). Uživatelům verze 5 nepřináší opravné vydání nic nového, samozřejmě pokud pravidelně aktualizují. Vydání obsahuje všechny aktualizace za posledního téměř půldruhého roku. Mageia 5.1 obsahuje LibreOffice 4.4.7, Linux 4.4.32, KDE4 4.14.5 nebo GNOME 3.14.3.

Ladislav Hagara | Komentářů: 17
3.12. 13:42 | Pozvánky

V Praze probíhá konference Internet a Technologie 16.2, volné pokračování jarní konference sdružení CZ.NIC. Konferenci lze sledovat online na YouTube. K dispozici je také archiv předchozích konferencí.

Ladislav Hagara | Komentářů: 0
Kolik máte dat ve svém domovském adresáři na svém primárním osobním počítači?
 (32%)
 (24%)
 (29%)
 (8%)
 (5%)
 (3%)
Celkem 785 hlasů
 Komentářů: 50, poslední 29.11. 15:50
Rozcestník
Reklama

Dotaz: opensuse 10.3 a chyba zypp-checkpatches-wrapper

16.11.2007 22:58 M.
opensuse 10.3 a chyba zypp-checkpatches-wrapper
Přečteno: 632×
Ahoj lidi, před chvilkou jsem dokončil aktualizaci bezpečnostních updatů a od té doby mě to vypisuje tuhle chybovou hlášku updateru a nemůžu se jí zbavit.
Nepodařilo se spustit pomocný program zypp-checkpatches-wrapper. Přesvědčte se, zda je balíček zypper nainstalován a zda pracuje správně.
Chtěj jsem udělat online aktualizaci přes Yast, ale i ten hází chybu.
Error loading language plugin /usr/lib/Yast2/plugin/lipy2lang_petl.so.324: cannot open shared object file: No such file or directory. No such client module sw_single.

Run 'yast2 - h' for help on usage.
Nevíte kde udělali soudruzi z opensuse chybu ;-)?

Odpovědi

Max avatar 16.11.2007 23:13 Max | skóre: 64 | blog: Max_Devaine
Rozbalit Rozbalit vše Re: opensuse 10.3 a chyba zypp-checkpatches-wrapper
Nejde náhodou o soubor libpy2lang_perl.so místo lipy2lang_petl.so ?
Máš ho na onom místě?
/usr/lib/Yast2/plugin/libpy2lang_perl.so
Popř symlink na onen soubor :
/usr/lib/Yast2/plugin/libpy2lang_perl.so.324
Zkontroloval jsi, zda máš skutečně onen zypper balíček nainstalován?
Zdar Max
Měl jsem sen ... :(
16.11.2007 23:26 M.
Rozbalit Rozbalit vše Re: opensuse 10.3 a chyba zypp-checkpatches-wrapper
Mám nainstalovaný zypper 0.8.23-7 Máš pravdu jsem se upsal :-). Soubor libpy2lang_perl.so jsem našel, ale soubor libpy2lang_perl.so.324 jsem nikde nenašel :-(
17.11.2007 08:46 majvan | skóre: 4 | blog: Fandime linuxu | Trenčín
Rozbalit Rozbalit vše Re: opensuse 10.3 a chyba zypp-checkpatches-wrapper
Takze problem mame asi vsetci, co v tej dobe robili update.
Tu je riesenie problemu: http://suseforums.net/index.php?showtopic=42066
17.11.2007 10:03 M.
Rozbalit Rozbalit vše Re: opensuse 10.3 a chyba zypp-checkpatches-wrapper
Tohle se jim vážně moc nepovedlo. Vyřešeno, ještě jednou díky :-)
17.11.2007 19:45 lolo6 | skóre: 20
Rozbalit Rozbalit vše Re: opensuse 10.3 a chyba zypp-checkpatches-wrapper
Plati tento postup aj pre x86_64,prosim?

Ok to solve (for anyone still desperate to get package management back)

Go to http://download.opensuse.org/distribution/10.3/repo/oss/suse/i586/ and pick up the following three packages and save them to their own folder (all 3 packages in one folder)

http://download.opensuse.org/distribution/10.3/repo/oss/suse/i586/libzypp-3.26.2-2.i586.rpm http://download.opensuse.org/distribution/10.3/repo/oss/suse/i586/boost-1.33.1-108.i586.rpm http://download.opensuse.org/distribution/10.3/repo/oss/suse/i586/zypper-0.8.23-7.i586.rpm

Open a shell and su to root

cd to the folder you put them in

rpm -e boost-1.33.1-108.2 (which erases the wonderfully and thoroughly tested package that caused the mess)

rpm -ivh *.*

Right click on the opensuse updater and click check now and all should be back to normal

a este prosba rpm -ivh *.* co ma byt miesto tych hvezdiciek a bodky.
17.11.2007 23:24 majvan | skóre: 4 | blog: Fandime linuxu | Trenčín
Rozbalit Rozbalit vše Re: opensuse 10.3 a chyba zypp-checkpatches-wrapper
Nie, tento postup nefunguje- musis si stiahnut x86-64 balicky. Tie sa nachadzaju v tomto adresari: http://download.opensuse.org/distribution/10.3/repo/oss/suse/x86-64

Inak je postup obdobny, len ine balicky sa pouzivaju.
18.11.2007 12:18 lolo6 | skóre: 20
Rozbalit Rozbalit vše Re: opensuse 10.3 a chyba zypp-checkpatches-wrapper
a ten prikaz rpm -e boost-1.33.1-108.2 zostane stejny? A co ma byt za tym rpm -ivh *.*,miesto tych hviezdiciek a bodky,prosim. Dakujem Note:ja viem zatial v textaku akurat ,tak pisat.zvladnem akurat cd
17.11.2007 19:50 lolo6 | skóre: 20
Rozbalit Rozbalit vše Re: opensuse 10.3 a chyba zypp-checkpatches-wrapper
Postup 2. Moze ho prosim niekto objasnit ako by to malo vyzerat pre toho,kto vie v konzole akurat pisat,prekladat netreba.

Do make it maybe a bit easier, use this a root:

export ARCH=$(rpm -q --qf "%{ARCH}\n" aaa_base) rpm -e boost-doc; rpm -e boost-devel; rpm -e boost; rpm -Uvh \ http://download.opensuse.org/distribution/10.3/repo/oss/suse/$ARCH/libzypp-3.26.2-2.$ARCH.rpm \ http://download.opensuse.org/distribution/10.3/repo/oss/suse/$ARCH/boost-1.33.1-108.$ARCH.rpm \ http://download.opensuse.org/distribution/10.3/repo/oss/suse/$ARCH/zypper-0.8.23-7.$ARCH.rpm

We need to take care of ARCH to install matching architecture for Power and x86 64bit Ignore Errors on "rpm -e", your system might not have all subpackages of boost.

Right click on the opensuse updater and click check now and all should be back to normal
18.11.2007 12:26 lolo6 | skóre: 20
Rozbalit Rozbalit vše Re: opensuse 10.3 a chyba zypp-checkpatches-wrapper
ako na to cumim,tak si myslim,ze tu akurat nahradim to ARCH s x86_64 a mozem to skopirovat do prikazovej konzoli,ale neviem ci aj s tymi zatvorkami a dolarovkami.
18.11.2007 14:00 lolo6 | skóre: 20
Rozbalit Rozbalit vše Re: opensuse 10.3 a chyba zypp-checkpatches-wrapper
No a tak to nebolo,Tu je vypis,povie mi niekto prosim podla toho aku to ma mat spravnu formu.

linux-3asl:/home/milanl # export x86_64=$(rpm -q --qf "%{x86_64}\n" aaa_base) rpm -e boost-doc; rpm -e boost-devel; rpm -e boost; rpm -Uvh \ http://download.opensuse.org/distribution/10.3/repo/oss/suse/$x86_64/libzypp-3.26.2-2.$x86_64.rpm \

http://download.opensuse.org/distribution/10.3/repo/oss/suse/$x86_64/boost-1.33.1-108.$x86_64.rpm \ http://download.opensuse.org/distribution/10.3/repo/oss/suse/$x86_64/zypper-0.8.23-7.$x86_64.rpm chyba: incorrect format: neznámy tag bash: export: `-e': not a valid identifier bash: export: `boost-doc': not a valid identifier chyba: balík boost-devel nie je nainštalovaný chyba: Failed dependencies: libboost_filesystem.so.1.33.1()(64bit) is needed by (installed) libzypp-3.26.3-1.1.x86_64 libboost_regex.so.1.33.1()(64bit) is needed by (installed) zypper-0.8.25-0.1.x86_64 Prenáša sa http://download.opensuse.org/distribution/10.3/repo/oss/suse//libzypp-3.26.2-2..rpm chyba: http://download.opensuse.org/distribution/10.3/repo/oss/suse//libzypp-3.26.2-2..rpm vynechané - prenos zlyhal - Neznáma alebo neočakávaná chyba Prenáša sa http://download.opensuse.org/distribution/10.3/repo/oss/suse//boost-1.33.1-108..rpm chyba: http://download.opensuse.org/distribution/10.3/repo/oss/suse//boost-1.33.1-108..rpm vynechané - prenos zlyhal - Neznáma alebo neočakávaná chyba Prenáša sa http://download.opensuse.org/distribution/10.3/repo/oss/suse//zypper-0.8.23-7..rpm chyba: http://download.opensuse.org/distribution/10.3/repo/oss/suse//zypper-0.8.23-7..rpm vynechané - prenos zlyhal - Neznáma alebo neočakávaná chyba warning: u 0x65d850 ctrl 0x65dde0 nrefs != 0 (download.opensuse.org http)
18.11.2007 23:46 lolo6 | skóre: 20
Rozbalit Rozbalit vše Re: opensuse 10.3 a chyba zypp-checkpatches-wrapper
Su dotazy na usporiadanie riadku tak narocne?Na druhej strane si uvedomujem,ze tato technologia berie rychly koniec ,ale snad sa niekdo ortodoxny najde.
Max avatar 20.11.2007 07:22 Max | skóre: 64 | blog: Max_Devaine
Rozbalit Rozbalit vše Re: opensuse 10.3 a chyba zypp-checkpatches-wrapper
Zkus to asi nějak takhle :
export ARCH=$(rpm -q --qf "%{x86_64}\n" aaa_base) rpm -e boost-doc; rpm -e boost-devel; rpm -e boost; rpm -Uvh \ 
http://download.opensuse.org/distribution/10.3/repo/oss/suse/$ARCH/libzypp-3.26.2-2.$ARCH.rpm \
http://download.opensuse.org/distribution/10.3/repo/oss/suse/$ARCH/boost-1.33.1-108.$ARCH.rpm \
http://download.opensuse.org/distribution/10.3/repo/oss/suse/$ARCH/zypper-0.8.23-7.$ARCH.rpm
Ty lomítka nazančují, že příkaz nekončí a pokračuje na dalším řádku, takže stačí, když to přesně takto opíšeš do konzole s tím, že tam buď to lomítko napíšeš, dáš eneter a pokračuješ na novým řádku, nebo tam to lomítko nenapíšeš a uděláš z toho jen velkou nudli.

Zdar Max
Měl jsem sen ... :(
Max avatar 20.11.2007 07:32 Max | skóre: 64 | blog: Max_Devaine
Rozbalit Rozbalit vše Re: opensuse 10.3 a chyba zypp-checkpatches-wrapper
Nebo to uděláš příkaz po příkazu (jako root) :
rpm -e boost-doc
rpm -e boost-devel
rpm -e boost
Pak si stáhneš ty tři balíčky do nějakého adresáře :
mkdir nejaky_adresar
cd nejaky_adresar
wget -c http://download.opensuse.org/distribution/10.3/repo/oss/suse/x86_64/libzypp-3.26.2-2.x86_64.rpm
wget -c http://download.opensuse.org/distribution/10.3/repo/oss/suse/x86_64/boost-1.33.1-108.x86_64.rpm
wget -c http://download.opensuse.org/distribution/10.3/repo/oss/suse/x86_64/zypper-0.8.23-7.x86_64.rpm
A pak je nainstaluješ :
rpm -ivh *.*
Jen doplním ještě k tomu předcházejícímu příkladu :
Ty dolary ($), které jsou před ARCH => $ARCH, naznačují, že ARCH je proměná a doplňuje se z nějaké definice.

Úplně přesně ale nevím, co která část onoho příkazu přesně dělá (ke skriptování v bashi mám zatím ještě daleko) a jelikož nepoužívám žádnou rpm distribuci, tak úplně přesně nevím, co daný rmp příkaz udělá, ale tuším ... :)

Zdar Max
Měl jsem sen ... :(
Max avatar 20.11.2007 07:37 Max | skóre: 64 | blog: Max_Devaine
Rozbalit Rozbalit vše Re: opensuse 10.3 a chyba zypp-checkpatches-wrapper
Jop, málem bych tapoměl :) :
rpm -ivh *.*
Ty hvězdičky naznačují, že se má nainstalovat vše v aktuálním adresáři. Myslím, že v našem případě by to mohlo vypadat i takhle :
rpm -ivh *
Ale kdo ví :)
Pokud to nepůjde, tak to zkus ještě jednotlivě, balíček po balíčku :
rpm -ivh libzypp-3.26.2-2.x86_64.rpm
rpm -ivh boost-1.33.1-108.x86_64.rpm
rpm -ivh zypper-0.8.23-7.x86_64.rpm
Zdar Max
Měl jsem sen ... :(
20.11.2007 13:11 lolo6 | skóre: 20
Rozbalit Rozbalit vše Re: opensuse 10.3 a chyba zypp-checkpatches-wrapper
Super,dik.Ja som vedel,ze tomu niekto rozumie.Idem na to,dam vediet.
20.11.2007 21:14 lolo6 | skóre: 20
Rozbalit Rozbalit vše Re: opensuse 10.3 a chyba zypp-checkpatches-wrapper
Tak ze dane prikazy som nestihol precvicit,problem sa dnesnym updateom vyriesil sam skor nez som stihol nieco podniknut.Inak dakujem vsetkym co sa snazili pomoct.

Založit nové vláknoNahoru

Tiskni Sdílej: Linkuj Jaggni to Vybrali.sme.sk Google Del.icio.us Facebook

ISSN 1214-1267   www.czech-server.cz
© 1999-2015 Nitemedia s. r. o. Všechna práva vyhrazena.