abclinuxu.cz AbcLinuxu.cz itbiz.cz ITBiz.cz HDmag.cz HDmag.cz abcprace.cz AbcPráce.cz
AbcLinuxu hledá autory!
Inzerujte na AbcPráce.cz od 950 Kč
Rozšířené hledání
×

dnes 18:11 | Nová verze

Společnost Oracle oficiálně oznámila vydání Java SE 9 (JDK 9), Java Platform Enterprise Edition 8 (Java EE 8) a Java EE 8 Software Development Kit (SDK). Java SE 9 přináší více než 150 nových vlastností.

Ladislav Hagara | Komentářů: 0
dnes 12:11 | Komunita

Na Humble Bundle lze získat hororovou počítačovou hru Outlast (Wikipedie) běžící také v Linuxu zdarma. Speciální akce končí v sobotu v 19:00.

Ladislav Hagara | Komentářů: 0
dnes 10:33 | Humor

Mozilla.cz upozorňuje na Knihu Mozilly (Wikipedie), tj. velikonoční vajíčko ve Firefoxu. Zobrazit jej lze zadáním about:mozilla do adresního řádku. Aktuální verze Firefoxu obsahuje proroctví 15:1 "Dvojčata Mamonu se rozhádala a jejich souboje uvrhly svět do nové tmy. Zvířeti se ale tma hnusila. A tak se stalo mrštnější a silnější, šlo vpřed a jeho počty rostly. A zvíře přineslo oheň a světlo do tmy". Firefox 57 bude obsahovat proroctví 11:14. To je zatím jenom v angličtině. Pomoci lze s překladem do češtiny.

Ladislav Hagara | Komentářů: 6
dnes 01:22 | Zajímavý projekt
Před měsícem byla spuštěna kampaň na podporu chytrého telefonu Librem 5, jenž by měl respektovat bezpečnost, svobodu a soukromí uživatelů. Cílem kampaně je vybrat alespoň milion a půl dolarů. Aktuálně je vybráno přes 600 000 dolarů, tj. 40 %. Kampaň poběží ještě další měsíc. Podporu projektu oznámilo KDE i GNOME.
Ladislav Hagara | Komentářů: 22
dnes 00:55 | Komunita

Agentura DISA (Defense Information Systems Agency) publikovala (pdf) Ubuntu 16.04 Security Technical Implementation Guide (STIG) (zip), tj. doporučené bezpečnostní nastavení Ubuntu 16.04. Ubuntu se tak dostalo mezi unixové operační systémy a linuxové distribuce AIX, HP-UX, Oracle Linux, Red Hat a Solaris [reddit].

Ladislav Hagara | Komentářů: 1
včera 22:55 | Bezpečnostní upozornění

CSIRT.CZ informuje, že byly vydány nové bezpečnostní aktualizace, které opravují několik zranitelných míst v Sambě. Útočník může využít zranitelnosti s cílem získání přístupu k potenciálně citlivých informací. Uživatelům a správcům je doporučeno, aby zkontrolovali bezpečnostní opatření pro CVE-2017-12150, CVE-2017-12151 a CVE-2017-12163 a provedli potřebné aktualizace.

Ladislav Hagara | Komentářů: 0
včera 21:44 | Komunita

Společnost Red Hat aktualizovala svůj slib ohledně softwarových patentů. Slib nově zahrnuje i open source software pod permisivními licencemi.

Ladislav Hagara | Komentářů: 0
včera 08:55 | Komunita

Do 22. září probíhá v Mountain View konference XDC2017 (X.Org Developer's Conference). Na programu je řada zajímavých přednášek. Sledovat je lze online. K dispozici je záznam přednášek ze včerejšího dne.

Ladislav Hagara | Komentářů: 0
20.9. 17:33 | Nová verze

Byla vydána nová stabilní verze 1.12 (1.12.955.36) webového prohlížeče Vivaldi (Wikipedie). Z novinek vývojáři zdůrazňují možnost zobrazení metadat u digitálních fotografií, vylepšený panel stahování a omezení sytosti barvy zdůraznění (YouTube). Nejnovější Vivaldi je postaveno na Chromiu 61.0.3163.91.

Ladislav Hagara | Komentářů: 40
20.9. 10:55 | Nová verze

Byla vydána verze 4.0 programovacího jazyka Swift (Wikipedie). Zdrojové kódy jsou k dispozici na GitHubu. Ke stažení jsou oficiální binární balíčky pro Ubuntu 16.10, Ubuntu 16.04 a Ubuntu 14.04.

Ladislav Hagara | Komentářů: 5
Těžíte nějakou kryptoměnu?
 (5%)
 (3%)
 (17%)
 (75%)
Celkem 557 hlasů
 Komentářů: 22, poslední 29.8. 11:23
    Rozcestník

    Dotaz: novejsi jadro pro OpenSuse 10.2?

    13.12.2007 11:29 hajoucha | skóre: 21
    novejsi jadro pro OpenSuse 10.2?
    Přečteno: 637×

    Ahojda

    mam opensuse 10.2 a jadro kernel-default-2.6.18.8-0.7

    Nyni potrebuji v systemu zprovoznit radic 3ware 9650SE-4lpml, ktery je vsak defaultne az v jadrech 2.6.19 a vyssich.

    Zkousel jsem stahnout ovladace od vyrobce, urcene primo pro Suse 10.2, nicmene prislusne moduly jsou zase jenom pro _starsi_ jadra a pri pokusu je zavest (prikazem insmod)hlasi chybu insmod: error inserting '/lib/modules/2.6.18.8-0.7-default/kernel/drivers/scsi/3w-9xxx.ko': -1 Invalid module format

    Sam normalne pouzivam jinou distribuci, avsak nyni mam docasne na starosti jiny stroj. Jak se takovyto problem resi v Suse?

    Odpovědi

    the.max avatar 13.12.2007 14:04 the.max | skóre: 46 | blog: Davidovo smetiště | Bílina
    Rozbalit Rozbalit vše Re: novejsi jadro pro OpenSuse 10.2?
    nevim jak se resi v suse, ale na www.kernel.org rostou zdrojaky novych kernelu, takze staci si ho stahnout, nakonfigurovat a prelozit.
    KERNEL ULTRAS Fan Team || Sabaton - nejlepší učitel dějepisu || Gentoo - dokud nás systemd nerozdělí.
    13.12.2007 14:24 hajoucha | skóre: 21
    Rozbalit Rozbalit vše Re: novejsi jadro pro OpenSuse 10.2?
    no, to prave lidi co pouzivaji suse moc nedoporucuji, takze si to nechavam az jako uplne posledni moznost.
    the.max avatar 13.12.2007 17:35 the.max | skóre: 46 | blog: Davidovo smetiště | Bílina
    Rozbalit Rozbalit vše Re: novejsi jadro pro OpenSuse 10.2?
    Jestli oni se spis neboji toho, ze se to bude ptat na takovy divny veci jako jaky maji procesor nebo jestli maji v pocitaci sbernici PCI:-D Me totiz prijde suse jako moc klikaci...
    KERNEL ULTRAS Fan Team || Sabaton - nejlepší učitel dějepisu || Gentoo - dokud nás systemd nerozdělí.
    Marek Stopka avatar 13.12.2007 20:10 Marek Stopka | skóre: 57 | blog: Paranoidní blog | London, United Kingdom
    Rozbalit Rozbalit vše Re: novejsi jadro pro OpenSuse 10.2?
    Jo, máš pravdu... Je strašně obtížné si v openSUSE pustit terminál s vimem. Dalo mi to hooodně práce. Ani nechápu jak to můžu každý den zvládat.
    13.12.2007 22:57 Ash | skóre: 53
    Rozbalit Rozbalit vše Re: novejsi jadro pro OpenSuse 10.2?
    On tím "klikací" asi myslel "zaměřené primárně na klikání" či tak něco. Mně to tedy tak také připadá... Docela dlouho jsem třeba bádal, jak z console nainstalovat 1-Click-Install chytrej foo.ymp :) Čekal jsem že by mělo jít něco jako ymp foo.ymp, ale nakonec jsem skončil u firefox foo.ymp. Asi poprvé od dob Windows, co jsem sw instaloval firefoxem :)

    (Jinak teda předpokládám že se to někde v yast2 dá dohledat v menu...)
    14.12.2007 10:47 miso | skóre: 36 | blog: iSCSI_initiator_howto | Praha
    Rozbalit Rozbalit vše Re: novejsi jadro pro OpenSuse 10.2?
    /sbin/OneClickInstallUI foo.ymp
    Project Satan infects Calculon with Werecar virus
    14.12.2007 11:41 Ash | skóre: 53
    Rozbalit Rozbalit vše Re: novejsi jadro pro OpenSuse 10.2?
    Díky, to by mohlo být ono. Asi to bude opravdu převlečený yast2, ale musím tedy říct, že chování v shellu je poněkud... nestandardní. Prostě klikací OS.
    # /sbin/OneClickInstallUI
    
    syntax error at line 1, column 49, byte 49:
    <!DOCTYPE HTML PUBLIC "-//IETF//DTD HTML 2.0//EN">
    ================================================^
    <html><head>
    <title>301 Moved Permanently</title>
     at /usr/lib/perl5/vendor_perl/5.8.8/x86_64-linux-thread-multi/XML/Parser.pm line 187
    Can't undef active subroutine during global destruction.
    
    # /sbin/OneClickInstallUI -h
    Usage: /sbin/yast2 [OPTIONS] [MODULE] [module specific parameters]
    
    OPTIONS:
            -h, --help      this message
            -l, --list      list all available modules
            -g, --geometry  default window size (qt only)
            --noborder      no window manager border for main window
            --fullscreen    use full screen
    
    exceptional case for installing packages:
    /sbin/yast2 OPTION <package> [<package> [...]]
    
    OPTION:
            -i, --install   install rpm package
                --update    update rpm package
                --remove    remove rpm package
    
    <package> can be a single short package name (e.g. gvim)
    which will be installed with dependency checking, or the full
    path to an rpm package (e.g /tmp/gvim.rpm) which will be
    installed without dependency checking
    
    
    # /sbin/OneClickInstallUI python-SOAPpy.ymp //...ok
    # /sbin/yast2 python-SOAPpy.ymp
    No such client module python-SOAPpy.ymp
    
    Run 'yast2 -h' for help on usage
    
    14.12.2007 12:02 Ash | skóre: 53
    Rozbalit Rozbalit vše Re: novejsi jadro pro OpenSuse 10.2?
    Jinak se oml. za OT, ono to sem přecejen nepatřilo.
    14.12.2007 13:24 Martin Vidner | Praha
    Rozbalit Rozbalit vše Re: novejsi jadro pro OpenSuse 10.2?
    Ja jsem hlavni spolupachatel OCI. (Hlavni pachatel je Benji Weber)

    # /sbin/OneClickInstallUI

    hloupa chyba, opravim

    # /sbin/OneClickInstallUI -h

    taky opravim

    # /sbin/OneClickInstallUI python-SOAPpy.ymp //...ok

    takze to funguje?

    # /sbin/yast2 python-SOAPpy.ymp

    No such client module python-SOAPpy.ymp

    to je korektni chybova hlaska. ymp neni yasti program
    14.12.2007 22:37 Ash | skóre: 53
    Rozbalit Rozbalit vše Re: novejsi jadro pro OpenSuse 10.2?
    No, já jsem ten SOAP už předtím nainstaloval přes firefox a tam asociovanou aplikaci, tam to zafunguvalo ok. To, že pak z console příkaz prošel a nic neprotestovalo, tak bych předpokládal, že to zafungovalo, neb u funkčních programů to je standardní chování. Ale jistý si tím nejsem, protože jak říkám, SOAP už byl nainstalovaný... Takže žel nemohu potvrdit.

    Jinak OCI je dobrý nápad a z GUI je to určitě supr :) Jakožto majitele Gentoo, kde "je v portage všechno - no flame" a seznam ofic. overlayí znám, mne hledání "těch správných" repozitářů pro Debian či SuSE někdy trochu potrápí... :) Já nejsem moc GUI typ a tohle jsem instaloval na serveru, čili když jsem si jako zdroj našel *.ymp, tak jsem hledal snadný způsob, jak to nainstalovat v consoli.
    14.12.2007 22:40 Ash | skóre: 53
    Rozbalit Rozbalit vše Re: novejsi jadro pro OpenSuse 10.2?
    Jo k tomu že ymp není yast program... Ono v GUI to okno které naběhlo mělo v titulku napsáno yast2 (!?) a ten help byl taky od yast2, takže odtud jsem soudil že to je nějaký překabátěný yast...
    13.12.2007 14:55 DNA
    Rozbalit Rozbalit vše Re: novejsi jadro pro OpenSuse 10.2?
    co si zkusit ten modul přeložit? Něco jako návod je ZDE na stránkách výrobce
    13.12.2007 15:14 hajoucha | skóre: 21
    Rozbalit Rozbalit vše Re: novejsi jadro pro OpenSuse 10.2?
    jo, to by bylo uplne supr. Ma to jediny problem v tom, ze za boha nejsem schopny najit zdrojak s ovladacem pro 3ware 9650SE-4LPML.
    13.12.2007 16:02 DNA
    Rozbalit Rozbalit vše Re: novejsi jadro pro OpenSuse 10.2?
    ZDE na stránce výrobce a vypadá nadějně, co jsem tak zběžně koukal do návodu, tak pro tebe v archivu bude Makefile.oth, pak při kompilaci se mu musejí předat parametry jako smp apod. Good luck
    13.12.2007 16:18 hajoucha | skóre: 21
    Rozbalit Rozbalit vše Re: novejsi jadro pro OpenSuse 10.2?
    jo, to zkusim. Mas link na ten navod?
    13.12.2007 16:45 DNA
    Rozbalit Rozbalit vše Re: novejsi jadro pro OpenSuse 10.2?
    už jsem ho sem dal v první reakci (TOTO), měl by být pochopitelný
    13.12.2007 17:01 hajoucha | skóre: 21
    Rozbalit Rozbalit vše Re: novejsi jadro pro OpenSuse 10.2?
    aha, tak to jo. Ja chapu ty instrukce, ale nechapu, pro ktere vsechny radice ten navod plati :) Protoze v otazce je "9000 series", ale v odpovedi je uz jenom "9500S". Mezitim jsem vyhledal jeste novejsi driver s nazvem "3w-9xxx-2.6.18kernel_9.5.0.tgz", lec ten pri kompilaci vyhodi jakousi divnou hlasku:/bin/sh: scripts/basic/fixdep: No such file or directory

    zkusim ten druhy zdrojak....

    13.12.2007 17:14 DNA
    Rozbalit Rozbalit vše Re: novejsi jadro pro OpenSuse 10.2?
    podle mě jde hlavně o postup při kompilaci, tzn. jednotlivé moduly nemají rozdílnou instalaci... Ještě úryvek (ODSUD:
    To compile a Linux driver for the 9500S or 9550SX/9590SE, you must have the Linux driver source installed on your system.  For the 2.4 Linux kernel, you must be booted to the UP kernel.  Download the 3ware driver source from the latest available 3ware code set (e.g. 9.3.0.3).  Extract the source 3w-9xxx.tgz (e.g. tar zxvf 3w-9xxx.tgz).  Change into the folder called driver that is created. 
    
    In the commands below, remember that the text you enter is case sensitive. (Be sure to type Makefile.rh, not makefile.rh.) Use the Makefile.rh for RedHat distributions, and Makefile.oth for other (e.g. SuSE) distributions.
    
    To build UP module, type: make -f Makefile.rh
    The file created is 3w-xxxx.o (7000/8000) or 3w-9xxx.o (9500S)
    
    To build SMP module, type: make smp -f Makefile.rh
    The file created is 3w-xxxx.smp (7000/8000) or 3w-9xxx.smp (9500S)
    
    To build Enterprise module, type: make ent -f Makefile.rh
    The file created is 3w-xxxx.ent (7000/8000) or 3w-9xxx.ent (9500S)
    
    To build Bigmem module, type: make big -f Makefile.rh
    The file created is 3w-xxxx.big (7000/8000) or 3w-9xxx.big (9500S)
    
    To build Hugemem module, type: make hug -f Makefile.rh
    The file created is 3w-xxxx.hug (7000/8000) or 3w-9xxx.hug (9500S)
    
    To build Boot module
    (this is used when creating a driver for the 32-bit driver diskette), type:
    make bot -f Makefile.rh
    The file created is 3w-xxxx.bot (7000/8000) or 3w-9xxx.bot (9500S)
    
    For compiling a driver for the 2.6 Linux kernel, see 3ware KB article 12690 http://www.3ware.com/kb/article.aspx?id =12690
    Omlouvám se za nezalamování řádků, nechce se mi to upravovat
    13.12.2007 17:31 hajoucha | skóre: 21
    Rozbalit Rozbalit vše Re: novejsi jadro pro OpenSuse 10.2?
    tak smula. Zkusil jsem zkompilovat ten zdrojak, ale chcipne to s asi milionem chyb. Zkusim jeste factory jadro. Treba to projde. Kdyz ne, tak jsem v pasti. Uz by snad jenom pomohl dotaz na 3ware support, aby tu binarku zkompilovali sami pro prislusne suse jaderko :))))
    13.12.2007 17:48 DNA
    Rozbalit Rozbalit vše Re: novejsi jadro pro OpenSuse 10.2?
    kdybys sem hodil jak jsi to zkoušel kompilovat a co ti to vrátilo za chyby, možná by se s tím dalo něco dělat... Je možné, že jsem ti poslal špatný odkaz na zdroják, nebo nemáš nainstalované a přeložené zdrojáky stávajícího jádra, prostě z toho že to chcípne s milionem chyb je těžké zjistit kde je problém. Možná jsi měl dotaz položit ve věštírně :D
    13.12.2007 15:31 Veritas | skóre: 13 | blog: veritas
    Rozbalit Rozbalit vše Re: novejsi jadro pro OpenSuse 10.2?
    Je možné si přidat do yastu repositář factory, kde se teď dá získat jádro, 2.6.24.

    V yastu přidat repositář factory http://download.opensuse.org/distribution/SL-OSS-factory/inst-source/ (měla by fungovat získat z url, nebo zadat ručně yast repositary) a mělo by to jet.

    Ale je to jen jedna z možností.
    Nehledej hry v Linuxu. Linux je hra!
    13.12.2007 21:00 vladaf
    Rozbalit Rozbalit vše Re: novejsi jadro pro OpenSuse 10.2?
    Lepsi je podle mne tento repozitar http://download.opensuse.org/repositories/Kernel:/Vanilla/openSUSE_10.2/ .
    To by melo byt nejnovejsi Vanilla jadro ve verzi pro pro Suse 10.2. S Factory jadrem jsem mel pred nejakym caskem na 10.0 problemy, nechodila mi myslim sitovka. Obecne je na http://download.opensuse.org/repositories/ spousta repozitaru aktualniho softwaru, ze az zrak prechazi :)
    13.12.2007 20:07 bluemoon
    Rozbalit Rozbalit vše Re: novejsi jadro pro OpenSuse 10.2?
    ten modul se zavadi jak jsem zbezne nasel: modprobe 3w-9xxx. Na rpm.pbone.net uz jsou jadra pro suse 2.6.23. tak si ho nainstaluj primo z rpm balicku, jednoducho bez kompilace a zaved modul. Kdyz by se nedarilo, tak se koukni do /boot/config-2.6.23...a zkus ho tam najit a edituj ho rucne: Ja jsem tam nasel tohle:
    CONFIG_BLK_DEV_3W_XXXX_RAID=m
    CONFIG_SCSI_3W_9XXX=m
    13.12.2007 20:11 bluemoon
    Rozbalit Rozbalit vše Re: novejsi jadro pro OpenSuse 10.2?
    musi tam byt =m to jest, ze se ten modul zavede pri startu systemu
    14.12.2007 15:02 hajoucha | skóre: 21
    Rozbalit Rozbalit vše Re: novejsi jadro pro OpenSuse 10.2?
    no, tak nakonec jsem system proste updatoval na 10.3 a tim je to vyrizeno. Kazdopadne dekuji vsem zucastnenym, bylo to poucne :)

    Založit nové vláknoNahoru

    Tiskni Sdílej: Linkuj Jaggni to Vybrali.sme.sk Google Del.icio.us Facebook

    ISSN 1214-1267   www.czech-server.cz
    © 1999-2015 Nitemedia s. r. o. Všechna práva vyhrazena.