abclinuxu.cz AbcLinuxu.cz itbiz.cz ITBiz.cz HDmag.cz HDmag.cz abcprace.cz AbcPráce.cz
AbcLinuxu hledá autory!
Inzerujte na AbcPráce.cz od 950 Kč
Rozšířené hledání
×

včera 20:40 | Zajímavý článek

Lukáš Růžička v článku S Hydrogenem za lepší rytmus aneb bubeníkem snadno a rychle na MojeFedora.cz představuje automatického bubeníka s názvem Hydrogen (Wikipedie): Hydrogen je velmi vydařený program, který rozhodně nesmí chybět ve výbavě žádného linuxového muzikanta. Umožňuje nejen vytváření jednoduchých bicích doprovodů, ale také sofistikované programování bicích a perkusí, jehož výsledek se naprosto vyrovná drahým

… více »
Ladislav Hagara | Komentářů: 1
včera 13:55 | Zajímavý projekt

UPSat (Twitter) je první open source nanodružice (CubeSat). Jedná se o společný projekt nadace Libre Space Foundation a University of Patras. Repozitáře projektu jsou k dispozici na GitHubu. Pod Libre Space Foundation patří také projekt SatNOGS (zprávička), projekt globální sítě open source pozemních satelitních stanic, vítězný projekt soutěže The Hackaday Prize 2014. UPSat je součástí mise QB50 (Twitter). ID UPSatu je GR02. GPS přijímač na UPSatu je od české společnosti SkyFox Labs. Součástí mise QB50 je i česká nanodružice VZLUSAT-1 s ID CZ02.

Ladislav Hagara | Komentářů: 3
21.4. 15:00 | Komunita

V diskusním listu Thunderbird planning vývojáři poštovního klienta Thunderbird řeší, zda by nebylo možné budoucí Thunderbird postavit nad webovými technologiemi, tj. nad Electronem, stejně jako například Nylas Mail. Gecko, nad kterým je Thunderbird postaven, se má hodně změnit. V plánu je odstranění vlastností, které Firefox už nepotřebuje, ale Thunderbird je na nich závislý [Hacker News, reddit].

Ladislav Hagara | Komentářů: 85
21.4. 10:22 | Bezpečnostní upozornění

Společnost Oracle vydala čtvrtletní bezpečnostní aktualizaci svých softwarových produktů (CPU, Critical Patch Update). Opraveno bylo celkově 299 bezpečnostních chyb. V Oracle Java SE je například opraveno 8 bezpečnostních chyb. Vzdáleně zneužitelných bez autentizace je 7 z nich. V Oracle MySQL je opraveno 39 bezpečnostních chyb. Vzdáleně zneužitelných bez autentizace je 11 z nich.

Ladislav Hagara | Komentářů: 6
21.4. 10:00 | Pozvánky

V úterý 25. dubna proběhne další Prague Containers Meetup. Přijďte se nechat inspirovat jak zlepšit build/delivery pipeline vašich kontejnerových aplikací.

little-drunk-jesus | Komentářů: 2
20.4. 21:33 | Komunita

Na Launchpadu se objevilo kódové jméno následující verze Ubuntu. Ubuntu 17.10 bude Artful Aardvark (mazaný hrabáč) [OMG! Ubuntu!].

Ladislav Hagara | Komentářů: 10
20.4. 20:11 | Zajímavý software

MojeFedora.cz informuje, že společnost Nylas oznámila vydání verze 2.0 poštovního klienta Nylas Mail (původně Nylas N1), která již plně podporuje Linux. Obchodní model společnosti je tzv. open core. Samotný klient je open source, ale uživatel si musí připlatit za některé pokročilé funkce. V základu se lze připojit k GMailu nebo libovolnému účtu přes IMAP. Podpora Exchange je pouze v placené verzi. Klient je napsaný nad Electronem.

Ladislav Hagara | Komentářů: 12
20.4. 15:55 | Zajímavý článek

České centrum pro investigativní žurnalistiku (ČCIŽ) publikovalo na svých stránkách článek s názvem Je česká státní správa „rukojmím Microsoftu“?. Drtivá většina české veřejné správy je závislá na výrobcích softwarového gigantu Microsoft – a nijak zvlášť jí to nevadí.

Ladislav Hagara | Komentářů: 18
20.4. 02:48 | Nová verze

Google Chrome 58 byl prohlášen za stabilní. Nejnovější stabilní verze 58.0.3029.81 tohoto webového prohlížeče přináší řadu oprav a vylepšení (YouTube). Opraveno bylo 29 bezpečnostních chyb. Mezi nimi i chyba umožňující phishing s unicode doménami.

Ladislav Hagara | Komentářů: 0
19.4. 22:44 | Nová verze

Po šesti týdnech od vydání verze 52.0 byla vydána verze 53.0 webového prohlížeče Mozilla Firefox. Z novinek lze upozornit například na nové kompaktní vzhledy – tmavý z Firefoxu Developer Edition a jeho světlá varianta. Na Linuxu byla ukončena podpora procesorů starších než Pentium 4 a AMD Opteron. Podrobné informace v poznámkách k vydání a na stránce věnované vývojářům. Řešeny jsou také bezpečnostní chyby.

Ladislav Hagara | Komentářů: 11
Chystáte se pořídit CPU AMD Ryzen?
 (4%)
 (35%)
 (0%)
 (7%)
 (45%)
 (9%)
Celkem 276 hlasů
 Komentářů: 31, poslední 20.4. 21:26
    Rozcestník

    Dotaz: Instalace nového připojení T-Mobile

    Pavel Janíček avatar 23.3.2008 20:58 Pavel Janíček | skóre: 4 | Beroun
    Instalace nového připojení T-Mobile
    Přečteno: 820×
    Příloha:
    Ahoj všem,
    na novém CD s názvem "web'n'walk manager" by měla být sekce podpory linuxu. A ano, mým úkolem je vymyslet "něco" co linuxáka připojí kdekoliv, kdykoliv ... znáte to :)

    Nejdřív moje idea:
    - To, co jsem vymyslel, by mělo fungovat "všude" - proto je třeba zůstat na úrovni řádkových příkazů
    - Program musí být schopná spustit i lama. - Moje idea je návod typu "otevřete konzoli a napište:
    su
    sh install.sh

    - na tom pracují i scripty pripojit a odpojit - aby se dalo připojit/odpojit jednoduše a jediným příkazem

    Known bugs:
    - Program předpokládá, že uživatel je root (v Ubuntu nic takového jako root není)
    - Program nic nedělá, jenom na obrazovku vypíše, co má dělat - To kvůli ladění, nechci, aby to komukoliv, kdo to v této fázi spustí, nějak "rozhasilo" systém
    - Program přepisuje soubor chap-secrets, pokud uživatel používal více připojení s ověřením CHAP, bude mu fungovat jenom to od T-Mobile (možná to bude nakonec kýžená vlastnost :)


    Jednoznačně bych byl rád, kdyby se na můj výtvor někdo podíval a navedl mě. Přeci jenom je to záležitost pro komunitu, tak bych chtěl využít komunity :)

    BTW je třeba někam do scriptu přidávat licenci?

    Jednoznačně mé díky patří všem, co se na to alespoň kouknou
    Díky! :)

    Odpovědi

    socket avatar 5.4.2008 11:43 socket | Lučenec
    Rozbalit Rozbalit vše Re: Instalace nového připojení T-Mobile
    ako tak kukam na ten instalaciny skript tak máš s toho nejake hala-bala, takže ty chceš aby ti to niekto opravil ? Dalej, tie 3 skripty by som riešil v jednom cez 1 argument. príklad :

    ./t-mobile.sh install alebo ./t-mobile.sh pripojit alebo ./t-mobile.sh odpojit

    ci ze by si pouzil jeden s 3 argumentov (install, pripojit, odpojit). Ale hlavne napíš čo vlastne chceš lebo stvojho príspevku som to veľmi nepochopil.
    ked nevieš, tak nefušuj.
    socket avatar 5.4.2008 11:44 socket | Lučenec
    Rozbalit Rozbalit vše Re: Instalace nového připojení T-Mobile
    este som zabudol, licencia ku programu nemusí byt prilozene ale kazdý skript alebo komplet cely program musi byt oznaceny pod aku licenciu je vypustený.
    ked nevieš, tak nefušuj.
    7.4.2008 22:30 miro
    Rozbalit Rozbalit vše Re: Instalace nového připojení T-Mobile
    Přeci jenom je to záležitost pro komunitu, tak bych chtěl využít komunity :)

    IMHO to není tak úplně pravda. Je to záležitost pro platící zákazníky T-mobilu (nikdo jiný - alespoň u nás - ten ovladač reálně nevyužije), takže považuji opravdu za špatné, že takový gigant jako T-mobile nemá doslova a do písmene pár šušňů, které by mohl uvalit do napsání pořádného nástroje. V té firmě opravdu nikomu (krom vás) nedojde, že jste na Linuxu už vydělali tím, že ta karta vůbec jde rozjet (díky panu Kosinovi) pod Linuxem (aniž by to T-mobile stálo byť jen zlámanou grešli), takže nechat nějakého profíka za pár tisícovek napsat instalační utilitu neznamená prodělek? Když vidím, jak o tom víte míň než já (a já bych si na opravdu slušný instalační skript netroufl), a když vidím, že to celé visí na vás, je mi z toho trochu úzko. Neberte to tak, že bych vás chtěl zrazovat, jsem rád, že je podpora Linuxu u T-mobile aspoň takováto, ale když tak na to koukám, můžu si hlavu ukroutit...

    Počítejte s tím, že slabší stránka komunity je v tom, že ne vždycky vám někdo odpoví, a i když vám odpoví, nemusí to vyřešit váš problém. I mě už se to stalo, a to na čemkoli ohledně IT nevydělávám. Vám možná leckdo nepomůže už z principu, protože si řekně něco ve smyslu, že kdyby si programátoři web'n'walk manageru řekli za práci o dvacet tisíc víc, T-mobile jim je bez problému dá, zatímco Linux je pro T-mobile zadarmo drahej, takže co by se "komunita" namáhala.

    Ale pokud je tohle ze strany T-mobilu v současné době maximum možného, tak se s vámi o pár postřehů rád podělím. Ale počítejte s tím, že jste nyní v situaci, kdy jednooký vede slepého, ten instalátor za vás zkrátka nenapíšu (podotýkám, že píšu výhradně o PCMCIA kartě).

    To, co jsem vymyslel, by mělo fungovat "všude" - proto je třeba zůstat na úrovni řádkových příkazů
    To není tak úplně pravda. Mnoho uživatelů bude mít nainstalováno Zenity v Gnome či Kdialog v KDE. U minimalistů se s vysokou pravděpodobností najde aspoň xmessage. Přítomnost těchto utilit se dá otestovat, stejně jako lze otestovat, zda je skript spuštěn z X nebo z textové konzole (a podle toho nabídnout uživateli textovou nebo grafickou interakci). Inspirací může být utilita k nastavování síťového rozhraní v distribuci Knoppix. Asi to nebude úkol pro vás, ale FYI obecně vzato to jde.
    Program předpokládá, že uživatel je root (v Ubuntu nic takového jako root není)
    V Ubuntu něco takového samozřejmě je. Jen se nebojte otestovat, jestli skript běží pod rootem, jinak skript BFU zhavaruje s (nejspíš) anglickou nesrozumitelnou hláškou.
    Program přepisuje soubor chap-secrets, pokud uživatel používal více připojení s ověřením CHAP, bude mu fungovat jenom to od T-Mobile (možná to bude nakonec kýžená vlastnost :)

    Jako vtip dobrý ;-) Jako vážně míněnou podporu (nejen) pro BFU by to asi nebyl nejlepší nápad. BTW - kdypak opravíte v tomhle dokumentu chybu v souboru /etc/ppp/peers/tm4g , na kterou jsem vás upozorňoval tady? ;-)

    Osobně bych ten ovladač asi přidal na to CD už zkompilovaný a jen ho překopíroval na příslušné místo a spustil depmod (zdrojáky ovladače by ale na médiu měly v souladu s GPL být taky). Ale to je spíš můj subjektivní pocit, že je to tak šikovnější, já to tak v každém případě dělám na ntb, o který se tak trochu starám, když vyjde nějaký patch kernelu, protože mi přijde nesmyslné kompilovat stále dokola to samé. Na druhou stranu to asi ničemu zásadnímu neublíží (leda by BFU neměl nainstalován gcc ;), rozhodně by však asi měl být BFU upozorněn, že po updatu jádra bude muset instalační skript pustit znovu. Naopak nevím, co se přihodí, pokud budu chtít nainstalovat již nainstalovaný ovladač (a dobrovolně zkoušet to nehodlám), takže by asi nebylo od věci tuhle věc taky ve skriptu otestovat.

    Za poměrně zásadní bych považoval to, že by měl skript testovat verzi jádra. Do nižších než 2.6.18 ten ovladač AFAIK nemá smysl tlačit (existuje snad jakási verze toho ovladače pro jádro 2.6.9 - nebo tak něco - s touhle verzí ovladače ale evidentně nepracujete). Do jádra 2.6.25 a vyššího ten ovladač taky netlačte, protože podle release notes k jádru 2.6.25RC1 to vypadá, že tam ten ovladač konečně bude. Dobrá zpráva pro T-mobile, a kdyby jeho manažeři chtěli pánům Kosinovi a Štěrbovi zaslat za jejich programátorskou a diplomatickou práci alespoň děkovný dopis, bylo by to od nich určitě hezké.

    Poslední poznámka se vztahuje ke skriptu odpojit - nevím, jestli zaslání signálu HUP procesům pppd způsobí ukončení připojení (předpokládám, že jste to testoval). Ačkoli mi není úplně jasné, zda existuje rozumný důvod, aby měl uživatel současně víc peer-to-peer připojení současně, přišlo by mi korektnější přes ps zjistit číslo procesu (vyvolaného skriptem pripojit) a tomu zaslat signál TERM (případně skript na pár vteřin zasleepovat a bude-li poté proces ještě existovat, poslat mu signál KILL).

    Obávám se, že můj výčet připomínek není úplný. Víc ale asi neporadím. Přeju mnoho štěstí a rozhodně se nenechte odradit od další propagace Linuxu ve vaší firmě.

    Pavel Janíček avatar 9.4.2008 16:33 Pavel Janíček | skóre: 4 | Beroun
    Rozbalit Rozbalit vše Re: Instalace nového připojení T-Mobile
    Uff, to jsem dostal nášup...

    K první poznámce: Máte pravdu. Osobně neočekávám jakoukoliv podporu. Jenom jsem si řekl, že by to byl dobrý nápad se alespoň zeptat. Doma mě vždycky učili "Líná huba, holý neštěstí", tak jsem si pro svůj dobrý pocit, že jsem se alespoň zeptal napsal do diskuze.
    BTW T-Mobile nejspíš bude mít "pár šušňů" ale to je asi nejvíc, co dovedu naznačit.

    Děkuji za postřeh, zkusím se tomu věnovat hlouběji

    Zkusím zapracovat do "verze 2.0"

    tento dokument projde úpravou, až bude jádro 2.6.25 ve finální verzi. A máte pravdu, jsou v něm ovladače na 4G kartu. Dokud nebude toto jádro stabilní, připadá mi úprava dokumentu, jako plýtvání času. Vím, že tam byly chyby, ale koukněte se ještě jednou na ten dokument. Zmiňovanou chybu jsem reportoval a podle info, co jsem dostal, by měla být opravena

    Na CD je ovladač zabalený i rozbalený, ale nezkompilovaný. Doplnil jsem README file popisující co a jak.

    Bohužel jsem první verzi dělal v absolutním časovém presu, takže CD bude plné chyb

    Ale osobně - poté, co jsem si adresář "Linux" na CD prohlédl, hrdě si myslím, že je to krok kupředu.

    Děkuji za feedback, moje flamewar já by se chtělo hodně hádat, ale nakonec jsem ho ukočíroval :-)

    Ještě jednou díky!
    10.4.2008 19:37 miro
    Rozbalit Rozbalit vše Re: Instalace nového připojení T-Mobile
    Jenom jsem si řekl, že by to byl dobrý nápad se alespoň zeptat.

    To je v pořádku, však jsem vás za to nesepsul ;-)

    moje flamewar já by se chtělo hodně hádat

    Pravda, mohl jsem si ušetřit místy uštěpačný tón, přiznávám, ale věřím, že jste pochopil, že moje uštěpačnost byla věnována výhradně vašemu zaměstnavateli, nikoli vám. Vám jsem naopak vyslovil uznání za to, co děláte v podmínkách, ve kterých to děláte. A opakuji - budu rád, když se nenecháte odradit. Upozornění na to, jak komunita (někdy) funguje či může fungovat bylo v podstatě věcnou poznámkou. Ostatně já osobně (ve vašem pojetí taky součást "komunity") jsem vám svůj čas a dobře míněnou snahu věnoval. V tomhle konkrétním případě může svoji roli hrát i to, že ten HW, na kterém funguje vaše připojení, je poměrně specifický, a asi se spoustě lidem (z dobrých důvodů) nechce kafrat do instalace něčeho, co neznají. Já tu kartu znám, ale zase neumím to, co byste vy potřeboval...

    Vím, že tam byly chyby, ale koukněte se ještě jednou na ten dokument. Zmiňovanou chybu jsem reportoval a podle info, co jsem dostal, by měla být opravena

    Tak to jste buď moje připomínky špatně četl nebo se z vašeho intranetu dostanete na jinou verzi dokumentu než co si stáhne zbytek světa z internetu. Takže abychom měli jasno, o čem se bavíme, jedná se o dokument, který jsem dnes stáhnul příkazem wget --no-cache http://t-mobile.cz/FileStorage/4G_combi_instalace_linux.pdf Kontrolní součet md5 je 8ebdab7ab6dfc2beca24340fd428f339 (u sebe zjistíte příkazem md5sum nazevsouboru). Pokud si myslíte, že to není nic proti ničemu, klidně ten soubor uploadnu jako přílohu. Nebo vám ho pošlu na vámi zadanou mailovou adresu nebo JID.

    Z toho, co píšu tady, nevidím opraveného vůbec nic.

    Neproporcionální font je formalita, budiž.

    Zastaralá informace o podpoře jader končící verzí 2.6.21. BFU přijde na vaše stránky, jestli by 4G karta stála za hřích, nastartuje noťas s distribucí openSUSE 10.3, která je už přes půl roku k mání, zadá uname -r , vypadne mu něco jako 2.6.22blablaněco a řekne si: "hm, asi se budu muset poohlédnout u konkurence, třeba to tam bude lepší; downgradovat distro kvůli tomu ale nebudu". Nevadí? Budiž.

    Třetí připomínka zni:

    (...) tohle prostě nemůže nikdy fungovat, protože v souboru /etc/ppp/peers/tm4g vám v řádku connect "/usr/sbin/chat -v -f etc/chatscripts/tm4g" chybí lomítko před "etc". Většina lidí, které tady potkáte, si s něčím takovým hravě poradí, ale jako návod pro béefúčka je to nepoužitelné.

    Na tohle jsem samozřejmě přišel tak, že mi ten návod nefungoval, takže jsem zkouknul konfiguráky a uhodilo mě to do očí. Tak jsem přidal lomítko a všechno běželo, jak má. A když se podívám na ten váš dokument, který jsem si dnes znovu stáhnul, pořád vidím connect "/usr/sbin/chat -v -f etc/chatscripts/tm4g" . Nefunkční konfigurák, který z nějakého důvodu není opraven, i když o tom nedostatku víte, to mi přijde docela zásadní. Vám ne?

    Suma sumárum: co tedy vlastně v tom dokumentu bylo opraveno?

    Ad úprava dokumentu až bude finální jádro 2.6.25: To je samozřejmě na vás, osobně bych uživatele asi upozornil na to, že mají sledovat nové informace, až přijde jádro 2.6.25, což pro většinu z nich znamená až si budou instalovat (*)buntu 8.10, openSUSE 11, Fedoru 10 (ale i dřívější, ve Fedoře se, tuším, updatují subminor verze jádra i v rámci jednoho distra) nebo příští verzi Mandrivy (neznám její číslování). Jde o to, aby si uživatelé nerozvrtali systém, ve kterém už budou mít funkční ovladač v jádře. To, proč se u ovladačů uvádí verze jádra, se kterými jsou kompatibilní, je dáno tím, že ovladač musí být napsán kompatibilně k ABI konkrétního jádra. To se však může změnit i v rámci subminor verzí kernelu, takže uživatel, který si jednou stáhne a přečte váš návod (případně použije ten z CD), se může pokusit jej aplikovat i v budoucnu (třeba při instalaci té desítkové Fedory) a přeplácne si tak podporu karty, kterou má zabudovanou přímo v jádře, (možná už) nefunkčním ovladačem. Raději bych těmto incidentům předešel včasným varováním. Je mi však jasné, že máte na práci i jiné věci.

    Ale osobně - poté, co jsem si adresář "Linux" na CD prohlédl, hrdě si myslím, že je to krok kupředu.
    To si myslím taky a nikdy jsem to nezpochybňoval. Gratuluju a díky za to.
    BTW T-Mobile nejspíš bude mít "pár šušňů"

    Super zpráva, jsem rád, že se blýská na lepší časy. Doufám, že budete mít příležitost trochu ohlídat zadání. Bylo by IMHO v zájmu T-mobilu, aby veškeré nástroje byly explicitně pod GPL (případně FDL pokud jde o dokumentaci) a aby krom čistě textového rozhraní někdo napsal i jejich zaintegrování do grafických síťových utilit, které používají mainstreamové distribuce (*buntu, Mandriva, openSUSE, Fedora). Pak je šance, že se to jednou dostane i přímo do nich, takže podpora Linuxu se v mnoha případech omezí na dotaz "máte distribuci tu a tu? V tom případě nepotřebujete nic zvláštního, prostě si v menu najděte položku "síťová připojení", tam tu kartu vyberte z rozbalovacího seznamu, odklepněte "OK" a můžete začít brouzdat. Pak můžete začít přidávat CD s Mandrivou jako bonus ke kartě ;-)

    Jo a ještě možná jednu věc by nebylo špatné pořešit, pokud už se rozjíždí nějaká podpora pro Linux. SIMka se prodává chráněná PINem, což speciálně na Linuxu je trochu problém. Jednak vám to ten ovladač neprozradí (takže když na to zapomenete, máte o zábavu postaráno), jednak jsem na to téma kdysi trochu googlil a nedostal jsem příliš uspokojivou odpověď. Existuje na to snad jakýsi AT příkaz, ale ta SIMka potřebuje nějaký čas, než se odemkne, a byl tam nějaký problém v tom, že další AT příkaz neuměl počkat na odemčení a dobýval se do zamčené SIMky. Tohle si pamatuju ale jen velmi matně. Osobně jsem to vyřešil tak, že jsem SIMku vrazil do mobilu a odemknul ji tam (což mi v mobilu smazalo historii hovorů, ve které jsem měl jedno důležité číslo, které jsem ještě neměl uložené v seznamu...). Kdyby i na takovou věc zbyly nějaký "šušně", určitě by to nezarmoutilo. ;-) Pokud "šušně" nebudou, tak by se na to dalo aspoň upozornit zde (vím, není to specifické pro Linux, Web'n'walk manažer ve Windows taky se zamknutou SIMkou nepoběží, ale kdysi jsem zběžně prolítnul dokumentaci k tomu programu, a tuším, že si o odemknutí sám řekne. Mě osobně to při instalaci karty hned nedošlo, takže jsem se chvíli trápil úplně zbytečně).

    16.1.2010 12:36 Jirka
    Rozbalit Rozbalit vše Re: Instalace nového připojení T-Mobile
    A co tak udělat skript, který nainstaluje KPPP a nakopíruje konfikurační soubory (pro KPPP) s nastavením T-Mobile. Já takto připojuji Siemens S65, naisntaloval jsme KPPP a podle pokynů ze stránky T-Mobile nastavil ručně potřebné parametry, vytáčím ikonou KPPP a ukončuji tlačítkem na KPPP.

    Založit nové vláknoNahoru

    Tiskni Sdílej: Linkuj Jaggni to Vybrali.sme.sk Google Del.icio.us Facebook

    ISSN 1214-1267   www.czech-server.cz
    © 1999-2015 Nitemedia s. r. o. Všechna práva vyhrazena.