abclinuxu.cz AbcLinuxu.cz itbiz.cz ITBiz.cz HDmag.cz HDmag.cz abcprace.cz AbcPráce.cz
AbcLinuxu hledá autory!
Inzerujte na AbcPráce.cz od 950 Kč
Rozšířené hledání
×

20.9. 10:55 | Nová verze

Byla vydána verze 4.0 programovacího jazyka Swift (Wikipedie). Zdrojové kódy jsou k dispozici na GitHubu. Ke stažení jsou oficiální binární balíčky pro Ubuntu 16.10, Ubuntu 16.04 a Ubuntu 14.04.

Ladislav Hagara | Komentářů: 0
dnes 23:33 | Zajímavý software

MojeFedora informuje, že PipeWire byl oficiálně oznámen (en). PipeWire bude zprostředkovávat aplikacím jednotný přístup k audiu a videu. Jedním z hlavních důvodů je možnost izolovat aplikace od audio a video zdrojů. Aplikace nebudou mít přímý přístup k hardwaru, ale budou se muset ptát multimediálního serveru PipeWire, který jim je na základě nastavených oprávnění poskytne nebo ne. V budoucnu by měl PipeWire nahradit PulseAudio.

Ladislav Hagara | Komentářů: 9
dnes 00:55 | Zajímavý software

Společnost IBM věnovala svůj JVM (Java Virtual Machine) s názvem J9 nadaci Eclipse. Nové oficiální jméno tohoto virtuálního stroje určeného pro běh aplikací napsaných v programovacím jazyce Java je Eclipse OpenJ9 (Wikipedie). Podrobnosti v často kladených dotazech (FAQ).

Ladislav Hagara | Komentářů: 13
dnes 00:11 | IT novinky

Mezinárodní konsorcium W3C (World Wide Web Consortium) publikovalo kontroverzní rozšíření HTML 5.1 EME (Encrypted Media Extensions) jako webový standard, tj. schválilo DRM v HTML 5.1. Mezinárodní nezisková organizace EFF (Electronic Frontier Foundation) hájící občanské svobody v digitálním světě zveřejnila na svých stránkách otevřený dopis adresovaný W3C. EFF s EME zásadně nesouhlasí a W3C opouští.

Ladislav Hagara | Komentářů: 31
včera 18:44 | Zajímavý projekt

Skywriter je deska umožňující snímat 3D gesta. Ben James na svých stránkách ukázal, jak lze pomocí této desky a Arduina Leonardo ovládat linuxový desktop. Videoukázka na YouTube. Ukázka kódu na GitHubu [reddit].

Ladislav Hagara | Komentářů: 4
včera 15:22 | Komunita

Od 8. do 10. září proběhla v Paříži konference UbuCon Europe 2017, tj. konference vývojářů a uživatelů linuxové distribuce Ubuntu. Dustin Kirkland z Canonicalu se ve své přednášce věnoval Ubuntu 18.04 LTS. Záznam přednášky byl zveřejněn na YouTube [reddit].

Ladislav Hagara | Komentářů: 1
včera 06:00 | Nová verze

Byla vydána verze 2.0 open source programu na kreslení grafů Veusz (Wikipedie). Z novinek je nutno zdůraznit přechod na Qt5 a PyQt5. Podrobnosti v poznámkách k vydání.

Ladislav Hagara | Komentářů: 0
17.9. 19:10 | Pozvánky

Společnost EurOpen.CZ pořádá 51. konferenci, která se bude konat 8. - 11. 10. 2017 v hotelu Vinné sklepy U Jeňoura, Prušánky - Nechory. Můžete se těšit na IoT s nádechem bezpečnosti, softwarový vývoj a optimalizace kódu, informační systémy ve státní správě a spoustu dalšího. Program konference a ceny viz: pozvanka51.pdf.

… více »
cuba | Komentářů: 0
17.9. 18:57 | Pozvánky

Šestý ročník konference LinuxDayshotový program (workshopy) a zároveň otevírá registraci. Čeká nás 67 přednášek rozdělených do čtyř místností a 13 prakticky zaměřených workshopů. Konference se uskuteční 7. a 8. října v pražských Dejvicích v areálu ČVUT na Fakultě Informačních Technologií.

Petr Krčmář | Komentářů: 0
17.9. 06:00 | Zajímavý software

Mozilla na svém blogu představuje doplněk Firefoxu s názvem Firefox Multi-Account Containers. Dosud byl doplněk k dispozici pod názvem Containers jako experiment Firefox Test Pilotu. Popis experimentu: Kontejnery vám umožní vytvořit ve Firefoxu profily pro všechny vaše online životy. Vlastní označení a barevné panely pomáhají udržet rozdílné aktivity — jako nakupování online, plánování cest nebo kontrolování pracovního e-mailu —

… více »
Ladislav Hagara | Komentářů: 14
Těžíte nějakou kryptoměnu?
 (5%)
 (3%)
 (17%)
 (75%)
Celkem 543 hlasů
 Komentářů: 22, poslední 29.8. 11:23
    Rozcestník

    Dotaz: aptitude a apt-get stavkuji

    19.6.2008 17:30 Nes | skóre: 20 | blog: Nes
    aptitude a apt-get stavkuji
    Přečteno: 1415×
    aptitude update - vpohode probehne a pak:
    aptitude upgrade
    W: The "upgrade" command is deprecated; use "safe-upgrade" instead.
    Čtu seznamy balíků... Hotovo
    Vytvářím strom závislostí       
    Čtu stavové informace... Hotovo
    Čtu rozšířené stavové informace      
    Inicializuji stavy balíků... Hotovo
    Načítám popisy úloh... Hotovo    
    Řeším závislosti...
    Řeším závislosti...
    Řeším závislosti...
    Řeším závislosti...
    Řeším závislosti...
    Řeším závislosti...
    Řeším závislosti...
    otevřené: 38; zavřené: 188; odložené: 343; konfliktní: 7                .Řeším závislosti...
    otevřené: 32; zavřené: 207; odložené: 388; konfliktní: 7                .Řeším závislosti...
    otevřené: 30; zavřené: 238; odložené: 444; konfliktní: 9                .Řeším závislosti...
    otevřené: 28; zavřené: 270; odložené: 499; konfliktní: 11               .Řeším závislosti...
    Řeším závislosti...
    otevřené: 27; zavřené: 316; odložené: 573; konfliktní: 11               .Řeším závislosti...
    Řeším závislosti...
    Řeším závislosti...
    Řeším závislosti...
    Řeším závislosti...
    Řeším závislosti...
    Řeším závislosti...
    Řeším závislosti...
    otevřené: 25; zavřené: 472; odložené: 793; konfliktní: 11               oŘeším závislosti...
    otevřené: 24; zavřené: 498; odložené: 837; konfliktní: 11               .Řeším závislosti...
    otevřené: 24; zavřené: 522; odložené: 883; konfliktní: 11               .Řeším závislosti...
    otevřené: 23; zavřené: 565; odložené: 953; konfliktní: 11               .Řeším závislosti...
    otevřené: 23; zavřené: 611; odložené: 1037; konfliktní: 11              oŘeším závislosti...
    otevřené: 22; zavřené: 637; odložené: 1081; konfliktní: 11              .Řeším závislosti...
    otevřené: 22; zavřené: 661; odložené: 1127; konfliktní: 11              .Řeším závislosti...
    otevřené: 21; zavřené: 704; odložené: 1197; konfliktní: 11              .Řeším závislosti...
    otevřené: 19; zavřené: 896; odložené: 1550; konfliktní: 12              oŘeším závislosti...
    otevřené: 16; zavřené: 924; odložené: 1592; konfliktní: 12              .Řeším závislosti...
    otevřené: 16; zavřené: 982; odložené: 1689; konfliktní: 12              oŘeším závislosti...
    otevřené: 15; zavřené: 1023; odložené: 1749; konfliktní: 12             .Řeším závislosti...
    otevřené: 17; zavřené: 1107; odložené: 1893; konfliktní: 12             OŘeším závislosti...
    otevřené: 15; zavřené: 1132; odložené: 1930; konfliktní: 12             .Řeším závislosti...
    otevřené: 17; zavřené: 1193; odložené: 2034; konfliktní: 12             oŘeším závislosti...
    otevřené: 14; zavřené: 1229; odložené: 2084; konfliktní: 12             .Řeším závislosti...
    otevřené: 18; zavřené: 1311; odložené: 2225; konfliktní: 12             OŘeším závislosti...
    otevřené: 17; zavřené: 1341; odložené: 2262; konfliktní: 12             .Řeším závislosti...
    otevřené: 16; zavřené: 1372; odložené: 2300; konfliktní: 12             .Řeším závislosti...
    otevřené: 14; zavřené: 1422; odložené: 2379; konfliktní: 12             oŘeším závislosti...
    otevřené: 14; zavřené: 1465; odložené: 2456; konfliktní: 12             oŘeším závislosti...
    otevřené: 14; zavřené: 1520; odložené: 2539; konfliktní: 12             oŘeším závislosti...
    otevřené: 14; zavřené: 1580; odložené: 2651; konfliktní: 12             OŘeším závislosti...
    otevřené: 13; zavřené: 1636; odložené: 2733; konfliktní: 12             oŘeším závislosti...
    otevřené: 12; zavřené: 1675; odložené: 2802; konfliktní: 12             oŘeším závislosti...
    otevřené: 12; zavřené: 1735; odložené: 2893; konfliktní: 12             oŘeším závislosti...
    otevřené: 11; zavřené: 1791; odložené: 2999; konfliktní: 12             OŘeším závislosti...
    otevřené: 12; zavřené: 1854; odložené: 3111; konfliktní: 12             oŘeším závislosti...
    otevřené: 13; zavřené: 1922; odložené: 3229; konfliktní: 12             OŘeším závislosti...
    otevřené: 11; zavřené: 1965; odložené: 3307; konfliktní: 12             oŘeším závislosti...
    otevřené: 15; zavřené: 2050; odložené: 3449; konfliktní: 12             oŘeším závislosti...
    otevřené: 14; zavřené: 2111; odložené: 3562; konfliktní: 12             oŘeším závislosti...
    otevřené: 12; zavřené: 2186; odložené: 3687; konfliktní: 12             OŘeším závislosti...
    otevřené: 13; zavřené: 2255; odložené: 3810; konfliktní: 12             OŘeším závislosti...
    otevřené: 21; zavřené: 2397; odložené: 4075; konfliktní: 12             oŘeším závislosti...
    otevřené: 20; zavřené: 2498; odložené: 4243; konfliktní: 12             .Řeším závislosti...
    otevřené: 19; zavřené: 2609; odložené: 4445; konfliktní: 12             oŘeším závislosti...
    otevřené: 17; zavřené: 2683; odložené: 4581; konfliktní: 12             oŘeším závislosti...
    otevřené: 15; zavřené: 2806; odložené: 4808; konfliktní: 12             oŘeším závislosti...
    otevřené: 14; zavřené: 2899; odložené: 4966; konfliktní: 13             .Řeším závislosti...
    otevřené: 14; zavřené: 3008; odložené: 5164; konfliktní: 13             oŘeším závislosti...
    otevřené: 13; zavřené: 3092; odložené: 5313; konfliktní: 13             .Řeším závislosti...
    otevřené: 9; zavřené: 3270; odložené: 5660; konfliktní: 13              oŘeším závislosti...
    otevřené: 6; zavřené: 3345; odložené: 5786; konfliktní: 14              oŘeším závislosti...
    otevřené: 8; zavřené: 3488; odložené: 6059; konfliktní: 14              OŘeším závislosti...
    otevřené: 5; zavřené: 3568; odložené: 6190; konfliktní: 14              oŘeším závislosti...
    otevřené: 4; zavřené: 3611; odložené: 6254; konfliktní: 14              .Následující balíky mají nesplněné závislosti:
      ghostscript: Koliduje s: gs-common (< 8.62) ale 0.3.13-0.1 je nainstalován a je podržen v aktuálním stavu.
                   Koliduje s: gs-esp (< 8.62) ale 8.15.3.dfsg.1-1etch1 je nainstalován a je podržen v aktuálním stavu.
                   Koliduje s: gs-gpl (< 8.62) ale 8.56.dfsg.1-1.1 je nainstalován a je podržen v aktuálním stavu.
    aptitude safe-upgrade probehne stejnym zpusobem....

    jakekoliv odinstalovani probehne stejnou chybou:
    aptitude remove nautilus-data
    Čtu seznamy balíků... Hotovo
    Vytvářím strom závislostí       
    Čtu stavové informace... Hotovo
    Čtu rozšířené stavové informace      
    Inicializuji stavy balíků... Hotovo
    Načítám popisy úloh... Hotovo    
    Následující balíky jsou PORUŠENY:
      deskbar-applet gnome-netstatus-applet gnome-power-manager 
      gnome-system-monitor gnome-utils 
    Následující balíky budou ODSTRANĚNY:
      nautilus-data 
    The following partially installed packages will be configured:
      gnome-terminal gnome-terminal-data 
    0 balíků aktualizováno, 0 nově instalováno, 1 k odstranění a 121 neaktualizováno.
    Potřebuji stáhnout 723kB/3006kB archivů. Po rozbalení bude uvolněno 12,7MB.
    Následující balíky mají nesplněné závislosti:
      gnome-power-manager: Závisí na: libgstreamer0.10-0 (>= 0.10.0) ale nedá se nainstalovat
                           Závisí na: libpanel-applet2-0 (>= 2.19.3) ale nedá se nainstalovat
      gnome-system-monitor: Závisí na: libglibmm-2.4-1c2a (>= 2.16.0) ale nedá se nainstalovat
                            Závisí na: libgtkmm-2.4-1c2a (>= 1:2.12.0) ale nedá se nainstalovat
      gnome-utils: Závisí na: libgnome-desktop-2 (>= 2.11.1) ale nedá se nainstalovat
                   Závisí na: libgnomeprint2.2-0 (>= 2.17.0) ale nedá se nainstalovat
                   Závisí na: libgnomeprintui2.2-0 (>= 2.17.0) ale nedá se nainstalovat
                   Závisí na: libpanel-applet2-0 (>= 2.19.3) ale nedá se nainstalovat
      deskbar-applet: Závisí na: libebook1.2-9 (>= 2.22.1) ale nedá se nainstalovat
                      Závisí na: libedataserver1.2-9 (>= 2.22.1) ale nedá se nainstalovat
                      Závisí na: libgnome-desktop-2 (>= 2.22.0) ale nedá se nainstalovat
                      Závisí na: python-gtk2 (>= 2.8.6-1) ale nedá se nainstalovat
                      Závisí na: python-glade2 (>= 2.8.6-1) ale nedá se nainstalovat
                      Závisí na: python-gnome2 (>= 2.12.4-1) ale nedá se nainstalovat
                      Závisí na: python-gnome2-desktop ale nedá se nainstalovat
                      Závisí na: python-dbus ale nedá se nainstalovat
      gnome-netstatus-applet: Závisí na: libpanel-applet2-0 (>= 2.19.3) ale nedá se nainstalovat
    E: Nebyl jsem schopen nalézt soubor s balíkem gnome-applets-data. Asi budete muset tento balík opravit ručně.
    Následující akce vyřeší tyto závislosti:
    
    Odstranit následující balíky:
    deskbar-applet
    gnome-power-manager
    gnome-system-monitor
    gnome-utils
    
    Instalovat následující balíky:
    libpanel-applet2-0 [2.20.3-3 (testing, now)]
    
    Skóre je -43
    
    Přijmout toto řešení? [Y/n/q/?] y
    Následující NOVÉ balíky budou instalovány:
      libpanel-applet2-0{a} 
    Následující balíky budou ODSTRANĚNY:
      deskbar-applet{a} gnome-power-manager{a} gnome-system-monitor{a} 
      gnome-utils{a} nautilus-data 
    The following partially installed packages will be configured:
      gnome-terminal gnome-terminal-data 
    0 balíků aktualizováno, 1 nově instalováno, 5 k odstranění a 120 neaktualizováno.
    Potřebuji stáhnout 0B/2284kB archivů. Po rozbalení bude uvolněno 51,7MB.
    Chcete pokračovat? [Y/n/?] y
    E: Nebyl jsem schopen nalézt soubor s balíkem gnome-applets-data. Asi budete muset tento balík opravit ručně.
    Zapisuji rozšířené stavové informace... Hotovo
    E: Nebyl jsem schopen nalézt soubor s balíkem gnome-applets-data. Asi budete muset tento balík opravit ručně.
    E: Vnitřní chyba: nemohu vytvořit seznam balíků ke stažení
    osobne si myslim ze jsou poskozene nejake knihovny - soubory - neexistuje nejaky prikaz co rekne aby cely system zkontroloval a opravil? Nebo nevite nejake jine reseni?

    Diky, uz se s tim morduju dlouho :-(
    ICQ 454104749 zacatecnik v debianu 64 bit, mala znalost anglictiny

    Odpovědi

    19.6.2008 18:25 LesTR | skóre: 17 | Plzeň
    Rozbalit Rozbalit vše Re: aptitude a apt-get stavkuji
    aptitude dist-upgrade?
    Save The World - http://www.worldcommunitygrid.org/ LesTR
    19.6.2008 20:15 Jan Šimák | skóre: 37 | Hradec Králové
    Rozbalit Rozbalit vše Re: aptitude a apt-get stavkuji
    Případně ještě přidat volbu --full-resolver Raději si ale předem přečti definici v man.
    19.6.2008 21:40 Nes | skóre: 20 | blog: Nes
    Rozbalit Rozbalit vše Re: aptitude a apt-get stavkuji
    v man aptitude se nenachazi zadne slovo co obsahuje resol, stejne tak ani neni v man apt-get
    ICQ 454104749 zacatecnik v debianu 64 bit, mala znalost anglictiny
    19.6.2008 21:34 Nes | skóre: 20 | blog: Nes
    Rozbalit Rozbalit vše Re: aptitude a apt-get stavkuji
     aptitude dist-upgrade
    Čtu seznamy balíků... Hotovo
    Vytvářím strom závislostí       
    Čtu stavové informace... Hotovo
    Čtu rozšířené stavové informace      
    Inicializuji stavy balíků... Hotovo
    Zapisuji rozšířené stavové informace... Hotovo
    Načítám popisy úloh... Hotovo                  
    Následující balíky jsou PORUŠENY:
      deskbar-applet ghostscript gnome-utils gnotepad+ libft-perl 
      libglade-gnome0 libglade0 libsasl2 libversion-perl 
    Následující NOVÉ balíky budou instalovány:
      alacarte{a} bsd-mailx{a} cdrdao{a} centerim{a} centerim-common{a} 
      cpp-4.2{a} desktop-base{a} desktop-file-utils{a} djview4{a} 
      djvulibre-desktop{a} djvulibre-plugin{a} dvd+rw-tools{a} 
      evolution-data-server{a} evolution-data-server-common{a} expect{a} 
      g++-4.2{a} gcc-4.2{a} gcc-4.2-base{a} genisoimage{a} ghostscript-x{a} 
      gnome-about{a} gnome-applets{a} gnome-control-center{a} 
      gnome-desktop-data{a} gnome-icon-theme{a} gnome-media{a} 
      gnome-media-common{a} gnome-menus{a} gnome-panel{a} gnome-session{a} 
      gnome-settings-daemon{a} grub-common{a} gstreamer0.10-alsa{a} 
      gstreamer0.10-plugins-base{a} gstreamer0.10-plugins-good{a} 
      gstreamer0.10-x{a} libaa1{a} libao2{a} libapache2-reload-perl{a} 
      libapm1{a} libbind9-30{a} libc-ares1{a} libcaca0{a} libcairomm-1.0-1{a} 
      libcamel1.2-11{a} libcap2{a} libcdio7{a} libclamav4{a} 
      libcompress-raw-zlib-perl{a} libcpufreq0{a} libcucul0{a} 
      libcurl3-gnutls{a} libdevmapper1.02.1{a} libdjvulibre21{a} libdns32{a} 
      libdv4{a} libebook1.2-9{a} libecal1.2-7{a} libedata-book1.2-2{a} 
      libedata-cal1.2-6{a} libedataserver1.2-9{a} libedataserverui1.2-8{a} 
      libegroupwise1.2-13{a} libemail-date-format-perl{a} libexempi3{a} 
      libffi5{a} libfsplib0{a} libgdata-google1.2-1{a} libgdata1.2-1{a} 
      libglib1.2ldbl{a} libglibmm-2.4-1c2a{a} libgnome-desktop-2{a} 
      libgnome-media0{a} libgnome-window-settings1{a} libgnomekbd-common{a} 
      libgnomekbd2{a} libgnomekbdui2{a} libgs8{a} libgsm1{a} libgssglue1{a} 
      libgstreamer-plugins-base0.10-0{a} libgstreamer0.10-0{a} 
      libgtkmm-2.4-1c2a{a} libgucharmap6{a} libgweather-common{a} 
      libgweather1{a} libio-compress-base-perl{a} libio-compress-zlib-perl{a} 
      libisc32{a} libisccc30{a} libisccfg30{a} liblwres30{a} libmetacity0{a} 
      libnautilus-burn4{a} libneon27-gnutls{a} libobparser21{a} 
      libobrender21{a} liboil0.3{a} liborbit0ldbl{a} libpanel-applet2-0{a} 
      libpci3{a} libperl5.10{a} libpq5{a} libpth20{a} libqt4-assistant{a} 
      libqt4-core{a} libqt4-dbus{a} libqt4-designer{a} libqt4-gui{a} 
      libqt4-network{a} libqt4-opengl{a} libqt4-qt3support{a} libqt4-script{a} 
      libqt4-sql{a} libqt4-sql-mysql{a} libqt4-svg{a} libqt4-test{a} 
      libqt4-xml{a} libqtcore4{a} libqtgui4{a} librsvg2-common{a} libshout3{a} 
      libslab0{a} libsoup2.4-1{a} libsox-fmt-alsa{a} libsox-fmt-base{a} 
      libsox0{a} libstdc++6-4.2-dev{a} libtag1c2a{a} libterm-readkey-perl{a} 
      libterm-readline-perl-perl{a} libtheora0{a} libtrackerclient0{a} 
      libvisual-0.4-0{a} libvisual-0.4-plugins{a} libwavpack1{a} 
      libxklavier12{a} libxsettings-client0{a} metacity{a} metacity-common{a} 
      nautilus{a} nautilus-cd-burner{a} netcat-traditional{a} 
      openssh-blacklist{a} openssh-blacklist-extra{a} openssl-blacklist{a} 
      perl-doc{a} python-cairo{a} python-glade2{a} python-gmenu{a} 
      python-gnome2{a} python-gobject{a} python-gtk2{a} python-numeric{a} 
      python-pyorbit{a} python-sepolgen{a} qt4-qtconfig{a} tcl8.5{a} 
      ttf-dejavu-core{a} ttf-dejavu-extra{a} wodim{a} xkb-data{a} 
    Následující balíky budou ODSTRANĚNY:
      centericq-common{u} g++-4.1{u} libarchive-tar-perl{a} libclamav3{a} 
      libcurl3{u} libdjvulibre15{a} libglib1.2{a} libgssapi2{a} libldap2{a} 
      libneon26{u} libobparser16{a} libobrender16{a} libopenexr2ldbl{u} 
      liborbit0{a} libperl5.8{u} libpq4{u} libssp0{u} libstdc++6-4.1-dev{u} 
      libungif4g{u} python2.4{u} python2.4-minimal{u} 
    Následující balíky budou aktualizovány:
      bind9 bind9-host centericq clamav-base clamav-daemon clamav-freshclam 
      courier-authlib cpp cpp-4.1 dnsutils dovecot-common dovecot-imapd eggdrop 
      eggdrop-data eject elinks elinks-data g++ gcc gcc-4.1 gcc-4.1-base 
      gdk-imlib11 gnome-applets-data gnome-bin gnome-keyring gnome-libs-data 
      gnome-system-monitor grub gs initscripts irssi klogd libapache2-mod-perl2 
      libaprutil1 libberkeleydb-perl libblkid1 libcairo-perl libcdparanoia0 
      libcompress-zlib-perl libconvert-uulib-perl libdbd-mysql-perl libdbi-perl 
      libdigest-sha1-perl libemail-date-perl libglib-perl libgnome2-canvas-perl 
      libgnome2-perl libgnome2-vfs-perl libgnome32 libgnomesupport0 
      libgnomeui32 libgnorba27 libgnorbagtk0 libgpgme11 libgtk1.2 libgtk2-perl 
      libgtkxmhtml1 libhtml-parser-perl libjasper1 libldap-2.4-2 
      liblocale-gettext-perl libmagick10 libmatchbox1 libnet-dns-perl 
      libnetaddr-ip-perl libnspr4-0d libpam-gnome-keyring librpcsecgss3 
      libruby1.8 libsasl2-2 libsasl2-modules libsemanage1 libsocket6-perl 
      libsvn1 libsys-syslog-perl libtext-charwidth-perl libtext-iconv-perl 
      libtime-piece-perl libunix-syslog-perl lighttpd lwresd mailx manpages 
      nautilus-data netcat nfs-common nfs-kernel-server openbox openssh-client 
      openssh-server pciutils perl perl-base perl-modules perl-suid 
      policycoreutils proftpd python-semanage razor sbcl scponly 
      selinux-policy-refpolicy-targeted sox spamassassin ssl-cert subversion 
      sysklogd sysv-rc tightvncserver ttf-dejavu uswsusp vbetool w3m wget 
      x11-xserver-utils xdg-utils 
    The following partially installed packages will be configured:
      gnome-terminal gnome-terminal-data 
    Následující balíky jsou DOPORUČENÉ, ale NEBUDOU instalovány:
      checkpolicy clamav libbsd-resource-perl libmudflap0-dev libnss-lwres 
      setools 
    116 balíků aktualizováno, 163 nově instalováno, 21 k odstranění a 3 neaktualizováno.
    Potřebuji stáhnout 7846kB/221MB archivů. Po rozbalení bude použito 266MB.
    Následující balíky mají nesplněné závislosti:
      libsasl2: Závisí na: libsasl2-2 (= 2.1.22.dfsg1-8) ale 2.1.22.dfsg1-21 se bude instalovat.
      libversion-perl: Závisí na: perl (< 5.9.0) ale 5.10.0-10 se bude instalovat.
                       Závisí na: perlapi-5.8.8 což je virtuální balík.
      libft-perl: Závisí na: perlapi-5.8.8 což je virtuální balík.
      gnome-utils: Závisí na: libgnomeprint2.2-0 (>= 2.17.0) ale nedá se nainstalovat
                   Závisí na: libgnomeprintui2.2-0 (>= 2.17.0) ale nedá se nainstalovat
      gnotepad+: Závisí na: libglib1.2 (>= 1.2.0) ale nedá se nainstalovat
      deskbar-applet: Závisí na: python-gnome2-desktop ale nedá se nainstalovat
                      Závisí na: python-dbus ale nedá se nainstalovat
      ghostscript: Koliduje s: gs-common (< 8.62) ale 0.3.13-0.1 je nainstalován a je podržen v aktuálním stavu.
                   Koliduje s: gs-esp (< 8.62) ale 8.15.3.dfsg.1-1etch1 je nainstalován a je podržen v aktuálním stavu.
                   Koliduje s: gs-gpl (< 8.62) ale 8.56.dfsg.1-1.1 je nainstalován a je podržen v aktuálním stavu.
      libglade-gnome0: Závisí na: libglib1.2 (>= 1.2.0) ale nedá se nainstalovat
      libglade0: Závisí na: libglib1.2 (>= 1.2.0) ale nedá se nainstalovat
    Následující akce vyřeší tyto závislosti:
    
    Odstranit následující balíky:
    deskbar-applet
    gnome-utils
    gnotepad+
    gnotepad+-help
    libft-perl
    libglade-gnome0
    libglade0
    libversion-perl
    
    Ponechat následující balíky v jejich aktuální verzi:
    libsasl2-2 [2.1.22.dfsg1-8 (< NULxxL>, stable, now)]
    libsasl2-modules [2.1.22.dfsg1-8 (stable, now)]
    
    Aktualizovat následující balíky:
    gs-common [0.3.13-0.1 (now) -> 8.62.dfsg.1-2.1 (testing)]
    gs-esp [8.15.3.dfsg.1-1etch1 (stable, now) -> 8.62.dfsg.1-2.1 (testing)]
    gs-gpl [8.56.dfsg.1-1.1 (now) -> 8.62.dfsg.1-2.1 (testing)]
    
    Ponechat následující závislosti nevyřešené:
    defoma doporučuje libft-perl
    elinks-data doporučuje elinks (= 0.11.3-7)
    gnome-applets doporučuje deskbar-applet
    Skóre je -2054
    
    Přijmout toto řešení? [Y/n/q/?] y
    Následující NOVÉ balíky budou instalovány:
      alacarte{a} bsd-mailx{a} cdrdao{a} centerim{a} centerim-common{a} 
      cpp-4.2{a} desktop-base{a} desktop-file-utils{a} djview4{a} 
      djvulibre-desktop{a} djvulibre-plugin{a} dvd+rw-tools{a} 
      evolution-data-server{a} evolution-data-server-common{a} expect{a} 
      g++-4.2{a} gcc-4.2{a} gcc-4.2-base{a} genisoimage{a} ghostscript{a} 
      ghostscript-x{a} gnome-about{a} gnome-applets{a} gnome-control-center{a} 
      gnome-desktop-data{a} gnome-icon-theme{a} gnome-media{a} 
      gnome-media-common{a} gnome-menus{a} gnome-panel{a} gnome-session{a} 
      gnome-settings-daemon{a} grub-common{a} gstreamer0.10-alsa{a} 
      gstreamer0.10-plugins-base{a} gstreamer0.10-plugins-good{a} 
      gstreamer0.10-x{a} libaa1{a} libao2{a} libapache2-reload-perl{a} 
      libapm1{a} libbind9-30{a} libc-ares1{a} libcaca0{a} libcairomm-1.0-1{a} 
      libcamel1.2-11{a} libcap2{a} libcdio7{a} libclamav4{a} 
      libcompress-raw-zlib-perl{a} libcpufreq0{a} libcucul0{a} 
      libcurl3-gnutls{a} libdevmapper1.02.1{a} libdjvulibre21{a} libdns32{a} 
      libdv4{a} libebook1.2-9{a} libecal1.2-7{a} libedata-book1.2-2{a} 
      libedata-cal1.2-6{a} libedataserver1.2-9{a} libedataserverui1.2-8{a} 
      libegroupwise1.2-13{a} libemail-date-format-perl{a} libexempi3{a} 
      libffi5{a} libfsplib0{a} libgdata-google1.2-1{a} libgdata1.2-1{a} 
      libglib1.2ldbl{a} libglibmm-2.4-1c2a{a} libgnome-desktop-2{a} 
      libgnome-media0{a} libgnome-window-settings1{a} libgnomekbd-common{a} 
      libgnomekbd2{a} libgnomekbdui2{a} libgs8{a} libgsm1{a} libgssglue1{a} 
      libgstreamer-plugins-base0.10-0{a} libgstreamer0.10-0{a} 
      libgtkmm-2.4-1c2a{a} libgucharmap6{a} libgweather-common{a} 
      libgweather1{a} libio-compress-base-perl{a} libio-compress-zlib-perl{a} 
      libisc32{a} libisccc30{a} libisccfg30{a} liblwres30{a} libmetacity0{a} 
      libnautilus-burn4{a} libneon27-gnutls{a} libobparser21{a} 
      libobrender21{a} liboil0.3{a} liborbit0ldbl{a} libpanel-applet2-0{a} 
      libpci3{a} libperl5.10{a} libpq5{a} libpth20{a} libqt4-assistant{a} 
      libqt4-core{a} libqt4-dbus{a} libqt4-designer{a} libqt4-gui{a} 
      libqt4-network{a} libqt4-opengl{a} libqt4-qt3support{a} libqt4-script{a} 
      libqt4-sql{a} libqt4-sql-mysql{a} libqt4-svg{a} libqt4-test{a} 
      libqt4-xml{a} libqtcore4{a} libqtgui4{a} librsvg2-common{a} libshout3{a} 
      libslab0{a} libsoup2.4-1{a} libsox-fmt-alsa{a} libsox-fmt-base{a} 
      libsox0{a} libstdc++6-4.2-dev{a} libtag1c2a{a} libterm-readkey-perl{a} 
      libterm-readline-perl-perl{a} libtheora0{a} libtrackerclient0{a} 
      libvisual-0.4-0{a} libvisual-0.4-plugins{a} libwavpack1{a} 
      libxklavier12{a} libxsettings-client0{a} metacity{a} metacity-common{a} 
      nautilus{a} nautilus-cd-burner{a} netcat-traditional{a} 
      openssh-blacklist{a} openssh-blacklist-extra{a} openssl-blacklist{a} 
      perl-doc{a} python-cairo{a} python-glade2{a} python-gmenu{a} 
      python-gnome2{a} python-gobject{a} python-gtk2{a} python-numeric{a} 
      python-pyorbit{a} python-sepolgen{a} qt4-qtconfig{a} tcl8.5{a} 
      ttf-dejavu-core{a} ttf-dejavu-extra{a} wodim{a} xkb-data{a} 
    Následující balíky budou ODSTRANĚNY:
      centericq-common{u} deskbar-applet{a} g++-4.1{u} gnome-utils{a} 
      gnotepad+{a} gnotepad+-help{a} gs-common{u} gs-esp{u} gs-gpl{u} 
      libarchive-tar-perl{a} libclamav3{a} libcurl3{u} libdb3{u} 
      libdjvulibre15{a} libft-perl{a} libglade-gnome0{a} libglade0{a} 
      libglib1.2{a} libgssapi2{a} libgtkxmhtml1{u} libldap2{a} libneon26{u} 
      libobparser16{a} libobrender16{a} libopenexr2ldbl{u} liborbit0{a} 
      libperl5.8{u} libpq4{u} libssp0{u} libstdc++6-4.1-dev{u} libungif4g{u} 
      libversion-perl{a} libxml1{u} python2.4{u} python2.4-minimal{u} 
    Následující balíky budou aktualizovány:
      bind9 bind9-host centericq clamav-base clamav-daemon clamav-freshclam 
      courier-authlib cpp cpp-4.1 dnsutils dovecot-common dovecot-imapd eggdrop 
      eggdrop-data eject elinks elinks-data g++ gcc gcc-4.1 gcc-4.1-base 
      gdk-imlib11 gnome-applets-data gnome-bin gnome-keyring gnome-libs-data 
      gnome-system-monitor grub gs initscripts irssi klogd libapache2-mod-perl2 
      libaprutil1 libberkeleydb-perl libblkid1 libcairo-perl libcdparanoia0 
      libcompress-zlib-perl libconvert-uulib-perl libdbd-mysql-perl libdbi-perl 
      libdigest-sha1-perl libemail-date-perl libglib-perl libgnome2-canvas-perl 
      libgnome2-perl libgnome2-vfs-perl libgnome32 libgnomesupport0 
      libgnomeui32 libgnorba27 libgnorbagtk0 libgpgme11 libgtk1.2 libgtk2-perl 
      libhtml-parser-perl libjasper1 libldap-2.4-2 liblocale-gettext-perl 
      libmagick10 libmatchbox1 libnet-dns-perl libnetaddr-ip-perl libnspr4-0d 
      libpam-gnome-keyring librpcsecgss3 libruby1.8 libsemanage1 
      libsocket6-perl libsvn1 libsys-syslog-perl libtext-charwidth-perl 
      libtext-iconv-perl libtime-piece-perl libunix-syslog-perl lighttpd lwresd 
      mailx manpages nautilus-data netcat nfs-common nfs-kernel-server openbox 
      openssh-client openssh-server pciutils perl perl-base perl-modules 
      perl-suid policycoreutils proftpd python-semanage razor sbcl scponly 
      selinux-policy-refpolicy-targeted sox spamassassin ssl-cert subversion 
      sysklogd sysv-rc tightvncserver ttf-dejavu uswsusp vbetool w3m wget 
      x11-xserver-utils xdg-utils 
    The following partially installed packages will be configured:
      gnome-terminal gnome-terminal-data 
    Následující balíky jsou DOPORUČENÉ, ale NEBUDOU instalovány:
      checkpolicy clamav libbsd-resource-perl libmudflap0-dev libnss-lwres 
      setools 
    113 balíků aktualizováno, 163 nově instalováno, 35 k odstranění a 2 neaktualizováno.
    Potřebuji stáhnout 0B/213MB archivů. Po rozbalení bude použito 214MB.
    Chcete pokračovat? [Y/n/?] y
    Zapisuji rozšířené stavové informace... Hotovo
    Extrahuji z balíků šablony: 100%
    Přednastavuji balíky...
    (Čtu databázi ... nyní je nainstalováno 65920 souborů a adresářů.)
    Odinstalování balíku deskbar-applet ...
    scrollkeeper-update: symbol lookup error: /usr/lib/libxml2.so.2: undefined symbol: gzopen64
    dpkg: chyba při zpracovávání deskbar-applet (--remove):
     podproces post-removal script vrátil chybový status 127
    Odinstalování balíku gnome-utils ...
    scrollkeeper-update: symbol lookup error: /usr/lib/libxml2.so.2: undefined symbol: gzopen64
    dpkg: chyba při zpracovávání gnome-utils (--remove):
     podproces post-removal script vrátil chybový status 127
    Zpracování spouštěčů pro balík menu ...
    Při zpracování nastaly chyby:
     deskbar-applet
     gnome-utils
    E: Sub-process /usr/bin/dpkg returned an error code (1)
    Instalace balíku selhala. Zkouším obnovit:
    Nastavuji balík lighttpd (1.4.13-4etch4) ...
    Starting web server: lighttpd failed!
    invoke-rc.d: initscript lighttpd, action "start" failed.
    dpkg: chyba při zpracovávání lighttpd (--configure):
     podproces post-installation script vrátil chybový status 1
    Nastavuji balík gnome-terminal-data (2.22.2-1) ...
    scrollkeeper-update: symbol lookup error: /usr/lib/libxml2.so.2: undefined symbol: gzopen64
    dpkg: chyba při zpracovávání gnome-terminal-data (--configure):
     podproces post-installation script vrátil chybový status 127
    dpkg: nesplněné závislosti zamezily konfiguraci balíku gnome-terminal:
     gnome-terminal závisí na gnome-terminal-data (>= 2.22); avšak:
      Balík gnome-terminal-data zatím není zkonfigurován.
     gnome-terminal závisí na gnome-terminal-data (<< 2.23); avšak:
      Balík gnome-terminal-data zatím není zkonfigurován.
    dpkg: chyba při zpracovávání gnome-terminal (--configure):
     problém se závislostmi - nechávám nezkonfigurované
    Zpracování spouštěčů pro balík menu ...
    Při zpracování nastaly chyby:
     lighttpd
     gnome-terminal-data
     gnome-terminal
    Čtu seznamy balíků... Hotovo                    
    Vytvářím strom závislostí       
    Čtu stavové informace... Hotovo
    Čtu rozšířené stavové informace      
    Inicializuji stavy balíků... Hotovo
    Zapisuji rozšířené stavové informace... Hotovo
    Načítám popisy úloh... Hotovo                 
    :-(
    ICQ 454104749 zacatecnik v debianu 64 bit, mala znalost anglictiny
    19.6.2008 23:30 Jirka P
    Rozbalit Rozbalit vše Re: aptitude a apt-get stavkuji
    Vida! Na ty hlášky o scrolkeeper-update si zkuste přečíst toto, s lighttpd vám bohužel neporadím...
    21.6.2008 11:20 Nes | skóre: 20 | blog: Nes
    Rozbalit Rozbalit vše Re: aptitude a apt-get stavkuji
    to scrollkeeper jsem vubec nepochopil co mam delat - je to neco s openoffice nebo tak neco :-(

    Jinak to lighttpd funguje a ja vrele doufam ze jeste dlouho bude (bezi mi na nem dost veci)
    ICQ 454104749 zacatecnik v debianu 64 bit, mala znalost anglictiny
    21.6.2008 15:36 Jirka P
    Rozbalit Rozbalit vše Re: aptitude a apt-get stavkuji
    scrollkeeper: v tom odkazu šlo o to, že tazatel měl nainstalovanou špatnou knihovnu libz. Takže ověřte, že

    ldd /usr/lib/libxml2.so

    vypíše řádek

    libz.so.1 => /usr/lib/libz.so.1

    a že

    nm -D /usr/lib/libz.so.1

    vypíše řádek s gzopen64.
    lighttpd funguje
    Proč teda píše

    Starting web server: lighttpd failed!
    21.6.2008 16:11 Nes | skóre: 20 | blog: Nes
    Rozbalit Rozbalit vše Re: aptitude a apt-get stavkuji
    # ldd /usr/lib/libxml2.so
    ldd: /usr/lib/libxml2.so: není souborem ani adresářem
    # nm -D /usr/lib/libz.so.1
    # 
    nevim proc to pise, ale lighttpd mi bezi :D - za to dam skoro krk :D ;-)

    Co tedy s tou knihovnou? Mam ten soubor zkusit nekde pohledat a nakopirovat? Jak poznam ze to je ta spravna?

    a ohledne toho druheho prikazu - to je take prikaz na zjisteni zda chybi jina knihovna?
    ICQ 454104749 zacatecnik v debianu 64 bit, mala znalost anglictiny
    21.6.2008 16:27 David Jaša | skóre: 44 | blog: Dejvův blog
    Rozbalit Rozbalit vše Re: aptitude a apt-get stavkuji
    Chybí ti balíček libxml2-dev.
    22.6.2008 17:58 Jirka P
    Rozbalit Rozbalit vše Re: aptitude a apt-get stavkuji
    # ldd /usr/lib/libxml2.so
    ldd: /usr/lib/libxml2.so: není souborem ani adresářem
    Sorry. Tak zkuste ldd /usr/lib/libxml2.so.něco, kde něco je asi 2. (zkoušel jsem si to u sebe, kde mam tu knihovnu i bez soname, protože mám ten -dev balík. Vy ho nepotřebujete)
    Co tedy s tou knihovnou?

    Nevim
    Mam ten soubor zkusit nekde pohledat a nakopirovat?
    Ne

    Jde o to, že se cosi neslinkovalo, protože chybí symbol gzopen64. Ten symbol má být v knihovně libz. A teď je možný, že tam není protože se slinkovalo se špatnou libz - např. /opt/co-já-vim/libz.so.1. To by měl zjistit první příkaz. Pokud to tak je, mělo by pomoct tu druhou knihovnu smazat, samozřejmě po tom, co se ujistíte, že to nic nerozbije.

    Nebo je možný, že jste nějak přepsal knihovnu v /usr/lib. V takovém případě pomůže přeinstalování zlib1g. To by měl zjistit druhý příkaz, který vypíše dynamické symboly v libz.so.1. (Ale pokud nemáte nainstalované binutils, tak na to zapomeňte). Výstup má být něco jako:
    jirka@debian:/usr/src/ltp-git$ nm -D /usr/lib/libz.so.1                           
    00000000 A ZLIB_1.2.0                                                             
    00000000 A ZLIB_1.2.0.2                                                           
    00000000 A ZLIB_1.2.0.8                                                           
    00000000 A ZLIB_1.2.2                                                             
    00000000 A ZLIB_1.2.2.3                                                           
    00000000 A ZLIB_1.2.2.4                                                           
             w _Jv_RegisterClasses                                                    
             w __cxa_finalize                                                         
             U __errno_location                                                       
             w __gmon_start__                                                         
    00001970 T adler32                                                                
    ...
    00003fb0 T gzopen64
    
    19.6.2008 21:56 Radek Šlesinger | skóre: 13 | Adamov
    Rozbalit Rozbalit vše Re: aptitude a apt-get stavkuji
    Nemícháš tam nějak stable a testing/unstable? Co máš v sources.list?
    Dalibor Smolík avatar 20.6.2008 13:07 Dalibor Smolík | skóre: 54 | blog: Postrehy_ze_zivota | 50°5'31.93"N,14°19'35.51"E
    Rozbalit Rozbalit vše Re: aptitude a apt-get stavkuji
    Míchání testing a unstable (mít obojí v sources.list) by nemělo mít nějak fatální následky. Ještě bych vyzkoušel aptitude install -f a sledovat výpis a pak dát aptitude dist-upgrade.
    Rozdíly v řeči a ve zvyklostech neznamenají vůbec nic, budeme-li mít stejné cíle a otevřená srdce.
    20.6.2008 13:46 Radek Šlesinger | skóre: 13 | Adamov
    Rozbalit Rozbalit vše Re: aptitude a apt-get stavkuji
    Já v těch výpisech právě vidím balíčky z Etche i z testingu. Na úspěšné míchání by to chtělo mít nastavené aspoň nějaké APT::Default-Release, ne?
    Dalibor Smolík avatar 20.6.2008 16:55 Dalibor Smolík | skóre: 54 | blog: Postrehy_ze_zivota | 50°5'31.93"N,14°19'35.51"E
    Rozbalit Rozbalit vše Re: aptitude a apt-get stavkuji
    samozřejmě :-) v souboru /etc/apt/apt.conf by mělo být APT::Default-Release "version";
    podle potřebné priority
    Rozdíly v řeči a ve zvyklostech neznamenají vůbec nic, budeme-li mít stejné cíle a otevřená srdce.
    20.6.2008 18:27 Radek Šlesinger | skóre: 13 | Adamov
    Rozbalit Rozbalit vše Re: aptitude a apt-get stavkuji
    No právě. :)
    21.6.2008 07:28 Nes | skóre: 20 | blog: Nes
    Rozbalit Rozbalit vše Re: aptitude a apt-get stavkuji
    sources.list - (prosim nekamenovat, to ne ja :D :D, to mi bylo porazeno...
    # 
    # deb cdrom:[Debian GNU/Linux 4.0 r0 _Etch_ - Official amd64 NETINST Binary-1 20070407-11:25]/ etch contrib main
    
    deb cdrom:[Debian GNU/Linux 4.0 r0 _Etch_ - Official amd64 NETINST Binary-1 20070407-11:25]/ etch contrib main
    
    deb http://ftp.cz.debian.org/debian/ etch main contrib non-free
    deb-src http://ftp.cz.debian.org/debian/ etch main contrib non-free
    
    #deb http://ftp.cz.debian.org/debian/ unstable main
    
    deb http://security.debian.org/ etch/updates main contrib
    deb-src http://security.debian.org/ etch/updates main contrib
    
    #deb http://www.claws-mail.org/debian/amd64/ etch main contrib non-free
    
    deb http://ftp.cz.debian.org/debian/ etch main
    deb-src http://ftp.cz.debian.org/debian/ etch main
    
    deb http://ftp.cz.debian.org/debian/ testing main
    deb-src http://ftp.cz.debian.org/debian/ testing main contrib non-free
    deb http://security.debian.org/ testing/updates main
    aptitude install -f - http://www.pastebin.cz/show/6351

    dist-upgrade - http://www.pastebin.cz/show/6352
    ICQ 454104749 zacatecnik v debianu 64 bit, mala znalost anglictiny
    Jakub Lucký avatar 21.6.2008 17:08 Jakub Lucký | skóre: 40 | Praha
    Rozbalit Rozbalit vše Re: aptitude a apt-get stavkuji
    To je nějaké celé namixované...

    Rozhodněte se, kterou verzi chcete používat (stable, testing, unstable) a tu nastavte jako jedinou aspoň do doby, než se to celé zkonsoliduje a zjistíte, jak na to...

    až si vyberete, upravte sources.list jen pro tento výběr, a proveďte apt-get update && apt-get -f install a uvidí se, co dál...

    Jestli nevíte, co si vybrat, tak zhruba popis:

    unstable - rychlé zařazování nového software, reálná (leč ve skutečnosti dost malá - za půl roku jen jeden opravdu problémový program) možnost, že program nebude fungovat.

    testing - o něco pomalejší přísun novinek, ale o to ještě nižší šance že narazíte na bug

    stable - ukrutně (dle mého) starý software, ale taky opravdové minimum bugů...
    If you understand, things are just as they are; if you do not understand, things are just as they are. (Zen P.) Blogísek
    22.6.2008 00:10 Nes | skóre: 20 | blog: Nes
    Rozbalit Rozbalit vše Re: aptitude a apt-get stavkuji
    v sources.list jsem vse zakomentoval, nechal jsem jen deb http://ftp.cz.debian.org/debian/ unstable main

    pak apt-get update + apt-get -f install =

    apt-get -f install Čtu seznamy balíků... Hotovo Vytvářím strom závislostí Čtu stavové informace... Hotovo E: Balík nautilus-data je potřeba přeinstalovat, ale nemohu pro něj nalézt archiv.

    tak jsem jeste odkomentoval:
    deb http://ftp.cz.debian.org/debian/ testing main
    deb-src http://ftp.cz.debian.org/debian/ testing main contrib non-free
    deb http://security.debian.org/ testing/updates main
    
    # apt-get -f install
    Mám:1 http://ftp.cz.debian.org testing Release.gpg [189B]
    Ign http://ftp.cz.debian.org testing/main Translation-cs                       
    Mám:2 http://ftp.cz.debian.org testing Release [74,4kB]    
    Mám:3 http://security.debian.org testing/updates Release.gpg [189B]            
    Ign http://security.debian.org testing/updates/main Translation-cs             
    Mám:4 http://security.debian.org testing/updates Release [40,7kB]              
    Mám:5 http://security.debian.org testing/updates/main Packages [147kB]
    Mám:6 http://ftp.cz.debian.org testing/main Packages [5104kB]
    Mám:7 http://ftp.cz.debian.org testing/main Sources [1934kB]
    Mám:8 http://ftp.cz.debian.org testing/contrib Sources [38,0kB]
    Mám:9 http://ftp.cz.debian.org testing/non-free Sources [41,8kB]
    Staženo 7381kB za 6s (1126kB/s)                                                
    Čtu seznamy balíků... Hotovo
    webseznam:/etc/apt# apt-get -f install
    Čtu seznamy balíků... Hotovo
    Vytvářím strom závislostí       
    Čtu stavové informace... Hotovo
    Následující extra balíky budou instalovány:
      nautilus-data
    Doporučované balíky:
      nautilus
    Následující balíky budou ODSTRANĚNY:
      capplets-data deskbar-applet gnome-applets-data gnome-netstatus-applet
      gnome-panel-data gnome-power-manager gnome-system-monitor gnome-user-guide
      gnome-utils
    Následující balíky budou aktualizovány:
      nautilus-data
    1 aktualizováno, 0 nově instalováno, 9 k odstranění a 137 neaktualizováno.
    13 instalováno nebo odstraněno pouze částečně.
    Potřebuji stáhnout 0B/4094kB archivů.
    Po této operaci bude na disku uvolněno 141MB.
    Chcete pokračovat [Y/n]? y
    (Čtu databázi ... nyní je nainstalováno 65920 souborů a adresářů.)
    Odinstalování balíku capplets-data ...
    update-mime-database: symbol lookup error: /usr/lib/libxml2.so.2: undefined symbol: gzopen64
    dpkg: chyba při zpracovávání capplets-data (--remove):
     podproces post-removal script vrátil chybový status 127
    Odinstalování balíku deskbar-applet ...
    scrollkeeper-update: symbol lookup error: /usr/lib/libxml2.so.2: undefined symbol: gzopen64
    dpkg: chyba při zpracovávání deskbar-applet (--remove):
     podproces post-removal script vrátil chybový status 127
    Odinstalování balíku gnome-applets-data ...
    scrollkeeper-update: symbol lookup error: /usr/lib/libxml2.so.2: undefined symbol: gzopen64
    dpkg: chyba při zpracovávání gnome-applets-data (--remove):
     podproces post-removal script vrátil chybový status 127
    Odinstalování balíku gnome-netstatus-applet ...
    scrollkeeper-update: symbol lookup error: /usr/lib/libxml2.so.2: undefined symbol: gzopen64
    dpkg: chyba při zpracovávání gnome-netstatus-applet (--remove):
     podproces post-removal script vrátil chybový status 127
    Odinstalování balíku gnome-panel-data ...
    gconftool-2: error while loading shared libraries: /usr/lib/libz.so.1: file too short
    dpkg: chyba při zpracovávání gnome-panel-data (--remove):
     podproces post-removal script vrátil chybový status 127
    Odinstalování balíku gnome-power-manager ...
    scrollkeeper-update: symbol lookup error: /usr/lib/libxml2.so.2: undefined symbol: gzopen64
    dpkg: chyba při zpracovávání gnome-power-manager (--remove):
     podproces post-removal script vrátil chybový status 127
    Odinstalování balíku gnome-system-monitor ...
    scrollkeeper-update: symbol lookup error: /usr/lib/libxml2.so.2: undefined symbol: gzopen64
    dpkg: chyba při zpracovávání gnome-system-monitor (--remove):
     podproces post-removal script vrátil chybový status 127
    Odinstalování balíku gnome-user-guide ...
    scrollkeeper-update: symbol lookup error: /usr/lib/libxml2.so.2: undefined symbol: gzopen64
    dpkg: chyba při zpracovávání gnome-user-guide (--remove):
     podproces post-removal script vrátil chybový status 127
    Odinstalování balíku gnome-utils ...
    scrollkeeper-update: symbol lookup error: /usr/lib/libxml2.so.2: undefined symbol: gzopen64
    dpkg: chyba při zpracovávání gnome-utils (--remove):
     podproces post-removal script vrátil chybový status 127
    Zpracování spouštěčů pro balík menu ...
    Při zpracování nastaly chyby:
     capplets-data
     deskbar-applet
     gnome-applets-data
     gnome-netstatus-applet
     gnome-panel-data
     gnome-power-manager
     gnome-system-monitor
     gnome-user-guide
     gnome-utils
    E: Sub-process /usr/bin/dpkg returned an error code (1)
    
    
    
    ICQ 454104749 zacatecnik v debianu 64 bit, mala znalost anglictiny
    Jakub Lucký avatar 22.6.2008 01:12 Jakub Lucký | skóre: 40 | Praha
    Rozbalit Rozbalit vše Re: aptitude a apt-get stavkuji
    Tak ten řádek přepište na
    deb http://ftp.cz.debian.org/debian/ unstable main contrib non-free
    a zkuste:
    apt-get update apt-get -t unstable nautilus-data
    Nevím, co přesně ty errory znamenají, ale jestli máte ještě navíc namixovaný 64bit s 32bitem, tak pánbůh s vámi....
    If you understand, things are just as they are; if you do not understand, things are just as they are. (Zen P.) Blogísek
    22.6.2008 01:38 Nes | skóre: 20 | blog: Nes
    Rozbalit Rozbalit vše Re: aptitude a apt-get stavkuji
    # apt-get update apt-get -t unstable nautilus-data E: Příkaz update neakceptuje žádné argumenty

    tak jsem zkusil
    # apt-get install -t unstable nautilus-data
    Čtu seznamy balíků... Hotovo
    Vytvářím strom závislostí       
    Čtu stavové informace... Hotovo
    Následující balíky byly nainstalovány automaticky a již nejsou potřeba:
      foomatic-db-engine poppler-utils smbclient foomatic-filters libslp1
      avahi-utils libnss-mdns libavahi-core5 samba-common cups-common libpoppler3
      libgs8 libdaemon0 avahi-daemon foomatic-db libavahi-compat-libdnssd1
    Pro jejich odstranění použijte 'apt-get autoremove'.
    Následující extra balíky budou instalovány:
      alacarte avahi-daemon avahi-utils capplets-data cdrdao cups-common
      deskbar-applet desktop-base desktop-file-utils dvd+rw-tools
      evolution-data-server evolution-data-server-common foomatic-db
      foomatic-db-engine foomatic-filters genisoimage gnome-about gnome-applets
      gnome-applets-data gnome-control-center gnome-desktop-data gnome-icon-theme
      gnome-media gnome-media-common gnome-menus gnome-panel gnome-panel-data
      gnome-session gnome-settings-daemon gnome-system-monitor gstreamer0.10-alsa
      gstreamer0.10-plugins-base gstreamer0.10-plugins-good gstreamer0.10-x libaa1
      libao2 libapm1 libavahi-compat-libdnssd1 libavahi-core5 libcaca0
      libcairomm-1.0-1 libcamel1.2-11 libcap2 libcdio7 libcpufreq0 libcucul0
      libdaemon0 libdv4 libebook1.2-9 libecal1.2-7 libedata-book1.2-2
      libedata-cal1.2-6 libedataserver1.2-9 libedataserverui1.2-8
      libegroupwise1.2-13 libexempi3 libffi5 libgdata-google1.2-1 libgdata1.2-1
      libglibmm-2.4-1c2a libgnome-desktop-2 libgnome-media0
      libgnome-window-settings1 libgnomecups1.0-1 libgnomekbd-common libgnomekbd2
      libgnomekbdui2 libgnomeprint2.2-0 libgnomeprint2.2-data libgnomeprintui2.2-0
      libgnomeprintui2.2-common libgs8 libgstreamer-plugins-base0.10-0
      libgstreamer0.10-0 libgtkmm-2.4-1c2a libgtksourceview-common
      libgtksourceview1.0-0 libgucharmap6 libgweather-common libgweather1
      libmetacity0 libnautilus-burn4 libnss-mdns liboil0.3 libpanel-applet2-0
      libpango1.0-0 libpango1.0-common libpoppler3 libpopt0 librsvg2-common
      libshout3 libslab0 libslp1 libsoup2.4-1 libtag1c2a libtheora0
      libtotem-plparser10 libtrackerclient0 libvisual-0.4-0 libvisual-0.4-plugins
      libwavpack1 libxklavier12 metacity metacity-common nautilus
      nautilus-cd-burner poppler-utils python-cairo python-dbus python-glade2
      python-gmenu python-gnome2 python-gnome2-desktop python-gobject python-gtk2
      python-numeric python-pyorbit samba-common smbclient wodim xkb-data
    Navrhované balíky:
      avahi-autoipd gnome kde xfce4 wmaker cdrskin evolution
      evolution-data-server-dbg cupsys foo2zjs foomatic-db-gutenprint
      foomatic-db-hpijs foomatic-gui cdrkit-doc tomboy cpufreqd cpudyn powernowd
      gnome-screensaver xscreensaver xrdb gnome-system-tools libpulse0 libdv-bin
      gnome-app-install gstreamer0.10-tools gstreamer0.10-plugins ttf-kochi-gothic
      ttf-kochi-mincho ttf-thryomanes ttf-baekmuk ttf-arphic-gbsn00lp
      ttf-arphic-bsmi00lp ttf-arphic-gkai00mp ttf-arphic-bkai00mp slpd openslp-doc
      eog evince pdf-viewer totem mp3-decoder tracker fam python-dbus-dbg
      python-dbus-doc python-gtk2-doc python-gnome2-desktop-doc python-gobject-dbg
      python-numeric-dbg python-numeric-ext python-numeric-tutorial smbfs
    Doporučované balíky:
      python-beagle python-soappy gnome-utils cupsys-client lpr lprng pdq rlpr
      gnome-netstatus-applet gnome-user-guide ghostscript
    Následující balíky budou ODSTRANĚNY:
      gnome-power-manager
    Následující NOVÉ balíky budou nainstalovány:
      alacarte avahi-daemon avahi-utils cdrdao cups-common desktop-base
      desktop-file-utils dvd+rw-tools evolution-data-server
      evolution-data-server-common foomatic-db foomatic-db-engine foomatic-filters
      genisoimage gnome-about gnome-applets gnome-control-center
      gnome-desktop-data gnome-icon-theme gnome-media gnome-media-common
      gnome-menus gnome-panel gnome-session gnome-settings-daemon
      gstreamer0.10-alsa gstreamer0.10-plugins-base gstreamer0.10-plugins-good
      gstreamer0.10-x libaa1 libao2 libapm1 libavahi-compat-libdnssd1
      libavahi-core5 libcaca0 libcairomm-1.0-1 libcamel1.2-11 libcap2 libcdio7
      libcpufreq0 libcucul0 libdaemon0 libdv4 libebook1.2-9 libecal1.2-7
      libedata-book1.2-2 libedata-cal1.2-6 libedataserver1.2-9
      libedataserverui1.2-8 libegroupwise1.2-13 libexempi3 libffi5
      libgdata-google1.2-1 libgdata1.2-1 libglibmm-2.4-1c2a libgnome-desktop-2
      libgnome-media0 libgnome-window-settings1 libgnomecups1.0-1
      libgnomekbd-common libgnomekbd2 libgnomekbdui2 libgnomeprint2.2-0
      libgnomeprint2.2-data libgnomeprintui2.2-0 libgnomeprintui2.2-common libgs8
      libgstreamer-plugins-base0.10-0 libgstreamer0.10-0 libgtkmm-2.4-1c2a
      libgtksourceview-common libgtksourceview1.0-0 libgucharmap6
      libgweather-common libgweather1 libmetacity0 libnautilus-burn4 libnss-mdns
      liboil0.3 libpanel-applet2-0 libpoppler3 librsvg2-common libshout3 libslab0
      libslp1 libsoup2.4-1 libtag1c2a libtheora0 libtotem-plparser10
      libtrackerclient0 libvisual-0.4-0 libvisual-0.4-plugins libwavpack1
      libxklavier12 metacity metacity-common nautilus nautilus-cd-burner
      poppler-utils python-cairo python-dbus python-glade2 python-gmenu
      python-gnome2 python-gnome2-desktop python-gobject python-gtk2
      python-numeric python-pyorbit samba-common smbclient wodim xkb-data
    Následující balíky budou aktualizovány:
      capplets-data deskbar-applet gnome-applets-data gnome-panel-data
      gnome-system-monitor libpango1.0-0 libpango1.0-common libpopt0 nautilus-data
    9 aktualizováno, 113 nově instalováno, 1 k odstranění a 255 neaktualizováno.
    13 instalováno nebo odstraněno pouze částečně.
    Potřebuji stáhnout 45,3MB/126MB archivů.
    Po této operaci bude na disku použito dalších 234MB.
    Chcete pokračovat [Y/n]? y
    Mám:1 http://ftp.cz.debian.org unstable/main capplets-data 1:2.22.2.1-1 [2266kB]
    Mám:2 http://ftp.cz.debian.org unstable/main libpopt0 1.14-3 [46,3kB]
    Mám:3 http://ftp.cz.debian.org unstable/main libgnomecups1.0-1 0.2.3-2 [73,7kB]
    Mám:4 http://ftp.cz.debian.org unstable/main libgnomeprint2.2-data 2.18.4-1 [173kB]
    Mám:5 http://ftp.cz.debian.org unstable/main libgnomeprint2.2-0 2.18.4-1 [288kB]
    Mám:6 http://ftp.cz.debian.org unstable/main libgnomeprintui2.2-common 2.18.2-1 [270kB]
    Mám:7 http://ftp.cz.debian.org unstable/main libgnomeprintui2.2-0 2.18.2-1 [171kB]
    Mám:8 http://ftp.cz.debian.org unstable/main libgtksourceview-common 1.8.5-1 [457kB]
    Mám:9 http://ftp.cz.debian.org unstable/main libgtksourceview1.0-0 1.8.5-1 [116kB]
    Mám:10 http://ftp.cz.debian.org unstable/main libtotem-plparser10 2.22.3-1 [779kB]
    Mám:11 http://ftp.cz.debian.org unstable/main python-gnome2-desktop 2.22.0-1 [420kB]
    Mám:12 http://ftp.cz.debian.org unstable/main python-dbus 0.82.4-2 [225kB]
    Mám:13 http://ftp.cz.debian.org unstable/main deskbar-applet 2.22.2.1-1 [736kB]
    Mám:14 http://ftp.cz.debian.org unstable/main gnome-panel-data 2.20.3-5 [3105kB]
    Mám:15 http://ftp.cz.debian.org unstable/main gnome-utils 2.20.0.1-2 [6655kB]
    Mám:16 http://ftp.cz.debian.org unstable/main foomatic-db 20080211-2 [17,9MB]
    Mám:17 http://ftp.cz.debian.org unstable/main foomatic-filters 3.0.2-20080211-3.1 [144kB]
    Mám:18 http://ftp.cz.debian.org unstable/main foomatic-db-engine 3.0.2-20080211-1 [289kB]
    Mám:19 http://ftp.cz.debian.org unstable/main libavahi-core5 0.6.22-5 [192kB]
    Mám:20 http://ftp.cz.debian.org unstable/main libdaemon0 0.12-2 [13,3kB]
    Mám:21 http://ftp.cz.debian.org unstable/main avahi-daemon 0.6.22-5 [161kB]
    Mám:22 http://ftp.cz.debian.org unstable/main avahi-utils 0.6.22-5 [122kB]
    Mám:23 http://ftp.cz.debian.org unstable/main cups-common 1.3.7-7 [1130kB]
    Mám:24 http://ftp.cz.debian.org unstable/main libavahi-compat-libdnssd1 0.6.22-5 [111kB]
    Mám:25 http://ftp.cz.debian.org unstable/main libnss-mdns 0.10-3 [26,1kB]
    Mám:26 http://ftp.cz.debian.org unstable/main libpoppler3 0.8.2-2 [826kB]
    Mám:27 http://ftp.cz.debian.org unstable/main libslp1 1.2.1-7.3 [53,3kB]
    Mám:28 http://ftp.cz.debian.org unstable/main poppler-utils 0.8.2-2 [222kB]
    Mám:29 http://ftp.cz.debian.org unstable/main samba-common 2:3.0.30-3 [3052kB]
    Mám:30 http://ftp.cz.debian.org unstable/main smbclient 2:3.0.30-3 [5288kB]
    Staženo 45,3MB za 5s (8229kB/s)  
    Extrahuji z balíků šablony: 100%
    Přednastavuji balíky...
    (Čtu databázi ... nyní je nainstalováno 65920 souborů a adresářů.)
    Odinstalování balíku gnome-power-manager ...
    scrollkeeper-update: symbol lookup error: /usr/lib/libxml2.so.2: undefined symbol: gzopen64
    dpkg: chyba při zpracovávání gnome-power-manager (--remove):
     podproces post-removal script vrátil chybový status 127
    Při zpracování nastaly chyby:
     gnome-power-manager
    E: Sub-process /usr/bin/dpkg returned an error code (1)
    ahcjo :-( ja se s toho snad nevyhrabu :-(
    ICQ 454104749 zacatecnik v debianu 64 bit, mala znalost anglictiny
    22.6.2008 01:51 Radek Šlesinger | skóre: 13 | Adamov
    Rozbalit Rozbalit vše Re: aptitude a apt-get stavkuji
    Vyhrabeš. Ale v sources.list nechej jenom jednu distribuci, v rámci ní aktualizuj seznam balíků, uveď balíky v systému do konzistentního stavu (což ve stable půjde, za testing a unstable se úplně zaručit nemůžu) a necpi mu tam ručně balíky z jiných distribucí.
    22.6.2008 02:32 Nes | skóre: 20 | blog: Nes
    Rozbalit Rozbalit vše Re: aptitude a apt-get stavkuji
    muzete mi prosim napsat postup? zkousel jsem v sources nechat odkomentovane jen
    deb http://ftp.cz.debian.org/debian/ etch main
    deb-src http://ftp.cz.debian.org/debian/ etch main
    deb http://security.debian.org/ etch/updates main contrib
    deb-src http://security.debian.org/ etch/updates main contrib
    ale i tak veskere pokusy konci chybou :-( - nevim jak na to "uvest do konzistentniho stavu"

    Dik
    ICQ 454104749 zacatecnik v debianu 64 bit, mala znalost anglictiny
    22.6.2008 08:15 David Jaša | skóre: 44 | blog: Dejvův blog
    Rozbalit Rozbalit vše Re: aptitude a apt-get stavkuji
    Pusť si aptitude v interaktivním režimu a pohraj si tam s balíčkama tak, aby tam nebyly žádné kolize (a tím pádem broken balíčky).
    Dalibor Smolík avatar 22.6.2008 18:12 Dalibor Smolík | skóre: 54 | blog: Postrehy_ze_zivota | 50°5'31.93"N,14°19'35.51"E
    Rozbalit Rozbalit vše Re: aptitude a apt-get stavkuji
    Mně jednou pomohl tento postup:
     apt-get --fix-broken --show-upgraded install
                     dpkg --configure --pending
    
    
    Rozdíly v řeči a ve zvyklostech neznamenají vůbec nic, budeme-li mít stejné cíle a otevřená srdce.
    22.6.2008 18:21 linuxik | skóre: 32 | Milovice
    Rozbalit Rozbalit vše Re: aptitude a apt-get stavkuji
    Ahoj, ted to dostat zpatky na etch kdyz uz mas v systemu balicky z testing bude problem, protoze apt neumi downgrade. Zkus pouze apt-get install -f a podivaj se ktere balicky zpusobuji problem, pripadne si zazalohuj si konfiguraci a zkus je odinstalovat. Kdyz to nepujde tak prepis v souces.list etch na testing a zkus to pomoci apt-get dist-upgrade, nevim cim to je, ale v tehle situacich mi pripada apt-get uspesnejsi nez aptitude.

    Založit nové vláknoNahoru

    Tiskni Sdílej: Linkuj Jaggni to Vybrali.sme.sk Google Del.icio.us Facebook

    ISSN 1214-1267   www.czech-server.cz
    © 1999-2015 Nitemedia s. r. o. Všechna práva vyhrazena.