abclinuxu.cz AbcLinuxu.cz itbiz.cz ITBiz.cz HDmag.cz HDmag.cz abcprace.cz AbcPráce.cz
AbcLinuxu hledá autory!
Inzerujte na AbcPráce.cz od 950 Kč
Rozšířené hledání
×
eParkomat, startup z ČR, postoupil mezi finalisty evropského akcelerátoru ChallengeUp!
Robot na pivo mu otevřel dveře k opravdovému byznysu
Internet věcí: Propojený svět? Už se to blíží...
včera 21:21 | Nová verze Ladislav Hagara | Komentářů: 0
včera 11:44 | Zajímavý projekt

Na Indiegogo byla spuštěna kampaň na podporu herní mini konzole a multimediálního centra RetroEngine Sigma od Doyodo. Předobjednat ji lze již od 49 dolarů. Požadovaná částka 20 000 dolarů byla překonána již 6 krát. Majitelé mini konzole si budou moci zahrát hry pro Atari VCS 2600, Sega Genesis nebo NES. Předinstalováno bude multimediální centrum Kodi.

Ladislav Hagara | Komentářů: 0
včera 00:10 | Nová verze

Byla vydána verze 4.7 redakčního systému WordPress. Kódové označením Vaughan bylo vybráno na počest americké jazzové zpěvačky Sarah "Sassy" Vaughan. Z novinek lze zmínit například novou výchozí šablonu Twenty Seventeen, náhledy pdf souborů nebo WordPress REST API.

Ladislav Hagara | Komentářů: 1
6.12. 12:00 | Zajímavý projekt

Projekt Termbox umožňuje vyzkoušet si linuxové distribuce Ubuntu, Debian, Fedora, CentOS a Arch Linux ve webovém prohlížeči. Řešení je postaveno na projektu HyperContainer. Podrobnosti v často kladených dotazech (FAQ). Zdrojové kódy jsou k dispozici na GitHubu [reddit].

Ladislav Hagara | Komentářů: 24
6.12. 11:00 | Bezpečnostní upozornění

Byly zveřejněny informace o bezpečnostní chybě CVE-2016-8655 v Linuxu zneužitelné k lokální eskalaci práv. Chyba se dostala do linuxového jádra v srpnu 2011. V upstreamu byla opravena minulý týden [Hacker News].

Ladislav Hagara | Komentářů: 2
5.12. 22:00 | Komunita

Přibližně před měsícem bylo oznámeno, že linuxová distribuce SUSE Linux Enterprise Server (SLES) běží nově také Raspberry Pi 3 (dokumentace). Obraz verze 12 SP2 pro Raspberry Pi 3 je ke stažení zdarma. Pro registrované jsou po dobu jednoho roku zdarma také aktualizace. Dnes bylo oznámeno, že pro Raspberry Pi 3 je k dispozici také nové openSUSE Leap 42.2 (zprávička). K dispozici je hned několik obrazů.

Ladislav Hagara | Komentářů: 6
5.12. 06:00 | Zajímavý software

OMG! Ubuntu! představuje emulátor terminálu Hyper (GitHub) postavený na webových technologiích (HTML, CSS a JavaScript). V diskusi k článku je zmíněn podobný emulátor terminálu Black Screen. Hyper i Black Screen používají framework Electron, stejně jako editor Atom nebo vývojové prostředí Visual Studio Code.

Ladislav Hagara | Komentářů: 50
5.12. 06:00 | Zajímavý článek

I letos vychází řada ajťáckých adventních kalendářů. QEMU Advent Calendar 2016 přináší každý den nový obraz disku pro QEMU. Programátoři se mohou potrápit při řešení úloh z kalendáře Advent of Code 2016. Kalendáře Perl Advent Calendar 2016 a Perl 6 Advent Calendar přinášejí každý den zajímavé informace o programovacím jazyce Perl. Stranou nezůstává ani programovací jazyk Go.

Ladislav Hagara | Komentářů: 10
3.12. 16:24 | Nová verze

Byla vydána Mageia 5.1. Jedná se o první opravné vydání verze 5, jež vyšla v červnu loňského roku (zprávička). Uživatelům verze 5 nepřináší opravné vydání nic nového, samozřejmě pokud pravidelně aktualizují. Vydání obsahuje všechny aktualizace za posledního téměř půldruhého roku. Mageia 5.1 obsahuje LibreOffice 4.4.7, Linux 4.4.32, KDE4 4.14.5 nebo GNOME 3.14.3.

Ladislav Hagara | Komentářů: 17
3.12. 13:42 | Pozvánky

V Praze probíhá konference Internet a Technologie 16.2, volné pokračování jarní konference sdružení CZ.NIC. Konferenci lze sledovat online na YouTube. K dispozici je také archiv předchozích konferencí.

Ladislav Hagara | Komentářů: 0
Kolik máte dat ve svém domovském adresáři na svém primárním osobním počítači?
 (32%)
 (24%)
 (29%)
 (8%)
 (5%)
 (3%)
Celkem 785 hlasů
 Komentářů: 50, poslední 29.11. 15:50
Rozcestník
Reklama

Dotaz: Chyba pri upgrade kernelu na verziu 2.6.32-3

16.3.2010 19:06 Patrik Uhrak | skóre: 31 | blog: pato
Chyba pri upgrade kernelu na verziu 2.6.32-3
Přečteno: 163×

Zdravim,

vcera sa mi stala nemila vec, pri upgrade kernelu na verziu 2.6.32-3 sa instalacia sekla pri polozke generating grub.cfg .  Skusal som si prejst aj postinst skript pre tento kernel a hladat, ci tam nie je nejaky preklep alebo nieco podobne. Ale / nie je to zas take velke prekvapenie  :)  / nic som tam nenasiel, tak som aspon odkomentoval riadok strict , co by malo pomoct pri zistovani chybu, co sa tyka samotneho skriptu. Tu je vypis :

root@debian:~# aptitude safe-upgrade 
Reading package lists... Done
Building dependency tree
Reading state information... Done
Reading extended state information
Initializing package states... Done
Reading task descriptions... Done
The following packages have been kept back:
libmagickcore2-extra{a}
The following partially installed packages will be configured:
linux-image-2.6.32-3-amd64
0 packages upgraded, 0 newly installed, 0 to remove and 1 not upgraded.
Need to get 0B of archives. After unpacking 0B will be used.
Writing extended state information... Done
Setting up linux-image-2.6.32-3-amd64 (2.6.32-9) ...
Global symbol "$question" requires explicit package name at /var/lib/dpkg/info/linux-image-2.6.32-3-amd64.postinst line 635.
Global symbol "$question" requires explicit package name at /var/lib/dpkg/info/linux-image-2.6.32-3-amd64.postinst line 637.
Global symbol "$question" requires explicit package name at /var/lib/dpkg/info/linux-image-2.6.32-3-amd64.postinst line 638.
Global symbol "$question" requires explicit package name at /var/lib/dpkg/info/linux-image-2.6.32-3-amd64.postinst line 640.
Global symbol "$question" requires explicit package name at /var/lib/dpkg/info/linux-image-2.6.32-3-amd64.postinst line 641.
Global symbol "$question" requires explicit package name at /var/lib/dpkg/info/linux-image-2.6.32-3-amd64.postinst line 643.
Global symbol "$question" requires explicit package name at /var/lib/dpkg/info/linux-image-2.6.32-3-amd64.postinst line 644.
Global symbol "$question" requires explicit package name at /var/lib/dpkg/info/linux-image-2.6.32-3-amd64.postinst line 647.
Global symbol "$question" requires explicit package name at /var/lib/dpkg/info/linux-image-2.6.32-3-amd64.postinst line 648.
Global symbol "$question" requires explicit package name at /var/lib/dpkg/info/linux-image-2.6.32-3-amd64.postinst line 651.
Global symbol "$question" requires explicit package name at /var/lib/dpkg/info/linux-image-2.6.32-3-amd64.postinst line 652.
Global symbol "$question" requires explicit package name at /var/lib/dpkg/info/linux-image-2.6.32-3-amd64.postinst line 655.
Global symbol "$question" requires explicit package name at /var/lib/dpkg/info/linux-image-2.6.32-3-amd64.postinst line 657.
Global symbol "$question" requires explicit package name at /var/lib/dpkg/info/linux-image-2.6.32-3-amd64.postinst line 662.
Global symbol "$question" requires explicit package name at /var/lib/dpkg/info/linux-image-2.6.32-3-amd64.postinst line 665.
Global symbol "$question" requires explicit package name at /var/lib/dpkg/info/linux-image-2.6.32-3-amd64.postinst line 666.
Global symbol "$ramdisk_cmd" requires explicit package name at /var/lib/dpkg/info/linux-image-2.6.32-3-amd64.postinst line 793.
Global symbol "$ramdisk_cmd" requires explicit package name at /var/lib/dpkg/info/linux-image-2.6.32-3-amd64.postinst line 794.
Global symbol "$ramdisk_cmd" requires explicit package name at /var/lib/dpkg/info/linux-image-2.6.32-3-amd64.postinst line 798.
Global symbol "$ramdisk_cmd" requires explicit package name at /var/lib/dpkg/info/linux-image-2.6.32-3-amd64.postinst line 802.
Global symbol "$answer" requires explicit package name at /var/lib/dpkg/info/linux-image-2.6.32-3-amd64.postinst line 941.
Global symbol "$answer" requires explicit package name at /var/lib/dpkg/info/linux-image-2.6.32-3-amd64.postinst line 942.
Global symbol "$answer" requires explicit package name at /var/lib/dpkg/info/linux-image-2.6.32-3-amd64.postinst line 944.
Execution of /var/lib/dpkg/info/linux-image-2.6.32-3-amd64.postinst aborted due to compilation errors.
dpkg: error processing linux-image-2.6.32-3-amd64 (--configure):
subprocess installed post-installation script returned error exit status 9
Errors were encountered while processing:
linux-image-2.6.32-3-amd64
E: Sub-process /usr/bin/dpkg returned an error code (1)

 

Mozno, ze niekto vie co s tym alebo aspon nejake docasne riesenie. Zatial som system nerestartol, ale co som pozrel grub.cfg , tak ten kernel tam je zaznamenany a aj spravne vytvorene cesty a vsetko k tomu. Neviem, co mohlo sposobit tuto chybu, lebo som nezasahoval do systemu nijak vyrazne alebo do nicoho, co by mohlo toto sposobit. Predtym vsetko islo ok, aj posledny update kernelu pred tymto nestastnym.

 

Dakujem za kazdu pomoc .

 

p.s.: Je to debian squeeze .

 

p.s. 2: Som to aj reportol, no zatial ziadna odozva, tak dufam, ze to nie je len lokalne, aj ked by nemalo.  http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=574031


Řešení dotazu:


Odpovědi

16.3.2010 21:51 Patrik Uhrak | skóre: 31 | blog: pato
Rozbalit Rozbalit vše Re: Chyba pri upgrade kernelu na verziu 2.6.32-3

Zdravim.

Takze sa mi to pred malou chvilou podarilo vyriesit. Postup bol naslednovny:

 

1. Kazdy balicek s kernelom ma svoje skripty pre instalaciu a odinstalaciu v /var/lib/dpkg/info/ a  tyka sa to skriptov *.{postinst,postrm,preinst,prerm}

Vsetky som ich premazal nasledovnym sposobom:

for i in /var/lib/dpkg/info/linux-image-*.{postinst,postrm,preinst,prerm}; do echo -e "#! /bin/bash\nexit 0" > "$i"; done

Cielom bolo, aby skripty koncili s exit statusom rovnym 0 .

 

2. Spustil som aptitude purge linux-image-2.6.32-3-amd64 ale hadzalo to este chyby. ( je uplne jedno, aky kernel som sa snazil odinstalovat, nainstalovat, cokolvek ) No a bol tam riadok nieco v zmysle o vykonani postrm hook script a v zatvorkach ( /usr/sbin/update-grub )

 

3.  Tak som zakomentoval obsah toho skriptu, vlastne len jeden riadok. Ono by stacilo kludne spravit aj to, co som spravil v bode 1 a netreba si tie subory ani otvarat a dopisovat exit 0 rucne.

 

4. Nasledne som konecne mohol odinstalovat vsetky kernele = vsetky neskonfigurovane kernele  a tiez grub.

 

5. Som bez kernelu a bootloader-u a dostavam o tom aj varovanie. :)

 

6. Nainstalovat grub a nasledne aj novy kernel.

 

7. Vsetko prebehlo ok a momentalne bezim uz na verzii 2.6.32-3 pre 64 bit

 

8. Bug kernelu to teda nie, kedze ten bezi. Co to sposobilo, netusim. Ale aspon som si to vyriesil.

 

p.s.: Neislo odinstalovat ani nainstalovat s uspechom ziadny kernel ani grub, nic, lebo sa snazili prv vyriesit stavajuce problemy.

Založit nové vláknoNahoru

Tiskni Sdílej: Linkuj Jaggni to Vybrali.sme.sk Google Del.icio.us Facebook

ISSN 1214-1267   www.czech-server.cz
© 1999-2015 Nitemedia s. r. o. Všechna práva vyhrazena.