abclinuxu.cz AbcLinuxu.cz itbiz.cz ITBiz.cz HDmag.cz HDmag.cz abcprace.cz AbcPráce.cz
AbcLinuxu hledá autory!
Inzerujte na AbcPráce.cz od 950 Kč
Rozšířené hledání
×

dnes 08:00 | Pozvánky

V Praze dnes probíhá konference Internet a Technologie 17.2 pořádaná sdružením CZ.NIC. Sledovat ji lze online. K dispozici je také archiv předchozích konferencí. Sdružení nedávno vydalo bezpečnostní pexeso. Ke stažení jako pdf pod licencí CC BY-NC-SA.

Ladislav Hagara | Komentářů: 0
dnes 07:22 | Nová verze

Byla vydána verze 10.2 a krátce na to opravná verze 10.2.1 open source alternativy GitHubu, tj. softwarového nástroje s webovým rozhraním umožňujícího spolupráci na zdrojových kódech, GitLab (Wikipedie). Představení nových vlastností v příspěvku na blogu a na YouTube.

Ladislav Hagara | Komentářů: 0
dnes 06:22 | Pozvánky

V úterý 28. listopadu se v Brně koná již 4. přednáškový večer Ruby Stories. Těšit se můžete na témata jako TDD, hybridní mobilní aplikace či programování v Elixiru. Více informací na Facebooku nebo se rovnou registruj na Eventbrite. Na místě bude zdarma drink a lehké občerstvení, tak dorazte.

ondrej-zadnik | Komentářů: 0
dnes 06:11 | Pozvánky

V úterý 28. 11. 2017 bude další Prague Containers Meetup. DC/OS a Mesos vás provede Mesosphere's Developer Advocate Matt Jarvis.

little-drunk-jesus | Komentářů: 0
včera 14:44 | Komunita

Mozilla.cz informuje, že Firefox bude možná upozorňovat na úniky vašich hesel. V Mozille prototypují upozorňování na únik informací o vašem účtu, pokud se na seznamu Have I been pwned? objeví služba, ke které máte ve Firefoxu uložené přihlašovací údaje. Informace se objevila v pravidelném newsletteru o vývoji Firefoxu.

Ladislav Hagara | Komentářů: 5
včera 00:22 | Bezpečnostní upozornění

Společnost ZONER informuje o bezpečnostním incidentu, při kterém došlo ke zcizení a zveřejnění části přihlašovacích údajů zákazníků k elektronické poště a webhostingu CZECHIA.COM.

Ladislav Hagara | Komentářů: 0
22.11. 23:44 | Nová verze

Byla vydána nová stabilní verze 1.13 (1.13.1008.32) webového prohlížeče Vivaldi (Wikipedie). Z novinek vývojáři zdůrazňují možnost zobrazení otevřených i uzavřených listů pomocí ikonky Okno na postranní liště a vylepšené stahování (YouTube). Nejnovější Vivaldi je postaveno na Chromiu 62.0.3202.97.

Ladislav Hagara | Komentářů: 9
22.11. 20:55 | Nová verze

Byla vydána verze 2017.3 dnes již průběžně aktualizované linuxové distribuce navržené pro digitální forenzní analýzu a penetrační testování Kali Linux. Aktualizovat systém lze pomocí příkazů "apt update; apt dist-upgrade; reboot". Z novinek lze zmínit 4 nové nástroje: InSpy, CherryTree, Sublist3r a OSRFramework.

Ladislav Hagara | Komentářů: 1
22.11. 01:55 | Bezpečnostní upozornění

Společnost Uber potvrdila bezpečnostní incident a únik dat v roce 2016. Unikly údaje o 57 milionech cestujících (jména, emailové adresy a čísla mobilních telefonů) a 600 tisících řidičích (navíc čísla řidičských průkazů).

Ladislav Hagara | Komentářů: 1
21.11. 23:44 | Humor

Co vypíše příkaz man půl hodiny po půlnoci? Text "gimme gimme gimme". Jedná se o virtuální velikonoční vajíčko připomínající skupinu ABBA a její hit Gimme! Gimme! Gimme! (A Man After Midnight). Problém nastane, pokud gimme gimme gimme nabourá automatizované testování softwaru. To se pak příkaz man musí opravit [Bug 1515352] [reddit].

Ladislav Hagara | Komentářů: 10
Jak se vás potenciálně dotkne trend odstraňování analogového audio konektoru typu 3,5mm jack z „chytrých telefonů“?
 (9%)
 (1%)
 (1%)
 (1%)
 (75%)
 (14%)
Celkem 757 hlasů
 Komentářů: 37, poslední 21.11. 15:21
    Rozcestník

    Dotaz: VMware server na Debian Squeeze 2.6.38

    polo23 avatar 13.8.2011 22:41 polo23 | skóre: 26 | blog: polo23
    VMware server na Debian Squeeze 2.6.38
    Přečteno: 252×
    Ahoj,
    mate nekdo zkusenosti s instalaci VMware serveru 2 na Debianu Squeeze s jadrem 2.6.38? Ptam se proto, ze se mi nedari VMware nainstalovat. Delal jsem to podle tohoto tohoto navodu. Pred spustenim instalacniho skriptu jsem instaloval vse potrebne:
    • Debian Squeeze 2.6.38-bpo.2-686-bigmem
    • linux-headers-2.6.38-bpo.2-686-bigmem
    • build-essential (11.5 version)
    Vysledek sputeni skriptu:
    sudo ./vmware-server-2.0.x-kernel-2.6.3x-install.sh
    You have VMware Server archive:
    VMware-server-2.0.2-203138.i386.tar.gz
    cat: /etc/*-release: Directory doesnt exits
    cat: /etc/*-release: Directory doesnt exits
    cat: /etc/*-release: Directory doesnt exits
    Extracting the contents of VMware-server-2.0.2-203138.i386.tar.gz
    Found .tar file for vsock module
    Found .tar file for vmnet module
    Found .tar file for vmci module
    Found .tar file for vmmon module
    Extracting .tar files in order to apply the patch…
    Untarring /home/polo/vmware/vmware-server-distrib/lib/modules/source/vsock.tar
    Untarring /home/polo/vmware/vmware-server-distrib/lib/modules/source/vmnet.tar
    Untarring /home/polo/vmware/vmware-server-distrib/lib/modules/source/vmci.tar
    Untarring /home/polo/vmware/vmware-server-distrib/lib/modules/source/vmmon.tar
    Testing patch…
    Creating some simlinks for the newer kernels…
    Applying patch…
    Preparing new tar file for vsock module
    Preparing new tar file for vmnet module
    Preparing new tar file for vmci module
    Preparing new tar file for vmmon module
    Checking that the compiling will succeed…
    Trying to compile vmnet module to see if it works
    Performing make in /home/polo/vmware/vmware-server-distrib/lib/modules/source/vmnet-only
    Using 2.6.x kernel build system.
    /home/polo/vmware/vmware-server-distrib/lib/modules/source/vmnet-only/driver.c: In function ‘VNetFileOpUnlockedIoctl’:
    /home/polo/vmware/vmware-server-distrib/lib/modules/source/vmnet-only/driver.c:1190: error: implicit declaration of function ‘lock_kernel’
    /home/polo/vmware/vmware-server-distrib/lib/modules/source/vmnet-only/driver.c:1192: error: implicit declaration of function ‘unlock_kernel’
    make[4]: *** [/home/polo/vmware/vmware-server-distrib/lib/modules/source/vmnet-only/driver.o] Error 1
    make[3]: *** [_module_/home/polo/vmware/vmware-server-distrib/lib/modules/source/vmnet-only] Error 2
    make[2]: *** [sub-make] Error 2
    make[1]: *** [all] Error 2
    make: *** [vmnet.ko] Error 2
    There is a problem compiling the vmnet module after it was patched.
    Z chybove hlasky nejsme schopny si s tim poradit - alespon pro me je nic nerikajici.

    Pokud nekdo mate jiny navod jak VMware server 2 instalovat, budu rad kdyz ho sem uvedete. Potrebuju to rozjet a na jine virtualizacni reseni prechazet nechci.
    http://www.it-kurz.cz

    Odpovědi

    14.8.2011 00:51 2X4B-523P | skóre: 38 | blog: Zelezo_vs_Debian
    Rozbalit Rozbalit vše Re: VMware server na Debian Squeeze 2.6.38
    myslím, že tento konkrétní problém bude v odstranění BIG_KERNEL_LOCK v novějších verzích Linuxu, moduly VMWare serveru/workstationu/playeru je nutné před kompilací patchovat ...
    polo23 avatar 14.8.2011 01:52 polo23 | skóre: 26 | blog: polo23
    Rozbalit Rozbalit vše Re: VMware server na Debian Squeeze 2.6.38
    Ahoj,
    diky za napovedu - vidim, ze jsem na dobre ceste:) To je presne to co ten skript, na ktery se odkazuju dela, je to patch s tim ze se pak pousti kompilace. Chytil jsem se nasledujicich 3 radku z vystupu skriptu:
    /home/polo/vmware/vmware-server-distrib/lib/modules/source/vmnet-only/driver.c: In function ‘VNetFileOpUnlockedIoctl’:
    /home/polo/vmware/vmware-server-distrib/lib/modules/source/vmnet-only/driver.c:1190: error: implicit declaration of function ‘lock_kernel’
    /home/polo/vmware/vmware-server-distrib/lib/modules/source/vmnet-only/driver.c:1192: error: implicit declaration of function ‘unlock_kernel’
    Vygooglil jsem nasledujici... Na jednom foru je dotaz proc se zobrazi pri kompilaci hlaska:
    implicit declaration of function
    Odpoved:
    You forgot to provide a prototype for a function within the scope
    visible to the compiler at the point where it was compiling a call to
    that function.
    Ten skript, ktery pouzivam pro zprovozneni VMware pouziva linux-headers a ziskava si je takto
    linux-headers-`uname -r`
    - cili vysledek je linux-headers-2.6.38-bpo.2-686-bigmem. JENZE ja jsem pomoci grep zjistil, ze jak funkce lock_kernel tak unlock_kernel (obe jsou zmineny v chybove hlasce)jsou deklarovany v /usr/src/linux-headers-2.6.38-bpo.2-common/include/linux/smp_lock.h. Jsou teda v jinych hlavickovych souborech.

    Je tedy nejaka moznost jak to "ohnout" tak aby to fungovalo?

    P.S. Prikladam patchovaci skripty (spoustim vmware-server-2.0.x-kernel-2.6.3x-install.sh).
    http://www.it-kurz.cz
    14.8.2011 23:34 2X4B-523P | skóre: 38 | blog: Zelezo_vs_Debian
    Rozbalit Rozbalit vše Re: VMware server na Debian Squeeze 2.6.38
    můžeš vyzkoušet patch který je ZDE, nevadí že je na workstation, moduly jsou stejné...
    polo23 avatar 15.8.2011 14:27 polo23 | skóre: 26 | blog: polo23
    Rozbalit Rozbalit vše Re: VMware server na Debian Squeeze 2.6.38
    Cau,
    diky za navod, ale podle toho to asi neudelam. Pouzivaji tam napr. cestu cd /usr/lib/vmware/modules/source, coz ja v systemu vubec nemam pac nemam VMware jeste instalovany...

    To muzu az po tom co patchnu potrebne soubory a zkompiluju potrebne moduly.

    Ja si spis myslim, ze bych se mel ubirat cestou zkompilovani tech modulu... prece kdyz se to povedlo tomu autoru clanku, ktery to dokazal patchnout a zkompilovat na 2.6.38 tak neni mozne abych se tim nejak neprokousal i ja ne?
    Podle me musi existovat moznost jak pri spusteni make poskytnout info o deklaraci potrebnych funkci - usuzuju z chybove hlasky.

    Ale to je spis na post do programatorske poradny.
    http://www.it-kurz.cz
    15.8.2011 15:30 2X4B-523P | skóre: 38 | blog: Zelezo_vs_Debian
    Rozbalit Rozbalit vše Re: VMware server na Debian Squeeze 2.6.38
    jedná se o to, změnit adresář před aplikací patche do adresáře se zdrojáky modulů: cd /nekam/kde/mas/vmware/modules/source
    15.8.2011 17:28 Michal Kubeček | skóre: 71 | Luštěnice
    Rozbalit Rozbalit vše Re: VMware server na Debian Squeeze 2.6.38
    Pouzivaji tam napr. cestu cd /usr/lib/vmware/modules/source, coz ja v systemu vubec nemam pac nemam VMware jeste instalovany...

    Proč by to měl být problém? Udělejte to, až si ho nainstalujete. Pokud si ho nehodláte instalovat vůbec, nic patchovat nepotřebujete. :-)

    To muzu az po tom co patchnu potrebne soubory a zkompiluju potrebne moduly.

    Proč myslíte? Standardně se moduly překládají až po instalaci. Tedy pokud se netrefíte do některé verze jádra, pro kterou jsou připravené už v instalačním balíku, ale to se mi za ty roky, co VMware používám, IIRC ještě nestalo. Lze si samozřejmě udělat i vlastní balíček s moduly (mám takový pro OpenSuSE), ale nemáte-li k tomu vážný důvod, nestojí to za námahu a navíc mi pak VMware při instalaci ty předem nainstalované moduly stejně pro jistotu smazal.

    Založit nové vláknoNahoru

    Tiskni Sdílej: Linkuj Jaggni to Vybrali.sme.sk Google Del.icio.us Facebook

    ISSN 1214-1267   www.czech-server.cz
    © 1999-2015 Nitemedia s. r. o. Všechna práva vyhrazena.